BIOS. Начало!

1. Boot & POST

При включении ПК автоматически запускается находящаяся в BIOS программа загрузки BOOT-ROUTINE. Эта программа вызывает подпрограмму самопроверки POST (Power-On Self Test), проверяющую процессор, микросхемы ROM, оперативную память, вспомогательные элементы материнской платы, жесткий диск и другую основную периферию.
Далее программа загрузки разыскивает другие BIOS-чипы, которые могут быть встроены, к примеру, в платы расширения. SCSI- контроллеры при этом будут запускать свои собственные тестовые программы.
После этого BIOS берется уже конкретно за платы расширения и расстановку и проверку распределения ресурсов (IRQ, DMA, I/O).
Далее с загрузочных секторов жесткого диска в дело вступает начальный загрузчик, BOOTSTRAP LOADER, - программа, знающая файловую структуру носителя данных. Начальный загрузчик вызывает загрузку загрузочных программ операционной системы.
Этот стандартный алгоритм значительно дополнился и модернизировался с внедрением PnP-технологии и новой PCI-шины, а позже с появлением операционных систем, разработанных с учетом внедрения новейших технологий. Но более подробно об этом будет сказано ниже.

(В зависимости от версии BIOS)
LOAD SETUP DEFAULTS, LOAD FAIL-SAFE, ORIGINAL или AUTO CONFIGURATION WITH POWER-ON DEFAULTS
- включение этих "безопасных" режимов имеет смысл только тогда, когда система либо вообще не запускается, либо при определенных конфигурациях зависает, сбоит, т.п. При включении таких режимов BIOS пеpеводит систему в самое "консеpвативное" состояние, отключит внутреннюю и внешнюю кэш-память, переведет видео-кэш в значение "Disabled", задаст максимально возможные режимы ожидания (Waitstates) и т.п. В результате такого выбора увеличивается вероятность включения системы и ее дальнейшей настройки.

Above 1 MB Memory Test
- при установке опции в "Enabled" в процессе тестирования ОЗУ проверяется область памяти свыше 1 Мб (область памяти XMS - Extended Memory Specification). На это расходуется дополнительное время в процессе загрузки, тем более такой тест является излишним, так как драйвер-менеджер памяти HIMEM.SYS сам осуществляет проверку оперативной памяти и предпочтительнее использовать именно этот тест, так как он работает в реальном рабочем окружении. При запрете опции расширенная память не тестируется, а только инициализируется.

BIOS Update
- (обновление BIOS). Процессоры семейства P6 (Pentium Pro, Pentium II, Celeron, Xeon), а ныне и процессоры следующих поколений имеют особый механизм, называемый "программируемым микрокодом", который позволяет исправить некоторые виды ошибок, допущенных при разработке и/или изготовлении процессоров, за счет изменения микрокода. Обновления микрокода хранятся в BIOS и загружаются в процессор в процессе выполнения инструкций BIOS. Именно поэтому BIOS для материнских плат с указанными выше процессорами необходимо регулярно обновлять. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
В "AMI BIOS" была встречена аналогичная опция под названием "CPU MicroCode Updation".
Опция может называться "Pentium II Microcode" или "Microcode Update".

В процессоры 6-го поколения, начиная с первого Pentium Pro, было встроено новое средство, которое позволяет исправлять многие ошибки процессоров, изменяя микропрограмму в самом процессоре. Это средство называется "перепрограммируемой микропрограммой". Модификации микропрограмм постоянно находятся в системной ROM BIOS (их объем составляет до двух килобайт) и загружаются в процессор системой BIOS во время выполнения POST-теста.
Чтобы можно было установить новую модификацию микропрограммы, BIOS системной платы должен содержать подпрограммы поддержки модификации микропрограмм, т.е. API (Application Program Interface - программный интерфейс приложений) обновления микрокода. Фактически все BIOS плат для Pentium Pro и Pentium II такие подпрограммы имеют. С помощью программы модификации процессора ("Processor Update Utility") фирмы "Intel", поставляемой обычно с т.н. "боксированными" процессорами, можно также определить, присутствует ли необходимый код в BIOS, сравнить номер версии процессора с номером версии микропрограммы модификации, загруженной в текущий момент, или установить новую микропрограмму модификации, если это необходимо. Указанная программа определяет используемый процессор во время выполнения POST (с помощью инструкции CPUID) и ищет соответствующее ему обновление в своей базе. Если найдена более новая версия микрокода, утилита локально перепрошивает блок данных в BIOS, не затрагивая остальные участки. Естественно, что для выполнения перепрошивки предварительно нужно разрешить перезапись флэш-памяти соответствующей перемычкой или опцией в "BIOS Setup" (см. отдельно). Несколько слов о термине "Stepping" (см. также "CPUID Instruction"). Чем выше Stepping процессора, тем меньше процессор содержит ошибок. Первый символ Stepping - это имя модели (k - ядро Katmai, c - Coppermine), второй символ указывает на серьезные изменения микрокода процессора (для процессоров Pentium III это буквы A, B или С), а последний - на незначительные изменения.

Boot From LAN First
- при установке опции в "Enabled" BIOS предпримет попытку первоначальной загрузки из сетевого загрузочного модуля, прежде чем пытаться загрузиться с локального носителя. Понятно, что данная опция по сути дает разрешение на использование удаленной загрузки.

Boot Sequence
- (последовательность начальной загpузки системы). Определяется последовательность опроса различных накопителей для загрузки операционной системы, можно сказать, поиска загрузочных файлов на устройствах в последовательности, указанной пользователем. Понятно, что, если в качестве первичного загрузочного устройства установлен жесткий диск, и обычно система с него и загружается, то выбор следующих носителей не имеет никакого значения.
Все эти устройства обозначаются либо буквами для физических жестких дисков и обычных дисководов, либо названием устройства, например, "CDROM" для накопителей CD-ROM. Поддерживаются устройства LS-120, Iomega ZIP, ATAPI CD-ROM, IDE- и SCSI-диски. Может принимать значения:
"A,C" - такой выбор оправдан только для случая загрузки с дискеты и встречался в старых моделях ПК,
"A,C,SCSI",
"A,SCSI,C",
"C only",
"C,A",
"C,A,SCSI",
"C,CDROM,A",
"CDROM,C,A",
"D,A,SCSI" (предназначено при использовании минимум двух IDE-жестких дисков),
"E,A,SCSI" (аналогично для 3-х дисков),
"F,A,SCSI" (аналогично для 4-х дисков),
"LS/ZIP,C",
"SCSI,A,C",
"SCSI,C,A".
Теперь заглянем в не такое уж и далекое прошлое. Очень непривычный вариант загрузки в свое время предлагал "Phoenix BIOS" с опцией "System Load". Опция имела два параметра:
"Standard" - ОС могла быть загружена (по умолчанию) либо с флоппика, либо с жесткого диска,
"Diskette Lock" - только с жесткого диска. Понятно, что это было давненько.
Один из ветеранов - опция "Boot devices". В ней явным образом указывалась не последовательность загрузочных устройств, а ...дисковод-загрузчик.
Ну а в более современных версиях BIOS опция "Boot Sequence" трансформировалась в несколько самостоятельных опций, естественно с большей возможностью отбора и большей гибкостью. Это выглядит следующим образом, например, у "AMI BIOS":
"First Boot Device"
"Second Boot Device"
"Third Boot Device"
"Boot Other Device" (или "Fourh Boot Device")
Параметры могут принимать следующие значения: "Floppy", "HDD-0", "HDD-1", "HDD-2", "HDD-3", "LAN" (или "Network"), "SCSI", "LS/ZIP", "CD-ROM", "Enable", "Disabled". Конечно, не все перечисленные устройства могут быть первичными загрузочными, перечислен весь перечень устройств для всех четырех опций.
А один из вариантов "AMI BIOS" содержит те же опции, но со значениями "Floppy", "Floptical" (RS 120), "CD ROM", "SCSI Device", "Network", "IDE0", "IDE1", "IDE2", а опция "Try Other Boot Devices" через значение "Yes" дает возможность не дополнительного выбора варианта загрузки, а по сути, определяет, поддерживает ли BIOS загрузку системы со второго или третьего загрузочного устройства, если система не была найдена на первом.
Более современный вариант "AMI BIOS" выглядит совсем необычно: "Disabled", "1st IDE-HDD", "2nd IDE-HDD", "3rd IDE-HDD", "4th IDE-HDD", "Floppy", "ARMD-FDD", "ARMD-HDD", "ATAPI CDROM", "SCSI" (только в качестве первого или второго загрузочного устройства), "NETWORK" и "I2O" (Intelligent Input Output) (последние два параметра только в качестве первого загрузочного устройства). Об ARMD (ATAPI Removable Media Disks) смотри подробнее в разделе "Peripherals & Resources", а также чуть ниже в опции "Support Removable Disks under BIOS as Fixed Disks".
Необходимо также отметить, что не всегда рекомендуется значение "Network" указывать в качестве первого загрузочного устройства. При этом могут возникнуть проблемы "арбитража" между сетевым адаптером и другим устройством в процессе загрузки системы.
Другое возможное название опции - "System Boot Sequence".
Необходимо еще отметить следующее. Все перечисленные варианты опций не охватывают всех возможных нюансов загрузки, предлагаемых различными версиями BIOS. Поэтому пользователь должен быть всегда готов к встрече с нестандартной ситуацией. Подтверждение тому - BIOS материнских плат от "ABIT" (BE6 и BP6), которые содержали дополнительный (extra) IDE-контроллер. Тогда в "BIOS Setup" указание на SCSI заменяется на "SCSI/EXT". Но самое главное это то, что система может быть загружена с IDE-диска на третьем или четвертом каналах IDE-интерфейса, ну и естественно со SCSI-диска и первых двух IDE-каналов. Правда, ситуация "усложняется" тем, что пользователю придется дополнительно повозиться с опцией
x Boot Sequence EXT Means
- (последовательность загрузки с дополнительных устройств) со значениями "IDE", "SCSI". Для того, чтобы грузиться с 3-го или 4-го IDE-каналов, надо в основной опции выбрать расширение "SCSI/EXT", а затем в дополнительной - значение "IDE".
В дополнение ко всему вышесказанному! Правда, это касается некоторых старых системных плат. Если система не может найти загрузочной области на "первом" устройстве, хотя она присутствует на последующих (или следующем), система может прекратить загрузку с выводом сообщения "No Operating System Found". Понятно, что в этом случае надо исправить последовательность загрузки в "Boot Sequence".
Дополнительно смотри ниже опцию "HDD Sequence SCSI/IDE First".

Boot Up Floppy Seek
- (поиск дисковода при загрузке компьютера). Так можно перевести название этой функции. Но смысл функции значительно шире, поскольку BIOS проверяет, есть ли дисковод для дискет, и идет ли речь при этом о 40- или 80-тидорожечном дисководе. Производится также проверка первоначального позиционирования головок (поиск нулевой дорожки), т.е. в итоге обеспечивается функционально достаточная проверка работоспособности дисководов гибких дисков при проведении теста самотестирования системы.
Поскольку все современные дисководы имеют 80 дорожек (с 1993 года дисководы на 40 дорожек не выпускаются; они поддерживали формат в 360 КБ), то выполнение этой функции является необязательным. Необходимо заметить, что BIOS не может определить разницу между 720K, 1.2M, 1.44M или 2.88M типами дисководов, т.к. все они имеют 80 дорожек. Имеет смысл установить эту опцию в "Disabled" (иначе - "Enabled"), что позволит сократить общее время тестирования ПК после его включения. Разрешение опции имеет смысл только в случае, когда загрузка системы производится с дискеты, да и то...
Другое название опции - "Floppy Drive Seek At Boot".
"Phoenix BIOS" содержит подобную опцию под названием "Fast Boot". Речь в ней идет о возможности пропустить проверку флоппи-дисковода. Уже из наименования опции становится понятным, какой смысл вкладывается в значения "Disabled"/"Enabled".
Подобную задачу решает и опция "Phoenix BIOS" под названием "Floppy Check".

Boot Up Numlock Status
- опция, определяющая, в каком режиме после включения компьютера ("Num Lock After Boot") должна работать дополнительная цифровая клавиатура (Numeric Keyboard). Разрешение этого параметра включает индикатор "Num Lock", и цифровая клавиатура становится "генератором" кодов цифр и знаков. В противном случае генерируются коды стрелок, <INS>, <DEL> и т.д., т.е. цифровая клавиатура функционирует в режиме управления курсором. Может принимать значения:
"On" (иногда "Enabled" или "Yes") - включено,
"Off" (иногда "Disabled" или "No") - отключено.
В некоторых версиях BIOS может появиться и значение "Auto", оно и будет устанавливаться по умолчанию.
Другие названия опции: "System Boot Up Numlock Status", "System Boot Up Num Lock". "AMI BIOS" предлагает свое название - "Boot Up Num-Lock", хотя ясно, что полет фантазии для данной функции весьма ограничен. Подтверждение тому - опции "Numlock" и "Num Lock (n/a)". Одним же из самых "старинных и красивых" вариантов была опция "Numlock enabled at boot".
Режим работы в любой момент времени меняется кнопкой <NumLock>.
Дополнительная информация представлена в разделе Keyboard.

Когда в 1986 г. появилась расширенная клавиатура, то многих пользователей стало раздражать то, что функция "Num Lock" после загрузки системы включалась автоматически. Поэтому со временем во многих системах стали предусматривать возможность управления первоначальным состоянием "Num Lock" через BIOS. Затем опция управления состоянием "Num Lock" стала стандартной функцией BIOS. Ну и параллельно расширенным аппаратным возможностям функция управления была введена в некоторые операционные системы (речь идет о файле CONFIG.SYS). Кстати, если в "BIOS Setup" соответствующая опция отключена, а в конфигурационном файле CONFIG.SYS указана директива "NUMLOCK=ON", то такое сочетание вполне может вызвать конфликтную ситуацию.

Boot Up System Speed
- опция выбора тактовой частоты процессора при загрузке. Значение "Low" переводит процессор в режим работы с половинной тактовой частотой и без использования внутренней кэш-памяти. Правда, в некоторых случаях тактовая частота системы может быть установлена на уровне AT-шины, т.е. около 8 МГц. Естественно, что изначально понижается пропускная способность системной и локальных шин, работы памяти и видеоканала, т.п. Такой режим может потребоваться при работе со старыми программами или платами расширения, а также при возможных проблемах при запуске системы. По умолчанию всегда устанавливается значение "High". Несмотря на кажущуюся архаичность данной опции, Вы ее найдете в самых современных системах.
Опция может носить название "System Boot Up CPU Speed". Тот же "AMI BIOS" мог предложить возможность смены тактовой частоты процессора с помощью набора клавиш - <CTRL>+<ALT>+<+> (или <->).

Boot Virus Detection
- (определение вируса в загрузочном секторе). Смысл этого параметра отличается от "Virus Warning" и заключается он в следующем. Если этот параметр запрещен ("Disabled"), то до загрузки операционной системы BIOS переписывает загрузочный сектор во флэш-память и сохраняет его там. Но при этом никаких последствий для системы и пользователя не возникает. При установке параметра в "Enabled" BIOS не будет загружать систему с жесткого диска, если содержимое boot-сектора будет отличаться от сохраненного в памяти. При этом система выводит сообщение, и пользователю далее предоставляется возможность либо загрузить систему с жесткого диска, либо с дискеты.
Опция может носить название "BootSector Virus Detection".

CPUID Instruction
- не совсем ясная опция. С одной стороны, в процессе проведения POST-теста на одном из его этапов выполняется команда CPUID для получения т.н. "CPU Vendor String" и параметров Family/Model/Stepping. Т.е. речь идет об идентификации процессора. Естественно, что этот этап POST никак не связан с присутствием в BIOS рассматриваемой опции.
С другой стороны, можно было встретить и такое разъяснение. При установке значения "Enabled" программы могут распознавать действующий процессор, например, 486-й, как процессор следующего поколения и даже...

Процессорная инструкция CPUID не имеет таких "древних" корней, как многие представленные здесь опции. Инструкция CPUID стала доступна у процессоров, начиная с некоторых моделей 486-х и затем с Pentium.
Необходимость в идентификации процессоров вызревала постепенно, по мере их развития. И была она связана прежде всего с не совсем полной совместимостью (точнее, обратной совместимостью) старших моделей процессоров семейства x86 с младшими.
Эти различия связаны не только с программным обеспечением и процедурами вычислительных операций, но и с управлением различным системным оборудованием или внешними устройствами, определяемым, прежде всего, временными характеристиками, последовательностью взаимодействия, т.п.
К тому же программное обеспечение в процессе своего совершенствования, среди прочих аппаратных нюансов, должно учитывать и процедуры обращения к портам ввода/вывода, к BIOS компьютера и т.д. Да и процессоры старших поколений имеют такие архитектурные особенности и расширения, использование которых без предварительной идентификации типа процессора может оказаться невозможным. Достаточно вспомнить о дополнительных процедурах, связанных с процессорами Cyrix.
В процессе идентификации процессора может быть считана различная информация: "тип" процессора (OEM-версия, Overdrive, Dual), "семейство", "модель", "степпинг" (специальная дополнительная информация производителя).
Процедура идентификации процессора стала просто необходимой для выполнения другой важной задачи, а именно, "обновления микрокода" (см. выше).

Cyrix 6x86 / MII CPU ID
- если в системе установлен соответствующий названию опции процессор, необходимо опцию разрешить ("Enabled"). В данном случае поддержка процессоров Cyrix осуществляется через BIOS, хотя можно встретить и более традиционный вариант - установку перемычек на системной плате.

Daylight Saving
- во включенном состоянии ("Enabled") эта опция позволяет автоматически добавлять или вычитать один час при весеннем или осеннем переводе времени (последнее воскресенье апреля и аналогично в октябре). Этот параметр можно отключить, если установлена "Windows 9x" (или выше), самостоятельно регулирующая этот процесс.

Delay IDE Initial
- (задержка инициализации IDE-устройства). В данном параметре устанавливается интервал времени (в секундах), в течение которого IDE-устройство не будет опрашиваться BIOS после включения питания. Ненулевое значение параметра рекомендуется устанавливать только в случае применения старых жестких дисков. Не все старые приводы способны были достичь номинальной скорости вращения за время, которое при включении ПК проходит до начала тестирования жесткого диска. При этом неверно могли быть определены параметры диска или даже пройти его инициализация. Продолжения загрузки системы при этом далее могло и не быть. Опция была введена первоначально в "AMI BIOS" для использования старых накопителей и позднее была оставлена для совместимости.
В различных версиях BIOS могут встретиться абсолютно идентичные функции: "Hard Disk Pre-Delay", "Delay For HDD (Secs)" и "Delay IDE Initial (Sec)". Хотя при этом могут несколько варьироваться значения параметров: от "0" до "15", от "0" до "30", от "1" до "15" и "Disabled". Возможен также и такой подбор значений: 3, 6, 9, 12, 15, 21, 30 и "Disabled" (по умолчанию). "Disabled" означает, что задержка не устанавливается для всех дисков в системе.
Есть еще одна интересная опция с названием "Delay for SCSI/HDD (Secs)". Все сказанное выше справедливо и для SCSI- дисков. Только речь здесь идет уже о PCI SCSI BIOS и о правильном определении параметров диска через BIOS SCSI-контроллера. Для этого и задается задержка от 0 до 60 сек.

Deturbo Mode
- при разрешении этого параметра сигнал FLUSH# процессора становится активным, и никакие данные после этого не кэшируются в свой внутренний кэш процессорами архитектуры Pentium Pro (Pentium II, Celeron и т.п.). Разрешение этого параметра ("Enabled") следует использовать только при необходимости сознательно замедлить работу компьютера. "Disabled" устанавливается по умолчанию.
Опция "AMI BIOS", "Boot Speed", аналогична предыдущим и предлагает следующие значения: "Deturbo" и "Turbo" (по умолчанию). Стоит напомнить, что снижение скоростных характеристик может понадобиться и для старых карт расширения.
Опции могут носить название "Turbo Switch", "Turbo Switch Function" и "Turbo/Deturbo Switch", хотя в некоторых случаях речь может идти только о разрешении работы переключателя <TURBO>. А в некоторых случаях, что естественно связано с реализацией чипсета и маркой процессора, возможно также периодически приостанавливать конвейер процессора. Некоторые из этих опций уже изъяты "из обращения".

В давние времена в компьютерах Turbo XT и ранних AT кнопка <TURBO> на передней панели ПК была предназначена для повышения тактовой частоты процессора сверх номинальной с целью ускорения его работы. При этом устойчивая работа на этой частоте не гарантировалась. Появление компьютерных систем с тактовыми частотами, превысившими характеристики предыдущих (4,77 и 8 МГц), сопровождалось далее не только сохранением переключателя <TURBO>, а и, можно сказать, совершенствованием turbo-режимов.
Прежде всего пришлось решать проблемы совместимости со "старым" программным обеспечением, у которого какие-либо временные характеристики, задержки формировались путем подсчета циклов процессора. Проблема заключалась в том, что многие старые программы пользовались для измерения времени скоростными параметрами XT, отчего на AT-моделях работали с ошибками. Поэтому на более поздних и быстрых AT-286 и ранних 386-х компьютерах кнопка <TURBO> стала использоваться для понижения частоты. В режиме "Turbo" процессор работал на своей максимальной частоте (читай, оптимальной), а при отжатой кнопке - на пониженной. Естественно, что при этом менялась частота синхронизации. В компьютерах AT-286 и 386, у которых входная системная частота делилась внутри процессора пополам, входной сигнал синхронизации назывался "CLK2IN".
В начале 90-х годов, на последних 286-х и 386/486-х компьютерах был введен другой способ управления скоростью: частота системного генератора была постоянной, а при замыкании контактов кнопки <TURBO> принудительно замедлялась работа с внешним кэшем и памятью. Для большинства программ это не давало заметного эффекта, поскольку сам процессор и его внутренний кэш (не в 286-х моделях) продолжали работать с обычной скоростью.
В последних 486-х моделях и первых "пентиумных" кроме обычного отключения внешнего кэша стал использоваться режим прерывистой синхронизации. Каким образом это решалось аппаратно?
В некоторых реализациях системных плат класса 386/486 порт вывода контроллера клавиатуры 8042, кроме участия в формировании сигналов Gate A20 и Soft CPU Reset, стал формировать также сигналы управления режимом "Turbo" и включения кэш-памяти. Эти сигналы нашли применение и в процедурах POST. На одном из этапов POST порт вывода программировался так, чтобы режим "Turbo" был включен (Hi-Speed), кэш L1 и L2 выключен (Cache-off).
Дальнейшее развитие компьютерных технологий привело к изменению и роли многострадальной кнопки <TURBO>. На большинстве современных системных плат кнопка <TURBO>, если она присутствует конечно, нынче участвует в реализации функций режима "Suspend". Режим "Suspend" обычно может быть запрещен опцией в "BIOS Setup", тогда кнопка <TURBO> не влияет на работу системы. На некоторых новых платах замыкание контактов кнопки снова понижает частоту системного генератора. Об использовании кнопки <TURBO> в реализации режимов энергосбережения - в соответствующем разделе.

Drive A
Drive B
- с помощью данных опций пользователь устанавливает спецификацию, формат, можно сказать, стандарт применяемых в системе флоппи-дисководов. Не имеет значения, присутствует второй "флоппик" в ПК или нет, процедуры инсталляции и установки параметров дисководов в "BIOS Setup" попросту стандартизованы, поскольку предложить еще что-либо по данной теме вряд ли возможно. Несколько обобщая возможные варианты параметров установки, имеем следующее:
"None" (или "Disabled", или "Not Installed") - дисковод отсутствует либо запрещен доступ к нему,
"360K, 5.25 in" - 5-1/4 - дюймовый стандарт дисковода, емкостью в 360 КБ,
"1.2M, 5.25 in" - 5-1/4 - дюймовый AT-стандарт высокой плотности, емкостью 1,2 МБ,
"720K, 3.5 in" - 3-1/2 - дюймовый стандарт, емкостью 720 КБ,
"1.44M, 3.5 in" - аналогично для емкости 1,44 МБ,
"2.88M, 3.5 in" - аналогично для емкости 2,88 МБ.
Опции, предназначенные для флоппи-дисководов, также могут носить разные наименования, хотя возможности здесь явно ограничены: "Floppy Drive A:/B:", "Diskette A:/B:", "Legacy Diskette A:/B:".

Flash BIOS Protection
- включение опции запрещает доступ к Flash BIOS вирусам и... неопытным пользователям. При этом не может быть произведено обновление содержимого Flash BIOS. Для обновления функцию надо отключить. На некоторых материнских платах функция реализована не в виде опции "BIOS Setup", а в виде перемычки, либо не реализована вовсе. Желательно функцию включить. Может принимать значения:
"Enabled" - защита установлена,
"Disabled" - доступ разрешен.
Естественно, что такая же функция присутствует и в "Phoenix BIOS". Только в "Flash Write" (это видно по названию) все наоборот: "Disabled" делает невозможной перезапись BIOS, "Enabled" допускает такую операцию. В любом случае более серьезного отношения к себе потребует документация на материнскую плату и знание самого процесса обновления Flash, если в этом будет необходимость.
Естественно, что после перезаписи BIOS защита должна быть установлена снова.
Несколько слов о необходимости перепрошивки BIOS! В связи с чем может возникнуть потребность решать такую задачу? Как правило, это связано с правильным распознаванием новых процессоров, поддержкой нового оборудования, т.п. Зачастую производители системных плат, выпуская новый продукт, заведомо идут на некоторое сокращение пользовательских установок "BIOS Setup", лишая конечного пользователя возможности полноценно настраивать систему. Позднее, а это происходит не всегда, такой производитель все же подготавливает обновления BIOS, размещая их на своем сайте.
Что касается оборудования, то достаточно вспомнить о различных ограничениях и поддержке жестких дисков большой емкости, о поддержке различных устройств в качестве загрузочных и т.д. Достаточно также вспомнить о полноценной поддержке стандарта ACPI со стороны BIOS и о многом другом. Все эти вопросы значительно полнее рассматриваются в литературе, посвященной модернизации BIOS, поэтому большей детализации здесь не требуется.

Floppy 3 Mode
- еще одна, не так уж и редко встречающаяся, опция по установке параметров флоппи-дисководов. Во включенном состоянии ("Enabled") опция позволяет системе, как это не тривиально, поддерживать 3,5-дюймовые дисководы с возможностью читать дискеты емкостью 1,2 МБ. Хитрость в том, что этот режим является японским стандартом для флоппи-дисководов и естественно не применяется, за исключением некоторых стран Юго-Восточной Азии и собственно Японии, во всем остальном мире. А по техническим параметрам совместное использование опции и таких "японских" дисководов позволяет достичь скорости передачи в 1 Мб/сек. Так что эта совместимость "в наших условиях" имеет мало смысла.
Опция может называться и "Floppy 3 Mode Support".

Halt On
- сразу после включения ПК, во время теста самопроверки POST, при нахождении какой-либо аппаратной ошибки система прекращает загрузку и выводит наименование устройства, вызвавшего сбой. Будет ли произведена остановка, и в каких случаях это произойдет, как раз и определяет параметр опции "Halt On". Возможными параметрами являются:
"No Errors" - POST никогда не прерывает работу, какая бы нефатальная для системы ошибка не была обнаружена (нарушение работы устройства или даже его отсутствие),
"All Errors" - остановка работы при возникновении любой критической, тем более фатальной, ошибки. Интегрированная опция,
"All, But Keyboard" - остановка при любой критической ошибке, кроме ошибки клавиатуры,
"All, But Diskette" - аналогично, только с игнорированием ошибок дисководов,
"All, But Disk/Key" - игнорирование ошибок клавиатуры и дисководов.
"Phoenix BIOS" содержит аналогичную опцию под названиями "Error Halt", "POST Error Halt" или "POST Errors", правда, с заметно ограниченными возможностями: "Halt On All Errors" (также "Enabled") и "No Halt On Any Errors" (также "Disabled").

HDD Sequence SCSI/IDE First
- в представленной уже опции "Boot Sequence" (или аналогичной) пользователь может выбрать в качестве загрузочного любое мыслимое и немыслимое устройство. Но так было не всегда. И это касается также SCSI- и IDE-дисководов. При размещении устройств IDE и SCSI в одной и той же системе загрузочным устройством мог быть основной (master) жесткий диск на первичном канале IDE. Обычно загрузка с диска SCSI при смешанной конфигурации была невозможна. Но это, прежде всего, было связано с возможностями системной платы. В современных материнских платах возможность загрузки с дисководов SCSI предусмотрена.
В BIOS материнской платы ASUS P/I-P55T2P4 (1996 г.) был предусмотрен параметр "HDD Sequence SCSI/IDE First". Аналогичные опции появились затем в BIOS системных плат других производителей. Благодаря такой возможности стало вполне реальным помещать загрузочную запись для операционной системы не только на диск IDE, но и на диск SCSI. А это позволяет загружать несколько ОС, не используя специальных программных средств. Возможными значениями параметра являются: "SCSI", "IDE".
Аналогичную задачу решает опция "First Hard Disk Drive". Абсолютно идентичны и ее значения.

Keyboard
- (клавиатура). Значение "Installed" не вызывает вопросов. Если установить "Not-installed", эта опция укажет BIOS на отмену пpовеpки клавиатуpы во вpемя стаpтового теста, что позволяет пеpезапускать ПК с отключенной клавиатуpой без выдачи сообщения об ошибке теста клавиатуpы. Это может оказаться необходимым при работе файл-сервера, сервера печати, в т.ч. из соображений безопасности.
Аналогичную задачу решает опция "System Keyboard" (AMI BIOS) с параметрами "Present" (по умолчанию) и "Absent".

LAN Remote Boot
- эта опция "Phoenix BIOS" заметно отличается от приведенной выше "Boot From LAN First", поскольку речь идет не о порядке подключения загрузочных модулей или разрешении удаленной загрузки. Данная опция предназначена для установки режима такой загрузки и носит протокольный характер. Функция удаленной загрузки может использоваться, с одной стороны, в специальных сетевых средах, когда ни флоппи-дисковод, ни жесткий диск не установлены в системе или опциально отключены. С другой стороны, удаленная загрузка может функционировать в локальном компьютере и при наличии других средств загрузки операционной системы. При удаленной загрузке могут быть реализованы два различных протокола загрузки: BootP и LSA. Отсюда и возможные значения:
"BootP" - "BootP" сетевой BIOS активизирован и операционная система может быть загружена с сервера посредством BootP-протокола,
"LSA" - аналогично для LSA-протокола,
"Disabled" - удаленная загрузка невозможна. Сетевой BIOS не активизирован.
Через "BIOS Setup" можно также включить поддержку "Intel Boot Agent", что позволит загрузить ПК по сети с использованием протоколов PXE и RPL. Так что возможны и другие вариации подобных опций.

Поскольку затронута тема использования такого программного продукта, как "Intel Boot Agent", то имеет смысл остановиться на некоторых вопросах подробнее.
"Intel Boot Agent" интегрирован во флэш-память сетевого адаптера. Он обеспечивает настройку параметров сетевого устройства, являясь конфигурационной программой. "Boot Agent Setup" подобен "BIOS Setup" системной платы. После включения ПК и успешного завершения POST-тестирования на экран монитора выводится сообщение:

Initializing Intel Boot Agent Version x.x
Press Ctrl+S to enter into the Setup Program..

Вывод этого сообщения означает, что пользователю предлагается войти в установочное меню "Boot Agent". После некоторого периода неактивности автоматически включаются установки, сохраненные ранее, и далее производится либо удаленная загрузка, либо локальная. А установочное меню может выглядеть следующим образом:

Intel (R) Boot Agent Version 3.0.00

Setup Menu

Network Boot Protocol | PXE
Boot Order | Try network first, then local drives
Show Setup Prompt | Enable
Setup Menu Wait Time | 8 seconds
Legacy OS Wakeup Support | Disable

Сетевые протоколы удаленной загрузки:
PXE (Pre-boot eXecution Environment) - современный протокол, используемый с WfM-совместимым сетевым ПО. WfM - это спецификация "Wired for Management Baseline". Этой спецификации соответствуют современные сетевые адаптеры серии "Intel PRO/100" или адаптеры, основанные на наборах 82559 или выше,
RPL (Remote Program Load) - используется для стандартного режима удаленной загрузки. Не все версии "Boot Agent" включают в себя поддержку RPL-протокола,
BootP (Bootstrap Protocol).

Пользователь уже привык к малозаметному, но постоянно изменяющемуся содержанию системного BIOS. Точно также, мало-помалу, совершенствуются конфигурационные установки "Intel Boot Agent". "Исчезла" малопонятная для пользователя опция "PnP/BEV Boot", где BEV - BIOS Entry Vector.
Опция "Setup Menu Wait Time" ранее называлась "Prompt Time", но сохранила свое назначение - время ожидания действий пользователя после вывода на экран вышеприведенного сообщения (2, 3, 5 или 8 сек.).
Опция "Show Setup Prompt" ранее называлась "Setup Message", но также сохранила свое назначение - показывать или нет вторую строчку выводимого сообщения с указанием правила входа в установочное меню.
Опция "Boot Order" по сути вобрала в себя две "старые" ("Default Boot" и "Local Boot") и предложила целый ряд значений на выбор:
"Try local drives first, then network",
"Try network only",
"Try local drives only" и приведенное выше.
Опция "Legacy OS Wakeup Support" заметно отличается от прежней "Power Mgmt" (значения "ACPI", "APM") и имеет значения:
"Disable" - для операционных систем, использующих технологии ACPI,
"Enable" - для не-"Windows" систем, таких как DOS или Nowell Netware.
Дополнительная информация об удаленной загрузке находится, как это ни странно, в сообщениях об ошибках системы при ее включении.

Language Support
- опция по установке языка интерфейса "BIOS Setup". Возможных значений, как правило, пять: "English (US)" (по умолчанию), "Francais", "Italiano", "Deutsch", "Espanol". Данная опция предложена "Phoenix BIOS". Он же предлагает и опцию "Language". "AMI BIOS" представил опцию "Change Language Setting".

Memory Test
- (тест памяти). Эта старенькая опция "Phoenix BIOS" (почти аналог "Quick Power On Self Test") позволяла пропустить ("Disabled") тест памяти при проведении POST-теста. Тест памяти, как нетрудно догадаться, проводился при выборе значения "Enabled".

Memory Test Tick Sound
- опция, позволяющая сопровождать тест памяти периодическими звуковыми сигналами. Рекомендуется устанавливать в "Enabled" для озвучивания пpоцесса загpузки, косвенной оценки объема инсталлированной памяти и дополнительного подтверждения, в частности, правильности установок "CPU clock speed/Turbo switch". Последнее может удивить пользователя! А дело в том, что по высоте тона (будем считать, что каждый наделен музыкальным слухом) можно, опять-таки несколько субъективно, оценить быстродействие загружаемой системы. На это как раз и влияют определенные опции "BIOS Setup", о них уже сказано выше, а также положение переключателя <TURBO>.
Данная опция в новых системах практически уже не встречается.

Numeric Processor Test
- (тест цифрового пpоцессоpа). Речь в данной опции идет о проверке математического сопроцессора (FPU - Floating Point Unit). Хотя эта опция и устарела, но тем не менее парк стареньких ПК еще не исчез бесследно. Устанавливается в "Disabled", если сопроцессор отсутствует (386SX, 386DX, 486SX, 486SLC, 486DLC, более низкие модели). Пpи отключении этого теста сопpоцессоp, если он даже и пpисутствует в системе, не pаспознается и считается отсутствующим.

Option ROM Scan
- (сканирование необязательного (опциального) ПЗУ). "Необязательное" ПЗУ - это фрагмент BIOS, который может располагаться на платах адаптеров и вызываться через системный BIOS для инициализации платы. Сканирование такого необязательного ПЗУ применяется в основном только к контроллеру SCSI. Параметр опции включает ("Enabled") или отключает ("Disabled") выполнение инициализации ПЗУ. Инициализация ПЗУ включает в себя сканирование шины SCSI на предмет наличия устройств, содержащих дополнительный BIOS. Но речь может идти и о системной загрузке через сеть. Тогда поиск дополнительного BIOS будет вестись и на специализированных сетевых картах расширения.
Следующая опция, "Delay on Option ROMs", решает еще одну задачу. Если опция включена, BIOS будет делать краткую задержку в конце каждого сканирования необязательного ПЗУ. Задержка предоставляет аппаратуре платы некоторое время, чтобы она пришла в устойчивое состояние после инициализации. Задержка несколько замедляет начальную загрузку, но ее имеет смысл включать, если во время начальной загрузки инициализация оборудования выполняется неустойчиво.
Еще одну дополнительную опцию предложил "AMI BIOS". В опции "Display Mode at Add-On ROM Init" также речь идет об инициализации дополнительного BIOS, но уже о том, в какой форме процесс инициализации "Add-On ROM" будет отображаться на системном мониторе во время проведения POST. Значения опции: "Force BIOS" ("принудительный вывод на дисплей процесса инициализации") и "Keep Current" ("сохранение текущего состояния" - не совсем ясный момент).

Overclock Warning Message
- при установке опции в "Enabled" в процессе самотестирования системы выводится соответствующее сообщение, если процессор разогнан. Столь замечательная опция принадлежит "AMI BIOS".

Quick Power On Self Test
- (быстрый тест компьютера после включения питания). Разрешение этого параметра приводит к некоторому сокращению времени, затрачиваемого на начальное самотестирование компьютера (POST), особенно при значительных объемах оперативной памяти. Следует только учесть, что память, например, в этом случае не тестируется, а только проверяется ее размер. Сокращение времени тестирования происходит также за счет пропуска некоторых пунктов проверки (например, упрощенно фиксируется готовность жесткого диска, без специальной паузы ожидания на "разгон" двигателя).
Если при работе ПК возникают какие-либо проблемы, то лучше при его включении осуществлять полный тест. Хотя надо отметить, что часто встречающиеся рекомендации по сокращению времени загрузки ПК не дают особенного эффекта, а вот проблем перед пользователями ставят достаточно. Поэтому к советам специалистов необходимо подходить дифференцировано, т.е. решать в каждом конкретном случае "свою" маленькую проблему. Но однозначно, если система работает длительное время стабильно и без сбоев, то опцию имеет смысл все же включить. Возможные проблемы, связанные уже с функционированием операционной системы, должны рассматриваться отдельно и не в связи с состоянием данной опции. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено (по умолчанию).
"AMI BIOS" может содержать аналогичную опцию под названием "Quick Boot" или "Quick Boot Mode". "Phoenix BIOS" предложил опцию "Fast Boot" со значениями "Auto" (разрешение "быстрого" теста) и "Disabled".
Напоследок несколько слов о самом тесте, хотя эта тема будет рассматриваться отдельно. Во время выполнения POST-теста проверяются все системные компоненты и устройства. Проверяются регистры чипсета, инициализируется и тестируется основная память, видеоканал, идентифицируется центральный процессор, идентифицируются устройства IDE-интерфейса, порты, в том числе такая стандартная периферия, как клавиатура и мышь, т.п. При всем этом составляются контрольные суммы (см. следующий раздел) конфигурации системы, которые могут затем сверяться со значениями, хранящимися в памяти, и иногда быть поводом для беспокойства. Включение вышеприведенной опции не затрагивает большинства подтестов и поэтому не должно вызывать тревоги при стабильной работе системы.

RTC Y2K H/W Roll Over
- при установке опции в "Enabled" происходит тестирование системы на проблему 2000 года. "Disabled" устанавливается по умолчанию. Несмотря на характер проблематики, опции такого рода встречаются довольно редко. Проверка на правильность отображения через CMOS RTC 2000-го года стала встраиваться в системы в 98-м году и не получила массового распространения. Причина заключалась и в том, что на уровне BIOS весьма непросто оказалось реализовать полноценную диагностику, ведь требовалась проверка не только "новогодней ночи", а и многих других дат (например, 29 февраля).

Scan User Flash Area
- (просмотр пользовательской области памяти). 4 КБ пользовательской области Flash-памяти, расположенной в области адресов FFFF8000h-FFFF8FFFh, стандартно предназначены для вывода на экран монитора в процессе POST-теста т.н. OEM-логотипа. Эта область памяти является перенастраиваемой. С помощью специальных утилит в эту область можно записать собственный логотип, а также при желании пользовательские бинарные файлы, которые могут быть запущены во время загрузки. Включение опции ("Enabled") позволяет BIOS просматривать Flash-память для поиска таких файлов и их запуска во время POST. "Disabled" устанавливается по умолчанию, при этом исполняемые коды пропускаются.
Данная опция характерна для "Phoenix BIOS" и "AMI BIOS".

Setup Prompt
- эта опция "AMI BIOS" позволяет выводить/не выводить на экран сообщение "Press F1 to enter SETUP" для доступа к "BIOS Setup" в процессе старта системы. "Enabled" устанавливается по умолчанию, а "Disabled" косвенно может служить в качестве защитной функции. "Phoenix BIOS" содержит такую же опцию, но с выводом сообщения "Press F2 to enter SETUP".
Но надо отметить, что на протяжении многих лет огромные армии пользователей ПК общались с системой через другую и естественно более привычную опцию "AMI BIOS" - "Hit "Del" Message Display", отключение которой не позволяло вывести на экран монитора сообщение о том, с помощью какой клавиши возможен доступ к "BIOS Setup".

Small Logo (EPA) Show
- данной опцией пользователь решает проблему, выводить на экран в процессе загрузки логотип или нет ("Enabled" и "Disabled" соответственно). EPA (Environmental Protection Agency) - это "Агенство по защите окружающей среды"). С его деятельностью связана реализация программ по энергосберегающим технологиям (подробнее об этом в разделе "ACPI").

Summary Screen
- опция "Phoenix BIOS", позволяющая выводить ("Enabled") или не выводить ("Disabled") на экран монитора системные (диагностические) сообщения в процессе загрузки системы.
Аналогичная опция "AMI BIOS" называется "Boot-time Diagnostic Screen". По умолчанию ("Disabled") BIOS отображает только графический логотип вместо более полезных сообщений о начальной загрузке. Для отображения всех информационных сообщений опцию надо включить.
С приведенными выше солидаризируется еще одна опция "Phoenix BIOS" под наименованием "Quiet Boot" ("спокойная загрузка"). Для нее "Disabled" означает полноценный вывод на экран всей процедуры начального тестирования (POST-сообщения), а "Enabled" ведет к показу только т.н. "OEM logo". Правда, при этом с помощью специального набора клавиш (он указывается в документации) можно все-таки вывести и более нужную информацию.
Но надо отдать должное "Phoenix BIOS". Еще в далекие начальные 90-е годы предвестником "Quiet Boot" была опция "Silent Boot" ("тихая загрузка"). Установка "Enabled" полностью скрывала все стартовые сообщения, и экран монитора оставался "пустым" (blank) в продолжение всей загрузки.

Support Removable Disks under BIOS as Fixed Disks
- данную и столь "длинную" опцию можно рассматривать как дополнение к опции "Boot Sequence", но ее самостоятельность налицо, поскольку речь идет о SCSI-интерфейсе. Опция позволяет использовать съемные медиа-устройства SCSI, такие как, например, CD-ROM, без инсталляции дополнительных драйверов. Возможные значения опции:
"Boot Only" (значение по умолчанию) - только выбранное съемное медиа-устройство назначается как загрузочное устройство и рассматривается как жесткий диск (см. дополнительно опцию "Primary Master ARMD Emulated as" в разделе, посвященном периферии),
"All Disks" - все съемные устройства поддерживаются SCSI BIOS и рассматриваются как жесткие диски,
"Disabled" - ни одно из устройств не воспринимается системой как жесткий диск из-за отсутствия поддержки SCSI BIOS и поэтому каждое из них нуждается в инсталляции соответствующих драйверов для функционирования в среде операционной системы. Возможна ситуация, когда съемное загрузочное устройство должно быть временно изъято из системы. В этом случае должна быть обеспечена поддержка оставшихся устройств со стороны ОС, после чего также выбирается значение "Disabled".
Данная опция будет проигнорирована при блокировке SCSI Host-адаптера.

Swap Floppy Drive
- (перестановка дисководов). Опция, позволяющая "поменять местами" дисководы A: и B: и сделать загрузочным дисковод B: (или наоборот). Опция имеет смысл только при наличии двух дисководов в компьютере и необходимости сделать загрузочным дисковод 5.25", хотя можно предположить наличие двух трехдюймовых дисководов. При этом дисководы меняются местами только логически, а не физически. Это означает, что никаких "механических" действий (переподключение дисководов) пользователь не производит. Стоит упомянуть, хотя это будет обидно для читателя, что загрузочным может быть только дисковод A:. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено (по умолчанию).
Опция может иметь название "Floppy Drive Swap" или "Onboard FDC Swap A&B" со значениями "No Swap" и "Swap AB".
Краткая справка! Шлейф для подсоединения дисководов имеет несколько перекрученных (twisted) проводников, по которым передаются сигналы "Активизация двигателя A(B)", "Выбор дисковода A(B)". Данная опция и позволяет как раз контроллеру флоппи-дисководов управлять этими сигналами, тем самым освободив пользователя от необходимости возиться со шлейфом.

USB Keyboard Support Via
- (поддержка USB-клавиатуры через ...). Таких методов два: либо поддержка USB-клавиатуры операционной системой на уровне драйверов, либо аппаратное определение через BIOS. Если есть необходимость работы в операционной системе, не поддерживающей USB-шину, то необходимо включить поддержку такой клавиатуры через BIOS. Естественно, что предварительно должна быть включена общая поддержка интерфейса. Может принимать значения:
"OS" - речь идет, например, о "Windows 98",
"BIOS" - такая установка необходима для той же "MS-DOS" или "UNIX".
Понятно, что включение поддержки USB-клавиатуры через BIOS, при работе с "Windows Me", никак не может ухудшить ситуацию.
"Phoenix BIOS" содержит почти аналогичную опцию, точнее даже две. К тому же они носят более расширенный характер, так как речь может идти и о "мыши". Но есть одно существенное отличие. Данные опции предназначены для поддержки функционирования на USB-шине "обычных", т.е. стандартных устройств. Их подключение может осуществляться через специальные переходники, поэтому ничего странного во всем этом, и с аппаратной стороны, и в самих этих опциях нет. "USB BIOS Legacy Support" через "Enabled"/"Disabled" разрешает/запрещает поддержку клавиатуры (или мыши) напрямую через BIOS. Вторая опция ("USB Legacy Support") разрешает/запрещает распознавание периферии операционной системой.

USB Mouse Support Via
- метод поддержки USB-мыши. Опция абсолютно аналогична вышеприведенной. Идентичны и ее параметры: "OS", "BIOS".

Video
- установка типа видеоадаптера для первичного системного монитора. Хотя вторичный монитор поддерживается и некоторыми ОС, установки в "BIOS Setup" для него отсутствуют. По умолчанию устанавливается "EGA/VGA". Возможны варианты:
"Mono" (Monochrome) - для монохромных видеоадаптеров,
"Hercules" - также для монохромных видеоадаптеров,
"MDA" - для монохромных видеоадаптеров, поддерживающих только текст,
"CGA 80" (Color Graphics Adapter) - для режима 80 колонок,
"CGA 40" (Color Graphics Adapter) - для режима 40 колонок,
"EGA/VGA" (Enhanced Graphics Adapter/Video Graphics Array) - для EGA-, VGA-, SVGA- и PGA-адаптеров мониторов. Последний параметр может называться и "VGA/PGA/EGA".
Опция может иметь название и "Primary Display", а для выбора значений могут быть предложены "VGA/EGA", "CGA40x25", "CGA80x25", "Mono" и "Absent" (или "Not-installed"). Вариант с отсутствующим дисплеем ("Absent") также может найти применение, как ни странно, например, в специализированных технологических системах. Во всяком случае, автор с такой ситуацией сталкивался.
Опция может также называться "Video Display" или даже "Video Card".
И еще! В "BIOS Setup" такой тип адаптера также может встретится, а в литературе так уж точно - XGA (eXtended Graphics Array). Такие видеоадаптеры начали выпускаться "IBM" в 1990-м г. для компьютеров с шиной MCA, они поддерживали режим "Bus Master", отличались повышенным разрешением, высококачественной графикой и производительностью.
Необходимо вспомнить и о применении жидкокристаллических дисплеев. Опция может называться "LCD&CRT", а значения параметра могут быть следующие:
"LCD" (Liquid Crystal Display) - жидкокристаллический дисплей,
"CRT" (Cathode Ray Tube) - дисплей с электронно-лучевой трубкой,
"AUTO" - автоматическое определение устройства. Это же значение не требует от пользователя дополнительных действий при смене монитора на другой тип,
"LCD&CRT" - объединенный параметр, который также устраивает оба типа устройсв.

Virus Check Reminder
- (напоминание о проверке системы на вирус). Суть данной опции в напоминании пользователю о необходимости антивирусной проверки системы, ее проведении и установке некоторых временных характеристик. Это означает, что на экран монитора в процессе загрузки выводится напоминание, совпадающее с названием опции. Выводится в виде вопроса, на который необходимо ответить. Сама же проверка на вирусы осуществляется с помощью встроенных программных средств. Для ответа возможны два варианта: "Yes" или "No". Если выбрать "No", вопрос-напоминание появится при следующей загрузке. Если выбрать "Yes", то будет произведена антивирусная проверка. Ну а временные характеристики - это и есть значения самой опции. Напоминание о проверке будет выводиться только в те дни, для которых производится дополнительная конфигурация. Конфигурационные значения опции могут быть следующие:
"Disabled" - функция "напоминания" отключена,
"Daily" - напоминание выводится каждый день в течение первой загрузки системы,
"Weekly" - то же самое, только раз в неделю,
"Monthly" - напоминание выводится только один раз в месяц, во время первой загрузки в текущем месяце.

Virus Warning
- (предупреждение о вирусе). Разрешение этого параметра ("Enabled") запрещает любую запись в загрузочный сектор жесткого диска (master boot record, или MBR, - главная загрузочная запись) или таблицу разделов (partition table). При попытке изменения этих областей BIOS останавливает систему с выводом на экран монитора соответствующего сообщения, а также подачей звукового сигнала. При этом пользователь может либо pазpешить запись, либо запpетить ее:
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
!!!WARNING!!!
Disk Boot sector is to be modified
Type "Y" to accept, any key to abort
Award Software, Inc
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Технически эта задача решается следующим образом.
На этапе проведения POST-теста перед входом в процедуру обработки дискового сервиса (INT13h) устанавливается транзитный программный модуль, который анализирует входные параметры функции и детектирует две ситуации: попытку записи в BOOT Sector и попытку форматирования 0-й дорожки. Если система условий выполняется, вместо дисковой операции выдается предупреждающее сообщение и звуковой сигнал. На соответствующем шаге теста выполняется перестановка вектора INT13h на транзитный контролирующий модуль, если в "BIOS Setup" включен данный режим. Данный алгоритм, в зависимости от прошивок (речь идет о несколько различных реализациях POST-процедур), может видоизменяться, но суть останется прежней. Подобным образом BIOS отслеживает ситуацию и при работе операционной системы.
Опция введена для защиты от так называемых boot-вирусов, поражающих загрузочный сектор. Естественно, что функционирование опции никак не распространяется на область данных жесткого диска. Стандартные действия при возникновении опасной ситуации - запуск антивирусных программ, прежде всего с защищенных дискет.
Эта опция должна быть обязательно отключена при форматировании жесткого диска, при вводе команды FDISK/MBR, при инсталляции операционных систем, при использовании администpатоpа начальной загpузки OS/2 (OS/2 Boot Manager), котоpый использует запись в загрузочный сектоp, при использовании дисковых менеджеров (EZ-Drive, OnTrack, MaxBlast и др.). Это означает, что BIOS не определяет различия между действительной вирусной атакой и, например, форматированием жесткого диска. Кроме того, некоторые диагностические программы при обращении к boot-сектору могут вызвать появление сообщения о "вирусной атаке", что не отражает текущую ситуацию. Применение этой функции не имеет смысла в случае использования SCSI- и ESDI-дисков (Enhanced Small Device Interface), поскольку они используют собственный BIOS на собственном контpоллеpе. В этом случае boot-вирусы "обходят" системный BIOS и напрямую прописываются на такие жесткие диски.
Но приведенная информация о "запретах" была бы неполной, если не учесть один существенный момент. Поскольку наиболее распространенные и чаще применяемые различные версии ОС "Windows" функционируют в защищенном режиме работы процессора, а подпрограмма "защиты" от вируса выполняется в реальном режиме, то включение опции может привести к заметному замедлению выполнения различных приложений.
Еще одним из возможных вариантов параметра может быть значение "ChipAway". С одной стороны это значение может восприниматься как аналог "Enabled", но прежде всего это один из варинтов встроенного в BIOS антивируса. При старте машины выводится надпись "ChipAway Virus Enabled", что не должно пугать пользователя. Но встроенный антивирус также окажется бесполезным при наличии собственного BIOS на внешнем контроллере жесткого диска.
Опция может называться также "Virus Protection", "Anti-Virus Protection", "BootSector Virus Protection".
Опция "Virus Warning" содержится и в "Phoenix BIOS", но с несколько другими значениями:
"Enabled" - система останавливается с выводом сообщения при попытке изменения загрузочного сектора,
"Confirm" - изменения вступают в силу автоматически. Это как раз и может потребоваться при инсталляции новой ОС,
"Disabled" - загрузочные сектора не проверяются (по умолчанию).

Wait for <F1> If Any Error
- если опция включена, BIOS будет ожидать нажатия клавиши <F1> для продолжения загрузки в случае какой-либо неисправности, определенной на стадии тестирования POST, но только в случае нефатальной ошибки. При этом может быть задан перечень аварийных событий, требующих подтверждения пользователя. Если установлено в "Disabled", система выводит пpедупреждение и пpодолжает загpузку без ожидания нажатия клавиши. Рекомендуется устанавливать в "Enabled" (или "Yes"). "Disabled" (или "No") может быть рекомендовано для серверных систем, работающих с отсоединенной клавиатурой.
Как видим, данная опция "AMI BIOS" по содержанию и своим действиям очень близка "эвардовской" "Halt On".

Weitek Coprocessor
- (сопpоцессоp Weitek). Если он имеется в системе, следует установить "Enabled". Интересно, что производительность этого сопроцессора в 2-3 раза превышала производительность стандартных интеловских. Сопроцессор Weitek использует (скорее, использовал) некотоpую часть системного ОЗУ, поэтому память из этой области должна была быть отобpажена где-нибудь в дpугих адpесах. Одна из "древних" опций "AMI BIOS". В свое время сопроцессор "Weitek" применялся в системах на 386-х процессорах.


BIOS. Продолжение!

1.1. Beeps

Если пpи проведении начального самотестирования системы возникают пpоблемы и BIOS не может завершить начальный тест, то можно услышать некоторую последовательность звуковых сигналов. Во многих случаях это помогает локализовать неисправность.

Сокращения: (к - короткий, д - длинный сигнал).

"AMI BIOS":

1д - POST Passed
- тест прошел без ошибок.
1д, 2к - Video failure
- нарушения в работе видеоарты. Возможны две причины:
а) сбой контрольной суммы Video BIOS ROM,
б) ошибка схемы, отвечающей за горизонтальную синхронизацию луча.
1д, 3к - Video failure
- возможны такие причины сбоев:
а) ошибка цифро-аналогового преобразователя,
б) ошибка при проверке локальной видеопамяти,
с) ошибка в процессе определения монитора.
Как правило, ремонт видеокарт малополезен, хотя, если дело касается только видеопамяти, то замена имеет смысл.
1к - DRAM refresh failure
- ошибка схемы регенерации памяти. Проверить правильность установки чипов памяти, при необходимости заменить.
2к - Parity Circuit Failure
- ошибка схемы четности памяти. Ошибка была найдена при проверке первых 64K основной памяти. Проверить правильность установки чипов памяти, при необходимости заменить.
3к - Base 64K RAM failure
- отказ первых 64K основной памяти. Проверить правильность установки чипов памяти, при необходимости заменить.
4к - System Timer Failure
- неисправен системный таймер. Проверить соответствующие модули на материнской плате (с возможной их заменой). В противном случае требуется замена материнской платы.
5к - Processor Failure
- нарушено функционирование процессора. Возможна переустановка процессора для улучшения контакта, а также проверка правильности установки перемычек для данного типа процессора.
6к - Keyboard Controller 8042/Gate A20 error
- ошибка адpесной линии A20 контpоллеpа клавиатуpы. Контроллер клавиатуры (8042) содержит переключатель, позволяющий процессору работать в виртуальном режиме. Это сообщение означает, что BIOS не в состоянии переключить процессор в защищенный режим. Необходимо вначале проверить клавиатуру и соединительный кабель. Необходимо также обратиться к опции "BIOS SETUP" - "Fast Gate A20", поэкспериментировав с ней. Необходимо переустановить чип контроллера клавиатуры либо заменить его. В противном случае потребуется замена материнской платы.
7к - Virtual Mode Exception Error
- ошибка исключения виpтуального pежима. Скорее всего нарушена работоспособность процессора (при этом процессор генерирует специальное прерывание), а возможно и чипсета.
8к - Display Memory Read/Write Test Failure
- ошибка теста чтения/записи памяти дисплея. Процессор не может обратиться к отображаемой видеопамяти графической карты. Проверить установку платы в разъеме, переустановить память на ней. В противном случае потребуется заменить видеокарту.
9к - ROM BIOS Checksum Failure
- ошибка контрольной суммы микросхемы BIOS. Необходимо попытаться переустановить этот чип. В противном случае необходимо перепрошить его или заменить микросхему.
10к - CMOS Shutdown Register Read/Write Error
- обнаружена ошибка при обращении к CMOS-памяти. Вызвать, если это возможно, "BIOS SETUP" и заново сохранить данные. Поскольку в большинстве случаев эта микросхема впаяна, то потребуется замена материнской платы.
11к - Cache Error/External Cache Bad
- неисправна внешняя кэш-память. Проверить правильность посадки модулей памяти. Если они припаяны, то также возможна замена материнской платы.

"AWARD BIOS":

1к - POST Passed
- тест прошел без ошибок.
1д, 2к (3к) - Video failure
- нарушена работа видеоканала. Система не обнаруживает монитор или графическую карту. В этом случае BIOS не может отобразить на экране сообщение об ошибке. Необходимо проверить установку платы в слот, а также исправность разъемов. Все аналогично, как и для "AMI BIOS".
2к
- обнаружена "легкая" ошибка. Например, не найден (или неисправен) жесткий диск. Необходимо, прежде всего, проверить разъемы и параметры диска.

1.2. Errors

В процессе старта системы и проведения POST-теста возможны различного рода аппаратные ошибки, сопровождаемые параллельным выводом на экран монитора соответствующих сообщений. Некоторые из приведенных ниже сообщений несколько утратили свою актуальность. Несколько ограничены сообщения об ошибках с EISA-шиной, SCSI-интерфейсом и "серверные" ошибки. В остальном, этот материал будет несомненно полезен.

Motherboard
BIOS ROM checksum error - System halted
- проверочная сумма при тесте ПЗУ по адресу F0000H-FFFFFH ошибочна. Возможно потребуется восстановление (перепрошивка) микросхемы с Flash BIOS.
BIOS update for installed CPU failed
- нарушение процесса обновления микрокода в процессоре (см. выше опцию "BIOS Update"). Одно из возможных действий - перезапись микросхемы с Flash BIOS. Эта тема в данных материалах не рассматривается.
CH-2 Timer Error
- ошибка второго таймера на системной плате. Большинство систем имеет два таймера.
CMOS battery failed, CMOS Battery Has Failed, CMOS Battery State Low, State Battery CMOS Low, CMOS Battery Low, System battery is dead, System battery is dead - Replace and run SETUP
- эти сообщения в начале загрузки компьютера свидетельствуют о неисправности батареи, ее разрядке или о возможном снижении питающего напряжения CMOS. Отсюда и возможные действия пользователя. Необходимо проверить напряжение на батарее при выключенном ПК (оно должно превышать 3В), необходимо проверить правильность установки соответствующего джампера на плате (если он присутствует) и при необходимости заменить батарею.
CMOS Checksum Error, CMOS Checksum Failure, System CMOS checksum bad, CMOS checksum bad
- неправильная контрольная сумма CMOS. После сохранения конфигурационной информации, в CMOS RAM генерируется контрольная сумма, которая проверяется затем на наличие ошибки. Вывод сообщения об ошибке свидетельствует о повреждении данных в CMOS, возможно из-за сбоя батареи или вирусного вмешательства. Если попытка восстановления "BIOS Setup" окажется неудачной, возможно придется обращаться в сервисный центр со своей материнской платой.
CMOS checksum error - Defaults loaded
- аналогичное сообщение, но с попыткой системы использовать заводские установки при загрузке.
CMOS Display Type Wrong, DISPLAY SWITCH IS SET INCORRECTLY, Display Switch Not Proper, DISPLAY TYPE HAS CHANGED SINCE LAST BOOT, CMOS Display Type Mismatch, Type Display CMOS Mismatch, Monitor type does not match CMOS - RUN SETUP
- неправильно выставлен тип монитора (монохромный или цветной) или изменился тип дисплея со времени последней загрузки. Переставить соответствующий джампер на материнской плате в правильное положение (Color/Mono - для устаревших систем) или исправить тип дисплея в "BIOS Setup".
CMOS Memory Size Mismatch, Memory Size Changed, MEMORY SIZE HAS CHANGED SINCE LAST BOOT
- объем физической памяти на материнской плате, определенный в течение POST-теста, не совпадает с тем, что хранится в CMOS. Или сообщение вызвано тем, что изменился размер памяти со времени последней загрузки. Причиной для этих сообщений может быть как физическое изменение (добавление/удаление модулей памяти), так и неисправность компонентов памяти. Необходимо перезапустить "BIOS Setup" (или "EISA Configuration Utility"), проверить все установки об объемах используемой памяти. После перезагрузки ПК ошибка может исчезнуть, иначе потребуется замена компонентов материнской платы.
Memory Size Decreased, Memory Size Increased
- аналогичные сообщения, но с конретным указанием уменьшения/ увеличения установленной памяти.
CMOS System Options Not Set, CMOS Settings Wrong
- данные в CMOS повреждены или отсутствуют. Действия пользователя аналогичны вышеприведенным.
CMOS Time and Date Not Set, CMOS Date/Time Not Set
- нарушены или не установлены параметры даты и/или времени. Задача сводится к проверке или установке этих параметров в "BIOS Setup".
DISKETTE DRIVES OR TYPES MISMATCH ERROR - RUN SETUP
- типы дисководов, фактически установленных в системе, и их описания в CMOS не совпадают. Необходимо запустить "BIOS SETUP" и ввести правильные типы дисководов.
Real time clock failure, Real time clock error
- ошибка часов реального времени. Необходимо вызвать "BIOS Setup" и попытаться установить правильное время. Если ошибка не исчезнет, то возможно придется обращаться в сервисные службы.
System timer error
- ошибка системного таймера на плате.

NVRAM:
NVRAM Checksum Error
NVRAM Data Invalid
NVRAM Cleared
- конфигурационные данные ESCD будут заново инициализированы, поскольку была выявлена ошибка в контрольной сумме NVRAM (Non-Volatile RAM - энергонезависимая память).
Checking NVRAM
Update OK!
Updated Failed
- производится проверка NVRAM. Данные NVRAM были нарушены, но их обновление прошло нормально. Данные NVRAM нарушены, их обновление оказалось невозможно.

Boot
Boot error Press F1 to retry (Phoenix)
- ошибка указывает на отсутствие жесткого диска или загрузочных областей. Возможно не выбран активный раздел.
CPU ID 0x failed
- ошибка инициализации процессора во время проведения POST-теста. Если такая ошибка появилась в серверной системе, то можно попробовать отключить установки в статусном меню CPU. В остальных случаях требуется вмешательство специалиста.
DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER
- не найден загрузочный диск. Прежде такое сообщение указывало на невозможность доступа к загрузочному устройству или на его отсутствие. А в качестве таких устройств могли фигурировать жесткий диск или флоппи-дисковод. Ныне к таким устройствам добавились CD-ROM, сетевые адаптеры с возможностью удаленной загрузки, т.п. (см. выше). Необходимо проверить правильность подключения стандартных дисководов, попытаться загрузиться с дискеты и проверить системные файлы на жестком диске.
Diskette Boot Failure, Invalid Boot Diskette
- дискета в дисководе А: не является загрузочной, т.е. невозможно загрузиться с дискеты в процессе запуска ПК. Дискета может не быть загрузочной, либо системные файлы повреждены.
Invalid Drive Specification
- жесткий диск не разбит на разделы, записи таблицы разделов повреждены или содержат неверные данные. Все действия необходимо начать с помощью программы FDISK.
Invalid Media in Drive D:
- это означает, что жесткий диск еще не разбит на разделы.
Invalid Media Type
- поврежден (или не инициализирован) загрузочный сектор, каталог или таблицы FAT. Диск может быть разбит на разделы, но не отформатирован.
Missing Operation System
- это сообщение, как и некоторые другие, не связано с проведением процедуры POST. Вывод этого сообщения ("Отсутствует операционная система") говорит, в лучшем случае, об отсутствии или нарушении основных конфигурационных файлов системы, а также о возможных нарушениях таблицы разделов жесткого диска. Запись в таблице раздела может указывать на сектор, который не является началом раздела. Причина ошибки может исходить и из главной загрузочной записи.
Для решения проблемы прежде всего необходимо проверить правильность установки параметров в BIOS (возможен сбой из-за разряда батареи). Главную загрузочную запись можно восстановить с помощью команды FDISK/MBR. Либо потребуется переформатирование логических разделов с последующей установкой ОС.
Operating system not found
- почти аналогичное сообщение, но требующее проверки параметров дисководов в "BIOS Setup", в том числе и в опции "Boot Sequence".
Override enabled - Defaults loaded
- если система не в состоянии загрузиться, используя текущую CMOS-конфигурацию, BIOS перезаписывает ее и устанавливает значения параметров по умолчанию.
PRESS A KEY TO REBOOT
- сообщение выводится после вывода информации об обнаружении ошибки в процессе выполнения POST-теста с необходимостью дальнейшей перезагрузки ПК. Нажать любую клавишу.
Press ESC to skip memory test
- предоставляется возможность пропустить полный тест памяти.
PRESS F1 TO DISABLE NMI, F2 TO REBOOT
- проблемы с немаскируемыми прерываниями. Возможно ошибка в работе контроллера прерываний, хотя ошибка может возникнуть и при проверке памяти по четности. Речь идет об обработчике-заглушке немаскируемого прерывания (Non-maskable Interrupt). Это не один из этапов POST, а процедура, на которую указывает вектор немаскируемого прерывания. Если возник запрос NMI, и не удалось идентифицировать причину NMI, в Port80 выводится этот код, на экран выводится сообщение: "Press F1 to disable NMI, F2 to reboot". И ожидаются действия пользователя по блокированию возникшей проблемы или для перезагрузки.
Primary Boot Device Not Found
- не найдено первичное загрузочное устройство (жесткий диск, флоппи, CD-ROM, т.п.). Необходимо проверить правильность подключения соответствующих устройств и установки по ним в "BIOS Setup".
No Boot Device Available
- аналогично.
NO ROM BASIC - SYSTEM HALTED (AMI)
- обозначает остановку процесса загрузки из-за повреждения или отсутствия загрузочного сектора, или главной загрузочной записи на загрузочном диске. Возможна даже ситуация, когда первичный раздел не активизирован. В этом случае надо воспользоваться, например, программой FDISK.EXE. Причиной ошибки может быть и неправильная установка параметров жесткого диска в "BIOS Setup". Но по большому счету речь может идти об отсутствии загрузочного устройства, будь то гибкий или жесткий диск, сетевой адаптер, т.п., с одной стороны, а с другой, об отсутствии интерпретатора BASIC в ПЗУ (прошивался в первых моделях ПК).
Действия пользователя при этом практически те же, что описаны для сообщения "Missing Operation System".
SYSTEM HALTED, (Ctrl-Alt-Del) TO REBOOT
- обозначает остановку процесса загрузки после обнаружения серьезной ошибки. Необходимо перезагрузить ПК с помощью одновременного нажатия трех указанных клавиш либо повторного включения питания. Возможно ошибка исчезнет.

Remote Boot:
After booting, my computer experiences problems
- после успешной удаленной загрузки возникли проблемы на компьютере клиента сети.
Flash device wrong size
- полная версия "Intel Boot Agent" не может загрузиться в память сетевого адаптера, поскольку ее размер составляет менее 64 КБ.
Media test failure, check cable
- определена неисправность в подключении сетевого кабеля к разъему RJ-45 на сетевом адаптере.
My computer does not complete POST
- невозможность загрузки "Intel Boot Agent", вызванная нарушениями в предварительном самотестировании.
PXE-E00: This system does not have free conventional memory. The Boot Agent cannot continue
- "Intel Boot Agent" не может получить в свое распоряжение достаточный объем свободной памяти в пределах первых 640 КБ системного ОЗУ для инсталляции программного обеспечения PXE-клиента.
PXE-E04: The LAN adapter is not functioning correctly or the wrong Boot Agent is installed. The Boot Agent cannot continue
- "Intel Boot Agent" не в состоянии прочитать один или более конфигурационных регистров PCI-адаптера. Адаптер может быть расконфигурирован или имеет место сбой программного обеспечения, инсталлированного на адаптере.
PXE-E06: This system does not support PCI option ROMs. The Boot Agent cannot continue
- не поддерживается распределение в верхней памяти BIOS сетевого адаптера в соответствии с PXE-спецификацией. "Intel Boot Agent" не может функционировать в этой системе. "Intel Boot Agent" возвращает управление основному BIOS системы и отказывается от удаленной загрузки.
This option has been locked and cannot be changed
- это сообщение выводится, когда пользователь пытается изменить конфигурационные установки, заблокированные системным администратором.
When using RPL protocol, the boot does not proceed normally
- невозможность удаленной загрузки при использовании стандартного RPL-протокола. Необходимо изменить тип протокола в "Boot Agent Setup" на PXE.

Chipset
8042 Gate - A20 Error!, GA20 Error
- неисправность работы вентиля линии A20 контроллера клавиатуры (8042). Заменить, если это возможно, контроллер клавиатуры. Ошибка может проявиться и во время переключения в защищенный режим работы процессора в процессе проведения теста POST. В некоторых случаях эту ошибку можно обойти, переведя в "BIOS Setup" опцию управления линии A20 на управление с помощью чипсета.
Address Line Short!
- проблема со схемой декодирования адреса памяти, адресных линий модулей памяти или с самими модулями. Имеет смысл перезагрузиться. Проблема может разрешиться сама собой. В противном случае возможно потребуется замена системных компонентов.
BUS Timeout NMI at Slot X
- ошибка тайм-аута обращения по системной шине для платы расширения в слоте X (EISA).
Fail-Safe Timer NMI
- прерывание от таймера, вызванное превышением допустимой длительности шинного цикла, которая контролируется системой.

Memory
Cache Memory Bad, Do Not Enable Cache!, Cache Memory Bad, System Cache Error
- ошибка внешней кэш-памяти. Возможно потребуется замена соответствующего компонента. Хотя сначала стоит попробовать просто перезагрузиться или отключить кэш в "BIOS Setup".
ECC Error
- некорректируемая ошибка в памяти. Ее адрес не может быть определен. Возможно потребуется обращение в специализированные технические службы.
Expansion ROM Allocation Fail
- ошибка выделения в основной памяти базового адреса для ПЗУ внешнего устройства.
Extended RAM Failed at offset: nnnn
System RAM Failed at offset: nnnn
- ошибка инициализации памяти. Произошел сдвиг начального адреса на nnnn-диапазон.
I/O Card Parity Error at xxxxx
- ошибка по четности по адресу ххххх при проверке отображаемой памяти карты расширения. Если адрес не может быть определен, то сообщение имеет вид
I/O Card Parity Error ????
Memory Address Error at XXXX
- ошибка в одном из модулей памяти с указанием конкретного адреса. Возможно требуется замена модуля.
Memory mismatch, run Setup
- необходимо установить опцию "Memory Relocation" в "Disable" (см. ниже).
Memory Parity Error at XXXX
- ошибка контроля четности при тестировании адреса ХХХХ. Если память поддерживает контроль четности, то требуется ее замена. Если адрес не может быть определен, то сообщение имеет вид
Memory Parity Error ????
Memory test fail
- BIOS сообщает, что при тестировании памяти имелись ошибки. При этом дополнительно сообщается о типе и месторасположении ошибки.
Memory Verify Error at XXXX
- ошибка при тестировании памяти, точнее при попытке записи по определенному адресу. Если ошибка повторяется, то потребуется замена памяти.
Off Board Parity Error, OFF BOARD PARITY ERROR ADDR (HEX) = (xxxx)
- ошибка по четности памяти, установленной на карте расширения.
OFFENDING ADDRESS NOT FOUND, OFFENDING SEGMENT
- это сообщение выводится как конъюнкция (логическое "И") операций проверки "I/O CHANNEL CHECK" и "RAM PARITY ERROR", когда ни одно из устройств, вызвавших проблему, не может быть точно определено. Возможна проблема и с контроллером памяти.
On Board Parity Error
- ошибка контроля четности системной памяти. Ошибка может быть вызвана соответствующей периферией, занимающей адрес, указанный в сообщении об ошибке.
Parity Error
- нелокализованная ошибка по четности при проверке системной памяти.
RAM PARITY ERROR - CHECKING FOR SEGMENT
- ошибка контроля четности памяти.
Uncorrectable ECC DRAM error
- некорректируемая ошибка памяти.

PCI
On Board PCI VGA not configured for Bus Master
- это сообщение выводится, когда интегрированная на системной плате видеокарта не настроена для работы в режиме "захватчика" шины. В "BIOS Setup" необходимо найти опцию "Shared PCI Master Assignment" (или аналогичную), установить значение "VGA".
PCI Error Log is Full
- это сообщение выводится, когда журнал фиксации конфликтных ситуаций содержит более 15 конфликтов, связанных с PCI-шиной. Дополнительные ошибки не будут заноситься в журнал (см. раздел о серверных установках).
Unknown PCI error
- нелокализованная ошибка PCI-устройства. Необходимо проверить все устройства на PCI-шине. Причина может быть и в мостовой схеме.

Resources
Bad PnP Serial ID Checksum
- контрольная сумма идентификационного номера P&P-устройства ошибочна.
DMA #1 Error, DMA #2 Error
- ошибка первого/второго канала DMA. Ошибка может быть вызвана соответствующим периферийным устройством.
DMA Bus Time-out
- устройство, работающее в режиме DMA, удерживает шину (цикл шины) более 7,8 мкс. Проблема в платах расширения или других "съемных" компонентах (модули памяти, например). Необходимо найти такое устройство, которое вызывает эту ошибку, и заменить ее. Причиной может быть и неисправность материнской платы.
DMA Error
- ошибка контроллера DMA. Возможна замена материнской платы.
Equipment Configuration Error
- ошибка конфигурирования ресурсов оборудования системы.
Floppy Disk Controller Resource Conflict
- контроллер флоппи-дисковода запрашивает ресурс, уже используемый.
INTR #1 Error, INTR #2 Error
- первый/второй контроллер прерываний не прошел POST. Необходимо проверить устройства, занимающие IRQ 0-7/IRQ 8-15.
Invalid System configuration Data
- нарушение области ESCD. Необходимо войти в "BIOS Setup" и опцию "Reset Configuration Data" (или аналогичную) установить в "Yes". Возможны также дополнительные действия по конфигурированию ресурсов через "BIOS Setup" или с использованием "ISA configuration utility".
Invalid System Configuration Data - run configuration utility
Press F1 to resume, F2 to Setup
- аналогичный и более полный вариант сообщения.
IRQ Setting Error,
I/O Resource Conflict(s),
Onboard xxx ... Conflict(s),
Onboard Parallel Port Conflict(s), Parallel Port Resource Conflict,
Onboard Parallel Port IRQ Conflict(s),
Onboard Serial Port Conflict(s),
Onboard Serial Port IRQ Conflict(s)
- эти все сообщения о конфликтности выделения ресурсов для конкретных устройств или системном распределении ресурсов требуют от пользователя стандартных действий. Ведь причина конфликта может быть достаточно проста. Устройству, например, выделен ресурс, уже используемый. Надо понять причину конфликта, определить, какой ресурс его вызвал: адрес ввода/вывода или прерывание. Дальнейшие действия - "ручное" изменение ресурса, будь-то установки в "BIOS Setup" или перемычки на плате расширения, и перезапуск системы.
PCI I/O Port Conflict
- два устройства запрашивают один и тот же ресурс.
PCI IRQ Conflict
- два устройства запрашивают один и тот же ресурс.
PCI Memory Conflict
- два устройства запрашивают один и тот же ресурс.
PnP ISA Card(s) Disabled
- неверно определенный ресурс карты расширения не позволяет системе ее использовать.
Primary Input Device Not Found
- назначенное первичное входное устройство (клавиатура, "мышь" или другое) не обнаружено.
Primary/Secondary IDE Controller Resource Conflict
- первичный/вторичный IDE-контроллер запрашивает ресурс, уже используемый.
Serial Port 1 Resource Conflict
- первый последовательный порт запрашивает ресурс, уже используемый.
Serial Port 2 Resource Conflict
- второй последовательный порт запрашивает ресурс, уже используемый.
Static Device Resource Conflict, System Device Resource Conflict
- не-P&P ISA-карта запрашивает ресурс, уже используемый.

Keyboard
K/B Interface Error, Keyboard/Interface Error
- ошибка связи с клавиатурой. Проверить подсоединение клавиатуры, проверить положение переключателя XT/AT на клавиатуре, а также поэкспериментировать с опцией "Halt On". В противном случае возможно неисправен контроллер клавиатуры.
Keyboard controller error
- ошибка контроллера клавиатуры. Необходимо вначале подключить другую клавиатуру.
Keyboard Error
- ошибка клавиатуры. Проверить подключение клавиатуры и соответствие типа клавиатуры контроллеру. А также необходимо проверить "временные" установки в "BIOS Setup". Можно попытаться отключить тестирование клавиатуры при загрузке.
Keyboard error nn
- ошибка клавиши на клавиатуре. В шестнадцатеричном виде указан ее код.
KEYBOARD ERROR OR NO KEYBOARD PRESENT
- ошибка инициализации клавиатуры или клавиатура отсутствует. Все действия аналогичны. Необходимо также удостовериться, что во время включения ПК не нажата какая-либо клавиша, а также проверить соответствие наличия клавиатуры и установок в "BIOS Setup".
Keyboard failure, press [F1] to continue
- причиной такого сообщения могут быть неконтакт (обрыв) кабеля клавиатуры, заедание какой-либо наиболее часто используемой клавиши. Но прежде всего необходимо проверить установки опций "Typematic Rate" и "Typematic Delay", так как может иметь место несовместимость установок клавиатуры в "BIOS Setup".
Keyboard is locked ... Unlock it
- необходимо разблокировать клавиатуру. Причиной такого сообщения может быть блокировка клавиатуры защитным ключом. Возможно потребуется проверить правильность подсоединения ключа к разъему материнской платы.
Keyboard is locked out - Unlock the key, Keyboard Stuck Key Failure
- "Phoenix BIOS" сообщает о залипании клавиши. Вполне возможно случайное удержание какой-либо клавиши (клавиш) во время тестирования системы.
PS/2 Keyboard Interface Error - необходимо проверить правильность подсоединения клавиатуры, возможна неисправность контроллера клавиатуры или интерфейсной схемы ввода/вывода.
PS/2 Keyboard Error or Keyboard Not Connected
- необходимо проверить правильность подсоединения клавиатуры.

Floppy
Diskette drive A/B error, Incorrect Drive A/B - run SETUP
- необходимо проверить правильность установок в "BIOS Setup", а также правильность подсоединения дисководов.
FDD Controller Failure, Floppy Disk Controller Error, FLOPPY DISK CNTRLR ERROR OR NO CNTRLR PRESENT
- ошибка связи с контроллером гибких дисков, невозможность инициализации контроллера, ошибка контроллера. Проверить подсоединение дисковода и его разрешенность на мультикарте (для устаревших систем).
Floppy disk(s) fail
- нельзя найти или инициализировать контроллер или сам флоппи-дисковод. Действия аналогичны.
Floppy disk(s) fail (40)
- это сообщение в конце теста ПК говорит о возможной ошибке в подключении шлейфа. Непрерывно светящийся индикатор также свидетельствует о неправильном подключении. Ошибка может заключаться и в несоответствии типа флоппи-дисковода, установленного в "BIOS Setup".

HD
ERROR ENCOUNTERED INITIALIZING HARD DRIVE, Failure Fixed Disk 0/1, Fixed Disk 0/1 Failure, Hard disk(s) diagnosis fail, C:/D: Drive Error, C:/D: Drive Failure, Hard Disk(s) fail (20)
- не инициализируется жесткий диск (жесткие диски). Проверить установку контроллера жестких дисков (для устаревших систем), соединительные кабеля, проверить установку джамперов на жестком диске, а также параметры "BIOS Setup". Но причина может заключаться и в неисправности диска, и жесткий диск может оказаться неформатированным.
ERROR INITIALIZING HARD DRIVE CONTROLLER, HARD DISK INSTALL FAILURE, HDD Controller Failure, Hard Disk Controller Failure, Fixed Disk Controller Failure, Hard Disk(s) fail (40)
- ошибка связи с контроллером жестких дисков, контроллер жестких дисков не инициализируется, неисправность контроллера. Проверить установку контроллера, подсоединение дисковода, подключение соединительных кабелей к системной плате, т.п. и параметры жесткого диска в "BIOS Setup". Также стоит проверить установку джамперов на жестком диске. Причина может быть и в том, что в ПК имеется диск SCSI, но BIOS материнской платы ожидает также наличия диска IDE. Надо войти в "BIOS Setup" и отключить жесткий диск.
HARD DISK initializing
Please wait a moment
- некоторые старые диски требовали дополнительного времени для инициализации. Понятно, что это сообщение не об ошибке.
HARD DISK INSTALL FAILURE
- нельзя найти или инициализировать контроллер или сам жесткий диск. Действия те же, т.е. проверить все механические установки и подключения, а также правильность установок в "BIOS Setup".
Primary IDE channel no 80 conductor cable installed - "современное" сообщение, и вывод его связан с подключением обычного 40-жильного соединительного кабеля к разъему контроллера с интерфейсом UDMA/66 и выше.
Primary/Secondary master/slave hard disk fail, Pri/Sec master/slave HDD Error, IDE Primary/Secondary Channel Master/Slave Drive Error
- POST определил ошибку в первичном/вторичном "master"/"slave" IDE-жестком диске.
Pri/Sec Master/Slave Drive - POST сообщает, что устройство несовместимо с интерфейсом ATAPI. Необходимо проверить правильность установок в "BIOS Setup".
Resuming from disk, Press TAB to show POST screen
- это сообщение от "Phoenix Technologies" и оно характерно для систем, использующих функцию "save-to-disk" при выключении компьютера. Такое сообщение может быть выведено при рестарте системы, а нажатие указанной клавиши позволяет вывести дополнительную информацию на экран.

EISA
EISA Configuration is Not Complete
- информация о конфигурации EISA-шины и устройств на ней задана не полностью. Система может быть загружена без расширений EISA, т.е. как ISA-система, но это даст возможность выполнить полноценно все процедуры конфигурирования с помощью EISA Configuration Utility (ECU).
EISA CMOS Inoperational
- ошибка доступа (в процессе чтения/записи) к дополнительной CMOS-памяти, предназначенной для хранения конфигурации EISA-устройств. Одной из причин может быть неисправность батареи. Здесь и далее основная рекомендация - запуск ECU-утилиты.
EISA CMOS Checksum Failure, EISA Configuration Checksum Error
- контрольная сумма энергонезависимой памяти EISA некорректна или нельзя прочитать информацию об EISA-слоте. Возможно плата в слот установлена неправильно. Причиной также может быть неисправность батареи.
Expansion Board not ready at Slot X
- BIOS не может инициализировать плату расширения в слоте X. Проверить саму плату и ее конфигурацию.
ID information mismatch for Slot X Wrong Board in Slot X, Wrong Board In Slot
- идентификатор установленной платы расширения EISA не совпадает с записью в CMOS для этого слота. Возможно установлена плата с ошибочным ID.
Invalid Configuration Information for Slot X
- недействительна конфигурационная информация для платы расширения в слоте X.
Invalid EISA Configuration
- недействительна конфигурационная информация EISA. Конфигурация могла быть неправильно запрограммирована, или имеет место ее нарушение.
Slot X Not Empty, Slot X Should Be Empty But EISA Board Found
- слот X, записанный в конфигурации как пустой, занят платой расширения.
Slot X Should Have EISA Board But Not Found
- слот X сконфигурирован под плату расширения, но она не обнаружена.

SCSI
Device connected, but not ready
- "ultra-wide SCSI"-контроллер не получил ответ при запросе данных от инсталлированного SCSI-устройства. Необходимо установить "Send Start Unit Command" в "Yes" в SCSI-конфигурационной программе.
Start unit request failed
- BIOS не может отправить "Start Unit Command" в SCSI-устройство. Необходимо в SCSI-конфигурационной программе "Send Start Unit Command" установить в "No".
Time-out failure during...
- необходимо проверить терминирование SCSI-шины и правильность кабельных подсоединений. Возможно одно из устройств на SCSI-шине неисправно.

Server
Service Processor not properly installed
- неправильно инициализируется контроллер управления сервером.
Storage Extension Group = xy
Configuration error, x Storage Extensions(s) found, configured are y SE(s).
Device List: k1, k2 ...
- несоответствие установок "Server menu - Storage Extensions" найденным коммуникационным устройствам, где:
SEs - storage expansion units (устройства расширения хранения информации). Несоответствие их установленному числу,
xy - номер группы,
x - число SEs, найденных на коммуникационной шине,
y - число SEs, введенных в конфигурацию,
k1, k2 ... - идентификаторы устройств хранения.
Необходимо проверить и исправить установки в "BIOS Setup".


BIOS. Продолжение!

2. Chipset

Auto Configuration
- этот режим во включенном состоянии ("Enabled") позволяет системе самостоятельно определить оптимальную настройку параметров чипсета. Под оптимальной настройкой здесь подразумевается такая установка заранее определенных параметров чипсета, при которой максимально уменьшится возможность нестабильной работы компьютера, правда с возможной потерей в производительности. Кроме того, при активизации этого режима становятся недоступными для самостоятельного редактирования многие из опций "BIOS Setup".
При выборе значения "Disabled" поля этих же опций заполняются значениями, сохраненными в CMOS-памяти, но они уже доступны пользователю.

Chipset I/O Wait States
- опция для установки n тактов ожидания в процессе взаимоотношений чипсета с устройствами ввода/вывода. Увеличение значения повышает надежность совместной работы устройств, но несколько снижает быстродействие. Вот один из вариантов ряда значений: "2 WS" (2T), "4 WS", "5 WS", "6 WS".

Chipset Special Features
- (специальные возможности чипсета). Данный параметр разрешает/запрещает все новые функции, появившиеся в 430-х наборах Intel (HX, VX или TX) по сравнению с FX. Если установлено "Disabled", чипсет функционирует как 82430FX. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Какие же положительные преимущества могли быть утеряны при запрещении опции? Перечислим основные.
Чипсет i82430FX (январь 95г.) поддерживал спецификацию PCI 2.0. Все последующие (HX, VX - февраль 96, TX - февраль 97) были оптимизированы под спецификацию PCI 2.1, которая стала поддерживать параллельное выполнение операций на PCI-шине. Об остальных нюансах спецификации PCI 2.1 см.ниже.
Если "южные" мосты чипсетов FX, HX и VX поддерживали работу IDE-устройств в режиме "bus-master", то PIIX4 (PCI ISA IDE Xcelerator) чипсета 82430TX уже поддерживал новый интерфейс UDMA/33.
В чипсете 82430FX, в отличие от последующих, не была еще реализована поддержка USB-шины.
Чипсеты VX и TX, кроме FPM- и EDO-памяти, стали поддерживать SDRAM-память.
И, наконец, для чипсета 82430HX могла быть снята мультипроцессорная поддержка и поддержка контроля по четности и коррекции ошибок (ECC).
Опция могла называться и "Chipset Global Features".

Command per Cycle
- (команда за такт). Параметр разрешает или запрещает выполнение команд за один такт. Включение опции заметно повышает производительность системы, поэтому рекомендуемое значение - "Enabled".

Delayed Read Request Expiration
- довольно необычная опция, предложенная в свое время для некоторых серверных систем на чипсетах i450NX. Временными параметрами опции можно было установить (дословно) "истечение срока задержки для запроса на чтение". Еще более необычными были сами значения (в системных тактах): "16 Clocks", "64 Clocks", "128 Clocks" и (!) "2^15 clocks". К сожалению, ничего более к этой опции добавить нельзя.

Extended I/O Decode
- опция разрешения расширенного декодирования шины адреса при операциях ввода/вывода. Стандартный диапазон адpесов устpойств ввода/вывода - 0...0х3FF, что является следствием 10-pазpядного адpесного пpостpанства ввода/вывода, принятого еще в PC AT. Расшиpенное декодиpование позволяет получить более шиpокий диапазон адpесов, снимая при этом очень давние и жесткие ограничения. Ведь центральный процессор может поддеpживать 16 адpесных линий, что расширяет диапазон устройств ввода/вывода до 64К-адресного пpостpанства. Необходимо отметить, что большинство "старых" материнских плат и адаптеров ввода/вывода могли декодировать только 10 адресных линий, тем самым ограничивая количество используемых портов ввода/вывода.
Если речь идет о PCI-шине, то порты ввода/вывода шины PCI могут быть как 8-, так и 16-битными. Для адресации портов на шине PCI доступны все 32 бита адреса, но процессоры x86 могут использовать только младшие 16 бит. Кроме того, на адресное пространство PCI влияет и 10-битное декодирование адреса, принятое в традиционной шине ISA. В результате каждый адрес порта на шине ISA, в случае расширенного декодирования и использования сконфигурированных ISA-устройств, имеет 64 "псевдонима", смещенных друг от друга на 1К (40h). Последний факт означает, что и при расширенном декодировании, и при наличии ISA-карт возможности адресации для устройств PCI оказываются также ограниченными.
Но речь может идти не только об ограничениях. Возможны конфликты, особенно в тех случаях, когда программы (драйвера) и сами устройства работают с различными адресными форматами. В одном случае, с адресами в шестнадцатеричной форме, в другом, в двоичной. В одном случае, адрес читается слева направо, в другом, справа налево. Такое тоже случается!
Вернемся к декодированию и возможным конфликтам, к вопросу о 16- и 10-битном декодировании. В качестве примера можно привести "смешивание" адресов для COM4 и некоторых S3-видеокарт. И напоследок немножко арифметики. Стандартный адрес "Sound Blaster" - 220h (10 0010 0000). Для карты с адресом 2A20h (10 1010 0010 0000) имеем полное совпадение с 220h по младшим десяти разрядам.
Смотри дополнительно главу "Порты".

Fast Decode Enable
- (pазpешение быстpого декодиpования). В этой опции речь идет об аппаратном (выполняемом специальной логикой) декодировании команды формирования сигнала сброса процессора. А точнее об аппаpатных сpедствах, контpолиpующих команды, пеpедаваемые на контpоллеp клавиатуpы.
Первоначально в PC AT использовались специальные коды, необpабатываемые клавиатуpой, для упpавления пеpеключением 286-го пpоцессоpа из защищенного pежима в реальный. 286-й пpоцессоp не имел для этого встроенных аппаpатных сpедств, поэтому фактически должен был пеpезапускаться для такого пеpеключения. Естественно, что подобная опеpация очень тормозила работу системы. Поскольку это было недостатком разработок IBM, не предполагавшей что операционным системам могут потребоваться пеpеходы между защищенным и pеальным pежимами, то пpоизводители "клонов" (аналогов IBM PC) добавили несколько интегральных микросхем (PLD chips) для контpоля за командами, пеpедаваемыми на чип контpоллеpа клавиатуpы. И когда обнаpуживался код "пеpезапуск CPU" ("reset CPU"), то "новые" чипы выполняли немедленный пеpезапуск процессора вместо длительной процедуры опроса контpоллеpом клавиатуpы своего pегистpа ввода, pаспознавания кода и затем кратковременной остановки CPU. Это "быстpое декодиpование" команды пеpезапуска позволило "современным" "OS/2" и "Windows" пеpеключаться между защищенным и pеальным pежимом быстpее и дало более высокую пpоизводительность.
Впервые такая возможность включения и отключения логики быстpого декодиpования была реализована в клонах "Compaq" с "Phoenix BIOS". Для пpоцессоpов 386 и выше такая проблематика была снята, т.к. сами процессоры стали содержать встроенные средства для пеpеключения между pежимами.
На 286-х и 386-х системах такая функция могла относиться и к настройке декодирования адреса ISA-шины, что позволяло ускорить обмен с периферией. В данном случае речь уже шла о совместном функционировании 8-ми и 16-битных устройств, к тому же имевших на "своем борту" 8-ми или 16-разрядные RAM- или ROM-память. Примером тому был 8-битный BIOS ROM на VGA-карте, к адресному пространству которого (C000-Dfff) могли обращаться другие 8-разрядные периферийные утройства. И скорее "раннее" декодирование адресных линий позволяло избежать возможных конфликтов.
Опция могла называться и "Fast Decode", и с теми же значениями: "Enabled" и "Disabled".

Host Bus Fast Data Ready
- (быстрая готовность данных на системной шине). Включение опции позволит считывать имеющиеся на системной шине данные одновременно с их выборкой. В противном случае данные будут удерживаться на шине один дополнительный такт. Понятно, что запрещение опции повышает стабильность системы, но снижает скоростные характеристики. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может иметь название и без ссылки на системную шину - "Fast Data Ready". Эти опции встречались довольно часто во времена 440-х чипсетов.

ICH Decode Select
- опция для установки используемого интегрированным контроллером (ICH - см. ниже) типа декодирования. Значения могут быть следующие: "Subtractive" (метод с вычитанием) или "Positive" (позитивный).

PIIX4 SERR#
- данная опция "AMI BIOS" позволяет системе осуществлять дополнительный контроль над сигналом SERR# (System Error). Для этого опция должна быть включена ("Enabled"). Детально об этом сигнале рассказано в разделе, посвященном PCI-шине (см. ниже). Что касается PIIX4, то это PCI ISA IDE Xcelerator чипсета i430TX (и выше).

Pipelined Function
- эта опция во включенном состоянии разрешает использование (включение) специального конвейера, или просто механизма конвейеризации, который позволяет чипсету (системному контроллеру) сигнализировать центральному процессору об инициировании следующего адресного цикла еще до того, как обработаны все данные текущего цикла. В итоге процессор начинает следующий цикл еще до завершения предыдущего. Понятно, что данная опция имеет интегрированный характер, т.к. речь идет о системной поддержке конвейеризации. Включение режима конвейеризации повышает производительность системы. Его отключение ("Disabled") имеет смысл разве что при сбоях системы.
То же содержание заключено в опциях "CPU Pipeline Function", "CPU Pipelined Function", "CPU Addr. Pipelining".
Опция "P5 Piped Address" предназначена для системной поддержки механизма конвейеризации для процессоров AMD пятого поколения. По умолчанию опция устанавливается в "Disabled".

System Performance
- эта нестандартная опция "Phoenix BIOS" имеет два варианта использования. "Standard" предлагает загрузку системы с обычными установками многих параметров, нечто наподобие загрузки по умолчанию. "Fast" же дает возможность использовать автоматическую настройку параметров чипсета, памяти, жесткого диска, других элементов системы, приводящую к максимальной производительности.

2.1. Оптимизация функционирования PCI-интерфейса и ISA-шины

8 Bit I/O Recovery Time
- (время восстановления для 8-битных операций ввода/вывода). Параметр измеряется в системных тактах и определяет, какую задержку система будет устанавливать после выдачи запроса на чтение/запись устройства ввода/вывода до выдачи следующего аналогичного запроса. Т.е. речь идет о временной вставке задержки (интервала) между последовательными 8-битными операциями обращения к пространству ввода/вывода. Не совсем понятное "время восстановления" - это период гарантированной неактивности определенных сигналов ISA-шины. Еще в составе 8-битной ISA-шины (контакты B13 и B14 соответственно) были сигналы IOWR# (I/O Write) и IORD# (I/O Read), отвечающие за запись в порт и за чтение порта ввода/вывода. Уже понятно, что время восстановления - это управляемая пользователем пауза между повторяющимися упомянутыми сигналами.
Эта задержка необходима, так как цикл чтения/записи для устройств ввода/вывода существенно дольше, чем для памяти или других более скоростных устройств. Тем более, что в данной опции речь идет об устройствах на ISA-шине, работающей значительно медленее шины PCI, фактически PCI-периферии, и для правильной обработки сигналов ввода/вывода требуется вставлять паузы между последовательными PCI-циклами. Значение этого параметра по умолчанию равно одному такту (иногда двум), и его следует увеличивать только в случае установки в компьютер какого-либо медленного 8-битного устройства или устройства, вызвавшего проблемы. Может принимать значения от 1 до 8 тактов, с шагом в один такт, и "N/A" (Not Available). Некоторые источники указывали раньше о добавлении по умолчанию минимум 3,5 системных тактов при выборе значения "N/A"!? Если в системе ISA-устройство отсутствует, то необходимо установить "N/A". Оно же может оказаться оптимальным и для производительности системы.
С другой стороны, акцентирование внимания на ISA-шину может весьма озадачить неискушенного пользователя, обратившего внимание на такую же или подобную опцию в современной системе, напрочь лишенной какого-либо намека на ISA-шину. А ведь речь то идет не об ISA-устройствах, точнее, не только о них. Все, что было "южнее" ISA-шины, с ее исчезновением не исчезло. А это, напомним, и последовательные, и параллельный порты, и т.п. Поэтому при чтении нижеизложенных опций необходимо помнить и об этом.
К вышесказанному необходимо добавить упоминание еще о двух аналогичных опциях. "8-bit Recovery Delay" - явное указание на задержку, и "8-bit Recovery Enable" со значениями "No (3.5 SYSCLKs)" и "Delay As Below".
16 Bit I/O Recovery Time
- (время восстановления для 16-битных операций ввода/вывода). Все сказанное выше верно и для 16-битных операций ввода/вывода на ISA-шине, с той лишь разницей, что диапазон возможных значений - от 1 до 4 тактов и "N/A".
Ранее подобные функции носили названия: "16-bit Recovery Delay", "16-bit Recovery Enable", "16-Bit Recovery Time", и, как видим, аналогично и для 8 бит. Довольно разнообразны были и предлагаемые варианты параметров: 1 - 4, "3.5 SYSCLKs" и "Delay As Below", а также 2T - 5T. Для 8-битных устройств дополнительно можно добавить такие варианты: 0 - 7 (SYSCLKs) и еще такой ряд - 3T, 4T, 5T, 8T.
Ниже детально рассмотрена опция "I/O Recovery Time", несколько устаревшая, но представляющая несомненный интерес.

16 Bit ISA I/O Command WS
- данная опция используется для компенсации возможной разницы между скоростью работы системных устройств ПК и его периферии, и, как видно из наименования опции, речь идет о 16-битных операциях ввода/вывода. Подобная компенсация необходима, например, если в системе не выделено дополнительное время ожидания/ответа устройства. В таком случае система может решить, что какое-либо неуспевающее ответить устройство вообще не функционирует и перестанет давать запросы на ввод/вывод из этого устройства. Данную опцию необходимо отключать ("Disabled") для повышения быстродействия только в случае, когда все устройства в таком режиме нормально функционируют, в противном случае возможна потеря данных. Естественным является отключение опции при отсутствии в системе ISA-карт расширения.
Опция может называться "ISA 16-bit I/O Wait States". При этом появляется возможность установить количество тактов ожидания вручную: 0, 1, 2, 3.

16 Bit ISA Mem Command WS
- данная опция по назначению аналогична предыдущей, с той лишь разницей, что она позволяет нужным образом соотнести скорость работы памяти ISA-устройства с возможностью системы записывать/читать из этой памяти. Параметр может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может называться "ISA 16-bit Mem Wait States". При этом появляется возможность установить количество тактов ожидания вручную: 0, 1, 2, 3.
Опция может носить и более общий характер - "16-bit Memory, I/O Wait State". И поскольку абсолютно те же задачи необходимо решать для 8-битных операций ввода/вывода, то на это направлена опция "8-bit Memory, I/O Wait State". С помощью этих опций количество тактов ожидания также устанавливается вручную.

AT Cycle Wait State
- по прочтении предыдущих опций данная опция уже не представляет сложности. Вставка дополнительных тактов ожидания в AT-циклах может понадобиться при использовании старых ISA-карт, особенно если они соседствуют с более быстрыми картами расширения (например, высокоуровневыми графическими картами). Понятно, что увеличение задержек снижает скоростные характеристики системы. Но подобная задержка могла понадобиться и для корректной работы DMA-каналов. Устаревшая опция.
Но был еще один важный аспект в процедуре установки тактов ожидания для некоторой карты расширения. Если карта обеспечивала 16-разрядную передачу данных, то выставив сигнал "MEMCS16" (Memory Cycle Select), такая карта сообщала процессору о своей "организации". К сожалению, некоторые карты по разным причинам "не успевали" выставить данный сигнал, и процессор инициировал 8-разрядный режим передачи данных. Потери производительности системы очевидны. В данном случае установка дополнительных тактов ожидания приводила к "своевременной" выдаче запроса о 16-разрядности.

Back to Back I/O Delay
- установка опции в "Enabled" ведет к вставке трех дополнительных AT-тактов в последовательные операции ввода/вывода, осуществляемые через AT-шину. Устаревшая опция.

Bus Request when FIFO is
- о FIFO-буферах чуть ниже. А данная опция позволяет отслеживать степень заполненности такого буфера, и который действует по принципу - "первым пришел, первым ушел". Если шинный FIFO-буфер заполнен на n%, то шина вынуждена сигнализировать об этом. Сама опция несколько необычна, столь же нестандартны и ее значения: "75% Full", "50% Full".

Byte Merge Support
- при стандартных операциях чтения/записи данные, направляемые от центрального процессора к PCI-шине, могут удерживаться некоторое время в специализированном буфере и накапливаться там (аккумулироваться). Для применения такой буферизации данная опция должна быть включена ("Enabled"). Но речь в данном случае идет не просто о разрешении или выполнении каких-то действий, речь идет о механизме (алгоритме), который, кроме всего прочего, реализован также во многих операциях конвейеризации, например, "PCI Pipeline". Такой механизм называется "Byte merging", или, дословно, - "байт слияние".
Если взять, например, техническое описание материнской платы на базе чипсета i430HX, то среди перечисления возможностей данного продукта можно найти такие пункты:
- Write-Back Merging for PCI to DRAM Writes
- 8-QWord Deep Merging DRAM Write Buffer
Но сразу необходимо отметить, что не все чипсеты содержат в себе такие буфера "слияния". В более современных системах термин "merging" может отсутствовать вовсе, а речь может идти только о буферах "с отложенной записью", о предварительном "пакетировании", т.п.
Вернемся к механизму "слияния". В указанном выше буфере, а в этой роли может выступать и буфер с "отложенной" записью, 8- или 16-битные последовательные данные "сливаются" до размеров двойного слова (dword - double word, или 32 бита) и сопровождаются одним адресом (по сути функция "пакетирования"). Возможности накапливать некий объем данных зависят от размеров такого буфера, размер которого может варьироваться, хотя стандартно используются 32-битные циклы записи. Далее чипсет направляет данные во внутренний буфер PCI-шины в наиболее благоприятный момент. Повышение производительности явным образом проистекает из уменьшения числа PCI-транзакций и возможности использовать всю пропускную способность PCI-шины. Что же касается упомянутого варьирования размера буфера, то его размер может составлять и 64 бита. При этом системный контроллер способен "отследить" до восьми последовательных управляющих сигналов "CPU Byte Enable", приостанавливая пересылку данных к месту назначения до слияния пакетов.
Ранее любое расширение возможностей для передачи потоковой информации предназначалось прежде всего для повышения производительности трансляции видеоданных. Но потребность в механизме "byte merging" несколько шире. Речь может идти и о "слиянии" последовательных адресов и их данных в одну "PCI-to-memory"-операцию. А в наименовании вынесенной выше опции как раз и содержится поддержка "byte merging" со стороны всей системы. Но особый смысл и эффект от применения данного механизма заключен в "слиянии" данных в одну операцию для адресов памяти, не представляющих собой непрерывного адресного пространства.
Возвращаясь к упомянутой "PCI-to-memory"-операции, необходимо отметить значительное повышение производительности с применением "byte merging" для "старых" программных продуктов, осуществлявших циклы записи в видеопамять в виде отдельных байтов. Но такая трансляция, естественно, не поддерживается всеми PCI-графическими картами. И, тем не менее, установка опции в "Enabled" допустима, если при этом не происходит ухудшения видеоряда ("Frame Buffer Byte Merging").
Но проблема затрагивает не только графические карты. Речь может идти и о некоторых сетевых PCI-картах, в частности 3Com 3C905-серии от "noname"-производителей, установленных в определенные системные платы, например "ASUS P3V4X".
Опция может носить множество различных наименований. "Byte Merging" ("Byte Merge") предназначена для системной поддержки и неявным образом для PCI-операций, "PCI Write-byte-Merge" и "CPU to PCI Byte Merge" - уже явным образом предназначены для поддержки буферизации-"слияния" в цепочке "процессор - шина PCI". Опция "Word Merge" предлагает нечто другое. Речь уже идет о слиянии в пакеты отдельных слов, но по прежнему о трансляции данных в кадровый буфер (более чем конкретно указывает на это опция "Frame Buffer Word Merging"). Поэтому иногда в литературе можно встретить указание, что "байт слияние" производится только для VGA-диапазона в области адресов (0A0000-0BFFFF).
О системной поддержке говорит и опция "Linear Merge". Но при ее включении "слиянию" могут быть подвергнуты только последовательные, т.н. "линейные" адреса процессора. Это физические адреса, начиная с нулевого и заканчивая максимально возможным для данного типа процессора. Данная опция учитывает особенности процессоров Cyrix, и в свое время была введена в BIOS для поддержки, например, процессоров Cyrix M1/M2 (и тут есть дополнительный пример - "Frame Buffer Linear Merging").
Приведем названия еще некоторых опций: "PCI Byte Merging", "Write Merging", "PCI Single Write Merge", "Pipelining With Byte Merge", "Write Gathering".

CPU Dynamic-Fast-Cycle
- опция, позволяющая ускорить доступ к ISA-шине. Когда центральный процессор инициирует новый шинный цикл, PCI-шина вынуждена исследовать "адресность" команд на предмет принадлежности информации одному из своих устройств. Если такая принадлежность не определена, инициируется ISA-шинный цикл. Когда опция включена ("Enabled"), доступ к шине ISA ускоряется за счет уменьшения задержек между выдачей процессором оригинальной команды и началом ISA-цикла. Процедурное "упрощение" осуществляется при этом на уровне "северного" моста чипсета. См. также выше опцию "Fast Decode Enable".

CPU Read PCI Retry
- чуть ниже детально рассмотрены процедуры повтора инициированных центральным процессором циклов. В данной же опции речь идет о возможности повторения чипсетом ("Disabled"/"Enabled") инициированных циклов чтения из PCI-шины.

CPU-to-PCI 6 DW FIFO
- опция включения/отключения специального буфера, позволяющего устройствам обращаться к PCI-шине и считывать до 6 двойных слов (Double Word). Работа с буфером построена по принципу "первым пришел - первым ушел" (First Input - First Output). Естественно, что буферизация передачи информации повышает быстродействие системы, но в таком виде эта опция встречается уже редко.

CPU-to-PCI Bridge Retry
- когда установлено значение "Enabled", контроллер мостовой схемы сможет, взяв на себя инициативу, повторить инициированные процессором циклы записи в PCI-шину. Но должны быть соблюдены определенные условия. При включенном значении опции функции "Passive Release" и "Delayed Transaction" должны быть также включены. При этом речь идет о т.н. "nonLOCK#" PCI-циклах. Что это такое?
LOCK# (Bus Lock) - это сигнал монополизации управления шиной. При активном состоянии сигнала во время транзакции блокируется доступ к шине других абонентов. Этот сигнал используется для захвата шины задатчиком, что является одним из процедурных моментов режима "bus-master". Этот сигнал является выходным для процессоров, активно используется на PCI-шине для установки, обслуживания и освобождения требуемого ресурса.
Теперь понятно, что "nonLOCK#" PCI-циклы не связаны с захватом шины PCI-устройством, тем более, что под упомянутым "контроллером мостовой схемы" подразумевается контроллер "южного" моста, а значит получателями информации могут быть и периферийные устройства. В данном случае задатчиком является центральный процессор. Поэтому возможна ситуация, когда некоторое устройство на PCI-шине или "южнее" не получило "своей" информации, и она "залежалась", например, в упоминавшемся выше буфере "отложенной" записи.
Опция может называться "Host-to-PCI Bridge Retry", а для опции "CPU-to-PCI Bridge Retry" значениями могут быть также "No Retry" и "Retry First". Последние параметры несколько подтверждают то, что чипсет без инициативы "свыше" сам может выступить инициатором пересылки задержанных ранее данных в PCI-шину.

CPU to PCI Burst Memory Write
- включение данного режима позволяет компоновать (ассемблировать) последовательные циклы записи процессора в пакетные (burst) PCI-циклы записи. Иногда можно встретить в описаниях термин "интерпретация циклов чтения CPU шиной PCI". Это не совсем корректно, поскольку речь идет о предварительной аппаратной буферизации данных. В противном случае ("Disabled") каждый одиночный цикл записи в PCI-шину будет представлять собой связанную FRAME#-последовательность.
Сам процесс формирования пакетов происходит во внутренних буферах PCI-шины с отложенной записью, и, что также немаловажно, без участия процессора. Таких буферов может быть четыре (чипсет Orion, например, содержал как раз 4 таких буфера). Применение буферирования, как и во множестве других случаев, позволяет не прерывать передачу данных при занятости системной или локальной шин. При включении опции ("Enabled") данный режим повышает производительность системы, однако возможны и проблемы, если в системе установлены нестандартные PCI-карты (прежде всего VGA) или устаревшие карты, не поддерживающие пакетный обмен данными.
Несколько слов о сути пакетного режима и повышении производительности. В обычном режиме на каждое считываемое или записываемое слово выдается отдельный адрес, в блочном режиме адрес выдается на весь пакет данных, затем без задержек непрерывно выполняется серия циклов чтения/записи, что и делает пакетный режим максимально эффективным.
Одно пояснение! В данном случае, если циклы записи не являются пакетными, буфер записи может и не заполняться при незанятости PCI-шины, он естественно может заполниться при занятости шины, ведь речь не идет о разрешении или запрещении использования буфера записи. Но его "освобождение" в любом случае будет происходить в виде одиночных операций, как было указано выше.
Опция может носить множество названий: "CPU Burst Write Assembly", "CPU-to-PCI Bursting", "CPU/PCI Burst Mem. Write", "CPU to PCI Burst Write", "CPU-to-PCI Write Bursting", "PCI Burst Write Combine", "PCI Write Bursting", "PCI Write Burst", "PCI Write Burs", "PCI Burst Write", "PCI Burst Write Combining", "CPU Burst Write", "Burst Write Combining", "Write Combining", "PCI Burst", "PCI Bursting", "PCI Chaining", "Burst Write Cycles", ну и "CPU-To-PCI Burst Mem. WR.".
В дополнение к вышеизложенному необходимо отметить следующее! "Ассемблирование" чипсетом пакетов в направлении к PCI-шине является одним из примеров подобного пакетирования. Инициатором может быть и сам процессор. Поскольку применение подобных механизмов практически всегда имело целью повышение производительности системы со стороны передачи видеоданных, то такие процессоры, как Pentium Pro, Celeron, Pentium II и III имели и имеют внутренний 32-байтный буфер, который позволяет осуществить в одном цикле 32 операции записи, обеспечивая при этом передачу информации в видеопамять графической карты в 8-битном цвете. Кстати, не все программные среды позволяли использовать имеющиеся возможности процессоров для такого пакетирования. Возможности процессоров Athlon "раскрылись" в "Windows NT" только после обновления SP6 (Service Pack 6).

CPU-to-PCI FIFO Cleaning
- включение данной опции ("Enabled") позволит принудительно очищать упомянутый выше буфер FIFO ("сбрасывать инфомацию") при задержках в освобождении системной или локальной шины, а также при заполнении полностью данного буфера. Устаревшая опция.

CPU-to-PCI IDE Posting
- включение данного режима позволяет оптимизировать циклы записи из CPU в интерфейс PCI IDE путем предварительной буферизации с отложенной записью. Параметр рекомендуется устанавливать в состояние "Enabled". Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может носить название "CPU-to-IDE Posting".

CPU to PCI POST/BURST
- данные, переданные от центрального процессора к PCI-шине, могут быть буферизированы (буферы PCI-шины с отложенной записью - "posted") и собраны в пакеты, или нет. Возможны следующие методы:
"POST/CON.BURST" - буферизация и стандартное пакетирование,
"POST/Agg.BURST" - буферизация и активное пакетирование,
"NONE/NONE" - буферизация и пакетирование не установлены,
"POST/NONE" - буферизация установлена, пакетирование нет.

CPU-to-PCI Read Buffer
- опция включения/отключения специального буфера, позволяющего устройствам обращаться к PCI-шине и считывать до 4-х двойных слов, не прерывая при этом работу процессора. Процессор может работать в это время над другой задачей, что повышает общую производительность. Эта опция должна быть включена обязательно ("Enabled"). В отключенном же состоянии опции буфер не будет использоваться, и циклы чтения процессора не будут полностью укомплектованы до тех пор, пока шина PCI не подаст сигнал о готовности принимать данные.

CPU to PCI Read Burst
- включение данной опции ("Enabled") позволит компоновать последовательные циклы чтения центрального процессора в пакетные (burst) PCI-циклы. Все сказанное выше в опции "CPU to PCI Burst Memory Write" верно и для данной опции, ибо речь идет о тех же самых буферах записи. Поэтому представленные ниже вариации наименования опции могут указывать явно на процедуру "чтения", а могут носить и интегрированный характер:
"CPU-to-PCI Bursting", "PCI Read/Write Burs", "PCI Read/Write Burst", "PCI Bursting", "PCI Burst", "PCI Dynamic Bursting", "Dynamic Bursting", "Dynamic PCI Bursting", "PCI Streaming".
И еще одна опция. "PCI Burst Interrupting". А значения ее "Allowed" и "Not Allowed". Столь необычные значения ("разрешить"-"не разрешить") по сути аналогичны блокировке режима пакетирования или его включению. Стоит напомнить, что не все транзакции на PCI-шине являются пакетными. И если рассматриваемые опции отключены, то при занятости шины эти транзакции будут также накапливаться в буфере. Но освобождаться они будут в виде одиночных циклов.

CPU-to-PCI Write Buffer
- в данной опции речь идет об использовании буфера записи данных, поступающих из центрального процессора на шину PCI. При установке параметра в "Disabled" циклы записи не буферизируются (буфер отключен) и направляются непосредственно на PCI-шину. Может возникнуть предположение, что такой способ передачи данных более эффективен. Но, как всегда, возникает проблема компенсирования разницы в скоростных характеристиках между CPU и PCI-шиной. И в этом случае процессор будет постоянно находиться в состоянии ожидания после начала каждого цикла записи и до тех пор, пока шина PCI не сообщит процессору о своей готовности к приему следующих данных. Фактически центральный процессор будет "простаивать", не имея возможности решать другие задачи вплоть до завершения текущего цикла записи.
При включении буфера (опция включена) процессор сможет записывать в буфер записи шины PCI по 4 слова данных за один цикл, не ожидая завершения текущего цикла PCI-шины. Буферизированные данные могут быть записаны в PCI-шину с началом нового цикла чтения шины либо в момент готовности шины к приему данных.
Очевидно, что применение такого буферирования положительно сказывается на производительности системы. Иногда можно встретить информацию, что такой внутренний буфер чипсета построен на микросхеме 82C586B.
Опция может называться просто - "CPU to PCI Buffer". В этом случае речь может идти уже об интегрированной функции (т.к. буферизация носит двунаправленный характер - чтение/запись) с теми же параметрами: включены буферы/отключены буферы. Но в данном случае надо посмотреть соседние опции. Если есть опция с указанием буфера чтения, то понятно, что имеем дело с буфером записи. Хотя такая неоднозначность в названиях пары опций еще не встречалась.
Упомянем еще одну аналогичную опцию - "CPU-to-PCI Uses Write Buffer". Ее значения - "No" и "Yes".

CPU-to-PCI Write Latency
- опция установки времени задержки перед операцией записи данных из процессора в шину (в тактах системной шины). Установка меньшего значения позволяет увеличить производительность, однако при этом возможно увеличение нестабильности работы системы. Тогда необходимо будет вернуться к большему значению. Возможный ряд значений: 1T, 2T, 3T.
Опция может называться также "Latency for CPU to PCI write", "CPU-to-PCI Write Delay" или "CPU-to-PCI Write Waits". Значения последней опции: "0T", "1T". И речь в ней, явным образом, идет о тактах ожидания.

CPU-to-PCI Write Posting
- содержание этой опции, естественно, окажется читателю уже знакомым. Но! В некоторых чипсетах, например, в том же наборе Orion, используются специальные внутренние буферы отложенной записи (Posted Write Buffers), которые используются для того, чтобы компенсировать разницу в скоростях процессора и шины PCI. Когда эта опция включена ("Enabled"), данные, записываемые из процессора в шину, будут вначале буферизироваться (до 4 двойных слов) и записываться без ожидания инициирования процессором следующего цикла. В отключенном же состоянии ("Disabled" - по умолчанию) циклы записи буферизироваться не будут, и процессору придется все время ожидать окончания предыдущего цикла записи перед началом нового, т.е. пока не закончится обработка запроса в PCI-шину. Такой режим, конечно же, снижает производительность. Но отключение опции может потребоваться и при использовании некоторых видеокарт, а также при работе процессора на определенных скоростях. Это может быть связано как с аппаратными особенностями, так и с процедурами "разгона".
Опция может носить множество названий: "CPU-to-PCI Posting", "CPU-to-PCI Write Post", "CPU-to-PCI Post Write", "CPU to PCI post memory write", "CPU/PCI Post Mem. Write", "PCI Posted Write Buffer", "PCI Post Write", "CPU-to-PCI Post Writes". Последняя опция может также предложить вариант с установкой времени задержки: "3T", "4T". Такие же значения (имеются ввиду временные параметры) предлагают и опции "PCI Post Write Timing", "CPU-to-PCI Post Write Timing". В некоторых случаях наличие возможности задержать циклы записи в PCI-шину является конечно более предпочтительным, чем полный отказ от использования буферирования с "отложенной" записью.
Еще конкретнее на временные характеристики (при задержке циклов записи) указывает опция "CPU/PCI Post Write Delay".
В завершение обзора опция "PPro to PCI Write Posting". Ничего особенного в использовании процессора Pentium Pro нет, только желательно данную опцию запретить, если речь идет о серверной системе.

Delayed Transaction
- (задержанная транзакция на PCI). Присутствие этого параметра в BIOS означает, что на материнской плате (в составе чипсета) есть встроенный 32-битный буфер с задержанной (чаще говорят, отложенной) записью для поддержки удлиненного цикла обмена на PCI-шине. Если этот параметр разрешен, то доступ к шине PCI, например, собственно PCI-устройств, разрешен во время доступа к более медленным устройствам на шине ISA, т.е. во время занятости PCI-шины. Это означает, что при обслуживании устройств на шине ISA (или периферии) система не будет прерывать PCI-транзакций, временно буферизируя данные, что и есть суть "задержанной транзакции". Это существенно увеличивает производительность системы, так как цикл такого обращения на ISA-шине занимает 50-60 тактов шины PCI. Понятно, что отключение опции (а значит и буфера) вызвало бы значительное замедление функционирования PCI-устройств (карты расширения, EIDE-интерфейс) в процессе завершения циклов чтения/записи от самых "южных" устройств ввода/вывода. Понятно также, что указанное "замедление" было бы вызвано элементарным простоем PCI-интерфейса.
Если компьютер укомплектован системной платой, не поддерживающей спецификацию PCI 2.1, этот параметр следует запретить, поскольку данная опция включает режим совместимости со спецификацией PCI версии 2.1 с одновременным включением в "северном" мосте упомянутого выше специального буфера. Правда, данная рекомендация по сути является избыточной. Выше уже акцентировалось внимание на однозначности соответствия пары "опция BIOS - буфер". Отключение опции может потребоваться при использовании какой-нибудь старой PCI-карты, не поддерживающей спецификации PCI 2.1. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Стоит отметить еще одну важную особенность! Если включены упоминавшиеся выше опции по "слиянию" (merging) отдельных байтов, слов, т.п., то данный буфер будет использован для объединения одиночных циклов записи в пакетные.
Опция может называться также "PCI Delayed Transaction", "PCI Delay Transaction", "Delayed Transaction Optimization", "Delayed Transactions" или "Delayed Transaction Timer" с теми же значениями ("включено"/"отключено").
Опция может называться и "PIIX4 Delayed Transaction" (т.е. с указанием наименования "моста"). Поддержка PCI-спецификации "видна" из наименования опции. "PIIX4" - принадлежность чипсетов i430TX и выше, а поддержка спецификации PCI 2.1 была введена "Intel" немного раньше.
Очень похожа на предыдущие, но только по названию, опция "ICH Delayed Transaction". Она "пришла" к нам из чипсетов Intel 810 и более поздних. В этих чипсетах отсутствует привычное большинству наличие конструктивных компонент, "северного" и "южного" мостов, присутствует новая шина. Но если абстрагироваться, то некоторая структурная похожесть все же есть! Процессор через системную шину соединяется с Graphics Memory Controller Hub. Последний с помощью интерфейса Accelerated Hub подключается к Integrated Controller Hub (ICH). К последнему подключается PCI-шина и через LPC-интерфейс вся возможная периферия. Что же мы видим? Привычное место PCI-шины заняла ускоренная шина с 66 МГц (магистральный канал трансляции данных), сама же PCI-шина заняла место "ушедшей в прошлое" ISA-шины. Теперь уже для ICH-"моста", LPC-интерфейса и периферийных каналов надо решать вопросы не столько совместной работы, сколько производительной работы. Тем более, что такие устройства как клавиатура, порты, все дисководы и т.п. подсоединяются к интегрированному контроллеру через высокопроизводительную кэш-память. Остается установить "Enabled".

DRAM-to-PCI 24 DW FIFO
- по аналогии смотри вышепредставленные опции. Хотя стоит подчеркнуть, что речь идет о буфере емкостью в 24 двойных слова.

DRAM to PCI RSLP
- когда опция включена ("Enabled"), чипсет допускает режим предвыборки на двух линиях данных от системной памяти к PCI-шине.

Early PCI Bus Request
- чуть выше была рассмотрена опция "Bus Request when FIFO is". Поэтому настоятельная рекомендация ее еще раз просмотреть. Если же ничего не знать об уже изложенном, то о чем идет речь в данной опции? Приведем "сухую" информацию о ее значениях: "Disabled", "2 Bytes Early", "4 Bytes Early", "6 Bytes Early". Пока не совсем ясно! В данной опции фиксируется остающееся свободное пространство шинного буфера, т.е. устанавливается объем свободной памяти буфера, при достижении которой выдается "request" (запрос) о его заполнении. Установка в "Disabled" снимает возможность посылки запроса.

Extra AT Cycle WS
- установка опции в "Enabled" разрешала вставить дополнительный такт ожидания в стандартный цикл AT-шины. Это могло понадобиться для улучшения распознавания ответа (реакции) несколько устаревшей периферии. Осталось отметить, что и сама опция уже достаточно устарела. Установка же значения "Disabled" вела к отказу от такта ожидания, а значит и повышению производительности.
По сути аналогична данной другая опция - "ISA Command Delay", определяющая задержку перед передачей данных для ISA-шины. Эта старенькая опция позволяла выбрать стандартный режим работы для ISA-устройств ("Normal Delay") и со вставкой дополнительного такта ожидания ("Extra Delay").

Fast AT Cycle
- (быстpый AT-цикл). Пpи установке опции в "Enabled" может быть ускоpена пеpедача данных для ISA-карт, особенно пpи pаботе с видеопамятью. Ускорение, а отсюда и повышение производительности, связано с укорочением циклов на системной шине. Понятно, что опция эта также устарела.

Fast Back-to-Back
- в опции, представленной выше ("CPU to PCI Burst Memory Write"), уже затрагивалась тема компоновки (правильнее сказать, ассемблирования) последовательных циклов записи процессора в пакетные (burst) PCI-циклы записи. Необходимо отметить, что такой механизм функционирования PCI-шины носит двунаправленный характер, т.е. это все справедливо как для циклов записи, так и для циклов чтения. Вот эта "интерпретация" последовательных циклов ("back-to-back"), или еще транслирование, в пакетные циклы зачастую называется преобразованием в "быстрые" ("fast") "PCI burst memory cycles". Отсюда и появление в названии опции двух терминов: "быстрый" и "последовательный". Естественно, что для повышения производительности системы опцию надо включить. Значение "Enabled" устанавливается и по умолчанию.
Как видим, данная опция ничем не отличается от множества опций, упомянутых выше. Просто был сделан дополнительный акцент. Приведем названия других возможных опций, предназначенных для решения этой же задачи: "Fast Back-to-Back Cycle", "Fast Back-to-Back Capability", "PCI Fast Back to Back Wr", "PCI Fast Back-to-Back", "Fast PCI Cycles".
Ну а об упомянутой двунаправленности говорят следующие две опции: "Fast Back-to-Back Read" и "Fast Back-to-Back Write".
Нет смысла выделять отдельно следующие две опции, хотя в них вроде бы и не идет речь о "быстрых" циклах, а о возможности чтения/записи последовательных циклов вообще: "Back-to-Back Write", "Back-to-Back Read".

Fast Frame Generation
- (быстрая генерация кадра). Выше была изложена целая "низка" опций, рассматривающих процессы буферирования транзакций от центрального процессора в PCI-шину. Данная опция направлена на оптимизацию тех же процессов, поскольку речь также идет о быстром "CPU-to-PCI"-буфере. Включение опции ("Enabled") позволяет процессору при использовании данного буфера завершать циклы записи даже, если данные в шину PCI еще не доставлены. То есть можно говорить об "отложенной" записи, что позволяет сократить общее количество циклов процессора.
В таком виде приведенная опция появилась во времена VLB-шины, предназначенной прежде всего для ускорения вывода графики. Но применение опции и тогда касалось оптимизации функционирования PCI-шины. В роли "PCI Master" выступал "PCI-VL bus bridge", и включение опции позволяло задействовать принадлежащий мосту указанный быстрый буфер.
Времена локальной шины VESA прошли, но и в более современных системах можно "встретить" указанную опцию. А у нее с самого начала были и свои "сородичи". "Quick Frame Generation" абсолютно идентична. "FRAMEJ generation" имела значения "Normal" (буферизация не используется) и "Fast". Опция "Frame Generation Delay" предлагала устанавливать задержку перед операцией записи данных из процессора в шину ("1T", "0T"). Фактически аналогична последней была опция "Reduce 1T for FRAME Generation", для которой "Enabled" означало снятие задержки в один такт.

I/O Posted Write Buffer
- опция отключения/включения (соответственно "Disabled" и "Enabled") специализированного буфера "отложенной" записи, предназначенного для оптимизации совместного сосуществования PCI-шины и устройств ввода/вывода при обращении к последним центрального процессора (см. дополнительно далее опцию "Write Post During I/O Bridge Access").

I/O Recovery Time
- (время восстановления для 8/16-битных операций ввода/вывода). Данная опция - "прародительница" опций, изложенных выше. Ее время ушло с появлением EIDE-интерфейса и "привязкой" последнего к PCI-интерфейсу, а также, что оказалось более естественным, с появлением различных устройств ввода/вывода, использующих 16-разрядный обмен данными. Поэтому естественным стало и последующее разделение на две самостоятельных опции. Но и для "нашей" опции время восстановления означало число тактов ожидания, вставляемых между двумя последовательными ("back-to-back") I/O-операциями.
Иногда в литературе, а также и некоторых версиях BIOS, можно встретить трактовку данной опции, как "AT Bus (I/O) Command Delay", что четко указывает на происхождение опции. Но при этом надо учитывать один нюанс. Речь все таки идет не о задержках между двумя последовательными обращениями, а о вставке тактов ожидания перед началом следующей I/O-операции. Хотя понятно, что в итоге сути это не меняет.
Нет ничего удивительного, что при рассмотрении данной опции мы можем сталкиваться и с работой жесткого диска. Передача данных от IDE-диска в основную память происходит без подтверждения приема информации (т.н. квитирования). Достаточно желания процессора прочитать дисковую информацию из дискового кэша, обращаясь через I/O-порт. Это т.н. PIO (Programmed I/O - программируемый ввод/вывод) и работает он с REP INSW-ассемблерными инструкциями. С помощью рассматриваемой опции возможно было добавить несколько тактов ожидания между инструкциями при работе с жестким диском. Но и тут был свой нюанс. Несомненной была тесная связь между опциями "I/O Recovery Time" и "AT BUS Clock Selection" (см. далее). Например, если системная AT-шина работала на частоте 8 МГц и к жесткому диску не было претензий, "I/O Recovery Time" могло быть отключено.
Если говорить о возможных значениях, то они могли быть выражены в тактах PCI-шины (bus clock - BCLK): "2 BCLK" (по умолчанию), "4", "8", "12". При запрещении опции ("Disabled") тот же жесткий диск будет работать производительнее. Рост производительности заметно увеличивается и при сокращении паузы. Необходимо отметить, что в предложенном виде данная опция довольно долго уживалась с PCI-шиной. В качестве значения опции могло также фигурировать выражение, например, типа "5/3". Первое значение определяло число тактов для 8-битных операций, второе - 16-битных. Приведенное значение ("5/3") являлось рекомендованным, хотя к предложенному могли быть добавлены и такие значения: "3T/2T", "4T/3T", "Disabled", "Enabled".
В "дописишные" времена задержка измерялась в тактах AT-шины (читай, ISA-шины), и в качестве значений мог фигурировать такой ряд: "1 CLK", "2 CLKs", "4 CLKs", "8 CLKs", "16 CLKs", "32 CLKs", "64 CLKs", "128 CLKs", "No Delay". Опция может (точнее, могла) называться также "I/O Recovery Period", а значения ее менялись от 0 до 1,75 мкс с шагом в 0,25 микросекунд. Опция могла называться и "I/O Cycle Recovery" со значениями "Enabled" и "Disabled". Такие же значения предлагали опции "On-Chip I/O Recovery" и "ISA I/O Recovery". Запрещение опции рекомендовалось только в случае, если устройства ввода/вывода могли поддержать скоростной обмен. Опция "ISA I/O Recovery" могла предложить и другой набор значений: "0 CLKs", "3 CLKs", "12 CLKs", "Slow".
Напоследок значения опции "I/O Recovery Time", "снятые" с системы "Anigma LP486i" много лет назад: "Short" и "Long".

L2 to PCI Read Buffer
- чипсет содержит свой собственный внутренний буфер для циклов записи в PCI-шину со стороны внешнего кэша. Когда этот буфер включен ("Enabled"), циклы записи из кэш-памяти второго уровня в PCI-шину предварительно буферизируются. При этом каждое устройство на PCI-шине "получит" свои собственные циклы полностью укомплектованными и без состояния ожидания.

Max PCI Burst Size
- (максимальный размер пакета на PCI-шине). Выше уже были рассмотрены вопросы, связанные с созданием и "движением" пакетов на PCI-шине. Но в качестве единого пакета может выступать объем информации, значительно превышающий несколько байт. Возможно ли такое? Вполне! Но есть факторы, могущие повлиять на размер PCI-пакета. Это непрерывность адресного пространства передаваемых данных, а также период полного "властвования" над системой, устанавливаемый для "мастер"-устройств. Отсюда и весьма "солидный" ряд значений опции: "256 Bytes", "512 Bytes", "1k Bytes", "2k Bytes", "4k Bytes". Последнее значение равно стандартному размеру страницы памяти. Неспроста!
И напоследок еще одна необычная опция - "Max. Burstable Range" (другие вариации: "Max, Burstable Range" и "Max burstable Range"). Этой опцией устанавливается максимальный размер непрерывной памяти, адресуемой как единый пакет на PCI-шине, сопровождаемый при этом уже знакомым нам сигналом FRAME# (pin A34). Параметр имеет два значения, и они не столь привлекательны: "0.5Kb" и "1Kb".

Passive Release
- (пассивное разделение). Эта опция включает/выключает механизм параллельной работы шин ISA и PCI. Если этот параметр разрешен ("Enabled"), то доступ процессора к шине PCI позволен во время "пассивного разделения" или, как говорят иногда, ее "освобождения". Проще говоря, включение данного режима позволяет шине PCI продолжать работу даже тогда, когда происходит передача данных от ISA-устройств, которые в обычном режиме могут тормозить работу более скоростной PCI-шины. Арбитр чипсета как бы выравнивает работу двух шин с учетом задержек ISA-шины. Технологически "пассивное разделение" осуществляется за счет применения встроенного в чипсет 32-битного буфера "отложенной" записи, где буферируются при необходимости PCI-циклы записи. Дальнейшая запись в PCI-шину происходит при ее "освобождении" от ISA-циклов, транслируемых через PCI-интерфейс.
К тому же несложно заметить, что опции "Passive Release" и "Delayed Transaction", несмотря на некоторые протокольные различия аппаратного функционирования, всегда находятся рядом в "BIOS Setup". Их использование непосредственно связано с одним и тем же буфером. Включение одной из них при отключенном состоянии другой бессмысленно!
Эти опции появились в свое время в "BIOS Setup" одновременно со способностью арбитра чипсетов Intel Triton VX/HX отбирать шину у "master"-устройств при отсутствии в течение какого-то времени запросов на передачу с их стороны. Рассматривая шире возможности арбитража применительно к данной опции, можно выделить следующее:
- арбитр может передать другому "master"-устройству доступ к локальной памяти,
- доступ к PCI-шине в качестве "master"-устройства может получить также другая карта расширения, а не только центральный процессор,
- арбитр получает возможность регулировать задержки (состояния ожидания) как для "ISA bus master"-, так и для "PCI bus master"-устройств.
Необходимость запрещения данного параметра может возникнуть при использовании либо "проблемных" ISA-карт, либо плат ISA, активно использующих каналы DMA (звуковые карты, устройства "Arvid", предназначенные для хранения информации). Запрещение также уместно при отсутствии ISA-карт в системе, хотя необходимо помнить, что системная периферия, даже при отсутствии ISA-карты, по сути подключается к той же ISA-шине. Вопросы арбитража подробно рассмотрены далее.
Опция может называться "PCI Passive Release".
Опция может называться и "PIIX4 Passive Release", но ее включение требует поддержки спецификации шины PCI 2.1.
Необходимо отметить, что механизм "пассивного разделения" в последние годы вышел за рамки взаимоотношения PCI- и ISA-шин. Затронуло сие и USB-интерфейс. Обычные PCI-циклы состоят из 8 тактов. Интерфейс шины USB допускает более короткие циклы, освобождая ведущую шину в середине обычного цикла. Это ускоряет доступ к шине других устройств. Опция "AMI BIOS" может называться "USB Passive Release".

PCI1 to PCI0 Access
- присутствие данной опции в "BIOS Setup" обычного (скажем, массового) компьютера вряд ли возможно. Речь может идти о мультипроцессорной либо серверной системах, для которых в свое время был разработан набор логики Intel 440NX. Данный набор включал в себя два специализированных расширителя мостов PCI с поддержкой четырех 32-разрядных или двух 64-разрядных PCI-шин. Включение такой опции ("Enabled") позволяло устройствам на разных шинах иметь доступ к локальной памяти "друг друга" и обмениваться данными между собой.

PCI#2 Access #1 Retry
- "деятельность" данной опции связана с функционированием "CPU to PCI Write Buffer" и опции, отвечающей за управление указанным буфером. Обычно, такой буфер записи включен, что позволяет процессору не ожидать освобождения PCI-шины. Далее данные могут быть переданы либо в наиболее благоприятный момент, либо перед началом следующего PCI-цикла.
Но возможна ситуация, когда при функционировании буфера произошел сбой. Это не связано никак с "переполнением" буфера, сбой мог произойти в процессе записи данных. При этом должна быть повторена процедура записи данных или передано сообщение "назад" для арбитража. Если опция включена, то будет повторена некоторая транзакция, и последующая запись в шину закончится успешно. Если установлено "Disabled", буфер принудительно сбросит свое содержание, при этом состояние регистров транзакции будет нарушено. Центральный процессор вынужден будет повторить снова цикл записи полностью. Рекомендуется включить данную опцию. Запрещение же опции может понадобиться при наличии в системе нескольких "медленных" PCI-устройств. Если же при этом опция будет включена, количество повторов циклов записи может заметно снизить производительность системы через замедление функционирования PCI-шины.

PCI Pipeline
- данная функция BIOS объединяет PCI- или CPU-конвейеризацию с механизмом "byte merging". "Байт слияние" используется для повышения производительности графических карт. И представленная функция контролирует механизм "byte-merge" для циклов записи в линейный кадровый буфер. Когда опция включена ("Enabled"), системный контроллер определенным образом проверяет состояние восьми линий процессора, являющихся сигналами "разрешения использования байт" ("BE[7:0]#" - "Byte Enable"). Эти линии контролируются всегда и независимо от установок "BIOS Setup", так как они могут быть непосредственно связаны с функционированием 64-битной шины данных. Рекомендованное включение опции может оказаться полезным не только для графических карт. "Простые" PCI-карты также могут получить "свое" ускорение от применения конвейеризации.
Опция может называться "PCI Pipelining".

PCI Post-Write Fast
- эта опция от "соседних" опций по работе буфера "отложенной" записи отличается только тем, что при циклах записи в PCI-шину будет использоваться буфер с более быстродействующей памятью.

PCI-to-CPU Write Buffer
- см. аналогичную информацию выше.

PCI to CPU Write Pending
- с помощью этой опции устанавливается режим работы системы при заполнении буфера записи полностью. По умолчанию, система будет вынуждена немедленно повторить цикл записи, что более предпочтительнее ожидания очистки буфера. Однако если установить некоторый тайм-аут для ожидания, то система будет некоторое время ожидать перед повтором цикла, пока буфер записи из PCI-шины не очистится, а это снижает производительность.
Опция может называться "Action When W_Buffer Full".

PCI-To-CPU Write Posting
- при установке опции в "Enabled" циклы записи центрального процессора, обращенные к PCI-шине (речь идет о чтении данных с локальной шины), завершаются предварительной буферизацией в буфере отложенной записи чипсета. При этом PCI-шина, не прерываясь, сможет продолжать процесс передачи данных в то время, когда центральный процессор переключился на выполнение другой задачи. Когда установлено "Disabled", буферизация отсутствует, и PCI-шина будет ожидать, пока CPU не освободится для другого цикла записи.
Опция может называться "PCI-to-CPU Posting".

PCI-to-DRAM 24 DW FIFO
- см. по аналогии вышеизложенное.

PCI to DRAM Buffer
- данная опция во включенном состоянии ("Enabled") увеличивает производительность совместной работы PCI-шины и памяти, позволяя временно хранить передаваемые данные в буфере (с последующей их передачей), если какое либо из устройств занято в данный момент. Наличие буфера предназначено, прежде всего, для компенсации работающих с разными скоростями системных компонент. Если опцию отключить, то PCI-шина будет ожидать, пока не будет закончен предыдущий цикл передачи данных от одного из устройств на шине PCI в системную память.
Опция может называться и проще - "PCI-to-DRAM Write", но ее содержание соответствует изложенному. Правда, ее значения несколько иные: "Faster", "Slower".
Последние значения, хотя и понятны пользователю, но достаточно абстрактны. Во всяком случае, должно быть понятно, что значение "Faster" более приемлемо для системы. Опция же "PCI-to-DRAM Buffer Timing" более конкретна, и значения ее: "x-3-3-3", "x-2-2-2". Последнее значение (временная характеристика обмена) соответствует более скоростному взаимодействию. О подобных временных диаграммах мы поговорим чуть ниже.

PCI-to-DRAM Bursting
- данная опция во включенном состоянии ("Enabled") позволяет оптимизировать совместную работу PCI-шины и основной памяти, а значит повысить общую производительность системы. Нетрудно увидеть, что речь идет о пакетном режиме передачи данных. О сути пакетной передачи информации см. выше.

PCI-to-DRAM FIFO Cleaning
- см. аналогичное выше.

PCI-to-DRAM Pipeline
- (конвейеризация передачи данных от PCI-шины к основной памяти). Установка опции в "Enabled" позволяет включить конвейер записи в основную память для PCI-циклов. В этом случае буферы чипсета хранят данные, записанные из PCI-шины, сам же чипсет запускает при доступе к памяти несколько циклов подряд, что повышает скорость обращения к памяти. При отключенном состоянии опции операции записи из PCI в DRAM ограничены до одного перемещения за цикл записи.
Опция может называться и "PCI-to-DRAM Pipelining".

PCI-to-DRAM Posting
- в данной опции речь идет также о буфере отложенной записи. Когда опция включена ("Enabled"), циклы записи из PCI-шины в основную память предварительно буферизируются. При этом передача данных от центрального процессора наиболее "благоприятным" образом чередуется с операциями "PCI-to-DRAM" при дополнительно включенном буфере отложенной записи в цепочке "CPU-to-DRAM".
Опция может называться "PCI-to-DRAM Post Write", "Posted PCI Memory Writes", "Posted Write Enable" или "Post Memory Writes".

PCI-to-DRAM Prefetch
- опция включения режима "предвыборки", значительно ускоряющего операции работы PCI-устройств с основной памятью. Достаточно подробно об этом режиме изложено в разделе "CPU". Но в данном случае присутствуют очень важные нюансы функционирования устройств, которые обязательно необходимо осветить уже сейчас.
При изучении множества изложенных выше опций (типа "N-to-M") могла да и пожалуй должна была выработаться у читателя уверенность, что речь всегда идет о направлении передачи данных. Но режим "предвыборки" представляет собой, прежде всего, оптимизацию механизма выдачи инструкций чтения (обращений к памяти), т.е. командной (адресной) информации. А значит, в данной опции мы говорим о направленности командной информации, предназначенной для чтения данных из основной памяти в сторону конечного получателя - PCI-устройства.
Приведем сразу несколько примеров аналогичных опций, подтверждающих сказанное: "PCI-to-DRAM Read Prefetch", "PCI Memory Read Prefetch", "PCI Read Command Prefetch". Все опции предлагают стандартные значения: "Disabled" и "Enabled".
Обратимся к аппаратной информации и поступим также, как сделали ранее. Возьмем техническое описание материнской платы на базе чипсета i430HX и обнаружим такой пункт -
22-DWord PCI-to-DRAM Read Prefetch Buffer.
Эта информация означает, что чипсет содержит специализированный буфер (размером в 22 двойных слова), предназначенный для динамического хранения запросов чтения данных из основной памяти - упомянутых инструкций чтения. Использование режима "предвыборки", а значит и буфера, основным образом предназначено для PCI-устройств, работающих в режиме захвата шины (режим "Bus Mastering"). В этом случае наиболее эффективно функционирует собственно PCI-шина и оптимально обеспечивается доступ к памяти устройств ввода/вывода. Уже чипсет берет на себя функцию управления запросами карты расширения. Применение режима наилучшим образом сказывается на производительности звуковых карт и PCI-карт с FireWire-интерфейсом (стандарт IEEE 1394). Блокировка режима ("Disabled") ведет к одиночным циклам чтения, число которых всегда ограничено сверху временными установками для функционирования "master"-устройств в системе (см. раздел "PCI").

PCI to ISA Write Buffer
- когда опция включена ("Enabled"), система временно будет хранить циклы записи в буфере, не прерывая при этом работу процессора. Если опция отключена, процессор должен будет "проследить" прохождение данных через PCI-шину и завершение цикла на медленной ISA-шине, что менее эффективно.

PCI-to-L2 Checkpoint
- данная опция, исходя из возможных значений ("2T", "3T"), может показаться аналогичной приведенной ниже "PCI-to-L2 Write Wait States". Но она устанавливает время (в тактах системной шины) от момента выдачи адресной информации контроллером PCI-шины до завершения ее декодирования контроллером кэш-памяти. Меньшее значение дает более высокую скорость, но при возникновении сбойных ситуаций значение необходимо увеличить.

PCI-to-L2 Read Wait States
- данная опция позволяет оптимизировать циклы чтения из внешнего кэша процессора в PCI-шину, устанавливая определенное количество тактов ожидания (в тактах системной шины). Оптимальный вариант выбирается путем опытной проверки. Значений всего два: "1T", "2T".

PCI to L2 Write Buffer
- чипсет может включать в себя собственный внутренний буфер для PCI-циклов записи во внешний кэш. Когда этот буфер включен ("Enabled"), циклы записи из PCI-шины во внешний кэш предварительно буферизируются во внутреннем буфере отложенной записи, так как в это время центральный процессор может быть занят "обслуживанием" какого-либо устройства ввода/вывода, например. При отключении буфера ("Disabled") шина PCI вполне может оказаться в состоянии простоя из-за ожидания завершения предыдущего системного цикла, что естественно снижает общую производительность системы.

PCI-to-L2 Write Wait States
- данная опция позволяет оптимизировать циклы записи из PCI-шины во внешний кэш процессора, устанавливая определенное количество тактов ожидания (в тактах системной шины). Оптимальный вариант выбирается, как и в большинстве подобных случаев, путем опытной проверки. Значений всего два: "1T", "2T".

PCI-to-PCI Posting
- поскольку PCI-шина обладает собственными буферами "отложенной" записи, то включение данной опции ("Enabled") позволит включить в работу данный буфер при обмене данными между устройствами на самой PCI-шине. Конечно, данная опция позволяет значительно оптимизировать функционирование PCI-шины, поскольку, а это стоит напомнить, обмен данными по ней идет как для самих PCI-устройств, так и для всех "нижестоящих". А тут еще и обмен друг с другом. Последнее, а также применение данной опции вообще, в большей степени указывает на оптимизацию работы "master"-устройств на PCI-шине. Нет сомнения, "хорошая" опция! Только встретить ее в "BIOS Setup" можно крайне редко.

ROM Wait States
- необычная и не совсем ясная опция, встретившаяся в системе на чипсете AMD645. Можно предположить, что речь идет о вставке дополнительного такта ожидания при доступе к системному BIOS. Но может быть суть в другом, например, при доступе к ПЗУ карт расширения. Значения опции: "1 WS" и "0 WS".

USB Passive Release
- см. выше опцию "Passive Release".

Write Post During I/O Bridge Access
- в таком виде данная опция уже не встречается, хотя и затрагивает весьма ответственный момент в работе системы, а именно, совместную работу PCI-шины и устройств ввода/вывода, "привязанных" к "южному" мосту. Включение опции ("Enabled" - по умолчанию) позволяет осуществлять предварительную "отложенную" буферизацию циклов записи PCI-шины в моменты обращения центрального процессора к периферийным устройствам. Чипсет может содержать специализированный буфер, предназначенный для "отложенной" записи. Аналогичная заглавной опция может называться "I/O Posted Write Buffer" с теми же значениями: "Disabled" и "Enabled". Включение опции, хотя и "притормаживает" работу PCI-устройств, тем не менее повышает общую производительность системы.
Опция может называться "Write Posting During I/O", а также иметь следующие названия: "I/O Cycle Post-Write", "PCI I/O Cycle Post Write", "Posted I/O Write".

Значительный по объему и дополняющий все вышеизложенное (и нижеизложенное тоже) материал расположен в разделах, посвященных PCI-шине, арбитражу, а также ISA-шине.


BIOS. Продолжение!

2.2. Специальные функции чипсета

Drive NA before BRDY
- когда выбрано "Enabled", сигнал NA (Next Address, подробнее читай ниже) устанавливается в каждом цикле чтения/записи на один такт раньше последнего сигнала BRDY#, таким образом вызывая генерацию процессором сигнала ADS# после сигнала BRDY# в следующем цикле, тем самым устраняя один потерянный такт и фактически увеличивая пропускную способность системной шины. С помощью сигнала BRDY# (Bus Ready) чипсет (точнее, т.н. "северный мост") сообщает процессору о том, что имеются данные и они доступны для чтения или есть готовность для приема данных для их дальнейшей записи.
В данной опции речь фактически идет о механизме конвейеризации, об "ускоряющих" возможностях сигнала "Next Address".

Extended CPU-PIIX4 PHLDA#
- при установке значения "Enabled" системный контроллер, входящий в состав "северного" моста, увеличивает на один такт (в тактах шины PCI) длительность сигнала PHLDA# и оставляет его активным в двух случаях:
* в течение адресной фазы в начале PCI-цикла чтения/записи,
* сопровождая адресную фазу "LOCK"-цикла центрального процессора.
При включенном значении опции функции "Passive Release" и "Delayed Transaction" должны быть также включены.
Сигнал PHLDA# (PCI Hold Acknowledge) применяется, в частности, для управления работой "арбитра" PCI-шины. Тема арбитража будет рассмотрена отдельно.

Gate A20 Option
- (выбор способа включения вентиля линии A20). Параметр позволяет управлять способом включения адресной линии A20, которая отвечает за доступ к памяти, физические адреса которой превышают 1 Мбайт. Стоит напомнить, что 20-разрядная адресная шина (A0 - A19) позволяла адресоваться в пределах первого мегабайта памяти. Если быть более точным, то эта линия отвечает за доступ к первым 64 килобайтам верхней памяти, известным как область HMA (High Memory Area). Доступ к HMA требует управления специальным аппаратным узлом, работа которого может быть блокирована или активизирована. При установке опции "Gate A20 Option" в состояние "Fast" работа линии будет контролироваться специальным набором микросхем на системной плате. Если линия А20 деблокирована, то HMA-область доступна для любой программы, функционирующей в реальном режиме работы процессора. Обычно эта область памяти отдается под MS-DOS, а для деблокирования линии используется драйвер HIMEM.SYS.
Может принимать значения:
"Fast" - управление осуществляется чипсетом, что повышает скорость работы,
"Normal" - управление осуществляется через контроллер клавиатуры.
В некоторых версиях BIOS опция может называться "Fast Gate A20 Option", а параметрами будут стандартные "Enabled"/ "Disabled". Иногда в старых версиях BIOS можно встретить опцию с почти романтическим названием "LOWA20# Select". А речь идет о том, какое устройство управляет низким уровнем сигнала на линии A20: чипсет или контроллер клавиатуры.
Достаточно редко, но все же можно встретить в литературе в отношении управления линии A20 такой термин, как "эмуляция". В данном случае имеется ввиду, что стандартный способ управления "вентилем" осуществляется через контроллер клавиатуры. А чипсет заменяет, подменяет это управление, "эмулирует" его (дополнительно см. ниже). И следующая опция очень хорошо показывает это. "Keyboard Emulation" имеет два значения. "Enabled" соответствует "Fast", а "Disabled" - "Normal". Следующая опция "Gate A20 Emulation" (или "Fast Gate A20 Emulation") уже не должна вызывать вопросов. Правда, опций с такими названиями, пожалуй, уже не встретишь. Иногда в литературе можно найти трактовку опции "Turbo Switch Function" как аналога "Fast Gate A20 Option", подразумевая функцию переключения, но это не совсем корректно.
Пользователям, умеющим работать с командной строкой, можно порекомендовать внешнюю команду DOS MEM /A, показывающую стандартную информацию о памяти и дополнительную информацию о сегменте HMA. Команда работает и в среде "Windows 9x".
Ну и наконец, опция "Cyrix A20M Pin", применявшаяся во времена 386-х процессоров. Процессоры Cyrix уже тогда были "особенными". Речь идет о дополнительной поддержке со стороны BIOS. Ведь в отличие от процессоров Intel, 386-е процессоры Cyrix имели собственный кэш. Такие процессоры могли иметь проблемы с обновленными комплектующими, поддерживающими кэш-память. Вполне вероятными были и другие системные конфликты. Чтобы обеспечить управление линии A20 контроллером клавиатуры, BIOS через включение опции ("Enabled") сообщал центральному процессору о состоянии вентиля. И еще о кэше. Установка "BIOS Setup" позволяла процессору через внутренний кэш кэшировать первые 64 КБ каждого (!) мегабайта памяти в реальном режиме (вентиль всегда был открыт в защищенном режиме работы процессора), и это было достаточно эффективным.

Логически память разбивается на сегменты размером по 64 КБ, что соответствует 2^16. В совсем "стареньких" машинах с 16-разрядными процессорами физически адрес не мог перейти ограничение в 64 КБ. 20-разрядная адресация, т.е. использование 20-разрядной адресной шины, достигалась благодаря тому, что при формировании 20-разрядного физического адреса использовалось суммирование со смещением в 4 разряда двух адресов: адреса сегмента и исполнительного адреса.
При вычислении физических адресов в системах с 8086/88-ми процессорами могла иметь место вполне стандартная ситуация, а именно адресное переполнение, которое при наличии 20-разрядной шины адреса приводило к сворачиванию адресного пространства в т.н. кольцо. А это и происходило как раз в процессе упомянутого суммирования.
В процессорах следующего поколения (в 286-х был преодолен предел в 1 МБ адресного пространства) на его выходе A20 устанавливалось значение "1", что соответствовало адресу из второго мегабайта памяти. При разработке процессоров и чипсетов машин класса IBM PC/AT) в схему чипсета был введен специальный вентиль Gate A20. В то время его появление в наборе логики было прежде всего связано с обеспечением полной программной совместимости с предыдущим классом машин. Вентиль принудительно устанавливал нулевое значение на линии A20 адресной шины.
На первых машинах, где был реализован контроль и управление линией A20, управление последней осуществлялось через программно управляемый бит чипа контроллера клавиатуры 8042 (или 8742) (см. дополнительно раздел "Keyboard"). Позднее эта функция была возложена и на чипсет, что значительно ускорило скоростные характеристики ("Gate A20 Fast Control") системы.
В итоге это означало, что появление 32-разрядных процессоров не вызвало заметных изменений по данной теме, поскольку специальный вход процессоров (A20M - A20 Mask) остался. Упомянутый вход современного процессора есть не что иное, как маскирование бита A20 физического адреса для эмуляции адресного пространства 8086 в реальном режиме работы процессора. А это связано и с тем, адресная линия A20 используется также для переключения из реального режима в защищенный, что сразу нашло применение в многозадачных и сетевых средах. Иногда можно встретить в описаниях и такие пояснения. Что существует категория пользователей, использующих старое программное обеспечение. Для таких и предназначена эта опция. Это означает, что наличие такой опции связано с совместимостью со старым ПО. Правда, фразы о категориях пользователей встречаются все реже и реже, но опция по прежнему входит в "стандартный" набор "BIOS Setup". Необходимо также отметить, что некоторые старые драйверы MS-DOS, например VDISK.SYS, могут блокировать линию А20, входя в конфликт с драйвером HIMEM.SYS (это опять таки из далекого прошлого).
Уточним вопрос об "эмуляции" и переключении процессора. Обычным образом программы для A20-операций используют обращения через BIOS или порты 60/64h, предназначенные для контроллера клавиатуры. Чипсет перехватывает эти обращения, тем самым эмулируя контроллер клавиатуры и разрешая дальнейшую генерацию соответствующих сигналов. Последовательность при этом следующая. В порт 64h записывается значение D1h, а затем в порт 60h - 02h. Если же в порт 64h затем записать значение FEh, то можно произвести "теплый" рестарт процессора. В обычном режиме работы процессора контроль линии A20, как "Fast", осуществляется через порт 92h, который программы используют для BIOS-вызовов. Возможна ситуация, когда контроль одновременно осуществляется и контроллером клавиатуры, и чипсетом. В этом случае линия A20 контроллируется через порты 60/64h.

Graphic Posted Write Buff
- чипсет может поддерживать собственный внутренний буфер для циклов записи графической памяти. Когда этот буфер включен, т.е. опция установлена в "Enabled", циклы записи процессора в графическую память попадают в буфер отложенной записи. При этом центральный процессор может начать новый цикл передачи данных еще до того, как графическая память закончит предыдущий цикл. При установке параметра в "Disabled" буфер не будет использоваться, и процессор будет находиться в ожидании в течение каждого цикла записи.

IBC DEVSEL# Decoding
- (декодирование адреса устройства). Сигнал DEVSEL (Device Select) означает "выбор устройства". Эта опция позволяет установить тип декодирования, используемый IBC (ISA Bridge Controller) для определения выбранного устройства. Чем дольше длится цикл декодирования, тем выше шанс корректного декодирования адреса, но снижаются скоростные показатели. Для отбора представлены следующие значения: "Fast", "Medium" и "Slow" (по умолчанию).

LOCK Function
- поскольку в данной опции идет речь об использовании сигнала LOCK#, то отключение опции ("Disabled") приведет к отказу от применения режима "bus-master" в системе.

NA Delay
- данная опция позволяет регулировать задержку (в системных тактах) перед выдачей сигнала NA# (Next Address). Меньшее значение повышает скоростные характеристики системы, но... Возможные значения опции: "0T", "1T", "2T".

NA# Enable
- если дословно, опция включения/отключения сигнала NA#. Установив "Enabled", мы включаем механизм конвейеризации, при котором чипсет сигнализирует центральному процессору о выдаче нового адреса памяти еще до того, как все данные, переданные в текущем цикле, будут обработаны. Следующий адрес (вместе со стробом EADS#) появится через два такта после NA#. Естественно, что включение такого режима повышает производительность системы. Запрещение опции ("Disabled") вовсе не означает отказ от использования сигнала "NA#", но его функционирование в значительной степени будет уже зависеть от качественных характеристик используемой в системе кэш-памяти и ее размера.
То же содержание заключено в опциях "NA# Pin Assertion" и "Chipset NA# Asserted".

NA# On Single Write Cycle
- возвращаясь к предыдущей опции, необходимо отметить, что центральный процессор может держать на внешней шине до нескольких незавершенных циклов. Данная опция позволяет "избавиться" от незавершенных циклов, вызванных неоптимальной частотой выдачи адресной информации, сбоями в конвейере, функционированием прикладного программного обеспечения в многозадачной среде, т.п. Включение данной опции фактически ведет к отказу от конвейеризации, выделению одиночных циклов записи, что действительно может потребоваться при сбоях в системе.

Negate LOCK#
- (отрицание сигнала LOCK#). Напомним, что сигнал LOCK# (Bus Lock) - это сигнал монополизации управления шиной, сигнал блокировки доступа к шине других абонентов. При установке опции в "Enabled" ранее некэшируемые "locked" циклы будут исполняться как "незакрытые" циклы, и поэтому они могут быть кэшированы. Повышение производительности очевидно.

Single ALE Enable
- (pазpешение одиночного сигнала ALE). Немножко информации. Пин B28 на шине ISA - это сигнал BALE (Bus Adress Latch Enable - разрешение защелкивания адреса). Это сигнал стробирования адресных разрядов. Может использоваться устройствами ввода/вывода для заблаговременной подготовки к предстоящему обмену информацией. Эта линия становится активной всякий pаз пpи появлении на адресной шине информации. Можно было встретить даже такую информацию об этом сигнале: "...показывает, что действительный адрес отложен (posted) на шине". Стоит добавить, что этот сигнал использовался еще во времена 808x-х процессоров. По некоторой информации сигнал этот мог использоваться DMA-контроллерами для сообщений центральному процессору о передаче данных. Его применение было связано с программированием устройств, поэтому использование сигнала было крайне редким.
Устанавливая "Enabled", активизируем одиночный сигнал ALE вместо множественных сигналов-стробов во время ISA-циклов. В какой-то степени выбор параметра был привязан и к скорости системной шины, т.е. пропускной способности системы. Поэтому установка в "Enabled" могла привести к замедлению быстpодействия видеоканала. Эта функция всегда оставалась достаточно "темной" функцией "BIOS Setup". "Disabled" рекомендовано.
Опция может называться также "ALE During Bus Conversion" с возможными вариантами выбора: "Single" (одиночный) или "Multiple" (множественный). Естественно, что при потоковой работе ISA-шины (т.е. множественных циклов чтения/записи) предпочтительнее была бы установка опции в "Multiple". Но какой правильный выбор должен был сделать пользователь, всегда оставалось загадкой.
Некоторые чипсеты имели поддержку усовершенствованного режима, при котором выдача множественных сигналов ALE производилась во время одиночных циклов шины. Функция BIOS при этом называлась "Extended ALE", а параметрами служили "Disabled" и "Enabled". Встречая данную опцию в более современных системах, естественно при наличии ISA-шины, необходимо понимать, что присутствие оной связано только с совместимостью со спецификациями AT-шины.
В наиболее "древних" версиях BIOS весь смысл сказанного выше был заключен в опции под названием "Quick Mode".

Stop CPU when PCI Flush
- при установке опции в "Enabled" центральный процессор, получив по своей входной линии (FLUSH) активный сигнал низкого уровня FLUSH#, вынужден будет приостановиться до тех пор, пока PCI-шина не закончит передачу данных. Запрещение опции не позволит процессору входить в режим ожидания, что естественно более приемлемо для системы. "Disabled" устанавливается и по умолчанию.
Опция может называться "Stop CPU When Flush Assert".

3. CPU

Backoff Processor
- очень редкая опция и не совсем однозначно трактуемая. BOFF# (Back Off) - сигнал безусловного отключения процессора от шины. По этому сигналу процессор отдает управление шиной в следующем же такте с прерыванием текущего цикла. По окончании действия сигнала "BOFF#" процессор рестартует прерванный шинный цикл. Возможные значения опции:
"Disabled" (или "No"),
"Enabled" (или "Yes").
Исходя из всего изложенного, можно предположить, что в опции речь идет о безусловной передаче управления шиной другому устройству, т.е. без установок различных интервалов ожидания, определенных условий передачи управления и т.п. Об этом будет подробно изложено далее (тема "арбитража"). Понятно, что для использования указанного сигнала опцию необходимо включить.
Опция может называться "Backoff CPU".

Base I/O Address
- опция установки базового адреса устройства. I/O-адреса - это адреса ввода/вывода, называемые также портами системных и периферийных устройств. По сути, это "почтовые ящики", через которые программы и устройства обмениваются сообщениями, данными. Каждому адресу отведен один байт системной памяти. Начиная с 386-х систем таких адресов имеется в наличии 65536, хотя большинство из них никогда не используется.
Базовый I/O-адрес - это первый адрес из того адресного пространства, что предоставлен данному устройству. Например, большинство сетевых адаптеров использует адресный диапазон в 20h, а для COM 1 резервируется диапазон с адресами от 3F8h по 3FFh, которые используются для различных задач, например, установки скорости, четности, т.п. Весь адресный диапазон ввода/вывода - 0000-FFFFh.
Для данной опции не приводятся конкретные значения. Да и по содержанию опция в большей степени "подходит" материалам, посвященным распределению ресурсов различных устройств. Но опция помещена в данном месте умышленно, чтобы подчеркнуть принадлежность адресов ввода/вывода не только памяти, а и центральному процессору. Ведь от него то и начинаются управляющие процедуры, и производятся они через порты ввода/вывода.
Если просмотреть главу "Порты", то можно обратить внимание на то, что имеющиеся адреса уже "закреплены" за системными или периферийными устройствами. Но при программировании устройства ввода/вывода, а это может быть карта расширения, вполне допустимо задействование "традиционных" адресов либо неиспользуемых. В некоторых случаях использование незадействованных адресов, что связано, например, с отсутствием устройства, не обязательно ведет к конфликтам.
Рассмотренная выше опция "Extended I/O Decode" показала нам некоторые нюансы и даже сложности декодирования адресов ввода/вывода. Опция "PCI I/O Start Address", предназначенная в общем-то для PCI-устройств, тем не менее позволяет для ISA-устройств создать дополнительную область адресов и тем самым избежать "неприятных накладок".

Branch Target Buffer
- просто редчайшая функция, скорее в смысле уникальности, а не частоты появления в различных версиях BIOS. О чем идет речь? BTB (Branch Target Buffer - буфер адресов перехода) - блок центрального процессора, отвечающий за динамическое предсказание переходов. При этом принимается во внимание, какие адреса переходов были выбраны ранее. Это важнейший узел современного процессора (см. специальную литературу).
Получается, что с помощью данной опции можно отказаться ("Disabled") от использования механизма предсказания переходов, ветвлений команд процессора или включить его ("Enabled"). Остается добавить, что включение опции повышает производительность системы.

CPU ADS# Delay 1T or Not
- опция установки задержки для сигнала ADS#. Несколько предваряющих слов. ADS# (Address Status) - строб адреса, вводимый инициатором обмена как индикатор действительности адреса. Сигнал действует на системной шине и может быть выходным как стороны процессора, так и со стороны чипсета. Передача адреса и адресного строба происходит одновременно, поскольку для адресного строба системная шина имеет свою выделенную линию. Понятно, что ADS# - это стандартный сигнал процессоров.
Представленная опция указывает и на возможность отсутствия задержки, что повышает скоростные характеристики обмена данными в системе. Фактически данная опция позволяет устанавливать время, в течение которого процессор (или чипсет, контроллер памяти) будет ждать от чипсета (процессора) сигнал статуса адреса данных, который определяет скорость отложенной записи на системной шине. Понятно, что речь также идет о передаче данных в PCI-интерфейс. Значение, устанавливаемое по умолчанию, менять нет необходимости. Однако при установке более скоростного процессора скорость можно и увеличить, т.е. снять задержку.
Вынесенная в заголовок опция имеет два значения: "1T", "No Delay".
А вот опция "Cyrix M2 ADS# delay" предложила стандартные "Enabled" и "Disabled". Опция "Latency from ADS# status" предложила числовые значения в тактах системной шины: "2T" (по умолчанию), "3T".
Необходимо понимать, что устанавливая "время задержки", мы тем самым определяем временные характеристики циклов записи. И с учетом того, что использование буфера отложенной записи ведет, как правило, к формированию небольших пакетов (двойными словами или в два DW). Поэтому установив значение "3T", мы получаем 5 системных тактов для каждого двойного слова. Арифметика тут простая. 3 такта задержки, один адресный такт и один такт на считывание данных.

CPU BIST Enable
- в некоторых чипсетах, начиная с 430-й серии, нашли применение специализированные BIST-регистры. Большой нагрузки они не несли. Если система (чипсет + процессор) поддерживает функцию встроенного самотестирования (Built-In Self Test), то BIST-регистр хранит в своих разрядах команды "Start BIST" или "Completion Code". Если "система" не поддерживает BIST-функции, то установка опции в "Enabled" не даст эффекта, а в соответствующих разрядах регистра будут установлены "0".
Встроенный и, что немаловажно, полноценный механизм самотестирования BIST был реализован в процессорах Pentium III. Он обеспечивал постоянный контроль над зависаниями и сбоями в микрокоде, больших программируемых логических матрицах, а также обеспечивал тестирование кэша команд (инструкций) и кэша данных, буферов TLB (Translation Lookaside Buffer - буфера страничной переадресации) и сегментов памяти ROM. В течение 10-30 мсек (время связано с внутренней частотой ядра процессора) внутренним тестированием охватывается около двух третей всех внутренних блоков процессора. Лишь только после завершения теста процессор переходит в рабочий режим, результаты же теста фиксируются в регистре EAX.

CPU Drive Strength
- данная и не совсем ясная опция определяет интенсивность (strength), а точнее длительность действия сигналов при передаче данных от чипсета к процессору. Параметр измеряется в системных тактах. Чем выше значение параметра, тем выше длительность сигналов, а применение этой опции "BIOS Setup" может оказаться полезным для процедур "разгона" процессоров. Но не для всякой системы увеличение значений опции может привести к сохранению стабильности "разогнанного" процессора. Значения опции следующие: 0, 1, 2, 3.
Осталось добавить, что данная опция требует дополнительного уточнения.

CPU Fast String
- (быстрые операции со строками). Разрешение этого параметра ("Enabled") позволяет использовать некоторые специфические особенности архитектуры семейства процессоров Pentium Pro (Pentium II, Deschutes и т.п.), в частности, возможность кэширования операций со строками. Надо только понимать, что и в самой пользовательской программе должны быть выполнены условия для включения этого механизма. Эти условия указаны в документации на любой процессор данного семейства. Параметр рекомендуется оставлять в состоянии "Разрешено".

CPU Line Read Multiple
- в данной опции речь идет о чтении процессором т.н. "full cache"-линии. Когда "cache"-линия заполнена данными, то их объем составляет 32 байта (восемь двойных слов). Поскольку линия "полная", система точно знает, как долго данные на линии будут считываться. На это системе потребуется 4 такта, после чего будет выставлен новый адрес. Поэтому системе не требуется сигнал об окончании передачи данных, и система не будет находиться в ожидании такого сигнала, будучи свободной для решения других задач. Когда опция включена ("Enabled"), процессор сможет считывать данные одновременно с нескольких "full cache"-линий. По умолчанию - "Disabled".
Опция может называться "CPU Multiple Reads".
Перечисленные ниже функции не содержат свойств множественности, но их размещение в данном месте более чем оправдано. Вот их наименования: "Allow Full Line Reads", "Full Cache Line Reads", "CPU Line Read". Каждая из них через "Disabled" или "Enabled" запрещает или разрешает использование "полных" линий чтения.
Опция "CPU-to-PCI Read-Line" имеет значения "On" и "Off", но различия на этом не заканчиваются. Опция под таким наименованием была введена и оптимизирована для работы с процессорами Intel OverDrive. Поэтому повышение эффективности использования CPU может быть достигнуто только с указанными процессорами. В противном случае опция должна быть отключена.

CPU Read Multiple Prefetch
- опция включения/отключения режима множественной предвыборки. Смысл процесса предвыборки (prefetch) заключается в том, что процессор, выбирая нужную инструкцию (например, из PCI-шины или памяти), одновременно начинает читать следующую, тем самым инициируя следующий процесс. Этому "способствует" то, что чипсет может иметь четыре линии чтения. Например, первые наборы логики с поддержкой процессоров Pentium Pro (Intel 450KX/GX, оба с кодовым названием Orion) как раз имели 4 такие линии чтения. Множественная же предвыборка позволяет выполнять одновременно несколько операций выборки инструкций, что существенно повышает быстродействие системы. По умолчанию устанавливается "Disabled".
Опция может называться и "CPU Multiple Read Prefetch".
Если же речь не идет о "множественных" операциях, то опция может называться "CPU Line Read Prefetch", "CPU Read Prefetch".

I/O Space Access
- данная опция через "Enabled" разрешает доступ ко всему пространству адресов ввода/вывода. Редкий BIOS обходится без странных опций.

Processor Number Feature
- опция для установки автоматического считывания и вывода информации о встроенном серийном номере процессора Pentium III в BIOS материнских плат, поддерживающих его установку. Для реализации такой возможности, естественно, требуется значение параметра как "Enabled". Во всех остальных случаях устанавливается значение "Disabled". Оно же устанавливается по умолчанию.
Опция может носить название "Processor S/N".
В "Phoenix BIOS" встречена аналогичная опция с названием "CPU Serial Number", а в "AMI BIOS" - "Processor Serial Number".
Зачем нужна информация о серийном номере? Скажем, для внешних программ. Один из примеров - считывание информации о процессоре при работе в Интернет. Естественно, что при этом нарушаются конфиденциальность и права пользователя. В свое время эта проблема достаточно бурно обсуждалась.

3.1. CPU Speed

Материал данного подраздела построен в соответствии со стандартными действиями пользователя: установка тактовой частоты системной шины + установка множителя (коэффициента перемножения) = установка внутренней частоты (частоты ядра) процессора. В большинстве современных версий BIOS опции установки частот системной шины, процессора вынесены, как правило, в отдельное меню, которое может называться, например, "CPU Frequency Control".
Но вполне реальна и ситуация, когда для возможных пользовательских действий через BIOS предварительно необходимо переставить соответствующую перемычку на системной плате в положение типа "Configure".

CPU Host Clock Select
- опция установки тактовой частоты системной шины. Еще не так давно BIOS достаточно новой материнской платы мог предложить такой замечательный ряд значений (в МГц): 66, 75, 83, 100, 103, 112, 124, 133. Затем появились наборы из 16-18 фиксированных значений, но они начинали отсчет уже со значения 100 МГц. В общем случае вариаций установки частоты может быть достаточно много. Особенно в этом плане выделяются материнские платы, буквально созданные для разгона (например, компаний "Soltek", "Abit", "ASUS"). И тогда без проблем можно "добраться" и до 166 МГц, и даже выше.
Опция может называться "CPU Bus Frequency" и предлагать такую подборку: "Auto", "66.8MHz", "68.5MHz", "75MHz", "83.3MHz", "100MHz", "103MHz", "112MHz". Значение "Auto" устанавливается по умолчанию и оно является рекомендованным.
Может быть предложен более "изощренный" вариант опции, связанный с тем, что модули памяти работают на частоте системной шины. Тогда опция может называться "Host/DRAM Frequency", а значения будут следующими: "66 MHz", "100 MHz". Понятно, что в данном варианте речь идет о SDRAM-памяти и интеловском чипсете с двумя фиксированными значениями тактовой частоты, например, 440BX.
Опция может называться "CPU Host Clock" или "External Bus Speed".
Несколько нестандартной оказалась опция "CPU Clock/Spread Spectrum" (смотри раздел "Special"). Согласно опции устанавливается не только частота системной шины, но и разрешается/запрещается ("On"/"Off") включение механизмов понижения электромагнитной интерференции в системе. На выбор параметров влияет также и установка базовой перемычки тактовой частоты шины процессора: 66 или 100 МГц. В итоге для предустановленных 66 МГц имеем следующий набор значений: "Default", "66MHz/Off", "66MHz/On", "75MHz/Off", "83MHz/Off", "95MHz/Off". Если же предварительно установлено 100 МГц, то имеем такой внушительный ряд: "100MHz/Off", "100MHz/On", "112MHz/On", "117MHz/On", "124MHz/Off", "133MHz/Off", "133MHz/On", "138MHz/Off", "140MHz/On", "150MHz/Off".
Опция "CPU Operating Speed" через значение "User Define" дает возможность устанавливать частоту FSB (Front Side Bus) от 66 до 153 МГц. В противном случае можно однозначно выбрать одно из фиксированных соотношений частоты ядра CPU и частоты шины от "300/66" до "1G/133".
Непосредственно к рассматриваемой теме примыкают вопросы т.н. "разгона" (overclocking) процессоров. Эта проблема уже достаточна освещена в литературе, нет смысла на ней останавливаться подробно. Со стороны же установок BIOS очень удобно, когда пользовательские действия адекватно воспринимаются и оцениваются. В этом плане меню "CPU Bus/PCI Freq" наиболее оптимально. Ведь превышение частоты PCI-шины свыше 37 МГц может повлечь за собой неисправность не только карт расширения, но и сбои жестких дисков.
В последние годы вариаций опций для установки системной частоты стало очень много. Простое их перечисление заняло бы немало места. Перечислим лишь некоторые. "CPU Host Clock Frequency". "CPU Host/PCI Clock" предлагает значение "Default", что равнозначно автоматической установке "стандартных" значений, а также возможность комбинирования двух системных частот. Опция может называться "CPU Host/3V66/PCI Clock".

CPU Ratio
- может принимать значения: 2, 2.5, 3, 3.5, 4, 4.5, 5, 5.5, 6, 6.5, 7, 7.5. Приведен практически весь возможный ряд коэффициентов умножения, который, как и сама опция, впрочем может отсутствовать вовсе, если коэффициент является фиксированным. Это довольно обычная ситуация, если речь идет об "интеловских" комплектующих. "Благоприятная" ситуация позволяет настраивать параметры работы CPU через BIOS, включая естественно нашумевший разгон процессоров.
Опция может называться "CPU Freq Ratio", а ряд значений может иметь несколько непривычный вид: "1:2", "1:3", "1:4", "1:5", "1:6", "1:7", "1:8", "2:5", "2:7", "2:9", "2:11", "2:13", "2:15".
В некоторых случаях для коэффициента умножения "не жалко" и двух опций:
"CPU Multiplier Shown" и "CPU Multiplier (Real)". Одна из этих опций позволяет установить значение вручную, а другая выводит на экран реально полученное значение, которое может и отличаться от желаемого.
Должно быть также понятно, что любая указанная цифра может оказаться недостаточно высокой для какой-нибудь последней реализации процессора и чипсета.

CPU Speed
- поскольку внутренняя частота процессора является результатом перемножения двух других параметров, то данная опция носит информационный характер. Результирующая частота процессора может быть представлена, например, в таком виде: 133 MHz (66 x 2).
Опция может называться "CPU Frequency (MHz)".
Во многих случаях данная опция выносится наверх окна соответствующего меню (подменю) "BIOS Setup", хотя ее значение является результатом вычисления. Но в некоторых случаях пользователь может иметь доступ к параметрам данной опции. Опция "CPU Speed" может предложить значение "Manual", тогда активируются поля "CPU Ratio" и "CPU Host Clock" для индивидуальных установок. Но это конкретная реализация не только версии BIOS, но и системной платы, наверняка содержащей специальную перемычку для возможности ручных настроек. В подтверждение сказанному можно привести параметры опции "CPU Speed" для материнской платы AbitSM2: "User Define" и "Automatic".
В продолжение и дополнение вышесказанного необходимо выделить опцию "CPU Freq Select" со значениями "Hardware" и "Software", определяющими метод установки внутренней частоты процессора. Первое значение определяет использование соответствующих перемычек на системной плате, второе же предполагает применение настроек через "BIOS Setup".
Но также реальна ситуация с непосредственным выбором частоты процессора без каких-либо предварительных установок. Так опция "Processor Speed" предложила ряд значений ("233", "266", "300" и т.д.), а пользователь должен понимать, что имея фиксированные 66 МГц, он косвенно устанавливает множитель: 3.5, 4, 4.5 и т.д.

CPU Vcore
- (установка напряжения ядра процессора). Не так уж много времени прошло с тех пор, как в современных системах был реализован мониторинг некоторых напряжений на материнской плате, "оборотистости" вентиляторов и контроль температуры. Появилась возможность устанавливать "критический" предел для температуры процессора и некоторые другие параметры. Можно ли было мечтать о самой возможности регулировки питания процессора! Но это уже прошлое!
При практически любом современном тестировании системных плат или отдельных системных компонентов возможности "разгона" оцениваются чуть ли не прежде всего, следуя за простым перечислением комплектности, оснащенности материнской платы. И производители системных плат не могут не учитывать желания миллионов пользователей. Еще не так давно такие компании, как "AOpen", а тем более "Soltek" или "Shuttle", вряд ли могли похвастаться заметной долей на рынке системных плат. Теперь же сравнительное тестирование материнских плат, чипсетов не обходится без их участия. И все благодаря заложенным возможностям "разгона" (достаточно вспомнить "нашумевшую" плату "Soltek SL-75DRV").
Одним из факторов, расширяющих эти возможности, является простая необходимость изменять (увеличивать!) напряжение питания ядра процессора. Сохранение стабильности системы при "простом" частотном "разгоне" без увеличения напряжения ядра процессора маловероятно. И данная опция предоставляет, как правило, целый ряд значений, который может видоизменяться как от версии BIOS или ее производителя, так и от производителя системной платы, чипсета, предназначенного для него процессора, а значит и напряжения ядра. Поэтому вариаций достаточно много. Приведем такой ряд значений: "1.750V", "1.775V", "1.800V", "1.825V", "1.850V" (напомним, что допустимое значение может составлять 1,5 В). Как видим, шаг составляет 0,025 В, и это "хороший" шаг! Ведь конкурентная борьба идет и за этот показатель. В проигрыше (при прочих равных показателях) может оказаться тот, кто предложит возможность изменять напряжение питания ядра процессора с шагом в 0,05 В. Стоит также напомнить, что значения порядка 1,8 В весьма близки к критическим, и любые действия в этом направлении более опасны, чем эксперименты с таймингами или прерываниями!!! Некоторые версии BIOS просто не позволяют переходить предел в 1,8 В. К счастью для пользователей Intel в своих последних моделях Pentium IV на ядре Northwood предусмотрела защиту, которая в случае опасности выхода процессора из строя тормозит его работу, тем самым сигнализируя о недопустимости каких-либо дальнейших действий по "разгону".
В данном случае приведенные значения не "привязаны" к конкретным моделям процессоров. Иначе описание опции превратилось бы неминуемо в перечень технических характеристик.
Понятно, что данная опция ныне располагается среди функций установки частотных характеристик системной платы, и все это может выглядеть следующим образом:
CPU Speed
CPU:System Frequency Multiple
System/PCI Frequency (MHz)
System/SDRAM Frequency Ratio
CPU Vcore
Опция может называться также "CPU Voltage Regulator". Опция "CPU Core Voltage", имея значение "Auto", также дает возможность устанавливать напряжение ядра процессора вручную.

В дополнение к вышеизложенному еще кое-что интересное!
SEL 100/66# Signal
- своим рождением этот сигнал ("100/66#") центрального процессора был обязан внедрению в материнские платы 100-мегагерцовой системной шины. Управление сигналом через установки BIOS приводит к тому, что линия, соответствующая этому сигналу, либо свободна ("high" - 100 мГц), либо заземлена ("low" - 66 мГц). Тем самым управление сигналом приводит к выбору частоты системной шины.
Позднее этот сигнал был переименован в "BSEL0#", а в паре с "BSEL1#" он стал принимать участие и в установке частоты шины в 133 мГц (см. таблицу).

Сигнал "BSEL0" (контакт AJ33)* | Состояние | Сигнал "BSEL1" (контакт AJ31)* | Состояние | Частота системной шины
0 | Замкнут | 0 | Замкнут | 66 МГц
1 | Разомкнут | 0 | Замкнут | 100 МГц
0 | Замкнут | 1 | Разомкнут | Нет применения
1 | Разомкнут | 1 | Разомкнут | 133 МГц

* Контакты приводятся для разъема Socket-370

Speed Error Hold
- эту опцию можно перевести, как "сохранение скорости при ошибке". Речь идет об установке нештатной внутренней частоты центрального процессора и ее последствиях. После установки такой частоты в "BIOS Setup" и последующей перезагрузки система просто остановится, а пользователь не получит желаемого "разгона". Правда, ошибочка вышла с названием опции. Данная опция появилась уже давненько, а вот фирменные технологии типа "RedStorm" совсем недавно. Вот они то и позволяют "сохранять" оптимальные частоты, по сути перестраивая "BIOS Setup" для последующей загрузки. Но это отдельная тема! Значения же рассматриваемой опции: "Enabled" (оно остановит загрузку) и "Disabled". Данная опция в свое время часто использовалась компанией "Abit" в своих системных платах.

Turbo Frequency
- данная опция (по наименованию) конечно же напоминает турбо-функции, изложенные ранее. Но! Речь вовсе не идет об устаревшей опции, влиявшей на некоторые скоростные характеристики, работу кэш-памяти, т.п. С помощью данной опции можно либо блокировать возможность изменения системной частоты, либо иметь такую возможность ("Enabled"). Представленная опция, как правило, функционирует в составе меню, позволяющем программно устанавливать частотные характеристики системы, т.е. через BIOS, или просто вместе с другими базовыми опциями. В свое время компания "ABIT" первой "проложила путь" к ставшим потом стандартными т.н. "CPU SoftMenu".
Конечно же данная опция не решает задачи увеличения частоты системной шины в n раз. Этот рост частоты может составлять 2,5%, не более. Да и система должна поддерживать прежде всего такой "Turbo"-режим. Но рассматривая возможность изменения системной частоты, пользователь однозначно должен предвидеть появление проблем со стабильностью системы. Для центрального процессора увеличение внутренней частоты на 2,5% не должно вызвать никаких проблем. Проблемы могут появиться в работе системной памяти, периферии, хотя в большинстве случаев стабильность системы не должна пострадать! Данную опцию вполне можно назвать "оверклокерской", хотя серьезных "разгонщиков" она вряд ли устроит.
В некоторых случаях включение режима "turbo frequency" осуществляется путем переустановки соответствующего джампера на материнской плате, и приведенная опция, не имея никаких параметров, только показывает "разогнанную" частоту.

Turbo Mode (75 MHz)
- специальная опция "AMI BIOS", предназначавшаяся для работы процессора Pentium II на 75-мегагерцовой системной шине. При установке опции в "Disabled" устанавливалась стандартная частота шины - 66 МГц. Включение же опции допускалось при использовании высококачественных плат расширения, модулей памяти, что требовалось спецификацией "Intel" в отношении нестандартной частоты. В противном случае система могла работать нестабильно.

Дополнительная информация о функциях чипсета и CPU содержится в опциях главы "PCI - Арбитраж, Bus-Master".

4. Memory

Memory Current
- опция "Phoenix BIOS" с установкой тока нагрузки для модулей памяти. Значения параметра следующие:
"8mA" - модули памяти требуют тока нагрузки в 8 мА,
"12mA" - модули памяти требуют тока нагрузки в 12 мА. Установка "12mA" становится необходимой, если используются модули памяти большой емкости (64 МБ и более), которые содержат большое число чипов памяти.

4.1. ECC, Parity

Устройствам динамической памяти присущ один серьезный недостаток - вероятность ошибки считывания информации из ячейки. Для обнаружения ошибок памяти и их корректировки используются схемы проверки целостности данных. Существует 2 способа контроля - с помощью проверки бита четности и с помощью кода коррекции ошибок (ECC - Error Correction Code или Error Checking and Correction). Второй способ надежнее, хотя сравнивать эти методы можно с большой натяжкой.
Для пpовеpки ошибок памяти по четности (во время проведения POST, обычного режима работы) каждый байт информации должен иметь дополнительный девятый pазpяд, котоpый пpи каждом обpащении к ОЗУ по записи устанавливается таким обpазом, чтобы общее число единиц было нечетным. Пpи каждом обpащении по чтению пpовеpяется признак нечетности. Естественно, что поддерживающие проверку по нечетности модули памяти должны содержать дополнительный модуль для хранения этой дополнительной информации. Пpи обнаpужении ошибки возникает немаскиpуемое пpеpывание NMI, котоpое нельзя блокиpовать. Компьютер при этом пpекpащает pаботу, и на мониторе отобpажается сообщение об ошибке памяти, обычно в виде "PARITY ERROR AT 0AB5:00BE SYSTEM HALTED".
Недостаток такой схемы очевиден. Невозможно на основе такого метода контроля целостности исправлять обнаруженные ошибки. Метод же ECC, применяемый на высокоуровневых ПК, серверах, позволяет обнаруживать и исправлять однобитовые ошибки памяти. Двухбитные ошибки определяются при этом, но не исправляются. В отличие от метода по четности при реализации коррекции ошибок каждый бит входит более чем в одну контрольную сумму, что позволяет в случае возникновения ошибки в некотором бите восстановить адрес ошибки и исправить ее. Далеко не все чипсеты поддерживали и поддерживают коррекцию ошибок. К тому же с середины 90-х годов схемы обычного контроля четности применяются все реже. Надо отметить, что ECC не является панацеей от дефектной памяти и применяется для исправления случайных ошибок.
Контроль четности (или метод по модулю 2) существует уже давно. В военной цифровой технике передачи данных существуют более сложные методы, например, по модулю 15. Методы коррекции ошибок также имеют свою предысторию. В системах передачи данных (в частности, телемеханике) также давно применяются и коды Хэмминга, и циклические коды с образующим полиномом, и т.п.
SmartCorrect - технология автоматической коррекции ошибок, разработанная корпорацией "Distributed Processing Technology" (DPT), предназначена для защиты всей подсистемы массовой памяти. Благодаря платам памяти с системой автокоррекции ошибок, высокопроизводительные адаптеры фирмы DPT могут обнаруживать и устранять любые нарушения целостности данных, возникшие на уровне кэш-памяти адаптера или на участках прохождения данных.

CPU Level 2 Cache ECC Check
- опция включения/отключения коррекции ошибок кэша второго уровня у процессоров архитектуры Pentium II и выше, которые поддерживают эту опцию. К примеру, процессоры Pentium II поддерживает коррекцию ошибок, начиная с частоты в 333 МГц. Включение ECC-коррекции несомненно повышает надежность системы, но при этом ее работа, как обычно указывается, несколько замедляется. Но сразу надо отметить, что это замедление несущественно и не должно служить причиной отказа от включения опции.
Как мы уже знаем, в некоторых процессорах допущены ошибки, и включение этого режима может привести к нестабильной работе системы. К тому же фактор надежности и стабильности играет прежде всего значительную роль в сетевых средах. Правда, не стоит забывать и о "разогнанных" системах.
Подытоживая сказанное, можно рекомендовать следующие установки. Если система поддерживает коррекцию ошибок, то она должна быть применена. Естественно, что при отсутствии кэш-памяти второго уровня или ее блокировке данная опция будет также недоступна, хотя представить себе систему без кэша второго уровня наверно сложно. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Чуть другие названия этой же опции: "CPU Level 2 ECC checking", "CPU L2 Cache ECC Checking" и "L2 Cache ECC Support".
"AMI BIOS" предлагает несколько иное наименование опции, но речь идет о том же кэше второго уровня - "Cache Bus ECC". Еще одна опция - "ECC CPU Checking".

Data Integrity (PAR/ECC)
- (целостность данных). Опция разрешения/запрещения контроля памяти на ошибки. Вид контроля устанавливается параметром "DRAM ECC/PARITY Select". Для включения данной опции требуется поддержка модулями памяти уже известных нам технологий. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

DRAM Data Integrity Mode
- (режим целостности данных DRAM). Это опция включения/отключения проверки целостности памяти. Включение опции позволит системе отслеживать и корректировать однобитные ошибки. Так же будут обнаруживаться двухбитные ошибки, но без исправления. Использование режима коррекции ошибок обеспечивает увеличение стабильности и целостности данных в системе, правда, при небольшой потере производительности. Если в системе не используются ECC-модули памяти, то опция должна быть отключена. Опция может быть отключена и при наличии ECC-модулей, но если ситуация в системе благоприятствует сохранению более высокой производительности. Может принимать значения:
"ECC" (иногда - "ECC Hardware") - разрешена коррекция,
"Non-ECC" - коррекция запрещена.
В некоторых случаях опция с тем же названием может иметь другой "набор" параметров: "Parity" и "ECC". При этом меняется и содержание функции. Опция может называться "DRAM Integrity Mode".
В "Phoenix BIOS" содержится аналогичная опция с названием "ECC Control". "Enabled" разрешает проведение коррекции (по умолчанию), "Disabled" запрещает. То же содержание вложено в опцию "ECC Memory Checking".
Значения "non-ECC" и "ECC" принадлежат и опциям "Memory Configuration", "ECC Configuration", хотя первая из них не совсем однозначна в наименовании.
В некоторых случаях к имеющимся параметрам может быть добавлено еще одно - "EC only" (режим проверки на четность, но только с выводом сообщений о возникновении ошибки). В зтом случае данная опция становится аналогичной одному из вариантов опции "DRAM ECC/PARITY Select", но при этом возникновение ошибки не приводит к полной остановке системы.

DRAM ECC/PARITY Select
- опция выбора режима коррекции ошибок/проверки по четности. Эта опция появляется только в BIOS тех материнских плат, в которых чипсет поддерживает ECC, и может быть использована только в том случае, если установлены модули памяти с истинной четностью. В некоторых вариантах BIOS этим параметром может устанавливаться только вид проверки, а разрешение на проверку устанавливается параметром "Data Integrity (PAR/ECC)" или аналогичным. Параметр может принимать значения:
"Parity" (по умолчанию) - в случае возникновения ошибки на монитор выдается сообщение о сбое по четности в памяти и работа компьютера останавливается,
"ECC" - в случае возникновения одиночной ошибки она исправляется (без вывода каких-либо сообщений) и работа системы продолжается. Если имеет место не одиночная ошибка, то работа компьютера также приостанавливается. Следует только учесть, что, по данным "Intel", скорость обмена с памятью при включении этого режима уменьшается приблизительно на 3%.
"Phoenix BIOS" содержит аналогичные опции под названиями "Parity Mode" (или "Memory Parity Mode") и со следующими значениями:
"Disabled" - проверка памяти запрещена,
"Parity" (по умолчанию) - аналогично, как и в "Award BIOS",
"ECC" - так же аналогично, как и в "Award BIOS", сообщение выводится только при двухбитной (и более) ошибке.
"AMI BIOS" "подарил" нам два варианта опции "Memory Error Detection". В одном случае значения параметра оказались уже знакомыми: "Disabled", "ECC", "Parity". Другой же вариант по сути стал аналогом функции "DRAM Data Integrity Mode" с разрешением или запрещением коррекции ошибок ("Enabled"/"Disabled").

Memory Parity/ECC Check
- опция разрешения/запрещения проверки целостности данных. Может принимать значения: разрешен контроль памяти на ошибки ("Enabled"), запрещен ("Disabled") и "Auto". Последняя установка активизирует проверку памяти автоматически с автоматическим же определением возможностей модулей памяти, как по четности, так и по коррекции ошибок. В другой версии BIOS в этой же опции может отсутствовать параметр "Auto".
Только два параметра ("Enabled"/"Disabled") предлагает и опция "Memory Parity (Error) Check". При включении опции и отсутствии необходимых модулей памяти загрузка ПК может прерваться с выводом сообщения "Parity Error".
Осталось отметить следующее! В случае приостановки загрузки системы из-за появления ошибки по четности (или при коррекции) и необходимости все таки произвести загрузку операционной системы, единственный путь обойти POST-тестирование - это запретить любые проверки памяти на четность и т.п. ("Disabled").

Single Bit Error Report
- (сообщение об однобитовой ошибке). Если включен режим коррекции ошибок, то установка опции в "Enabled" позволит системе вывести сообщение о имеющей место однобитовой ошибке и ее коррекции. Решение этой задачи берет на себя контроллер памяти, он же направляет центральному процессору сообщение об ошибке памяти. Отключение опции ведет к отказу от вывода сообщений, но коррекция никак не отменяется.


BIOS. Продолжение!

4.2. "Затенение" памяти, выделенная память

"Shadow Memory" - это так называемая "теневая" память. В адресах памяти от 640 КБ до 1 МБ (A0000h - FFFFFh) находятся "окна", через которые "видно" содержимое различных системных ПЗУ. Например, адреса F0000h - FFFFFh занимает системное ПЗУ, содержащее BIOS системы, окно C0000h - C7FFFh - ПЗУ видеоадаптера (видео-BIOS) и т.п. При включении режима "Shadow" для каких-либо адресных диапазонов, соответствующих системным ПЗУ либо картам расширения, содержимое их ПЗУ копируется в участки основной памяти, которые затем подключаются к этим же адресам вместо ПЗУ, "затеняя" их.
Дает ли это какие-нибудь преимущества? Повышается ли при этом производительность системы? Включение "затенения" дает в первую очередь значительное ускорение работы с данными ПЗУ за счет более высокого быстродействия микросхем ОЗУ (в сравнении со временем доступа к ROM BIOS в 150-200 нс). Кроме того, при обращении к микросхемам BIOS непосредственно используется 8-разрядный доступ (8-битная шина "X-bus"), что включение "затенения" ПЗУ делает еще более эффективным. Это означает, что при обращении к постоянной памяти за один такт можно считать только один байт в отличие от 32-разрядного, как минимум, доступа к оперативной памяти (16-битный доступ ушел в историю с уходом 286-х систем). Кроме этого, появляется возможность модифицировать видимое содержимое ПЗУ: все современные системные BIOS используют это для самонастройки, а в область видео-BIOS обычно загружаются экранные шрифты и т.п.
Что это за теневая память физически? Этот вопрос связан с распределением памяти вообще. В первом мегабайте памяти используются по прямому назначению, т.е. как основная память, 640 КБ, а остальные 384 КБ оказываются в адресном пространстве, зарезервированном для ПЗУ и внешних устройств. В современных платах вся память представляет собой непрерывный массив, поэтому разрывать адресное пространство модулей памяти на две части нельзя и поэтому часть системной области приходится аппаратно исключать, теряя при этом 384 КБ.

Как скопировать в эту память содержимое ПЗУ? Для этого применяют несколько способов:
1) Организация "Shadow Memory". Доступ к ней регулирует чипсет. Как правило, "Shadow Memory" находится в адресном пространстве в том же месте, где и исходное ПЗУ. Поскольку две области памяти в одном месте физически находиться не могут, для управления этой памятью в чипсете есть специальная схема, которая может подключить в этот фрагмент адресного пространства либо исходное ПЗУ, либо ОЗУ.
Несколько слов о защите от записи. Обычно "Shadow Memory" в нормальном состоянии находится в режиме "Read Only" (только для чтения). Это породило проблемы, например, при написании русификаторов, так как приходится открывать "затененные" участки той же видеопамяти. Различные версии BIOS позволяют решать эту проблему, имея опции с возможностью указания, следует ли оставлять требуемый диапазон "Read Write" или "Read Only".
Но не только BIOS способен управлять Shadow-функциями чипсета. Такое управление может осуществлять программа, умеющая корректно обращаться к регистрам чипсета на низком уровне. Начиная с 386-х в защищенном режиме работы процессора имеется страничная организация памяти, обеспечивающая формирование физического (реального) адреса из виртуального адреса программы. Именно эта возможность и обеспечивает в большинстве распространенных драйверов памяти (менеджеров) не только выполнение функций затенения, но и получение памяти EMS при наличии расширенной памяти в компьютере. Программно возможности "Shadow"-функций менеджеров памяти значительно более гибкие, чем у чипсета, управляемого BIOS. В частности, управление размерами памяти, выделяемой для "Shadow Memory", может производиться достаточно малыми по размеру страницами - 4 КБ, что позволяет эффективнее использовать адресное пространство первого мегабайта. В MS-DOS возможность управления "Shadow"-памятью имеет драйвер памяти HIMEM.SYS (ключ /SHADOWRAM:ON|OFF).
Затенение полезно, главным образом, в 16-разрядных ОС. 32-разрядные системы не используют 16-разрядный код из ROM. Вместо него они загружают 32-разрядные драйверы в ОЗУ, заменяя ими 16-разрядный код BIOS, который, таким образом, используется только в процессе загрузки системы.
2) Организация блоков верхней памяти UMB (Upper memory blocks), по сути аналогия предыдущему варианту.
3) Перемещение (relocation). Это перенос неиспользуемой памяти из системной области (640 КБ - 1 МБ) в область расширенной (Extended) памяти. Чаще всего перемещаться может весь фрагмент сразу, то есть все 384 КБ. Это связано со сложностью схемы управления адресными линиями. В этом случае освободить остаток первого мегабайта можно, только выключив все без исключения установки "Shadow". В первых IBM PC устанавливалось 640 КБ основной памяти и отдельно расширенная память, поэтому со старшими 384 КБ проблем не возникало. Позднее, а это также было давно, некоторые чипсеты (Neat, OPTi495, SiS471, др.) имели возможность переносить старшие 384 КБ за пределы пеpвого мегабайта, пpисоединяя их к pасширенной памяти. Одни чипсеты могли переносить свободные от "затенения" участки, другие - только все 384 КБ целиком.

Последующая серия опций объединена одной темой ("Теневое ПЗУ адаптеpа ХХХХ,16K") и представляет собой, в основном, устаревшие аппаратные решения.
Adaptor ROM Shadow C800,16K
- опция для маскиpования ПЗУ некотоpых специальных каpт - сетевых, различных контpоллеpов и т.п. По умолчанию устанавливается "Disabled". Установка в "Enabled" допустима только тогда, когда в систему инсталлирована каpта расширения с ПЗУ, занимающим эти адpеса. В свое время большинство дисплейных видеоадаптеров, таких как MDA, Hercules, использовали ПЗУ с адpесом C800. Поскольку эти каpты были низкоскоростными, затенение этого адpеса улучшало общую пpоизводительность системы.
Дополнительная и интересная информация! Некотоpые версии BIOS допускали включение теневого ОЗУ со снятой защитой от записи. Пpи помощи дpайвеpа возможно было использование "теневой памяти" в качестве области UMB. Это давало некотоpое пpеимущество в скоpости в сpавнении с UMB-областью, обеспечиваемой пpи помощи драйвера EMM386.
Возможна вполне современная ситуация, когда затенению может быть подвергнут загрузочный BIOS сетевого адаптера. В этом нет никакой необходимости, т.к. загрузка удаленной системы вряд ли есть непрерывный процесс.
Adaptor ROM Shadow CC00,16K
- эта область предназначалась для некоторых (естественно, старых) адаптеpов жестких дисков.
Adaptor ROM Shadow D000,16K
- адресная область для использования сетевыми картами.
Adaptor ROM Shadow D400,16K
- некоторые специальные контроллеры (это было давно) для четырех floppy-дисководов имели отображаемый BIOS ROM в диапазоне адресов D400...D7FF.
Adaptor ROM Shadow D800,16K
Adaptor ROM Shadow DC00,16K
Adaptor ROM Shadow E000,16K
- возможная область для размещения EMS-страницы.
Adaptor ROM Shadow E400,16K
Adaptor ROM Shadow E800,16K
Adaptor ROM Shadow EC00,16K
- эта область могла быть использована системой после копирования SCSI-контроллерами своего BIOS.
Некоторые SCSI-контроллеры не использовали адресов ввода/вывода. Их адресный BIOS-диапазон содержал перезаписываемые адреса, которые в действительности являлись I/O-портами. Это означало, что эти адреса не должны были затеняться и даже кэшироваться.
Совершенно аналогично "работали" следующие опции:
C8000-CBFFF Shadow
CC000-CFFFF Shadow
D0000-D3FFF Shadow
D4000-D7FFF Shadow
D8000-DBFFF Shadow
DC000-DFFFF Shadow
Совершенно те же опции предложил "Phoenix BIOS" в меню под названием "Shadow Memory Regions". Хотя то же меню "Phoenix BIOS" в другом варианте предложило "укрупненные" области памяти "C8000-CFFFF" (и т.д.) со значениями "Disabled" и "Shadow".
И совершенно ясно, что возможны также другие вариации по "затенению". Например, опция "E8000 - EFFFF Shadow" может быть использована для поддержки интегрированного SCSI-контроллера.
И еще одно важное замечание, не утратившее актуальности и по сей день. Речь идет о специализированных ISA-адаптерах с микропроцессорами, память которых организована как двухпортовая. Если память такого микропроцессора по одному из портов со стороны компьютера адресуется как страница в области указанных адресов, то "затенение" для этой области должно быть запрещено ("Disabled").
Обобщая сказанное, необходимо отметить, что затенение разделяемой ("shared") памяти недопустимо. Разделяемая память служит также в качестве буферов сетевых контроллеров, т.п.
Еще пример затенения адресных областей:
C000,16K Shadow
C400,16K Shadow
C800,16K Shadow
CC00,16K Shadow
D000,16K Shadow
D400,16K Shadow
D800,16K Shadow
DC00,16K Shadow
Ничего нового, разве что первые две опции меню неявно предназначены для затенения видео-BIOS (см. подробно ниже). На этом остановимся, ибо есть еще вариации по затенению областей памяти в виде отдельных меню, но пользователю уже несложно будет с ними разобраться.

Base Memory Address
- данной опцией устанавливается начальный адрес адресного диапазона, выделяемого под потребности некоторой PCI-карты. Понятно, что возможности адресации обеспечиваются 32-разрядной шиной.
Опция может называться "Memory Start Address".

BIOS Devnode for Shadow RAM
- эта опция используется (включается при "Enabled") для некоторых карт расширения, чья ROM-память не требует коррекции того региона основной памяти, который эта карта занимает. "Disabled" позволяет разблокировать фиксированный начальный адрес области памяти для устройства и изменять его динамически.

CD Hole
- столь необычная опция "AMI BIOS" предназначена для управления адресной областью в диапазоне DC000h - DFFFFh. Если установлено значение "Disabled", то любое обращение, запрос к данному пространству направляется основному SCSI-контроллеру (хотя это может быть и сетевое устройство). Если же выбрано "Enabled", доступ к этому региону памяти контролируется одним из PAM (Programmable Attribute Map) регистров, т.е. стандартным способом.
Стоит остановиться на этой теме подробнее.

В состав "северного" (Host-to-PCI Bridge) моста чипсета, среди множества других, входят и семь программируемых PAM-регистров. Через установку различных аттрибутов они позволяют управлять тринадцатью адресными сегментами различного размера в диапазоне от 640 КБ до 1 МБ адресного пространства. С другой стороны, кэширование этими областями осуществляется через MTRR-регистры центрального процессора (о них будет сказано ниже).
Каждый PAM-регистр (см. таблицу) контролирует два региона, обычно по 16 КБ каждый. Каждый из регионов "обслуживается" четырьмя битами, два из которых зарезервированы, а два остальных - это "Read Enable" и "Write Enable". В зависимости от состояния этих бит ("0" или "1") осуществляется либо доступ к основной памяти, либо запросы перенаправляются на PCI-шину. Поэтому, если установлены два "0", доступ к выбранному диапазону памяти невозможен.
В процессе начальной загрузки и выполнения инструкций BIOS при копировании некоторого BIOS в выбранную "затеняемую" область в соответствующем регистре по соответствующему аттрибуту "Write Enable" устанавливается "1". После окончания всех процедур, связанных с затенением, для данного диапазона (регистра) устанавливается режим "только для чтения" (read only), что соответствует аттрибутам "Read Enable", равным "1", и "Write Enable", равным "0". При этом все циклы записи в данную область перенаправляются непосредственно шине расширения.
Понятно, что если речь идет о выделенной RAM-памяти, то оба аттрибута будут равными "1".

PAM-регистр | Сегмент памяти | Назначение | Примечание
PAM0[3:0] | Зарезервировано |  |
PAM0[7:4] | 0F0000h - 0FFFFFh | BIOS Area | Область системного BIOS. 64K-байтный сегмент, который может кэшироваться, читаться и перезаписываться. При блокировке этой области данная адресная зона "выпадает" из карты памяти
PAM1[3:0] | 0C0000h - 0C3FFFh | ISA Add-on BIOS* | Expansion Area (C0000h-DFFFFh), или область расширения, - это 128К-байтная область, разделенная на восемь 16K-байтных сегментов. Каждый из сегментов может находиться в одном из четырех состояний: только для чтения, только для записи, чтения/записи или заблокированном. Каждый из сегменов может кэшироваться. При блокировке этой области данная адресная зона "выпадает" из карты памяти
PAM1[7:4] | 0C4000h - 0C7FFFh | ISA Add-on BIOS*
PAM2[3:0] | 0C8000h - 0CBFFFh | ISA Add-on BIOS*
PAM2[7:4] | 0CC000h - 0CFFFFh | ISA Add-on BIOS*
PAM3[3:0] | 0D0000h - 0D3FFFh | ISA Add-on BIOS
PAM3[7:4] | 0D4000h - 0D7FFFh | ISA Add-on BIOS
PAM4[3:0] | 0D8000h - 0DBFFFh | ISA Add-on BIOS
PAM4[7:4] | 0DC000h - 0DFFFFh | ISA Add-on BIOS
PAM5[3:0] | 0E0000h - 0E3FFFh | BIOS Extension | Расширенная область системного BIOS (E0000h-EFFFFh) разделена на четыре 16К-байтных сегмента. Каждый сегмент независимо от других может кэшироваться, считываться и быть перезаписываемым. При блокировке этой области данная адресная зона "выпадает" из карты памяти
PAM5[7:4] | 0E4000h - 0E7FFFh | BIOS Extension
PAM6[3:0] | 0E8000h - 0EBFFFh | BIOS Extension
PAM6[7:4] | 0EC000h - 0EFFFFh | BIOS Extension

Примечание.
* - Сегмент C0000h - CFFFFh может быть использован SMM-пространством, если используется SMRAM-регистр (об SMM см. ниже).

E0000 ROM belongs to ATBUS
- один из примеров "стареньких" опций по выделению фрагмента из "верхней" памяти для использования системными устройствами. В данном случае "Yes" позволяло зарезервировать такой фрагмент за AT-шиной. Обычно, E000-область зарезервирована за кодом системного BIOS, но некоторые системы не использовали его стандартным образом. Например, "OS/2" использовала этот диапазон для работы в защищенном режиме и "грузила" код Advanced BIOS в область E000h-EFFFh.

E8000 32K Accessible
- аналогичная опция, хотя и не такая "древняя", поскольку предназначалась для использования (и опция, и адресная область) PS/2-системами, 32-разрядными ОС, под "PnP"-область.

Extended ROM RAM Area
- наличие этой опции характерно для старых версий "AMI BIOS". Пользователю предоставлялся выбор, где хранить данные о жестком диске: в верхнем килобайте базовой системной памяти, начиная с 639-го килобайта, или в адресах нижней памяти в области DOS-памяти или системного BIOS (0:300). Необходимо было помнить, что вторая адресная область могла также использоваться некоторой периферией (звуковыми, сетевыми и т.п. картами расширения). В этом случае конфликтов можно было избежать, если система через BIOS могла использовать полноценные механизмы "затенения", которые впрочем могли и отсутствовать в очень старых системах. Вполне возможна была ситуация с изменением параметров жесткого диска в этой области памяти перед ее полным отображением, так как в ней содержался блок параметров фиксированного диска. В некоторых случаях могло потребоваться изучение документации на соответствующие платы расширения или контроллеры по использованию ими данной области памяти.
Опция могла (или может) называться "RAM Area" или "Hard Disk Type 47 - RAM Area". Последняя опция напоминает нам о процедуре пользовательской установки параметров жесткого диска.

ISA LFB Size
- опция "AMI-BIOS" для установки размера линейного буфера кадра (LFB - Linear Frame Buffer), во многом аналогичная или близкая по смыслу нижерасположенной "Memory Hole At 15M-16M". Кроме размещения ROM-адреса в пределах 15-16 МБ, опция позволяла (в таком виде она уже не встречается) установить размер линейного видеобуфера графических адаптеров в области основной памяти, доступной для ISA-шины (1, 2, 4 МБ). Это суть диапазоны 15-16, 14-16 и 12-16 МБ соответственно. Еще одним значением являлось "Disabled" с отказом от выделения под ISA-адаптер линейного буфера кадра. "Disabled" могло потребоваться при объеме памяти не более 8 МБ (в 96-м г. это было почти пределом) и при работе с MS-DOS. Такое же значение необходимо было установить при использовании ISA-карт с отсутствующим кадровым буфером. Запрещение опции не позволяло использовать "Plug and Play's Configuration Manager" или "ISA Configuration Utility". Если же какое-то из значений ("1 MB", "2MB" или "4MB") было выбрано, то следующая опция "ISA LFB Base Address" становилась доступной.
DOS-приложение могло использовать стандартно под видеопамять только 64 КБ основной памяти. В этом объеме не "поместится" и "хороший" графический файл. Совместно развивающиеся технологии памяти и работы с ней позволили создать механизм пейджинга, суть которого заключается в том, что можно отображать разные части видеопамяти на один и тот же видеосегмент (0a000h) поочередно. Но это переключение отнимает время у процессора, снижая эффективность метода. Идеальным вариантом стало использование линейного буфера кадра, который доступен только в защищенном режиме работы процессора, а значит за пределами первого мегабайта, и с использованием расширения VBE (VESA BIOS Extension) не ниже версии 2.0.
Для графических PCI-карт с использованием линейного буфера кадра стало возможным применение возможностей чипсета (PCI Burst Mode).
Опция может называться "ISA VGA Frame Buffer Size" или "ISA Linear Frame Buffer". Дополнительная информация может быть почерпнута из упомянутой и приведенной ниже опции.

x ISA LFB Base Address
- данная опция не имеет параметров и носит информационный характер. Показывает основной адрес LFB, если установлен размер в предыдущей функции. Адрес устанавливается автоматически.

ISA Mem Block Base
ISA Mem Block Size
- об этих опциях см. ниже.

ISA Shared Memory Size
- (размер разделяемой памяти ISA). Опция позволяет выделить блок в "верхней" (upper) памяти, который обычно "затеняется" и который не будет в данном случае использован для дублирования (shadowing) содержимого ПЗУ в основную память, для доступа к ней ISA-карты. Через установку опции в "Disabled" (по умолчанию) мы отключаем возможность установки такого блока в системной памяти. Данную опцию необходимо включать только при установке в систему ISA-карты, которая использует верхние адреса памяти. Это означает, что в системе используются не "Plug and Play" ISA-карты (т.н. "legacy card"), конфигурируемые "вручную". Указывая размер требуемого блока, пользователь и "включает" опцию. Размер блока выбирается в пределах от 16 до 96 кБ с шагом в 16 кБ.
Необходимо знать еще вот о чем! В системе могут быть использованы ISA-адаптеры, у которых память собственного микропроцессора является двухпортовой и организована так, что со стороны адаптера она имеет некоторые физические адреса, а по второму порту она адресуется со стороны IBM PC/AT как страница памяти компьютера, расположенная в области адресов (в зависимости от установки перемычек на плате), например: C800h, D000h, т.п. В этом случае задачи адресации решаются на уровне специального прикладного ПО и драйвера. Таких специальных плат расширения в свое время было разработано достаточно много для использования в системах реального времени под MS-DOS.
К вышесказанному еще несколько слов. Некоторые "настоящие" (legacy) платы ISA имеют встроенную память (ПЗУ), которая не видна без специального программного драйвера. Поскольку об этой памяти BIOS ничего не знает, BIOS может (по ошибке) приписать адреса этой памяти другим платам PCI или ISA. При использовании таких карт расширения требуется серьезное изучение документации.

x ISA Shared Memory Base Address
- (базовый адрес разделяемой памяти ISA). Опция доступна при включении предыдущей функции. При этом устанавливается начальный адрес "ISA Shared Memory". Опциально устанавливается C8000h, CC000h и т.д. Необходимо помнить, что при выборе начального адреса не должен быть использован E0000h-адрес. Если же в предыдущей опции выбран блок памяти размером в 64 кБ, то может быть использован в качестве начального адреса адрес D0000 или ниже.
В других версиях BIOS могут встретиться другие наименования такой функции, точнее такой пары, - "ISA Mem Block Base" и "ISA Mem Block Size". В качестве значений для первой могут быть указаны адреса C800, CC00, D000, D400, D800 и DC00, а также значение "No/ICU" (нет/ICU), оставляющее управление этим параметром на усмотрение BIOS или программы ICU (ISA Configuration Utility). А размер блока выбирается из ряда: 8K, 16K, 32K, 64K. Необходимо также добавить, что при выборе самого размера блока надо ориентироваться на "потребности" конкретной карты, а также на ...количество таких "вредных" ISA- карт.
И еще одна интересная пара функций. Только "начальной" является опция "Used Mem Base Addr". Она как бы "охватывает" более широкий спектр устройств. Предполагается, что к некоторой области верхней памяти пожелают иметь доступ не только ISA-устройства. Для выбора предлагается, как и выше, любой сегмент памяти между C800H и DC00H адресного пространства (6 возможных адресов), а также по умолчанию - "N/A" (как "Disabled"). При включении опции активируется поле "Used Mem Lenght" для установки размера блока: 8, 16, 32 или 64 кБ.
Теперь "AMI BIOS"!
"Reserved Memory Size" и
x "Reserved Memory Address".
Параметры основной опции: "Disabled", "16K", "32K", "64K". Параметры же второй: C000, C400, C800, CC00, D000, D400, D800 или DC00.

Memory Hole At 15M-16M
- (буквально - "дырка" в памяти в диапазоне 15-16 МБ). При включенном состоянии параметра система, для повышения производительности, будет копировать более медленную память устройства, например, подключенного к ISA-шине, в более быструю основную память. Это происходит за счет выделения специальной области памяти и перемещения в нее данных ROM-памяти карты расширения или устройства сопряжения. Естественно, что действие этой функции представляет собой механизм "эатенения", который позволяет обращаться, в данном случае к устройствам ввода/вывода, как к адресному пространству ОЗУ и за счет этого увеличить скорость доступа к таким устройствам. Для функционирования этого механизма необходимо исключить для всех обычных программ возможность использования указанной области памяти, что и делает BIOS при разрешении этого параметра. При отсутствии ISA-устройств данная опция должна быть отключена ("Disabled"). По умолчанию эта опция, как правило, включена.
Общее представление есть! Рассмотрим некоторые уточнения и дополнения. Разрешать этот параметр следует в том случае, если это требуется в документации на используемую в системе плату расширения или устройство. Некоторые старые ISA-карты (например, ранние видеокарты высокого разрешения) требуют выделения для них специального адреса памяти, лежащего в некотором диапазоне. Кроме того, это выделение запрещает доступ в старшие адреса памяти, расположенные выше 16 МБ. Это означает, что, независимо от объема инсталлированной в системе памяти, операционная система не сможет обращаться к этому адресному пространству. Поэтому включение данной опции должно быть оправдано. По сути, данная функция сохранена в "BIOS Setup" по причине фактора совместимости со старыми картами. Необходимо помнить и о том, что когда мы говорим вообще об ISA-картах, то должны подразумевать и функционирование DMA-каналов, которое достаточно жестко вписывается в канву ограничений ISA-шины. Но об этом будет сказано отдельно. Может принимать значения: "Enabled" (разрешено), "Disabled" (запрещено).
Немного дополнительной информации. Включение функции позволяет создать пропуск в динамической памяти, а точнее разрыв. Для адресов, попадающих в этот диапазон, циклы процессора и PCI будут игнорироваться самим чипсетом. Последствия для неподготовленного пользователя при создании "дырки" могут быть самыми непредсказуемыми. Возможна ситуация, когда такой режим может понадобиться и PCI-плате, если она нуждается в отдельном управлении адресами. Поэтому не должно удивлять присутствие такой опции и в системах, уже лишенных привычной ISA-шины.
И что также очень важно, выбранный диапазон "выпадает" и из объема кэшируемой памяти, а во-вторых, и из возможности воздействия на него (управляемости) операционной системы. Последнее, естественно, связано уже с функционированием аппаратных компонент.
В более "старых" версиях BIOS могут встретиться другое наименование такой функции - "Memory Hole", и значения параметров: "None", "at 512 kB", "at 15 MB". Действие некоторых параметров уже понятно, а для значения "at 512 kB" стоит указать, что для "затенения" используется часть базовой памяти в пределах 512-640 КБ. Есть еще один вариант и абсолютно идентичный. С тем же названием и фактически с теми же значениями: "Disabled", "512KB-640KB", "15MB-16MB". Те же значения предлагает опция "Fixed Memory Hole".
Был встречен и такой вариант опции "Memory hole": значения "Disabled" (по умолчанию), "Conventional" и "Extended". Все эти необычные параметры также предназначались для выделения адресного пространства под "стандартные" (legacy) ISA-устройства.
"AMI BIOS" может содержать опцию под названием "Memory Hole at 15M Addr.", т.е. близкую к исходной.
Необходимо также достаточно определенно представлять себе, что выделение некоего объема памяти предназначалось не только (и даже не столько) для переноса данных ROM-памяти какого-либо устройства, сколько для формирования в системной памяти области, являющейся по сути локальной памятью этого устройства или даже локальной памятью шины. Иначе зачем выделять под область "затенения" 1 МБ и более. Например, в некоторых версиях BIOS можно было встретить такой набор значений: "Disabled", "14M-16M", "15M-16M".
Более определенно на сей счет "говорит" старенькая функция "Memory Hole Size" с такими предложениями: "1 Mb", "2 Mb", "4 Mb", "8 Mb", "Disabled". Все это богатство предназначалось для системной AT-шины, а также резервировалось под потребности ISA-карт. Исходя из вышесказанного, станет более понятна опция "15-16M Memory Location" с параметрами: "Local" (по умолчанию) и "Non-local". Аналогичная опция могла называться и "Local Memory 15-16M".
Может возникнуть еще один вопрос. Почему все рассматриваемые функции "привязаны" к 16 МБ? Еще раз стоит подчеркнуть, что наличие всех этих функций в более современных версиях BIOS связано только с принципом совместимости с возможно эксплуатируемыми или специально разработанными картами расширения, устройствами сопряжения, или, как иногда говорят, устройствами связи с объектом (УСО), т.п. Появление же на свет божий всех этих опций "совпало" с появлением в середине 80-х славной 16-разрядной ISA-шины, для которой добавление 4 дополнительных адресных линий означало увеличение максимального размера адресуемой памяти до 16 МБ. Поэтому, задавая некий размер адресной области, мы однозначно определяем ей место "в конце" 16-мегабайтного адресного пространства.
Еще несколько слов о "Phoenix BIOS", предлагавшем аналогичную опцию под названием "ISA Memory Gap". Правда, в различные времена предлагалось два варианта опции. В одном из них была возможность использовать/не использовать последний мегабайт памяти, как "ISA memory area". Другой вариант опции предлагал также уже знакомые значения: "1 Mb", "2 Mb", "4 Mb", "8 Mb" и "Disabled".
Ну и напоследок не отдельные опции, а пары совместных функций или даже отдельные подменю. "Memory Hole Start Address" (а могут быть и такие варианты - "Memory Map Hole Start Address" или "Memory Map Hole End Address") дает возможность установить начальный адрес "дырки" из ряда, начиная с 1-го по 15-й МБ с шагом в один мегабайт. Но эта опция становится доступной, если включена базовая опция "Memory Map Hole".
Очень давние предложения от "AWARD"! Поверьте, такие системы до сих пор функционируют! Необходимо вначале включить ("Enabled") опцию "Allocate Memory Hole", а затем поработать над "Hole Start Adress" и "Hole Size". Причем размер "дырки" варьируется в пределах (!) от 64 КБ до 8 МБ (через удвоение шага), а установка начального адреса позволяет перемещать по адресному пространству выбранную область.
Напоследок вполне современный и весьма неожиданный эффект от применения "нашей" опции. В периодике как-то появилась информация, что включение опции помогло решить проблему нестабильной работы чипсетов VIA в системе с установленными звуковыми картами Creative SB Live! и Aureal, причем PCI-картами!. Хотя еще раньше была озвучена информация о конфликтах со звуковыми картами, такими как Diamond MX300 или Soundblaster той же "Creative Labs", и что эти конфликты системных ресурсов удалось разрешить за счет использования "дырки" в памяти. Так что пусть опция еще поживет?!
Memory Remapping
- (перераспределение памяти). Поскольку аналогичная опция может называться "Memory Relocation", то пользователь уже знает, о чем идет речь. Очень старенькая опция, применение которой имело смысл в системе с ограниченным объемом оперативной памяти. Включение опции ("Enabled") требовало запрещения всех видов "затенения" в области адресов A0000 - FFFFF, в т.ч. "затенения" видео- и системного BIOS. Детальнее см. выше.

Memory Reservation
- так называется меню с "низкой" опций ("C800 - CBFF" и т.д., см. выше), из возможных параметров которых ("Available" и "Reserved) следует, что выбранный 16К-байтный диапазон может быть соответственно либо доступен для использования некоторым устройством (пример "выделенной" памяти), либо зарезервирован для использования любым программным обеспечением.
Нечто подобное предлагает "Phoenix BIOS" в меню "PCI/PNP ISA UMB Region Exclusion". Правда, т.н. "Upper Memory Blocks" не предназначены для использования стандартными ISA-картами (не Plug&Play-картами). А в остальном и диапазоны те же, и значения.

Shadowing Address Ranges (xxxxx-xxxxx Shadow)
- данная опция подобна вышепредставленным и позволяет разрешать ("Enabled") или запрещать ("Disabled") "затенение" указанного адресного диапазона для использования некоторой картой расширения. Запрещение допустимо, если такая карта не используется, или для такой карты в той же "Windows9x" функционирует соответствующий драйвер. Стоит напомнить, что "WindowsNT" не использует механизмов "затенения", и что некоторые карты, использующие диапазон CXXXh-EFFFh для операций ввода/вывода, могут не работать при включенном "затенении". В последнем случае запросы чтения/записи памяти могут не проходить, например, к той же ISA-шине.

System BIOS Shadow
- опция разрешения применения теневой памяти на область системной ROM BIOS. Рекомендуется установить в "Enabled" для повышения производительности системы, однако необходимо еще раз подчеркнуть, что улучшения эффективности системы можно добиться только в "MS-DOS" или "Windows 3x". При этом старшие 384 КБ из первого мегабайта памяти станут недоступными в качестве ОЗУ.
Некоторые старые версии BIOS (речь идет об устаревших системах) давали возможность "затенения" отдельных областей из выделенных под системный BIOS 64 КБ. Это было достаточно удобно, так как такие адресные зоны - суть фрагменты по 16 КБ (шаг адресов в 400h). В современных системах такой возможности нет, прежде всего аппаратной. Поэтому при включении режима "затенения" системный BIOS затеняется целиком.
Опция может называться "System Shadow" или "System ROM Shadow F000, 64K". Когда-то такая функция называлась совсем просто - "BIOS Shadow".

VGA Type
- данные этой опции используются BIOS системы, когда затенение видео BIOS включено. Оказывается, важно и то (см. чуть ниже), о какой видеокарте (читай, шине) идет речь. Отсюда и возможные значения: "Standard" ("стандартное затенение" - по умолчанию), "PCI", "ISA/VESA".

Video BIOS Shadowing
- при включении этой опции ("Enabled") BIOS видеокарты, как мы уже знаем, будет скопирован в оперативную память (по адресам C0000h-C7FFFh), что ускорит обращение к нему. За счет чего? Это уже известно! За счет различной разрядности шин памяти и времени доступа к ячейкам памяти. Но современные операционные системы обращаются к видеокартам напрямую, минуя их BIOS. Ну а "Windows NT" вообще не использует затеняемую память. А вот производительность графики в "старушке" MS-DOS сильно зависит от того, включена данная опция или нет. Если при включении теневой памяти не наблюдается какого-либо ускорения работы графических функций, то необходимо проверить соответствие адресов ROM BIOS видеокарты и установленной затеняемой области. Если не используются старые программы, лучше опцию отключить, так как, если какое-нибудь приложение обратится к адресам, занятым Video BIOS, возможны сбои.
Опция может называться "Video ROM Shadow C000, 32K", "Video ROM BIOS Shadow", "Video ROM Shadow", "Video BIOS Shadow" или "Video Shadow".
Некоторые версии BIOS также предлагают "затенение" отдельных областей, и тогда вместо одной, а точнее как дополнение к основной опции, предлагается набор из, например, следующих опций:
"Video ROM Shadow C000, 16K"
"Video ROM Shadow C400, 16K"
Такой вариант с опциями появился по причине того, что видеокарта на своем "борту" могла иметь и 16K-байтный объем ROM-памяти. В этом случае затенялся только диапазон C400h. Современные видеокарты, по сути предназначенные для использования в мощнейших программных средах, имеют значительно большие размеры Video BIOS, и только часть этого кода (32 КБ) может быть затенена. Нонсенс! При этом возможны сбои, т.к. при обращении к видео BIOS обращение будет происходить по адресам, принадлежащим физически разной памяти.
Еще одно важное замечание, которое не было отображено выше. Современные видеокарты хранят свой BIOS в микросхемах, допускающих перепрограммирование (во Flash BIOS), позволяющем получить доступ на скоpостях, сpавнимых со скоpостью обpащения к ОЗУ. Скоpость обpащения к VGA BIOS опpеделяется также и скоpостью шины (ISA, EISA или VLB). А если речь идет о PCI или AGP? И тогда может оказаться, что необходимости затенять VGA BIOS нет, и при этом появляется возможность освободить 384 кб ОЗУ для других целей. Но все же к VGA BIOS обращения происходят часто, особенно это характерно для игрового ПО. Так что решает проблему каждый пользователь сам и в каждом конкретном случае.
Также необходимо помнить о том, что BIOS интегрированного видеоадаптера располагается, как правило, по адресам системного BIOS. Тут как раз и необходимо дополнительно упомянуть, что функционирование видеоканала в современной системе обеспечивается управлением графического процессора через видеодрайвер, а не с помощью набора команд от центрального процессора. В последнем случае BIOS видеокарты обеспечивал определенный набор функций, совершенно игнорируемых в современной системе. Поэтому можно сказать, что первородное назначение видео BIOS сохраняется по причине обратной совместимости со стандартным VGA-интерфейсом.


BIOS. Продолжение!

4.3. Кэширование памяти

Как правило, кэш-память (Cache Memory) ассоциируется всегда с центральным процессором. Кэш-память представляет собой статическое ОЗУ, обладающее значительно более высоким быстродействием, нежели динамическое. Фактически, кэш-память предназначена для согласования (компенсации) скорости работы сравнительно медленных устройств с относительно быстрым центральным процессором, т.е. она играет роль быстродействующего буфера между процессором и относительно медленной динамической памятью. Для кэш-памяти характерно значительно меньшее время доступа (Access time). Время доступа - это характеристика, показывающая, сколько времени необходимо для того, чтобы получить доступ к той или иной ячейке памяти.
Кэш-память изготавливается на микросхемах статической памяти, не требующей регенерации. Кэш-память значительно дороже динамической, поэтому ее объем, как правило, не превышает 512 КБ. Объем и быстродействие кэш-памяти являются определяющими параметрами быстродействия всей системы для подавляющего большинства задач, решаемых на компьютере. Цифры впечатляющей разницы в быстродействии между различными видами DRAM уменьшаются во много раз при оценке производительности компьютера в целом из-за кэш-памяти. Для большего увеличения быстродействия кэш-памяти она встраивается в собственно кристалл процессора и работает при этом на той же тактовой частоте, что и сам процессор.
При попытке доступа к данным процессор сначала обращается к внутренней кэш-памяти, если их там нет, то ко внешней, лишь затем к основной динамической памяти.
Когда процессор первый раз обращается к ячейке памяти, ее содержимое параллельно копируется в кэш, и в случае повторного обращения может быть с гораздо большей скоростью выбрано из кэша. При записи в память значение попадает в кэш, и либо одновременно копируется в память (схема Write Through - прямая или сквозная запись), либо копируется через некоторое время (схема Write Back - отложенная или обратная запись). При обратной записи, называемой также буферизованной сквозной записью, значение копируется в память в первом же свободном такте, а при отложенной (Delayed Write) - когда для помещения в кэш нового значения в кэш-памяти не оказывается свободной области. При этом в память вытесняется наименее используемая область кэша. Вторая схема более эффективна, но и более сложна за счет необходимости поддержания соответствия содержимого кэша и основной памяти. Очевидно, что контроллер кэш-памяти должен быть достаточно интеллектуальным, чтобы решать столь сложные задачи, в том числе, определять, какие данные могут понадобиться процессору в следующий момент.
Сейчас под термином "Write Back" в основном понимается отложенная запись, однако это может означать и буферизованную сквозную.

Память для кэша состоит из собственно области данных, разбитой на блоки (строки), которые являются элементарными единицами информации при работе кэша, и области признаков (tag), описывающей состояние строк (свободна, занята, помечена для дозаписи и т.п.). В основном используются две схемы организации кэша: с прямым отображением (direct mapped), когда каждый адрес памяти может кэшироваться только одной строкой (в этом случае номер строки определяется младшими разрядами адреса динамической памяти), и n-связный ассоциативный (n-way associative), когда каждый адрес может кэшироваться несколькими строками. Ассоциативный кэш более сложен, однако позволяет более гибко кэшировать данные.

Основные типы кэш-памяти:
Asynchronous SRAM,
Synchronous Burst SRAM,
Pipelined Burst SRAM.
Эти три типа памяти построены по статической схеме и выпускаются для организации кэш-памяти 2-го уровня. Два последних типа обеспечивают пакетный режим доступа к данным.
1. Asynchronous SRAM (асинхронная статическая память) используется еще со времен 386-х процессоров. Принцип работы простейший! Процессор посылает адрес необходимой ячейки памяти, контроллер ищет данные и в случае успеха передает их процессору. При этом в оптимальном варианте работает схема 3-2-2-2 (3 такта на считывание первого сегмента данных и по два такта на считывание 3-х последующих).
2. Synchronous Burst SRAM (синхронная пакетная статическая память) позволяет получить наиболее быстрый доступ в системах с тактовой частотой шины до 66 МГц. Являясь пакетной, эта кэш-память позволяет реализовать схему 2-1-1-1. В системах с частотой системной шины более 66 МГц эта схема ухудшается до 3-2-2-2.
3. Pipelined Burst SRAM (статическая память с блочным конвейерным доступом) приобрела к 1997 году наибольшее распространение, обеспечивая схему доступа 3-1-1-1, которая не ухудшается с ростом тактовой частоты. "Конвейерность" заключается в том, что при считывании нескольких последовательных ячеек памяти они буферизируются, и это позволяет уменьшить время, которое затрачивает процессор на такую процедуру.
Пакетные типы кэш-памяти получают синхронизирующий сигнал от процессора. Кэш содержит счетчик, который, когда бы процессор ни начал цикл, позволяет модулю кэша автоматически быстро выполнить последовательность из четырех циклов. Первый и самый длинный цикл инициализируется процессором. Следующие три вырабатываются модулем кэша синхронно с синхронизирующими импульсами процессора.

В предыдущей главе и в опциях, представленных далее, достаточно полно изложены всевозможные варианты "затенения" и кэширования фрагментов памяти, расположенных в верхних 384-х килобайтах первого мегабайта системной памяти. Несколько "особняком" от них выделяются предложенные опции. Не по их виду, а по тем значениям, которые возможны для них. Вот эти опции:
Video BIOS C000-C3FF
Video BIOS C400-C7FF
C800-CBFF Memory
CC00-CFFF Memory
D000-D3FF Memory
D400-D7FF Memory
D800-DBFF Memory
DC00-DFFF Memory
Ext BIOS E000-E3FF
Ext BIOS E400-E7FF
Ext BIOS E800-EBFF
Ext BIOS EC00-EFFF
Довольно внушительно. А вот и значения этих опций:
"PCI Device" - выбранный диапазон отдается под потребности PCI-устройства,
"Shadowed" - выбранный диапазон "затеняется",
"Write Prot." - выбранный диапазон защищен от записи. При загрузке системы в этот адресный диапазон копируется некое ПЗУ и в процессе работы эти адреса доступны только для чтения,
"Uncached DRAM" - некэшируемый регион памяти,
"PCI/Cached" - выбранный диапазон принадлежит PCI-устройству и кэшируется,
"Shadowed/Cached" - выбранный диапазон "затеняется" и кэшируется,
"Write/Cached" - по адресам выбранного фрагмента может производиться запись и этот фрагмент кешируется,
"Cached DRAM" - кэшируемая область памяти.
В некоторых версиях BIOS к указанным диапазонам может быть добавлена область системного BIOS:
System BIOS Area

Cache Base 0-512k
Cache Base 512-640k
Cache Extended Memory Area
- для использования этих опций, предложенных "Phoenix BIOS", предварительно должно быть включено кэширование в системе, для чего может быть предназначена интегрированная опция "Cache". Понятно, что механизм кэширования может быть включен для двух областей: основной памяти и расширенной (типа XMS). А данные опции дают возможность выбрать метод кэширования для каждой из областей. Итак:
"Write Back" - данные сначала записываются в кэш, в основную же память по необходимости либо "при удобном случае". Наиболее быстрый метод. Более подробно см. ниже,
"Write Through" - данные записываются в кэш и в основную память одновременно,
"Write Protect" - выбранная область кэшируется, но при этом защищена от записи,
"Uncached" (или "Disabled") - запрещено кэширование для выбранной области.

Следующая "пачка" опций "Phoenix BIOS" выглядит уже привычно, хотя присутствуют важные особенности.
Cache A000-AFFF
Cache B000-BFFF
Cache C800-CBFF
Значения опций: "Write Back", "Write Through", "Write Protect", "Disabled", а также
"USWC Caching" (Uncacheable Speculative Write Combining) - режим некэшируемой объединенной записи. Применяется для отображаемых в памяти устройств ввода-вывода и отображаемого кадра видеопамяти.

"Cache Memory" - так называется внушительное меню "Phoenix BIOS" со следующими опциями:
Cache System BIOS Area
Cache Video BIOS Area
Cache DRAM Memory Area
- в данных опциях выбираются либо разрешение/запрет кэширования, либо метод кэширования (см. выше). Следующая опция-меню "Cache Memory Regions" может быть использована, если в опции (см. ниже) "Cache" выбрано любое из двух значений: "Intern only" или "Intern and Extern". Вот эти опции, надеюсь, уже понятные пользователю:
C800 - CBFF
CC00 - CFFF
D000 - D3FF
D400 - D7FF
D800 - DBFF
DC00 - DFFF
Значения этих опций стандартны: "Enabled" и "Disabled". Включение какой-либо опции приводит к кэшированию выбранной адресной области. Если в системе используется ISA-карта с двухпортовой памятью, отображаемой в системной памяти в ROM-области, то для такой адресной области кэширование должно быть запрещено.

640KB to 1MB Cacheability
- опция через установку в "Enabled" позволяет кэшировать последние 384 КБ из первого мегабайта ОЗУ.

Async L2 Cache Leadoff
- данной опцией устанавливается (в системных тактах) время подготовительной фазы до начала непосредственной операции чтения данных из асинхронного кэша 2-го уровня (или записи).
Опция может называться "Async SRAM Leadoff Time", "L2 Async SRAM Leadoff". Значения же опции могут иметь следующий вид: "3T", "4T". В некоторых случаях есть возможность поварьировать временной характеристикой раздельно для операций чтения и записи: "4T/4T", "3T/3T", "3T/4T". Опция "L2 Async SRAM Burst" со значениями "2T" и "3T" аналогична приведенным, разве что указывает на наличие блочных операций.
Речь может идти об аналогичных характеристиках и для синхронной кэш-памяти, и тогда опции будут выглядеть совершенно идентично: "Sync SRAM Leadoff Time", "L2 Sync SRAM Leadoff". Значения последней опции уже знакомы: "3T", "4T".
Попробуем расширить приведенный перечень опций, поскольку речь идет о той же длительности первого обращения к памяти или о возможных задержках (тактах ожидания) при обращении к кэш-памяти:
"L2 Leadoff Timing", "Cache Read Hit 1st Cycle WS", "CPU-to-L2 Checkpoint", "L2 Cache Check Point", "CPU-to-L2 Read Wait States", "CPU-to-L2 Write Wait States", "SRAM Burst R/W Cycle", "L2 Cache Burst Read". К уже имеющимся значениям добавилось еще одно - "1T". Понятно, что меньшее значение дает более высокую скорость, а значит и повышает производительность системы, но при возникновении сбойных ситуаций значение необходимо увеличить.

Cache Burst Read Cycle
- опция, определяющая режим обращения процессора к кэш-памяти. В данном случае речь идет не о методах доступа к кэш-памяти, а о временных параметрах, характеризующих этот доступ. Суть сказанного заключается в том времени, которое необходимо затратить, начиная от момента выдачи адресной информации до момента появления данных на выходных линиях микросхем памяти. Мы описали кратко общий алгоритм обращения к памяти, независимо от того, о какой памяти идет речь. Подытожив изложенное, можно говорить о некотором количестве системных тактов, затрачиваемых на процедуру чтения.
Начиная с 486-х, процессоры могут обращаться к кэш-памяти в режиме "Burst Mode". Во время "блочного" цикла чтения процессор берет из вторичной кэш-памяти (читает) последовательно друг за другом 16 байт данных (четыре двойных слова). Первое обращение занимает больше тактов, чем каждое из трех последующих. Так, например, соотношение (а точнее, временная диаграмма) 3-1-1-1 означает, что первое обращение требует три такта, а второе, третье и четвертое - по одному. Указанные три такта включают в себя подготовительную фазу (leadoff) и собственно считывание первого 32-битного пакета. Число тактов, требующихся для первого обращения, может быть указано также в некоторых версиях BIOS в отдельных самостоятельных опциях. Именно об этом опция "Async L2 Cache Leadoff" и ей подобные (см. выше).
Установка правильного значения зависит и от скоростных характеристик системных компонент (что и определяет время доступа), и от требований к стабильности системы. "Хорошие" временные характеристики возможно было сочетать только с быстрой динамической памятью. Более "древняя" динамическая память, совместимая со страничной адресацией (FPM), позволяла получать очень "хорошие" временные диаграммы, но при этом не будем забывать о системных частотах того времени.
Нетрудно заметить, что возможности влиять на временные характеристики связаны с параметрами первого обращения. Какое значение "выдерживает" система при обращении процессора к кэш-памяти, можно установить экспериментально, уменьшив значение числа тактов в последовательности обращений на 1, например, до 2-1-1-1. При зависании компьютера необходимо будет вернуть прежнее значение.
Опция может называться "Cache Read Burst", "Cache Read Hit Burst", "Async SRAM Burst Time", "Cache Read Burst Mode", "Cache Burst Read Cycle Time".
Как правило, конкретная опция может предложить пару некоторых значений. Ну, а если просуммировать представленные и достаточно многочисленные опции, то можно получить такой ряд параметров: "2-1-1-1", "3-1-1-1", "2-2-2-2", "3-2-2-2", "4-1-1-1". Опция "Async L2 Cache Burst" предложила значения "x-2-2-2" и "x-3-3-3". Как устанавливать "x" уже известно. Такое разнообразие не должно удивлять. Ведь системы могли иметь всего 128 КБ вторичного кэша, а значит диаграмма 3-2-2-2 могла быть не столько оптимальной, сколько единственно возможной (например, для систем с тактовой частотой в 33 МГц). С другой стороны, необходимо представлять себе, что диаграмма 3-1-1-1 для 486-х систем в сравнении с 4-1-1-1 для систем с процессором Pentium вовсе не является выигрышной.
Дополнительная информация по временным характеристикам изложена далее.

Cache Rd+CPU Wt Pipeline
- разрешение опции ("Enabled") позволяет включить конвейеризацию для циклов чтения из кэш-памяти и циклов записи, что естественно значительно повышает производительность системы. По сути эта опция - аналог других опций по конвейеризации кэш-памяти (см. далее).
Опция может называться "Cache Rd+CPU W/T Pipeline".

Cache Timing
- если в системе установлен только один модуль асинхронной кэш-памяти, то необходимо выбрать значение "Fast". Значение "Fastest" устанавливается при наличии в системе двух банков вторичного кэша. В некоторых случаях вместо "Fast" может быть и значение "Faster". Тогда надо внимательнее ознакомиться с имеющимся в системе кэшем, дабы действовать наверняка (см. ниже опцию "Pipeline Cache Timing").
Пользователь должен быть готов и к встрече с опцией "Cache Performance", благодаря которой также устанавливаются скоростные характеристики. Но при этом необходимо учитывать и характеристики основной памяти. Если система использует EDO-память, то значение "Standard" окажется оптимальным, для SDRAM-модулей подойдет "Default" (!), значение "Fast" также окажется оптимальным для SDRAM-памяти, но и позволит эффективнее эксплуатировать кэш.

CPU External Cache
- (внешний кэш процессора). Этой опцией разрешается/запрещается использование внешнего кэша процессора (кэша второго уровня, или "L2"). Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственного замедления работы системы, например, при установке какой либо старой платы расширения, или первичного тестирования компьютера. Запрет возможен и для старого программного обеспечения, а также для самых первых версий "OS/2". Во всех случаях возможно потребуется отключить как все виды кэширования, так и "затенения". Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Если вспомнить былое, да и не такое уж далекое, то необходимо отметить, что при отсутствии кэша второго уровня или его неисправности разрешение использования внешнего кэша могло привести к сбоям системы.
Поскольку речь идет лишь о включении или отключении кэш-памяти, то в данном случае, казалось бы, нет смысла рассматривать специфику отдельных процессоров или чипсетов. Однако! Вспомним первые процессоры Celeron с отсутствующим кэшем L2, и тогда сказанное чуть выше оказывается вполне актуальным. Определенные сложности могут возникнуть и при разгоне процессоров. Стоит напомнить, что у архитектуры P5 (Pentium, Pentium MMX) кэш работает на частоте шины, а для архитектуры P6 частота кэш-памяти "привязана" к частоте ядра. При этом она может быть половинной (Pentium II) либо равной ей (Pentium Pro).
Опция может называться "External Cache Memory", "External Cache", "CPU Level 2 Cache", "L2 Cache Enable", "L2 Cache" или "L2 Cacheing".

CPU Internal Cache
- (внутренний кэш процессора). Этой опцией разрешается/запрещается использование внутреннего кэша процессора (кэша первого уровня, или "L1"). Стоит напомнить, что внутренний кэш стал принадлежностью процессоров, начиная лишь с 486-х. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
В некоторых случаях опции по управлению внутренним и внешним кэшем могут быть объединены в одну опцию - "Cache Memory", со значениями "Disabled", "Internal" и "Both". В других же, как это предложил "Phoenix BIOS", может быть предложено небольшое меню "Cache" с дальнейшим выбором параметров:
"Enabled" - включено кэширование, но требуется дальнейшее уточнение,
"Intern Only" - используется только внутренний кэш,
"Intern and Extern" - внутренний и внешний кэш включены,
"Disabled".
Опция может называться "Internal Cache Memory", "CPU Level 1 Cache" или "L1 Cache".
А вот опции "System Cache", "Memory Cache" разрешали (или нет) использование кэш-памяти в системе. Хотя возможно встретить и небольшое подменю, аналогичное вышеприведенному.

Необходимо различать две принципиально разные стратегии работы с кэш-памятью. Одна из них предполагает наличие кэша только для чтения, другая - кэша с последующей записью. В одном случае буферизируются только те данные, которые считываются, а в другом кратковременно запоминается информация, которая позже должна быть записана в память. Отсюда и основные методы организации кэш-памяти:
Write Through - метод сквозной записи. Предполагает наличие двух копий данных - в основной и кэш-памяти, т.к. то, что процессор записал в кэш-память, немедленно копируется в основную память, т.е. без промежуточного хранения в кэше. Этот способ работы с кэш-памятью более медленный, но более надежный,
Buffered Write Through - метод буферизованной сквозной памяти. Процесс записи выполняется в буферы, организованные по принципу "FIFO" ("First Input - First Output" - "первым пришел - первым ушел"),
Write Back - метод обратной записи, при котором содержимое основной памяти обновляется только тогда, когда из кэш-памяти в нее записывается полный блок данных, то есть какое-то время процессор не обращается к основной памяти. Это означает, что в процессе работы данные записываются в быстродействующий кэш, а уж затем, когда система будет менее загружена, записываются в оперативную память. В другой ситуации процессор переносит данные в оперативную память из ячейки кэш-памяти только перед считыванием в эту же ячейку данных из другого адресного пространства оперативной памяти.
Очень быстрый способ, но могут возникнуть проблемы с устройствами, которые сами обращаются к памяти, минуя процессор, например, контроллер DMA. Последнее требует специальной поддержки со стороны системной платы, чтобы при обмене по DMA можно было поддерживать согласованность данных в памяти и внутреннем кэше. Метод "Write Back" приблизительно процентов на 10 повышает производительность системы в сравнении с "Write Through".

External Cache Write Policy
- опция по выбору метода работы внешней кэш-памяти. Значения уже известны: "Write Back" (или "Write-back") и "Write Through" (или "Write-through"). Иногда может быть и третье - "Disabled", как отказ от использования внешней кэш-памяти. Опция может называться "External Cache", "L2 Cache Mode", "L2 Cache Update Mode", "L2 Cache Policy", "L2 Cache Write Policy".
Кроме стандартных режимов "Write-Back" и "Write-Through", для кэша второго уровня могут быть также применены режимы "Adaptive WB1" и "Adaptive WB2". С помощью обоих адаптивных "write-back" методов есть возможность сократить влияние недостатков, свойственных стандартным методам. Системный контроллер должен определять оптимальную "политику" записи в кэш, в соответствии со спецификациями SRAM-памяти.
Немного истории! Адаптивное кэширование (Adaptive Caching) - это первоначально метод работы с кэш-памятью (буфером) жестких дисков, позволяющий изменять во время работы как размер сегмента кэш-памяти, так и количество сегментов для повышения производительности работы диска. Применение адаптивного кэширования всегда подчеркивалось и подчеркивается производителями жестких дисков как очевидное достоинство их продукции. Как видим, данный метод нашел применение и в системной памяти.

Internal Cache WB or WT
- очень давняя опция из "AMI BIOS". Ну и значения ее видны из названия: "WB" (Write Back) и "WT" (Write Through). Иногда также может присутствовать третье значение - "Disabled". Иногда значения могут иметь следующий вид: "Write-Back", "Write-Thru". При выборе значения надо помнить о том, что некоторые 486-е процессоры не поддерживают режим "Write Back".
Опция может называться "L1 Cache Mode", "L1 Cache Update Mode", "L1 Cache Write Policy", "L1 Update Mode", "L1 Cache Policy" или "Internal Cache". Многие современные системы вообще не содержат подобной опции, т.к. они оптимизированы для эффективного использования PBSRAM.
Ну и в конце интегрированная опция, охватывающая оба кэша, - "Cache Strategy".

L2 Cache Allocation
- сначала немного теории. "K5/K6 Write Allocation" - это нововведение компании "AMD", которое сводится к следующему. У процессоров Intel поводом для кэширования ячейки является только ее чтение. После того, как ячейка с определенным адресом кэширована, это используется и при записи (режим "Write Back"), однако само кэширование выполняется только при чтении. Поэтому, если в выполняемом коде попадается серия из последовательных записей по одинаковым (или расположенным рядом) адресам, кэш используется неэффективно при отсутствии обращений к этим адресам. "AMD Write Allocation" - режим, при котором поводом для кэширования является не только чтение данных, но и их запись. Это чревато коллизиями, как любое отступление от стандарта "Intel", поэтому "AMD" предусмотрела возможность программного управления этим режимом, вплоть до отключения его. Речь идет, конечно, об управлении через BIOS. Настройка регистров процессоров AMD K5/K6, управляющих этим режимом, является одним из этапов POST-теста.
Сразу становятся понятны проблемы поддержки процессоров AMD K6 через BIOS, и не только связанные с правильным распознаванием процессора и его скорости. Необходимо, чтобы BIOS корректно поддерживал функцию "Write Allocate", не говоря уже о физическом наличии данной опции в "BIOS Setup". Так что вопросы обновления BIOS могут оказаться весьма насущными.
Теперь о значениях:
"Always" - абсолютно и однозначно осуществляется поддержка указанного выше режима кэширования через BIOS,
"CPU Controlled" - поддержка функции "Write Allocate" осуществляется программным путем, а именно со стороны операционной системы, т.е. при первоначальной загрузке драйверов поддержки процессоров AMD.
В системе на чипсете Ite8330g (от "Integrated Technology Express") эффект от применения опции "AMD K6 Write Allocation" достигался через "Enabled". Значение "Disabled" могло пригодиться для других процессоров. Нетрудно увидеть, для поддержки каких процессоров предназначена эта опция.
"Silicon Integrated Systems" давно славилась поддержкой процессоров от разных производителей. Неудивительно, что для наборов, например, 530, 540 или 5581 была предусмотрена опция "L2 Single Read Allocation". Опция могла называться и "Single Read L2 Cache Alloc.". Значения опций те же самые ("Enabled", "Disabled"), а вот их содержание чуть другое. Скорее всего, речь идет о поддержке одиночных операций записи/чтения, хотя эта опция требует дополнительного изучения.
Ну и напоследок опция "Write-Through Allocate". Включение опции ("Enabled") позволяет снизить частоту "промахов" при работе с кэш-памятью как первого, так и второго уровня.

L2 Cache Banks
- опция, позволявшая указать, из какого количества банков состоит кэш второго уровня. Значения могли быть такие: "1 Bank", "2 Banks".
Опция может называться "L2 Cache Config". При этом значения опции следующие: "1 Bank (1-1-1-1)", "2 Banks". Несложно заметить, что при конфигурации кэш-памяти с одним банком скоростные характеристики (временная диаграмма) указываются явным образом, а при указании двухбанковой организации становится доступной опция
x 2-Bank L2 Cache Speed,
которая предлагает хотя и два варианта для выбора, но все же более "медленные": "2-1-1-1", "3-1-1-1".

L2 Cache Burst Addressing
- данная опция позволяет устанавливать режим адресации для кэша второго уровня. Возможные значения:
"Toggle Mode" - такое значение опции позволяет контроллеру кэша менять режимы адресации,
"Linear Mode" - используется режим последовательной адресации.
Опция может называться "Cache Bursting". Значения параметров она имеет те же самые, хотя по названию трудно определить функциональную направленность этой опции.
Мы уже знаем о некоторых особенностях процессоров семейства Cyrix. Так вот для них конкретно предназначена опция "Linear Mode SRAM Support". Если в системе установлен процессор Cyrix, например, Cyrix M1/M2, то необходимо выбрать "Enabled".
Опция "L2 Cache Burst Addressing" в свое время была "замечена" в системе с набором логики SiS5581. И хотя этот чипсет предназначался для системных плат формфактора LPX/NLX, он был эквивалентен набору i430TX. А вот более "старенький" набор SiS496 предлагал опцию "L2 Cache CPU Burst Type" со значениями "Normal (Intel)" и "Lin. Burst (AMD)".
Дополнительно см. выше (раздел "CPU").

L2 Cache Cacheable Size
- данной опцией устанавливается размер (объем) кэшируемой памяти, поддерживаемой в системе. Значения могут быть следующие: "64 MB", "128 MB", "192 MB", "256 MB", "512 MB" (могут быть естественно и другие значения). А выбор значения зависит, с одной стороны, от объема инсталлированной памяти (установку "512 MB" можно рекомендовать при наличии в системе более 64 МБ ОЗУ), а с другой, от характеристик чипсета. Последнее являлось и является одним из важнейших параметров чипсетов. Достаточно вспомнить "интеловские" чипсеты 430NX и 430TX, и окажется, что первый из них поддерживал 512 МБ, а второй - 64 МБ кэшируемой памяти.
Более давние опции назывались "Cacheable RAM" или "Cacheable RAM Address Range". Речь в них шла об установке значения в 4, 8, 16 или 32 МБ. Такие значения были вызваны огpаничением, накладываемым количеством pазpядов адресной шины системной памяти. Ведь в кэш-памяти необходимо было хранить как содержимое ячейки памяти, так и ее адрес. Выбор оптимального значения был также ограничен величиной инсталлированной в системе памяти. При наличии в системе 4 МБ ОЗУ выбор 16 МБ был малооправдан.

L2 Cache Size
- данная опция позволяет указать объем установленной на системной плате кэш-памяти 2-го уровня. В подобном виде такие опции уже не встречаются. Встречались такие вариации значений:
"0 K", "256 K", "512 K",
"0 KB", "64 KB", "128 KB", "256 KB", "512 KB", "1 MB", "2 MB".

L2 Cache Timing
- опция установки временных интервалов обращения к кэш-памяти второго уровня. Это одновременно и разъяснение наименования опции, и большая тема, рассматривающая временные характеристики при обращении процессора к кэш-памяти. Чуть выше уже были изложены основы для понимания временных диаграмм. Но речь в основном шла о процедурах "блочного" чтения. Попробуем расширить изложенный материал, дополнительно рассмотреть циклы записи в кэш-память, а также характеристики последовательных обращений.
Начнем со значений: "3-1-1-1", "2-1-1-1". Не должно быть вопросов. Но опция "L2 Cache Timing" в другом случае предложила такой ряд значений: "3-1-1-1-1-1-1-1", "3-1-1-1-3-1-1-1", "3-2-2-2-3-2-2-2", "3-1-1-1-2-1-1-1". Данная вариация - есть не что иное, как временная характеристика двух циклов записи, следующих друг за другом. При улучшенной оптимизации доступа выигрыш несомнен. Явным образом на последовательность двух циклов указывает опция "L2 Cache Back-to-Back Read".
"L2 Cache Write Timing" предложила значения "3T/2T" и "2T/1T". Первый и второй параметры в значении опции - это и есть количества тактов в первых фазах двух "слипшихся" циклов ("back-to-back"). Такие возможности были уже реализованы в стареньком SiS496-чипсете. Для чипсетов следующего поколения (530, 540) было сохранено наименование опции, а вот значения "упростились": "2-2-2-2", "3-3-3-3".
Опции "L2 Async Cache Write Wait States", "L2 Async Cache Read Wait States" представили уже знакомые нам "x-3-3-3" и "x-2-2-2".
Нет уже смысла перечислять возможные значения опции "L2 Cache Speed", они весьма близки к вышеприведенным. Более интересны опции вида "n-Bank L2 Cache Speed", позволяющие устанавливать характеристики для разных банков раздельно. Хотя к экспериментам с подобными опциями надо подходить осторожно. Вот один из примеров подобных опций - "2 Bank PBSRAM". Ее значения: "3-1-1-1", "2-1-1-1". Первая диаграмма является оптимальной как для циклов чтения, так и для циклов записи, как на частоте 66 МГц, так и для более высокой частоты.
Мы уже столкнулись с тем, что опции могут иметь интегрированный характер, но могут быть быть представлены раздельно для циклов чтения и записи. Вот еще один пример такой пары: "Asysc. SRAM Read WS", "Asysc. SRAM Write WS".
Еще некоторые опции, не требующие отдельного рассмотрения: "Cache Read Cycle", "Cache Read Option", "SRAM Read Timing", "SRAM Read wait state".
Напоследок стоит упомянуть, что в "устаревших" системах можно встретить возможности оптимизации с конкретным указанием на внутренний кэш - "L1 Cache Update Scheme".

L2 Cacheing Control
- наличие в "BIOS Setup" данной опции предполагает присутствие других опций, предназначенных для регулировки рабочих характеристик внешнего кэша (эта опция несколько устарела, сейчас правильнее было бы говорить - кэша второго уровня). Приведенная же опция могла блокировать такие регулировки ("Disabled") либо разрешить дальнейшую работу ("Enabled") по управлению вторичным кэшем.

Memory above 16MB Cacheable
- опция поддержки кэширования оперативной памяти, расположенной за пределами первых 16 мегабайт ОЗУ. Для решения такой задачи опция должна быть включена ("Enabled"). Понятно, что для реализации этих возможностей должны были быть выполнены определенные условия (см. в частности опцию "L2 Cache Cacheable Size"). С другой стороны, а данная опция "пахнет стариной", могли стоять конкретные задачи функционирования системного и прикладного программного обеспечения, не требующего (или требующего) кэширования большего объема динамической памяти.

Non-Cacheable Block-1 Size
- (pазмеp пеpвого некэшиpуемого блока памяти). Hекэшиpуемая область памяти пpедназначается для отобpажаемой памяти устpойств ввода/вывода, котоpую либо не пpедполагается кэшиpовать, либо делать это нецелесообразно. Если некэшиpуемая область перекpывает диапазон фактически используемых адpесов ОЗУ, то можно ожидать значительного уменьшения эффективности системы пpи обpащении к этим адpесам. Если же некэшиpуемая область пеpекpывает лишь несуществующие адpеса ОЗУ, то нет повода для беспокойства.
Если нет смысла кэшиpовать некотоpую область памяти, то можно исключить 2 области памяти. Существуют весьма уважительные пpичины для исключения кэшиpования некотоpых областей. Hапpимеp, если область памяти соответствует некоей буфеpной памяти каpты расширения и каpта может изменять содеpжимое этого буфеpа без уведомления кэша о необходимости отключения соответствующей стpоки кэш-памяти. Hекотоpые веpсии BIOS пpедоставляют больше возможностей для выбора параметров данной опции, чем пpосто "Enabled"/"Disabled", в частности возможен такой вариант: "Nonlocal", "Noncache" и "Disabled". По умолчанию опция устанавливается в "Disabled".
Non-Cacheable Block-1 Base
- опция для установки базового адреса некэшируемого адресного диапазона.
Как правило, такая пара опций сопровождается еще одной "дружной" парой, поскольку речь может идти и о другом регионе памяти, что расширяет возможности конфигурирования:
Non-Cacheable Block-2 Size
Non-Cacheable Block-2 Base
Другие версии BIOS могут предложить несколько иной вариант аналогичных опций и, пожалуй, более понятный пользователю:
Non-Cacheable Block 1
Block 1 Start Address
Block 1 Size
Для данных опций приведем один из возможных вариантов значений (соответственно): "Disabled", "0500000H", "64KB".

PCI Cycle Cache Hit WS
- при установке значения "Normal" (стандартный режим) обновление кэша второго уровня происходит во время стандартных PCI-циклов и стандартным методом. Речь идет о стандартном режиме поиска информации в кэш-памяти. При установке же значения "Fast" (режим ускорения) кэш-память обновляется безусловно, то есть без тактов ожидания, затрачиваемых на время поиска информации в кэше. Такое обновление не требует каких-либо строб-импульсов. Можно говорить о 100%-ном "попадании" (hit).
Аналогичная опция может называться "PCI cycle cache hit sam point".

PCI Master Read Caching
- данная опция, подобно "Video RAM Cacheable", может служить помехой производительности системы, хотя и предназначена для ее повышения. Если опция включена ("Enabled"), L2-кэш будет использоваться для кэширования циклов чтения "master"-устройств на PCI-шине, что должно повысить их производительность. Естественно, в системе кэширование должно быть включено.
Какие же проблемы могут возникнуть по применению этой опции? А причина кроется в объеме вторичного кэша. Поэтому в системах с процессорами Duron такая опция должна быть отключена, иначе возрастет количество "промахов", а количество "попаданий" в кэш заметно понизится. Серьезность проблемы налицо. Даже с процессорами Athlon могут возникнуть конфликты, ведь кэшировать необходимо огромные массивы информации. Поэтому рекомендованный выбор - запретить опцию ("Disabled").

Pipeline
- опция устанавливается в "Enabled" для включения механизма конвейеризации при наличии в системе конвейерной синхронной кэш-памяти. Опция носит интегрированный характер, точно также как и опция "L2 Cache Pipelining". Правда, последняя более конкретна.
Опции "Read Pipeline" и "Write Pipeline" (или "Write Pipelining") позволяют разделить включение режима конвейеризации для циклов чтения и записи в PBSRAM.
Но на этом возможности "варьирования" с наименованиями опций не заканчиваются. Производители системных плат (Acer, Tyan и другие), применявшие наборы микросхем от VIA Technologies (Apollo VP3 и Apollo MVP3), предложили максимально конкретизированный набор опций: "Cache Pipelined Reads" и "Cache Pipelined Writes". Для систем на чипсете AMD 640 различия от приведенных опций уже почти незаметны глазу: "Cache Read Pipeline", "Cache Write Pipeline". Выбор значений для всех опций при этом не меняется - "Disabled" и "Enabled".

Pipeline Cache Timing
- если в системе установлен только один модуль PBSRAM, то необходимо выбрать значение "Faster". Значение "Fastest" устанавливается при наличии в системе двух банков вторичной конвейерной блочной SRAM-памяти.
Опция "SRAM Speed Option" предлагает те же самые значения, хотя из ее названия не совсем ясно на первый взгляд, о каком типе кэш-памяти идет речь и о каких скоростных характеристиках. Речь же идет о возможности влиять на работу вторичной кэш-памяти.

Shadow Memory Cacheable
- (кэшиpование "теневой" памяти). Опция, позволяющая включить режим кэширования для тех участков памяти, для которых уже включен режим "затенения". Опция носит интегрированный (обобщенный) характер. Любое обращение к "затененным" адресным пространствам будет вызывать копирование востребованной информации в кэш процессора. Целесообразность включения режима ("Enabled") зависит от множества факторов: что собственно было затенено (видео BIOS, системный BIOS, ПЗУ адаптеров или область, выделенная под работу специализированного контроллера), какая ОС инсталлирована и от некоторых других. Многие из этих факторов рассмотрены отдельно. Что касается операционных систем, то рекомендовать включение такого кэширования можно для "MS-DOS" и "OS/2" (да и то не всегда), "Linux" и другие "Unix"-подобные ОС вообще не используют кэшируемую ROM-память. Что же касается "Windows", речь не идет о "Windows3x", то такое включение может быть рекомендовано не всегда. В любом случае, любая рекомендация требует опытной проверки на конкретной системе. Это касается и оборудования, и операционной системы.
Больший эффект может быть достигнут, если BIOS предлагает вместо обобщенной опции несколько таких опций и с возможностью установки кэширования для отдельно взятого адресного фрагмента. Эти опции могут иметь два значения: "Cached" и "Disabled". А представлены они могут быть в следующем виде:
C000,16K Shadow
C400,16K Shadow
C800,16K Shadow
CC00,16K Shadow
D000,16K Shadow
D400,16K Shadow
D800,16K Shadow
DC00,16K Shadow
В некоторых случаях опции могут быть представлены в виде "C000 Shadow Cacheable" и "F000 Shadow Cacheable" со значениями "Enabled" и "Disabled".

SRAM Back-to-Back
- установка опции в "Enabled" позволит сократить задержки между 32-битными циклами передачи, так как следующие "друг за другом" циклы будут объединяться в единый, с одним адресом, 64-битный пакет.

SRAM Type
- в зависимости от типа установленной кэш-памяти надо выбрать один из вариантов, синхронная либо асинхронная память интегрирована в системе: "Synchronous", "Asynchronous".

Sustained 3T Write
- если конвейерная потоковая кэш-память инсталлирована в системе, то включение опции ("Enabled") позволит осуществлять непрерывный трехтактовый цикл записи при доступе к PBSRAM на системных частотах 66 или 75 МГц.

SYNC SRAM Support
- если в системе установлена синхронная кэш-память, то есть возможность "уточнить", какая же именно. Значения следующие:
"Standard" - обычная синхронная SRAM,
"Pipelined" - конвейерная кэш-память.

System BIOS Cacheable
- (кэширование области системного BIOS). Разрешение этого параметра приводит к возможности кэширования области памяти по адресам системного BIOS (F0000H-FFFFFH) во вторичную кэш-память. Включение параметра будет иметь смысл только в случае разрешения функций системного кэширования в разделе "BIOS Features Setup" (как правило), а также, если системный BIOS уже "затенен". Если какая-либо программа попытается выполнить операцию записи в эти адреса, то система выдаст сообщение об ошибке. Это в лучшем случае! Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может называться и "System ROM Cacheable".
Но есть и свое "но"! При включении опции кэшированию подлежит часть системной BIOS, содержащей код для запуска системы и основные функции ввода/вывода. Тем не менее возможности ускорения, речь идет о системном BIOS, через использование кэша процессора редко используются, т.к. часть кэш-памяти, которой всегда недостаточно, резервируется под BIOS, обращение к которому не происходит постоянно. Поэтому рекомендованное значение - "Disabled".

Контроллер кэш-памяти оперирует строками (cache line) фиксированной длины. Строка может хранить копию блока основной памяти. С каждой строкой кэша связана информация об адресе скопированного в нее блока основной памяти и признаки ее состояния. Информация о том, какой именно блок занимает данную строку и ее состояние, называется тегом (tag) и хранится в связанной с данной строкой ячейке специальной памяти тегов (tag RAM).
Для хранения тегов используется отдельная микросхема асинхронной SRAM (Tag SRAM), а для более чем 8-битного тега - пара микросхем. Синхронизировать работу Tag SRAM не имеет смысла, поэтому асинхронная память тегов используется как для асинхронного кэша, так и для синхронного кэша 2-го уровня.
Необходимый объем памяти тегов, т.е. количество ячеек, можно вычислить, разделив объем установленной кэш-памяти на длину строки кэша, определяемой чипсетом. Кстати, функции кэш-контроллера для внешнего кэша выполняет чипсет. Длина строки обычно равна количеству байт, передаваемых за один стандартный пакетный цикл (16 байт для 486-го процессора, 32 байта для Pentium и выше).
Для кэша с обратной записью (WB) необходима еще и память для хранения признака "чистоты" строки. Признак может храниться в отдельной микросхеме (Dirty SRAM) или занимать (для строки) один бит в Tag SRAM.

Изложенный материал поможет разобраться и понять содержание представленных опций.

Tag Compare Wait States
- данная опция позволяет регулировать скоростные характеристики кэш-памяти, а точнее, доступ к ячейкам Tag SRAM. Выбор значений не очень большой (0 или 1 такт ожидания), что напрямую связано с процедурой входа в Tag SRAM. На первом или втором такте шинного цикла. Тег-операции с нулевым ожиданием требуют использования 12-нс SRAM или лучше.
Опция может называться "L2 TAG Output Delay". Но наличие задержки уже определяется значением "Enabled". "Disabled", понятно, снимает всякую задержку.

Tag Option
- опция предлагает для выбора два значения. Одно из них, равное 8 битам, не предполагает использования т.н. "dirty"-бита. Второе же выделяет собственно под тег 7 бит и еще один бит под признак "dirty".
Опция может называться "Alt Bit in Tag SRAM" или "Alt Bit Tag RAM". Слово "аlt" не должно "смущать" пользователя. Это обычное сокращение. В данном случае от alternative, что можно перевести и как "дополнительный". Значения опции: "7+1 Bits" и "8+1 Bits". Правда, в некоторых случаях возможны значения "Enabled" и "Disabled", как способ управления дополнительным битом.
Идентична последним опция "L2 (WB) Tag Bit Length". Опцией устанавливается размер основного тега (7 или 8 бит), дополнительный бит используется автоматически и пользователю "недоступен". Точно также функционируют опции "L2 Cache Tag Bits", "L2 Cache Tag Length" ("7 bits", "8 bits").
Опция может называться "Tag RAM Size". Но в ней уже не идет речь об использовании дополнительного "dirty"-бита. В соответствии со спецификацией инсталлированного "tag RAM"-чипа необходимо и выбрать размер тега (7 или 8 бит).

Tag Ram Includes Dirty
- значение "Enabled" не вызывает возражений, т.к. использование дополнительного "dirty"-бита направлено на повышение функциональных возможностей системы. Ну а что же "Disabled"? Снова немного теории!
Если опции "BIOS Setup" позволяют сделать это, то иногда имеет смысл уменьшить объем кэшируемой памяти до объема реально установленной памяти. При этом возможно более эффективное кэширование имеющейся памяти за счет реструктуризации общения чипсета и кэша. С другой стороны, увеличение объема кэшируемой вторичным кэшем памяти обычно требует установки дополнительной микросхемы Tag SRAM, т.к. возрастает разрядность тега. А как поступить, если объем инсталлированной памяти все же превышает объем кэшируемой и установка дополнительной микросхемы вызывает проблемы. В этом случае установка "Disabled" может спасти ситуацию. Отказ от использования "dirty"-бита автоматически ведет к его добавлению в адресную часть тега и к увеличению объема кэшируемой памяти в 2 раза.
Стоит напомнить, что для современного Pentium IV объем кэшируемой вторичным кэшем памяти составляет 4 ГБ.
Опция может называться "L2 Cache Dirty Tag" или "L2 Dirty Bit" и с теми же значениями ("Enabled" и "Disabled").

Tag/Dirty Implement
- данная опция по сути ничем не отличается от вышеприведенной, хотя имеет непривычные значения и ..."дочернюю" опцию. Значение "Separate" означает отказ от использовании "dirty"-бита, а "Combine" объединяет последний с тегом, доводя общую разрядность до 8 или 9 бит, что устанавливается опциями, изложенными выше.
x Dirty pin selection
- если предыдущая опция установлена в "Combine", данная опция становится активной и предлагает два значения:
"I/O" - сигнал "Dirty" носит двунаправленный характер,
"IN" - является только входным сигналом.
Данная опция требует дополнительного изучения.

Несколько в стороне от приведенных опций по использованию "памяти тегов" мы расположим две опции:
"L2 Cache Tag" и "Use Internal TAG RAM". Обе они имеют значения "Enabled" и "Disabled". Назначение этих опций не совсем понятно, и поэтому требует дополнительного "расследования".

USWC Write Posting
- USWC (или "Uncacheable, speculative write combining" - режим объединенной некэшируемой записи) - режим работы с видеопамятью, повышающий производительность системы, построенной на процессоре Pentium Pro (и всех последующих процессорах семейства P6 и более современных). Для реализации режима необходимо наличие у графической карты линейного буфера кадра (linear frame buffer), а также включение функции кэширования видеопамяти (например, опция "Video RAM Cacheable") и выбора соответствующего типа ее кэширования (см. ниже). Должен быть также установлен основной режим кэширования как "write-back". При этом данные небольшого объема комбинируются (объединяются) в 64-битные циклы записи, что позволяет снизить количество транзакций, необходимых для переноса некоторого объема данных в линейный буфер кадра видеокарты. Наличие кадрового буфера у видеокарты стандартно, но не все графические карты могут поддерживать такой режим записи. Это в большей степени связано не с самими графическими картами или установками "BIOS Setup", а с функционированием немодифицированных 32-разрядных драйверов графических адаптеров, которые должны использовать т.н. "протокол разделенной записи" (Partial Write protocol). Неоправданное включение режима может привести к нарушениям работы видеоканала, сбоям и даже проблемам с загрузкой системы.
Ну а с буферизацией отложенной записи мы уже знакомы. Если система позволяет применять "USWC"-режим, то включение опции ("Enabled") может еще несколько повысить производительность системы. Опция может называться "USWC Write Post".

Video BIOS Cacheable
- (кэширование области BIOS видеокарты). Разрешение этого параметра приводит к возможности кэширования области памяти по адресам BIOS видеокарты (C0000H-C7FFFH) во вторичной кэш-памяти процессора. Параметр будет использован только при включении кэш-памяти в разделе "BIOS Features Setup" (или аналогичном). Но предварительно должна быть также включена функция "затенения" Video BIOS.
Если какая-либо программа попытается выполнить запись в эти адреса, то система выдаст сообщение об ошибке либо, что более вероятно, зависнет. Пpи наличии видеокаpты с "ускоpителем" (а таковыми являются все современные видеокарты) необходимо отключить кэширование видеопамяти и видео-BIOS, дабы центральный процессор мог "отслеживать" любые изменения, пpоизводимые устpойством ввода в буфеp кадpа изобpажения. Опция должна быть отключена и при установке на компьютер современной операционной системы, что является ныне стандартной ситуацией. Такая ОС просто игнорирует видео-BIOS, обращаясь к видеокарте через графический драйвер. Об оправданности включения этой опции можно дополнительно сказать то же самое, что и по системному BIOS. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может называться "Video BIOS Area Cacheable".

BIOS VGA - это фактически программа, предназначенная для управления схемами VGA. Также через BIOS пользовательские программы могут инициировать некоторые процедуры и функции VGA, не обращаясь при этом непосредственно к адаптеру.
Область адресов видео-BIOS (C0000H-C7FFFH) давно уже как бы стандартизована. Но так было, естественно, не всегда. В зависимости от типа графический адаптер занимал следующие адреса:
MDA (видеобуфер) - B0000h-B0FFFh (4 КБ),
CGA (-::-) - B8000h-BBFFFh (16 КБ),
EGA (видео-БИОС) - C0000h-C3FFFh (C7FFFh) (16 {32} КБ),
VGA (-::-) - C0000h-C7FFFh (32 КБ).

Video Memory Cache Mode
- (установка режима кэширования для видеопамяти). Параметр действителен только для процессоров архитектуры Pentium Pro (Pentium II, Celeron и выше), для которых кэш второго уровня (L2) стал внутренним, т.е. интегрированным в процессорный модуль (ранее L2-кэш представлял собой отдельный чип на системной плате). Такое требование может показаться несколько специфичным и непонятным! Но речь, с одной стороны, идет о кэшировании центральным процессором данных из видеопамяти, а отсюда и повышенные требования к пропускной способности кэша.
С другой стороны, а это и причина, и следствие, к обычным режимам работы с кэш-памятью ("Write Through" и "Write Back") были также добавлены режимы "Write Combine" (WC - объединенная запись) и "Write Protected" (WP - защищено от записи). Уже в первом процессоре семейства (Pentium Pro) была предусмотрена возможность изменять режим кэширования в зависимости от конкретной области памяти через специальные внутренние регистры, называемые MTRR (Memory Type Range Registers). С помощью этих регистров для конкретной области памяти стало возможным устанавливать режимы UC (uncacheable combining - не кэшируемая объединенная запись), WC (write combine - объединенная запись), WP (write protected - защищено от записи), WT (write through - сквозная запись) и WB (write back - обратная запись). Установка интегрированного режима USWC (uncacheable, speculative write combine - не кэшировать, режим объединенной записи) позволяет значительно ускорить доступ к буферу видеопамяти и вывод данных через шину PCI на видеокарту (естественно, что и в AGP-порт также, и даже в большей степени). Добавим, что под термином "combine" подразумевается по сути пакетный режим, который может оказаться весьма эффективным и в ДОС-приложениях, т.к. позволяет передавать за один такт объединенные 8- или 16-битные циклы.
Следует учесть, что видеокарта должна поддерживать доступ к своей памяти в диапазоне A0000 - BFFFF (128 КБ) и иметь линейный буфер кадра. Правда, трудно представить, что этого может не быть. Поэтому лучше установить режим USWC, но в случае возникновения каких-либо проблем (система может даже не загрузиться, если карта не поддерживает этот механизм) необходимо установить значение по умолчанию - "UC". К таким возможным проблемам можно добавить работу с "noname"-картами, с картами, для которых задекларировано "всё и вся", а также возможные конфликты при совместной работе со звуковой картой. Поэтому установка оптимального значения требует проведения дополнительных экспериментов с системой. Может принимать значения:
"UC",
"USWC".

Несколько слов о MTRR-регистрах и режимах работы.
Memory Type Range Registers осуществляют операции записи/чтения в то же самое время, что и обычные MSR (Machine Specific Registers) стандартного Pentium-процессора используют собственные инструкции чтения и записи. MTRR являются 64-битными регистрами и разделяются на фиксированные и переменные MTRR. Фиксированные MTRR имеют дело с памятью в пределах 1 МБ, управляемой через "BIOS Setup". Переменные MTRR позволяют кэшировать память за пределами 1 мегабайта.
Использование режима WC опциально предназначено только для видеопамяти. В некоторых случаях перепрограммирование CMOS-памяти позволяет конфигурировать диапазон 0-640 КБ основной памяти для применения к нему WC-режима для эффективной отладки "железа". WP-режим применяется для "затенения" различных областей памяти и использования их как ROM-памяти.

Video RAM Cacheable
- (кэширование области видеопамяти графического адаптера). Разрешение опции ("Enabled") позволяет увеличить производительность системы путем кэширования видеопамяти по адресам A0000h-AFFFFh. Речь идет и об использовании кэша второго уровня для видеопамяти, и об ускорении доступа к видеопамяти. Но могут возникнуть сбои, если "нехорошие" программы попытаются произвести запись по указанным адресам. Поэтому неудивительно, что по умолчанию устанавливается "Disabled".
Но есть и другие причины отказа от кэширования видеопамяти. Уже не самые современные видеокарты имеют полосу пропускания в 2,47 ГБ/сек. (128 бит x 166 МГц). Между тем, полоса пропускания SDRAM-памяти может составлять около 0,99 ГБ/с (64 бит x 133 МГц), если память работает на частоте 133 МГц. Для Pentium III-650 полоса пропускания кэша второго уровня составляет 19,4 ГБ/с (256 бит x 650 МГц). Целесообразно ли кэшировать видеопамять графической карты, имея "на борту" более медленную системную память? Однозначно, это не имеет смысла, имея даже такую пропускную способность вторичного кэша. Необходимо учесть и то, что локальная видеопамять и L2-кэш соединяются между собой через AGP-шину с максимальной полосой пропускания в 0,99 ГБ/с при использовании AGP4X-протокола.
Ну и опять таки надо помнить об ограниченном объеме кэш-памяти (смотри внимательно возможности процессоров) при "массированных" PCI-циклах чтения, что неминуемо приведет к возрастанию доли промахов при обращении к кэш-памяти .
Опция может называться "Video Buffer Cacheable".

Weak Write Ordering
- (нестрогое упорядочение записи). При включении опции ("Enabled") процессор направляет циклы записи в свой внутренний кэш в порядке, отличном от последовательного (потокового) кода. Циклы записи во внешний кэш всегда происходят в строгом порядке.


BIOS. Продолжение!

4.4. Регенерация памяти

Динамическая память любого типа, в отличие от статической, даже при подаче питающих напряжений не обладает способностью хранить свою информацию сколь угодно долго. Состояние элементарной ячейки динамической памяти определяется наличием или отсутствием заряда на конденсаторе, и этот заряд подвержен утечке. Поэтому для сохранения данных в динамической памяти ее ячейки необходимо периодически подзаряжать, что и составляет суть процесса регенерации. Как это происходит, чуть ниже.
При выполнении операции чтения регенерация выполняется автоматически. Полученные на усилителе сигнала данные тут же записываются обратно. Считается, что такой алгоритм позволяет уменьшить число требуемых регенераций и увеличить быстродействие. Но это совершенно не так! Считывается ли информация из памяти или нет, "частота" регенерации при этом не меняется. Она либо вообще не регулируется (нет соответствующих опций в "BIOS Setup"), либо является строго фиксированной после соответствующиих установок.
Возможны три различных метода регенерации данных.
Регенерация одним RAS (RAS Only Refresh - ROR). Этот метод использовался еще в первых микросхемах DRAM. Адрес регенерируемой строки передается на шину адреса и выдается сигнал RAS (точно так же, как при чтении или записи). При этом выбирается строка ячеек, и данные из них поступают на внутренние цепи микросхемы, после чего записываются обратно. Так как далее сигнал CAS не следует, цикл чтения/записи не начинается. Затем передается адрес следующей строки и так далее, пока не будет пройдена вся матрица памяти, после чего цикл регенерации повторяется. К недостаткам этого метода можно отнести то, что занимается шина адреса, и в момент регенерации блокируется доступ к другим подсистемам компьютера.
CAS перед RAS (CAS Before RAS - CBR) - стандартный метод регенерации. При нормальном цикле чтения/записи сигнал RAS всегда приходит первым, за ним следует CAS. Если же CAS приходит раньше RAS, то начинается специальный цикл регенерации - CBR. При этом адрес строки не передается, а микросхема использует свой внутренний счетчик, содержимое которого увеличивается на 1 при каждом CBR-цикле (т.н. инкрементирование адреса строки). Этот режим позволяет регенерировать память, не занимая шину адреса, что, безусловно, более экономично.
Автоматическая регенерация памяти (Self Refresh - SR, или саморегенерация). Этот метод обычно используется в режиме энергосбережения, когда система переходит в состояние "сна" ("suspend"), и тактовый генератор перестает работать. В таком состоянии обновление памяти по вышеописанным методам невозможно (попросту отсутствуют источники сигналов), и микросхема памяти выполняет регенерацию самостоятельно. В ней запускается свой собственный генератор, который тактирует внутренние цепи регенерации. Такая технология работы памяти была внедрена с появлением EDO DRAM. Необходимо отметить, что в режиме "сна" память потребляет очень малый ток.
В классической реализации PC AT запросы на регенерацию DRAM генерировал канал 1 системного таймера 8254. К его выходу подключен триггер, работающий в счетном режиме и меняющий свое состояние на противоположное при каждом запросе. Состояние этого триггера можно программно считывать через бит 4 порта 61h. Проверка Refresh Toggle заключалась в проверке того факта, что этот триггер переключается с заданной частотой. Но со временем стали применяться другие алгоритмы регенерации памяти (что и изложено выше), и несмотря на то, что Refresh Toggle сохраняется для совместимости, по нему уже нельзя проверить формирование запросов на регенерацию. Циклы регенерации выполняет входящий в состав чипсета контроллер регенерации, который для выполнения своей задачи должен получать управление магистралью каждые 15,6 мкс. Во время цикла регенерации производится чтение одной из N ячеек памяти.

Burst Refresh
- (пакетная регенерация). Как правило, трактовка этой опции в литературе носит ошибочный характер. При разрешении опции ("Enabled") в единый пакет собираются запросы на регенерацию, причем такое пакетирование может в некоторых случаях обеспечивать аккумулирование запросов по всему объему строк в памяти. Такой метод ведет к значительному повышению производительности, но есть и обратная сторона. На достаточно длительные промежутки времени и постоянно происходит захват шины памяти, что приводит к блокировке доступа к ней процессора или других устройств.
Опция может называться "DRAM Burst Refresh".

CAS Before RAS Refresh
- метод регенерации памяти, когда сигнал CAS устанавливается раньше сигнала RAS. В отличие от стандартного способа регенерации, этот метод не требует перебора адресов строк извне микросхем памяти - используется внутренний счетчик адресов. Однако, этот способ регенерации должен поддерживаться микросхемами памяти. Если раньше можно было встретить фразы, что большинство модулей памяти поддерживает такой метод регенерации, то сейчас это уже стандартное аппаратное решение. Использование этого метода позволяет заметно снизить потребляемую модулями памяти энергию. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может называться "CAS Before RAS".

CAS-to-RAS Refresh Delay
- действие этой опции возможно при включенном состоянии предыдущей (или аналогичной), так как в данном случае устанавливается время задержки между стробирующими сигналами (в тактах системной шины). Естественно, что установка меньшего значения приводит к снижению времени, затрачиваемого на регенерацию. Большее же значение повышает надежность, т.е. достоверность данных, находящихся в памяти. Оптимальный вариант для данной системы выбирается опытным путем. Может принимать значения: "1T", "2T" (по умолчанию).

Concurrent Refresh
- (паpаллельная, или конкурирующая pегенеpация). При активизации этой опции как аппаратные средства регенерации, так и центральный процессор получают одновpеменный доступ к памяти. При этом процессору не нужно будет ожидать, пока произойдет регенерация. При установке опции в "Disabled" пpоцессоp должен будет ждать, пока схема pегенеpации не закончит pаботу. Естественно, что включение опции повышает производительность системы.

Decoupled Refresh
- (раздельная регенерация). Поскольку ISA-шина имеет невысокую скорость работы, то включение этой опции ("Enabled") позволит чипсету разделить регенерацию для основной памяти и ISA-шины. При этом процесс регенерации для ISA-шины может быть завершен во время выполнения процессором других инструкций. Использование этой опции заметно увеличивает производительность всей системы. Опция эта играла заметную роль во времена 486-х машин.
Но могла возникнуть и проблема, которая заключалась в том, что некоторые карты расширения (обычно, видеокарты) требовали к себе внимания процессора во время начального цикла регенерации шины. Естественно, что это могло привести к нежелательным сбойным ситуациям. Отключение опции могло потребоваться также, если при работе с графическими режимами высокого разрешения на экране монитора появлялись какие-то символы или "снег". При этом необходимо было отключать и такой метод работы с памятью, как "Memory Relocation" (см. выше). Сказанное выше было характерно, например, для видеокарт на чипе S3 801 (таких, как SPEA V7 Mirage), работающих совместно с некоторыми картами-контроллерами производства "Adaptec" с расширенной ROM-памятью, необходимой для обслуживания жестких дисков объемом свыше 1 ГБ.
Опция может называться "Decoupled Refresh Option".

Distributed Refresh
- (распределенная регенерация). Не совсем ясно, что "прячется" под этой опцией, хотя есть предположение, что это аналог "раздельной регенерации". В свое время данную опцию можно было встретить в системах на чипсетах от "VIA Technologies". Значения опции: "Disabled" и "Enabled".

DRAM Ahead Refresh
- опция, позволяющая включать ("Enabled") режим "предвидения" для цикла регенерации. Суть этого "предвидения" станет более понятна из следующей опции, которая становится активной при включении разрешения.
x DRAM Ahead Refresh Timing
- данная же опция по сути позволяет "отодвинуть" начало цикла регенации на 10 или 40 системных тактов. Небольшое, но все же повышение производительности. Столь уникальные опции были реализованы в системах на наборе SIS540 и более пока нигде не встречались.

DRAM Burst at 4 Refresh
- эта опция также связана с пакетной регенерацией, но суть ее иная. Разрешение опции ("Enabled") включает регенерацию по 4 строки в пакете. Такой метод заметно повышает производительность. При этом шина освобождается намного быстрее, чем в случае с опцией "Burst Refresh".

DRAM CAS# Precharge
- (время предварительного заряда CAS). Эта функция применяется при наличии в системе синхронной динамической памяти, и с ее помощью устанавливается (в тактах системной шины) время для формирования сигнала CAS (накопления заряда по CAS) до начала цикла регенерации памяти (см. ниже дополнительно "DRAM RAS# Precharge Time"). Уменьшение этого значения увеличивает быстродействие, но возможны проблемы со стабильностью системы, если в то же время установлены "пограничные" значения для RAS-строба. Если установлено слишком малое значение (время), также и регенерация может оказаться незавершенной, что в итоге приведет к потере данных, находящихся в памяти.
Опция может иметь наименования: "CAS# Precharge", "CAS# Precharge Time", "FPM CAS# Precharge", "FPM DRAM CAS Precharge", "EDO/FPM CAS Precharge Time", "EDO CAS# Precharge", "EDO DRAM CAS Precharge".
Большим разнообразием значений все перечисленные опции не отличаются. "1T", "2T" или такой ряд: "1T", "1T/2T", "2T". Некоторое разнообразие внесла опция "CAS Precharge Period": "1T", "2T", "3T", "4T".

DRAM RAS Only Refresh
- включение/отключение метода обновления DRAM, альтернативного методу "CAS-before-RAS". Если BIOS содержит другие возможности по регенерации памяти, то эту опцию необходимо отключить. В противном случае придется использовать этот устаревший метод обновления памяти.

DRAM RAS# Precharge Time
- (время предварительного заряда RAS). Эта функция применяется при наличии в системе синхронной динамической памяти и она позволяет устанавливать время (в тактах системной шины) для формирования сигнала RAS (иногда говорят о накоплении заряда по RAS) до начала цикла регенерации памяти. Фактически, тем самым устанавливается минимальный интервал между двумя последовательными циклами чтения или записи. Уменьшение этого значения увеличивает быстродействие. Но если установлено недостаточное время, регенерация может быть некомплектной, что в итоге приведет к потере данных, находящихся в памяти. Естественно, что за повышением частоты, на которой работает память, следует и выбор большего значения, что важно при разгоне памяти. Возможные значения могут быть представлены в различном виде: в виде цифровых значений - "3", "4" и т.д.; с указанием системных тактов - "3 Clocks" или "1T". А обобщенный ряд значений имеет следующий вид: 0T, 1T, 2T, 3T, 4T, 5T, 6T, хотя в каждом конкретном варианте может быть представлено 2-4 значения.
Опция может иметь множество названий: "DRAM RAS# Precharge Period", "RAS# Precharge Time", "RAS Precharge Timing", "RAS# Precharge Period", "FPM DRAM RAS# Precharge", "FPM RAS Precharge", "RAS# Precharge", "DRAM RAS Precharge", "EDO RAS Precharge", "EDO RAS# Precharge Time", "EDO RAS Precharge Timing", "FPM/EDO RAS# Precharge Time", "EDO/FPM RAS Precharge Time".
Как видим, опция не потеряла своей актуальности с появлением EDO-памяти и, что интересно, затем также BEDO- и SDRAM- модулей, поскольку данный параметр является одной из важнейших характеристик чипов памяти: "BEDO RAS Precharge", "SDRAM RAS Precharge Time".
Правда, кроме привычных параметров типа "3T" или "2 Clks" (эти значения и характерны для SDRAM-модулей) в различных версиях BIOS стали "встречаться" новые виды значений, таких как: "Same as FPM" и "FPM-1T", "Fast" и "Normal", "Fast" и "Slow". Для последней пары параметров "Slow" (медленно) равносильно увеличению количества тактов, что повышает стабильность работы системы, поэтому значение "Fast" следует устанавливать в случае уверенности в качестве модулей памяти. Что же касательно первой пары, то для опций вида "FPM DRAM RAS# Precharge" ряд значений мог иметь вид: 2T, 3T, 4T, 5T, 6T, а отсюда и возможный результат для SDRAM-памяти, хотя совершенно не очевидный.
Вполне возможна и ситуация, когда версия BIOS предоставляет возможность установки каких-либо параметров для каждого банка памяти в отдельности. Поскольку речь идет о "предзаряде" для RAS#-строба, то опция (опции!) может называться "Bank 0&1 (2&3)(4&5): EDO/SDRAM Precharge" со значениями: "3T/2T", "4T/3T".
"AMI BIOS" для "своей" опции "SDRAM RAS# Precharge" предложил дополнительное значение "Auto". Правда, один из вариантов опции "SDRAM RAS Precharge" представил и значения "Disabled"/"Enabled". Запрещать опцию можно только в случае абсолютной уверенности в модулях памяти, иначе неприятностей не избежать. Раз коснулись возможности запрещать/разрешать механизм предзаряда, то нужно отметить и возможность включать ("Enabled") оптимизацию предзаряда - "SDRAM: Optimal RAS# Prech.".
Для данной опции (опций!) необходимо отметить пару важных моментов. Нельзя путать данную опцию с опциями типа "Refresh RAS Active Time", которые отвечают за длительность сигнала RAS#. В нашем случае речь идет как бы о подготовительном процессе. И второе! Данную опцию совершенно правильно было бы разместить и в разделе, посвященном стандартной оптимизации памяти (см. ниже). Процедуры выставления сигнала RAS# и при регенерации, и при операциях чтения/записи идентичны.
В завершение вышесказанного опция "RAS# Precharge/Refresh" со значениями "3T/4T" и "4T/5T". Данной опцией устанавливаются одновременно и время подготовительной фазы, и общее время активности сигнала RAS# для цикла регенерации.

DRAM Refresh Method
- опция установки метода регенерации. Опция может называться также "Refresh Type", "DRAM Refresh Type", "DRAM Refresh Mode" или "Refresh Type Select". При любых вариациях опция, как правило, среди возможных параметров содержит только два параметра. Приводим весь возможный ряд: "CAS before RAS" (или "CAS-RAS"), "RAS only", "RAS# Before CAS#", "Normal", "Hidden".

DRAM Refresh Period
- установка периода (частоты повтора), требуемого для регенерации памяти, в соответствии со спецификацией модулей памяти. В новейших версиях BIOS такая опция может и не присутствовать, хотя ее наличие в современной системе по прежнему позволяет оптимизировать процесс регенерации. Ранее такая опция предлагала пользователю широкий простор для творчества: в зависимости от версии BIOS и его производителя, чипсета, модулей памяти. Опция могла также носить название "Refresh Cycle Time (us)", "DRAM Refresh Cycle Time", "Memory Refresh Rate", "DRAM Refresh Rate Select", "DRAM Refresh Rate","SDRAM Refresh Rate" или просто - "DRAM Refresh". Вот неполный перечень значений, с которыми мог встретиться пользователь:
"For 50 MHz Bus", "For 60 MHz Bus", "For 66 MHz Bus", "Disabled" (такой необычный вариант встретился в системе на i430FX),
"50/66 MHz", "60/60 MHz", "66/66 MHz",
"15 us", "30 us", "60 us", "120 us",
"Disabled" (или "No Refresh"), "15.6 us", "31.2 us", "62.4 us", "124.8 us", "249.6 us",
"15.6 us", "31.2 us", "62.4 us", "125 us", "250 us",
"15.6 us", "62.4 us", "124.8 us", "187.2 us",
"1040 Clocks", "1300 Clocks",
"15.6 us", "7.9 us", "FR 128 CLKs" (понятно, что речь идет о частоте - "frequency"),
"Disabled", "Normal",
"Fast", "Slow",
"Faster", "Slower",
"Disabled" (устанавливаются стандартные 15,6 мкс), "Enabled" (соответствует удвоению частоты).
Остается отметить, что чем реже производится регенерация памяти, тем эффективнее работает система. Но если явно наблюдаются нарушения в работе системы, то частоту обновления необходимо повысить. Значение "Disabled", появляющееся в некоторых версиях, не должно использоваться. В противном случае следует ожидать потери информации в памяти. И наконец, если пользователь видит на экране перед собой целый ряд значений для выбора, то это может означать, что в состав чипсета входит специальный конфигурационный регистр, в котором три разряда (или менее) "отданы" под возможные комбинации устанавливаемой частоты.
Как дополнение к изложенному рассмотрим еще некоторые опции и чипсеты, для которых они были реализованы:
"DRAM Refresh Ratery Time" (SIS530) - "15.6 us", "7.8 us", "3.9 us",
"Refresh Rate" (AMD751) - "20.4 us", "15.3 us", "10.2 us", "5.1 us".
Опция "Refresh Mode Select", несмотря на некоторое несоответствие в названии, предложила значения "7.8 μsec", "15.6 μsec", "64 μsec", а опция "Refresh Interval" - "7.8 μsec", "15.6 μsec", "31.2 μsec", "64 μsec", "128 μsec".
Вот тут и может возникнуть, с одной стороны, мнимое несоответствие, а с другой, некоторое непонимание сути представленных опций. Ведь в названиях опций упоминаются и "частота", и "период", и "интервал", и "время цикла". Поэтому требуется дополнительное разъяснение.
Понятно, что одновременно регенерировать всю динамическую память невозможно. Допустимо также говорить о построчной регенерации матрицы памяти (об этом см. выше). Тогда можно ввести сразу два понятия. Первое - временной интервал между регенерацией, например, соседних строк. Второе - время полного цикла регенерации, т.е. время, через которое необходимо будет снова регенерировать условную начальную строку. "Обычный" чип памяти содержит 4096 строк. Можно утверждать, что общее время цикла регенерации составляет 64 мсек (один из стандартов JEDEC). И тогда упомянутый интервал (период) регенерации составляет:
64000 : 4096 = 15.6 μsec.
Это означает, что каждые 15,6 мкс контроллер памяти инициирует цикл регенерации отдельной строки памяти. И это значение характерно для тех же модулей DIMM емкостью 128 Mbit или меньше. Если же речь идет о модулях емкостью 256 Mbit и более, то количество строк составит 8192 и интервал регенерации 7.8 μsec, обусловленный сохранением времени общего цикла в 64 мсек. Если же в системе используются модули различной емкости, то временная характеристика регенерации устанавливается по модулю большей емкости, т.е. с более высокой частотой.
Необходимо отметить, что применявшиеся ранее модули памяти во многих случаях позволяли удлинить цикл регенерации, т.е. увеличить ее интервал, тем самым несколько повышая производительность системы.
И, конечно же, картина была бы неполной, если бы мы не вспомнили о RAMBUS DRAM. Мы не будем детально останавливаться на архитектуре этого типа памяти, напомним только, что структура и организация банков памяти носит многоканальный характер. Причем каждый канал данных представляет собой шину шириной всего в один (!) байт. Но за счет высокопроизводительного конвейера, высокоскоростной внутренней магистрали, синхронизируемой собственным тактовым генератором, пропускная способность шины памяти уже доведена до 3,2 ГБ/сек. Ну а теперь опция - "RDRAM Refresh Rate, Channel N", и ее значения: "No refresh", "1.95 us", "3.9 us", "7.8 us".

DRAM Refresh Queue
- этот параметр во включенном состоянии допускает использование более эффективного метода обновления памяти. Дело в том, что чипсет способен формировать последовательность нескольких запросов обновления памяти, пока шина процессора не будет готова к выполнению следующей операции. Речь здесь идет об использовании режима конвейеризации запросов на регенерацию памяти. "Enabled" разрешает постановку в очередь, как правило, 4 запросов регенерации памяти. Установка в "Disabled" означает отключение конвейеризации, что естественно снижает эффективность и приводит к проведению всех циклов регенерации либо по приоритету запросов, либо в соответствии с методами, изложенными в других опциях.
Данный режим должен быть всегда включен. "Enabled" устанавливается и по умолчанию. Одно условие! Установленные модули памяти должны поддерживать это свойство, большинство современных типов памяти поддерживают этот метод. Более того! Использование столь эффективного метода регенерации зависит и от реализации чипсетом таких функций, и от версии BIOS. В таком явном, "пользовательском", виде такая опция повстречалась в "AMI BIOS".
Опция может называться также "DRAM Refresh Queing".

DRAM Refresh Queue Depth
- данная опция позволяет установить степень ("глубину") конвейеризации, т.е. количество возможных ступенек конвейера. Чем выше это число, тем большее количество запросов на регенерацию в данное время находится в обработке. Возможные значения, что естественно зависит от указанных выше реализаций и возможностей, имеют вид:
"0" (равносильно "Disabled"), "4", "8", "12" (по умолчанию).
Опция может называться также "Refresh Queue Depth".

Extended Refresh
- (расширенная регенерация). Введение (в свое время) этой опции в BIOS предполагало использование специальных EDO-чипов. Регенерация содержимого ячеек EDO DRAM при этом стала производиться через 125 мкс, а не через каждые 15,6 мкс, как при стандартной регенерации. Это несколько повысило общее быстродействие памяти.

Fast DRAM Refresh
- (быстрая регенерация DRAM). Контроллер памяти предоставляет два режима регенерации памяти: стандартный (Normal) и скрытый (Hidden). В каждом из режимов CAS-строб выставляется перед RAS-сигналом, однако в режиме "Normal" для каждого строб-импульса выделяется дополнительный такт процессора. Это старый метод обновления памяти, и поэтому имеет смысл установить значение данного параметра в "Hidden", который обеспечивает и повышенное быстродействие, и большую эффективность (см. ниже), также и по причине того, что CAS-строб может и не выставляться - быть "скрытым".

Hidden Refresh
- (скpытая pегенеpация). Когда установлено значение "Disabled", память регенерируется по IBM AT методологии, используя циклы процессора для каждой регенерации. Когда опция "Hidden Refresh" установлена в "Enabled", контроллер памяти "ищет" наиболее удобный момент для регенерации, независимо от циклов CPU. При этом регенерация происходит одновременно с обычным обращением к памяти. Алгоритм регенерации памяти при этом многовариантен: разpешаются циклы pегенеpации в банках памяти, не используемых центральным процессором в данный момент, взамен или вместе с ноpмальными циклами регенерации, выполняемыми всякий pаз (каждые 15 мс) пpи опpеделенном пpеpывании (DRQ0), вызванном таймеpом и инициируемом схемой регенерации.
Для регенерации каждый pаз тpебуется до 4 мс. В течение этих 4 мс один цикл pегенеpации пpимеpно каждые 16 мкс pегенеpиpует по 256 стpок памяти (здесь и выше приведены характеристики для модулей памяти малой емкости). Каждый цикл pегенеpации занимает столько же или чуть меньше вpемени, чем один цикл чтения памяти, т.к. сигнал CAS для pегенеpации при этом не тpебуется.
"Hidden refresh" отличается максимальной скоростью и эффективностью, наименьшими нарушениями активности системы и наименьшими потерями производительности, также позволяя поддерживать состояние памяти во время нахождения системы в режиме "suspend". Этот режим более быстрый, чем "Burst Refresh". Но наличие в BIOS этой функции еще не означает ее реализации. После установки опции в "Enabled" стоит тщательно проверить работоспособность компьютера. Некотоpые модули памяти позволяют использовать "Hidden Refresh", некотоpые - нет. В большинстве случаев pекомендуется установить в "Enabled".

Hi-Speed Refresh
- с помощью этой опции чипсет быстрее проведет регенерацию основной памяти. Правда, эффект от этой установки значительно меньше, чем от включения "Slow Refresh". Последний режим регенерации предпочтительнее. К тому же эта функция поддерживается не всеми чипами памяти.

ISA Refresh
- опция разрешения/запрещения проведения регенерации памяти для ISA-шины. В таком виде эта опция уже не встречалась даже в последние годы существования ISA-шины.

ISA Refresh Period
- установка периодичности для регенерации ISA-шины. Возможный ряд значений: "15 us", "30 us", "60 us", "120 us".

ISA Refresh Type
- опция с установкой метода регенерации памяти для ISA-шины. Возможные значения параметра: "Normal" и "Hidden". Аналогичная опция с названием "ISA Bus Refresh Mode" могла предложить другие значения: "Slow" и "Fast".

PCI-to-DRAM RAS# Precharge
- тема "предзаряда" уже достаточно нами освоена, поэтому стоит лишь сказать кратко о назначении данной опции - установка времени "предзаряда" строба RAS# при циклах записи PCI-шины в основную динамическую память. Значения опции: "2T", "3T".

RAS Precharge @Access End
- когда выбрано "Enabled", RAS#-строб остается в активном состоянии в конце процесса "предзаряда". Если же установлено "Disabled", RAS# переводится в пассивное состояние (высокий уровень).

RAS Timeout
- когда установлено значение "Disabled", цикл регенерации динамической памяти производится в стандартном режиме, т.е. каждые 15,6 мкс. Дополнительный цикл регенерации памяти вставляется при выборе значения "Enabled".

Ref/Act Command Delay
- (установка задержки для цикла чтения/записи). Параметром выбирается время задержки между окончанием цикла регенерации и началом цикла чтения или записи. Опция может принимать значения: "5T", "6T" (по умолчанию), "7T", "8T".
Система на наборе SIS530 предложила опцию под названием "DRAM Refresh/Active Delay" с чуть более консервативными значениями: "9T", "8T", "7T", "6T". Более развитый чипсет (SIS540) представил уже две опции: "DRAM REF/ACT Delay" ("10T", "9T") и "DRAM ACT/REF Delay" ("10T", "9T", "8T"). Понятно, что последняя опция предназначена для выбора задержки для режима регенерации после окончания цикла чтения/записи. Меньшие значения, конечно, более предпочтительны. Данная опция уже не встречается в современных системах.

Refresh During PCI Cycles
- опция, разрешающая/запрещающая проведение регенерации памяти во время циклов чтения/записи на шине PCI. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

Refresh RAS# Assertion
- (установка периода активности сигнала RAS). Этим параметром устанавливается длительность сигнала RAS (в тактах системной шины) для цикла регенерации. Меньшее значение увеличивает производительность системы. Но поскольку принимаемые значения определяются качеством памяти и чипсетом, то к их установке необходимо подходить осмотрительно. Может принимать значения: "4T" (или "4 Clks"), "5T" (или "5 Clks"). Могут быть и другие значения.
Опция может называться также "Refresh Assertion", "Refresh RAS Active Time" или "RAS Pulse Width Refresh".

Refresh Value
- данной опцией устанавливался множитель частоты регенерации. Меньшее значение увеличивало производительность системы за счет снижения частоты регенерации. Но при этом также оптимальный вариант мог быть достигнут только опытной проверкой. Значения опции могли быть выбраны из ряда: 1, 2, 4, 8, 16. Иногда можно было встретить и значение 0,5. Опция эта давно уже не встречается.
Опция может называться "Refresh Divider".

Refresh When CPU Hold
- довольно устаревшая опция, предлагавшая производить регенерацию ("Enabled") или не делать этого ("Disabled") во время пауз процессора.

SDRAM Idle Limit
- данная опция устанавливает количество "пустых" тактов ожидания перед перезарядкой SDRAM-модулей. Оптимальная установка позволяет улучшить производительность циклов чтения/записи путем настройки интервала времени, в течение которого банк памяти может оставаться "пустым" перед перезарядкой (recharging), т.е. перед перезаписью содержимого памяти обратно в ячейки. При этом данная установка не может функционировать как задержка цикла регенерации.
Уменьшение количества тактов с 8 (по умолчанию) до 0 означает, что банк SDRAM-памяти будет немедленно регенерироваться как только контроллер памяти выставит достоверный запрос. При увеличении "SDRAM Idle Limit" от 8 тактов и более перезарядка банка будет задержана на большее время, тем самым возрастет время "хранения" информации из памяти во внутренних цепях. Пришедшая в это время команда чтения/записи будет исполнена мгновенно. Тогда приходится признать, что эффективность памяти возрастет, когда банк более длительное время будет оставаться "пустым". Но всегда есть свое НО! Во внутренних цепях перезарядки не хранятся все строки банка памяти, а только регенерируемой строки. Поэтому пришедший запрос, например, на чтение некоторой строки наверняка не "попадет в точку", и системе придется ожидать завершения регенерации, особенно в случае завышенного значения параметра.
В основном приходится выбирать между значениями в пределах между 0 и 8-ю тактами, правда, насколько позволит это версия BIOS. Конечно, подобная настройка требует серьезной опытной проверки. Поэтому, если есть возможность управлять частотой регенерации, то данную опцию лучше заблокировать. Опытным специалистам можно порекомендовать "поиграть" с двумя характеристиками.
Опция может называться "DRAM Idle Timer". Указанные опции предложили два ряда значений:
"Disabled", "0 Cycle", "8 Cycles", "12 Cycles", "16 Cycles", "24 Cycles", "32 Cycles", "48 Cycles",
"0 clocks", "2 clocks", "4 clocks", "8 clocks", "10 clocks", "12 clocks", "16 clocks", "32 clocks".
Подобные опции достаточно редки. Но вот система на достаточно современном чипсете AMD751 предложила сразу две:
"Idle Precharge Limit" с рядом "0 cycles", "8 cycles", "12 cycles", "16 cycles", "24 cycles", "32 cycles", "48 cycles" и "No idle precharge" и "Extra High Idle Limit" со значениями "Disabled"/"Enabled". Последняя опция разрешает или запрещает вставку дополнительного такта ожидания.

SDRAM Precharge Control
- (управление предварительным зарядом SDRAM). Данная опция определяет, чем управляется "предзаряд" SDRAM - центральным процессором или самой SDRAM-памятью. В некоторых версиях BIOS такая опция может называться (трактоваться) как "SDRAM Page Closing Policy" ("метод закрытия страниц SDRAM" - см. дополнительно в следующем разделе). Если эта опция отключена ("Disabled"), то все циклы процессора к SDRAM завершаются командой "All Banks Precharge Command" в интерфейсе SDRAM-памяти, что улучшает стабильность, но понижает производительность памяти. Если же эта опция включена ("Enabled"), то предварительный заряд контролируется самими чипами памяти. Это уменьшает количество предзарядов SDRAM, значительно возрастает число циклов CPU-to-SDRAM до того момента, когда требуется регенерация памяти. Это однозначно ведет к повышению общей производительности системы, но может влиять на ее стабильность.

SDRAM Refresh
- опция выбора метода регенерации для SDRAM-памяти. Возможные варианты: "Serial" (последовательный перебор строк при регенерации) и "Simultaneous" (одновременная регенерация). При рассмотрении опции "Burst Refresh" уже отмечались недостатки пакетной регенерации, при которой в единый пакет собираются запросы на регенерацию. "Перезарядка" строк происходит мгновенно, но пока не завершится полная регенерация, доступ к шине памяти будет невозможен. Поэтому об оптимальной установке для конкретной системы можно будет говорить после экспериментальных тестов.
Данная опция была замечена в системах, построенных на чипсетах SIS620, SIS600 и некоторых других.

Self-Refresh
- опция включения режима "саморегенерации" основной памяти (если установлено "Enabled"). Этот режим подробно описан выше, в вводной статье.
Опция может называться также "EDO/FPM DRAM Self-Refresh".

Slow Refresh (1:4)
- (медленная pегенеpация). При включении этой опции ("Enabled") схема регенерации будет в 4 раза реже регенерировать память (64 мкс против 16), чем в обычном pежиме. При такой установке пpоизводительность системы повышается благодаpя уменьшению конкуpенции между CPU и схемой pегенеpации, однако не все типы динамических ОЗУ могут поддеpживать такие циклы (в этом случае будет получено сообщение об ошибке четности или о сбое системы). Тогда необходимо установить значение "Disabled". Опция в свое время получила распространение с развитием такого типа ПК, как "laptop" (дорожный ПК), в качестве энергосберегающей функции. В современных системах эта опция встречается все реже.
В свое время считалось также, что применение "медленной регенерации" будет достаточно эффективным при использовании 16-битных ISA-карт расширения, работающих в режиме "bus master". Поскольку сама ISA-карта может быть инициатором запроса на регенерацию, то понятно, что "медленная регенерация" в меньшей степени бы нарушала передачу данных по DMA-каналам.
Опция может называться также "DRAM Slow Refresh", "Slow Refresh" или "Slow Refresh Enable".
Опция может называться и "Slow Memory Refresh Divider". Но этой опцией устанавливался делитель для медленной регенерации: 1, 4, 16 или даже 64. Устанавливать самые большие значения, т.е. в максимальной степени снижать частоту регенерации, позволяла только специальная память.

Staggered Refresh
- трудно переводимый тип регенерации, что-то наподобие "регенерации с перекатыванием". Но этим непонятным термином обозначают "шахматную" регенерацию. Как известно, регенерация выполняется на банках памяти последовательно, с последовательным перебором строк. Но при наличии нескольких банков памяти и включении данной опции банки памяти регенерируются одновременно, но со сдвигом по перебору строк.
Данный тип регенерации позволяет сгладить броски потребления модулями памяти, выравнивая токи в процессе различных переключений. Так как уменьшаются броски тока, то такая регенерация эффективна с точки зрения снижения помех.
С помощью этой несколько устаревшей опции есть возможность установки временного интервала между регенерируемыми строками, измеряемого в системных тактах (0T, 1T, 2T, 3T, 4T, 5T, 6T, 7T). Установка в "0" позволяет регенерировать все строки в банках одновременно. Но опция может предложить и обычный набор значений: "разрешить применение"/"отказать" ("Enabled" и "Disabled").
Опция может называться также "Refresh Stagger" или "DRAM Refresh Stagger By".


BIOS. Продолжение!

4.5. Конфигурирование основной памяти

Auto Configuration
- опция автоматического конфигурирования параметров доступа к основной памяти. Опция обычно находится в разделах "Advanced Chipset Setup" или "Chipset Features Setup" и позволяет настроить время доступа к модулям памяти в автоматическом режиме либо в "ручном" режиме и в соответствии со спецификациями применяемых модулей памяти. Чтобы выйти на режим пользовательской настройки, достаточно установить параметр в "Disabled". Значение "Auto" (автоматическая конфигурация) устанавливается по умолчанию. Среди возможных фиксированных значений обычно встречаются значения "60 ns" и "70 ns" для модулей памяти с соответствующим быстродействием в наносекундах.
Опция может называться также "DRAM Auto Configuration" или "Auto Configure EDO DRAM Tim" ("tim" - это timing). В последней опции параметр "Enabled" заменил "Auto", в остальном отличий нет.
Значительно большие различия оказываются в том случае, когда под опцией "Auto Configuration" "скрывается" настройка параметров доброй половины соответствующего раздела "BIOS Setup". Тогда автоматически конфигурируются параметры кэш-памяти, основной памяти, регенерации и даже скорость ISA-шины. Практически все они будут нами изучены.

Bank nn DRAM Type
- этой устаревшей опцией (еще для AT-286) устанавливался объем модулей памяти, собранных в банки с номерами nn. Значение параметра выбиралось из ряда: "64K", "256K", "1M".

Bank nn Numer of Banks
- этой также устаревшей опцией (для AT-286) устанавливалось количество заполненных банков из банков nn. Значение параметра выбиралось из ряда: "0", "1", "2".

Base Memory Size
- эта опция-ветеран "AMI BIOS" содержит параметры по установке размера основной системной памяти: "512KB", "640KB" (по умолчанию). Правда, "Phoenix BIOS" также содержал такую опцию.

CAS# Latency
- (задержка CAS - CL). Важнейшая характеристика чипа памяти, определяющая минимальное количество циклов тактового сигнала от момента запроса данных сигналом CAS до их появления и устойчивого считывания с выводов модуля памяти. Возможные значения параметров: 2, 3 или в тактах - 2T, 3T (3 Clks). Значение в 3 такта устанавливается по умолчанию. Уменьшение параметра нужно осуществлять крайне осторожно.
Другое название опции - "CAS# Latency Clocks".
Давно это было, но сказанное об "ожидании CAS" и тогда было верно. Об этом свидетельствуют перечисленные ниже опции: "CAS Width in Read Cycle", "CAS-to-Read Delay", "DRAM CAS Timing Delay", "CAS Output Delay". Столь важная характеристика памяти сохранила свою "важность" и с внедрением памяти типа SDRAM, а опция стала называться "SDRAM CAS# Latency" (или реже "SDRAM CAS Latency Time").
Отметим, что меньшее значение увеличивает производительность системы (установка в 2 такта в сравнении с 3-мя ускоряет систему на 1-2%). Рекомендуется устанавливать меньшее значение для SDRAM с быстродействием 10 нс или лучше.

CAS# Pulse Width
- большим разнообразием значений данная опция, в отличие от "RAS# Pulse Width", не отличается. Ею устанавливается период активности сигнала CAS (в системных тактах). Стандартный набор значений параметра: 1T, 2T.
В большинстве случаев версия BIOS могла предложить раздельную установку параметров как для режима записи, так и для чтения из памяти. Тогда опций могло быть две, например, "Write CAS# Pulse Width" и "Read CAS# Pulse Width". Опция могла быть представлена в интегрированном виде - "EDO CAS Pulse Width R/W", со следующими значениями: "1T/1T", "1T/2T", "2T/2T".
Вот еще пара примеров наименований опции, мало чем отличающихся друг от друга: "FPM DRAM Write Pulse Width", "FPM CAS# Pulse Width", "CAS# Write Pulse Width", "DRAM Write CAS Width".
Те же самые опции могут неожиданно предложить более солидный ряд значений: 2T, 3T, 4T, 5T. Вот еще один пример подобной реализации - "FPM/EDO Read Pulse Width": "1T/2T", "2T/1T", "3T/2T", "4T/3T".
Ну и напоследок еще одна опция, "Post Write CAS Active", с помощью которой устанавливалось время активности CAS- сигнала для циклов записи в память со стороны "мастер"-устройства на PCI-шине.

CPU to DRAM Page Mode
- когда опция установлена в "Disabled", контроллер памяти закрывает страницу памяти после доступа к ней. При этом очищается т.н. page open register. Когда опция включена (по умолчанию), страница памяти остается открытой на случай повторного обращения к ней, т.е. при отсутствии запроса к ней. Такой режим работы памяти более производителен.
Этот же смысл характерен для множества функций с подобными наименованиями: "DRAM Page Mode", "DRAM Paging", "DRAM Paging Mode", "DRAM Page Open Policy", "SDRAM Page Control".
Так же широк и выбор возможных значений параметров. В различных версиях BIOS можно даже найти опции с одинаковыми названиями, но различными значениями параметров. Например, "CPU to DRAM Page Mode" может предоставить для выбора значения "Use Paging" и "No Paging". Возможны и следующие вариации значений параметров:
"Always Open" и "Closes",
"Page Closes", "Stays Open" и "Closes If Idle",
"Normal" и "Disabled".
И еще пара опций: "DRAM Page Closing Policy" со значениями "Closed", "Open" и "Page Open Policy" со значениями "Close Page", "Hold Open".
В некоторых случаях усовершенствованный (enhanced) механизм работы чипсета и контроллера памяти позволяет с помощью дополнительной информации об открытой странице памяти сохранять ее некоторое время открытой даже при отключенной опции: "DRAM Enhanced Paging", "Enhanced Page Mode", "Enhanced Paging".

DDR_1T/2T_Item
- столь необычный вид опции для настройки параметров современной DDR SDRAM-памяти не должен удивлять подготовленного пользователя. Речь идет об ускорении обмена с памятью (уменьшается на один такт время переадресации DDR) либо сохраняется более "медленный" обмен, устанавливаемый по умолчанию. Значений опции всего два: "1T CMD" и "2T CMD". Возможностей для экспериментирования немного, но его можно осуществить более основательно.

DRAM Clock
- опция установки тактовой частоты для работы модулей памяти. Имеет смысл дополнительно еще раз просмотреть подраздел "CPU Speed". Значения данной опции предлагаются следующие: "Host CLK" (по умолчанию) и "66 MHz". Согласно первому параметру тактовая частота модулей памяти устанавливается равной тактовой частоте системной шины, другое значение устанавливается как фиксированное.
Попробуем разъяснить эти значения. Производимые к 98-му году модули SDRAM предназначались для работы на частоте 66 МГц. Появившийся в первой половине 98-го чипсет i440BX представил системную шину с частотой 100 МГц. Уже до этого было практикой показано, что чипы SDRAM могли устойчиво работать на частотах более 66 МГц, а некоторые модули вполне успешно работали и работают на частоте 100 МГц. Отсюда и возможное использование значения "Host CLK", тем более, если речь идет о поддержке частот 75 или 83 МГц.
Опция может называться и "DRAM Speed" (см. ниже), а значения могут быть "Host CLK" и "AGP CLK".

DRAM Interleave Mode
- опция установки разрешения/запрещения режима "чередования" банков памяти, а также возможного выбора банков памяти, подлежащих "чередованию". Значения данной опции выглядят следующим образом: "No Interleave", "Banks 0+1", "Banks 2+3", "Both". Включение опции или установка оптимального режима "чередования" позволяет оптимизировать процессы регенерации памяти и доступа к ней, а значит и повысить производительность памяти. Несколько подробнее об этом чуть ниже.
Опция "SDRAM Bank Interleave" предложила два варианта возможных значений. Первый - стандартные "Disabled" и "Enabled", а второй - "Disabled", "2 Bank", "4 Bank". Во втором случае выбор банка возможен только для 64-мегабитных модулей. Если в системе применяются 16-мегабитные модули interleave должен быть заблокирован.
Опция может называться "Interleave Mode" или "Bank Interleave", но главное, что для включения опции требуется заполнение хотя бы двух банков памяти.
Если же остановиться на выборе оптимального значения из такого ряда: "None", "2 Banks", "4 Banks", "Auto", то прежде всего надо отметить недопустимость отключения опции: заметное снижение производительности гарантировано. Запрещение допустимо разве что в случаях появления сбоев в системе. Выбор значения "4 Banks" нежелателен для односторонних ("Single-Sided") модулей. Поэтому оптимальными являются значения "Auto" или "2 Banks".

Interleave ("чередование") - способ ускорения работы подсистемы памяти, основанный на предположении, что доступ происходит к последовательным адресам памяти. Этот метод реализуется аппаратно на уровне контроллера и требует организации банка памяти таким образом, что суммарная ширина шины модулей превосходит ширину системной шины в k раз (это число называется коэффициентом interleave и является степенью двойки). Таким образом, каждый банк состоит из k "нормальных" банков. Контроллер распределяет "нормальное" адресное пространство подсистемы так, что каждый из k последовательных адресов физически находится в разном банке. Обращение к банкам организовано со сдвигом по фазе (стоит напомнить, что отдельный цикл обращения может требовать 5 тактов шины и более). В результате при последовательном обращении к данным за один обычный цикл обращения можно получить до k обращений в режиме interleave. Реальный выигрыш, разумеется, меньше. Кроме того, interleave заметно увеличивает минимальный размер банка (как в числе модулей, так и в емкости). В SDRAM interleave реализован на уровне чипа.

DRAM Page Idle Timer
- (таймер пассивного состояния страницы памяти). С помощью этой функции устанавливается время (в системных тактах), в течение которого контроллер DRAM, после перехода процессора в режим ожидания, ждет закрытия всех открытых страниц памяти. Параметр сохранил свою актуальность со времен FPM. Для увеличения быстродействия устанавливается минимальное значение данного параметра, однако при этом возможна нестабильная работа системы. Оптимальный вариант устанавливается опытным путем. Опция может называться "Paging Delay", "DRAM Idle Timer", а возможные значения выбираются из ряда: 1T, 2T, 4T, 8T. Правда, иногда такой ряд может иметь следующий вид: 0, 2, 4, 8, 10, 12, 16, 32.
Последний вариант используется для работы со страницами памяти в системах с EDO- и SDRAM-памятью. Установленные параметры "запоминаются" в 4-разрядном регистре DIT (DRAM Idle Timer). Появление "1" в старшем разряде ("Infinite" - бесконечность) ведет к сохранению открытого состояния страниц памяти. Примеры этому изложены чуть выше.

DRAM Prefetch Buffer
- (буфер предвыборки памяти). Чипсет может содержать (в составе "северного" моста) буфер "предвыборки", предназначенный для временного хранения инструкций чтения. Режим "предвыборки", наверное, уже достаточно хорошо понят читателем, к тому же далее будут рассмотрены дополнительные опции на эту тему (см. обязательно опцию "Read Prefetch Memory RD"). Опция может принимать значения:
"Enabled" - буфер включен,
"Disabled" - буфер не используется.

DRAM Prefetch Buffer Size
- (размер буфера предвыборки чтения). Понятно, что данная опция позволяет установить размер уже известного нам буфера. Но в каких единицах? Данный буфер представляет собой небольшой "конвейер", в котором инструкции чтения перемещаются "от входа к выходу", с более дальнего уровня к ближнему. Поэтому в данной опции устанавливается глубина такого конвейера, поэтому и размер буфера вычисляется не в байтах, а в уровнях, о чем и свидетельствуют применяемые значения опции: "1-level", "4-level".
Опция может называться "Read Prefetch Buffer Size".

DRAM Prefetch Delay
- (задержка предвыборки чтения). Опция позволяет оптимизировать процесс "предвыборки" чтения путем выбора задержки (в системных тактах). Данная задержка предназначена не для центрального процессора, задержка используется контроллером памяти при выдаче команды чтения. Тем не менее, даже наличие задержки при применении режима "предвыборки" чтения сохраняет эффективность режима в сравнении со стандартными процедурами чтения. Понятно, что меньшее значение ускоряет процесс чтения и повышает эффективность работы памяти. Опция может принимать значения: "2T", "3T".

DRAM Speculative Leadoff
- (DRAM опережающее чтение). При включении этой опции контроллер памяти может начать выполнять операцию чтения до того, как полностью будет декодирован адрес, по которому находятся требуемые данные. Процесс начинается с того, что процессор инициирует сигнал чтения одновременно с генерацией необходимого адреса, а контроллер памяти (при разрешении параметра Speculative Leadoff) выдает команду чтения до полной расшифровки адреса. Включение этого режима позволяет повысить общую производительность системы на несколько % при снижении общих затрат времени на операцию чтения (за счет уменьшения задержек операции чтения). Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено (устанавливается по умолчанию, т.к. функцию должны поддерживать прежде всего системные компоненты, а это происходит не всегда).
Опция может называться "Speculative Leadoff", "SDRAM Speculative Read", "Speculative Lead Off".

DRAM Speed Selection
- опция установки конечно же не скорости применяемой в системе DRAM-памяти, а времени доступа к ней. Как правило, не рекомендуется менять значения, устанавливаемые по умолчанию. При установке значений надо помнить, что установка меньших параметров хотя и повысит быстродействие системы, но может привести и к полной нестабильности ее работы, потери данных. Кроме того, если установлены банки памяти с разной скоростью доступа, то необходимо устанавливать значение, соответствующее наиболее медленной памяти. Однозначный вывод: к изменению "скорости" надо относиться осторожно. Возможные значения: "50 ns", "60 ns", "70 ns". Вполне могут быть и другие значения.
Опция может называться "EDO DRAM Speed Selection", "EDO DRAM Speed (ns)", "DRAM Speed".

DRAM Type
- с помощью этой опции устанавливается тип инсталлированной памяти. Возможные значения: "Page Mode Std", "FPM", "EDO", "BEDO", "SDRAM".

EMS
- разрешение/запрещение аппаратной поддержки центральным процессором расширенной (отображаемой) памяти, или как говорят, EMS-памяти (Expanded Memory Specification). Значения опции были стандартны: "Disabled" и "Enabled". Опция предназначалась для систем на 286-х процессорах.

EMS Memory Base Address
- данной опцией устанавливался базовый адрес окна EMS в основной памяти. Возможные значения: "C0000h", "C4000" и т.д., включая "E0000h". Знакомые значения! Устаревшая опция.

EMS Page Reg I/O Base
- данной опцией устанавливался базовый адрес портов ввода/вывода (регистров процессора) для отображения страниц EMS. Предлагался для выбора целый ряд возможных значений: "208h", "218h", "258h" и т.д., до "2E8h". Также устаревшая опция.

EMS Page(n) Addr Extension
- опция позволяет расширить объем отображаемой памяти для страницы n. Возможные значения имели следующий вид: "0 to 2 Mb", "2 to 4 Mb" и т.д.

Fast MA to RAS# Delay
- (задержка между RAS- и MA-стробами). Опция, очень схожая с функцией "RAS# to CAS# Delay". Поэтому имеет смысл вначале внимательно изучить последнюю. Действие же данной опции еще более критично по отношению к пользовательским регулировкам, поскольку речь идет о задержке между RAS-стробом и сигналом MA (Memory Adress), согласно которому данные считываются из памяти. Это уже несколько устаревшая опция, предназначенная для работы с FPM DRAM. Значения, устанавливаемые по умолчанию, рекомендовалось изменять только в случае замены чипов памяти или замены процессора. Значения же были стандартны: "Disabled" и "Enabled".
Опция могла называться и "Fast MA to RAS# Delay CLK". Тогда для выбора могли быть предложены значения в системных тактах, аналогично как и для "RAS# to CAS# Delay".

MA Wait State
- (такты ожидания чтения памяти). Параметр позволяет установить или снять дополнительный такт ожидания перед началом чтения памяти. Для памяти типа EDO один такт всегда уже есть по умолчанию и установка значения "Slow" добавит еще один такт ожидания. Для SDRAM-памяти нет такого такта ожидания по умолчанию и установка в "Slow" один такой такт вводит. Лучше не изменять установленное по умолчанию значение данного параметра. Выбор значения "Fast" требует дополнительной опытной проверки, тем более в случае возникновения сообщений об ошибках адресации памяти. Может принимать значения:
"Slow" (по умолчанию) - добавляется один такт,
"Fast" - нет дополнительного такта ожидания.
Еще одно название опции - "MA Additional Wait State". В названии содержится то, о чем идет речь. А возможные значения обычны: "Enabled" и "Disabled". В некоторых случаях параметры могут быть представлены и в виде тактов: "0 ws", "1 ws".

OS Select for DRAM > 64Mb
- параметры этой опции косвенно (или прямо) отвечают за указание операционной системы, установленной на ПК. Дело в том, что методы работы с памятью (управления памятью) объемом более 64 МБ у операционной системы IBM "OS/2" отличны от других операционных систем. Поэтому необходимо правильно указывать операционную систему, хотя выбор соответствующего значения невелик: "OS/2" или "Non-OS/2". Правда, необходимо учитывать фактор "древности" OS/2. Если инсталлирована в системе "OS/2 Warp v3.0" или выше данные "сложности" можно игнорировать.
Опция может называться "OS/2 Onboard Memory > 64MB" или "OS/2 Compatible Mode" с обычными "Enabled" и "Disabled".
"AMI BIOS" также содержит аналогичную опцию с названием "Boot To OS/2" с параметрами "Yes" и "No".

RAMW# Timing
- в наименовании опции содержится несколько нестандартное, но прижившееся в литературе и разных версиях BIOS название сигнала "Memory Write Enable". Опять таки можно встретить сокращенное название сигнала и как "MWE", и как "WE". При любой вариации этот сигнал означает запись данных в ячейки памяти. Данная же опция отвечает за установку длительности этого сигнала. Уменьшая возможное значение параметра, можно достичь наиболее оптимального режима работы памяти, но нельзя забывать и о надежности системы.
Возможных вариаций данной опции не очень много: "FPM/EDO RAMW# Timing", "RAMW# Assertion Timing". Более разнообразны значения параметров: 2T, 3T или, например, "Normal" и "Fast". Опция может предложить и такую пару значений: "Normal" и "Faster", причем последнее соответствует одному системному такту.

RAS# Pulse Width
- данной опцией устанавливается фактически длительность сигнала RAS, т.е. время его активности в системных тактах. Дополнительно имеет смысл посмотреть опцию "Refresh RAS# Assertion" в разделе "Refresh".
Обзор различных вариантов, наименований начнем с нестандартной опции "RAS Minimum Active", предлагавшей ряд значений от "4T" до "7T". Это довольно давний вариант и с элементами надежности системы. Затем появилась опция "RAS Active Time" с небольшим рядом: 4T, 5T, 6T. Внедрение FPM-модулей ("FPM DRAM RAS# Pulse Width") дало новый вариант: 3T, 4T, 5T, 6T. Уменьшение времени нахождения сигнала RAS в активном состоянии конечно же повышает быстродействие системы. Но в данном случае, как и во многих других, должно действовать "золотое" правило: "Ускоряя, не ухудшай!"
Те же значения имела опция "RAS# Pulse Width" для EDO-памяти. А вот опция "EDO/SDRAM RAS# Pulse Width" предложила почти окончательный вариант: "5T/4T", "6T/5T", "7T/6T", "8T/7T".

RAS# to CAS# Delay
- (задержка между RAS- и CAS-стробами). Во время доступа к памяти обращения к строкам и столбцам выполняются отдельно друг от друга. Этот параметр и определяет временной сдвиг между этими сигналами. Эта задержка необходима для того, чтобы чип памяти имел достаточно времени для однозначного определения адреса строки ячейки памяти, который выставляется по сигналу RAS (Row Address Strobe), и адреса столбца, выставляемого по сигналу CAS (Column Address Strobe).
В некоторых случаях опция предлагает через стандартные "Enabled" и "Disabled" соответственно установку/снятие паузы между RAS- и CAS-строб-импульсами, используемыми, когда в DRAM происходят операции чтения/записи или обновления содержимого памяти. Значение "Disabled" (отключено) устанавливается для более высокого быстродействия, а значение "Enabled" - для более стабильной работы системы. В большинстве версий BIOS применяется установка длительности задержки в циклах тактового сигнала, что естественно дает пользователю большую гибкость в процессе оптимизации работы памяти. В этом случае меньшее значение, конечно же, улучшает скоростные характеристики, но повышает вероятность нестабильной работы системы. Попросту считывание информации об адресе строки или столбца может происходить с ошибкой. В любом случае оптимальные параметры проверяются путем опытной эксплуатации, поскольку не все чипы памяти смогут "вытянуть" минимальные значения задержек. Как правило, по умолчанию устанавливается большее значение времени задержки.
Различные версии BIOS предлагают и разные варианты установки задержки в системных тактах. Это могут быть "2T" и "3T" (или "3 Clks", или "3 Clocks"). В других случаях может быть предложен целый ряд значений: 0T, 1T, 2T, 3T. Если же обобщить все возможные вариации (прежде всего это связано с типом памяти), то параметр меняется от 0T до 5T.
Ну а если пользователь встретится со следующим предложением: "Fast" и "Slow", - то это уже не должно вызвать проблемы. Тем более, что опция может носить название "Fast RAS# to CAS# Delay", и для такого варианта значение "Enabled" означает более скоростной режим работы памяти. Правда, эта же опция предложила и стандартные значения: "3" (BIOS & Setup defaults) и "2".
В обозначение функции вынесено самое простейшее из возможных наименований важнейшей характеристики чипов памяти. В данном случае эта характеристика не "привязана" к какому-то типу памяти. Но ее смысл и важность актуальны со времен простейшей FPM DRAM, о чем и свидетельствуют многочисленные названия функции: "RAS# to CAS# Address Delay", "RAS to CAS Delay Time", "DRAM RAS-to-CAS Delay Timing", "RAS to CAS Delay Timing", "DRAM RAS to CAS Delay", "FPM/EDO RAS-to-CAS Delay", "EDO RAS to CAS Delay", "SDRAM RAS# to CAS#", "SDRAM RAS# to CAS# Delay".
Естественно, что действие перечисленных функций возможно, если в системе и установлена соответствующая названию память. Особого разъяснения в данном случае не требуется. С другой стороны, использование данных опций возможно, если в системе инсталлирована синхронная память.
Еще небольшой комментарий. "Обычная себе" опция "SDRAM RAS# to CAS# Delay" может предложить для выбора значения "Same as FPM" и "1T". В таком виде опция встречается крайне редко, причем предлагаются, по сути, крайние варианты. Установка в "1T" автоматически может привести к сбойной работе, а установка задержки, "такой же, как для FPM", означает, что чипы SDRAM- памяти смогут автоматически регулировать важнейший параметр?
Ну и напоследок к перечисленным уже функциям необходимо добавить еще парочку "стареньких", дабы картина была более полной: "RAS To Address Delay", "FPM DRAM Addr To CAS Delay". К перечисленным выше значениям необходимо добавить еще значение "Auto", что и рекомендуется в большинстве случаев.

Read-Around-Write
- опция включения ("Enabled") оптимизационных возможностей памяти. Этот метод оптимизации памяти заключается в том, что, если операция чтения памяти адресована в область памяти, данные из которой еще находятся в промежуточном буфере после начала цикла записи, то чтение требуемых данных происходит не из DRAM, а из буфера напрямую. Конечно же, речь идет о данных той части памяти, которые представляет собой последнюю запись и в данный момент еще находятся в буфере, который так и называется - "Read-Around-Write buffer".
Назначение буфера понятно. Данные в нем аккумулируются (накапливаются), а затем записываются в память уже в виде блока (пакета). Окончание цикла записи может быть прервано командой чтения, и поэтому иногда говорят об изменении последовательности команд. Фактически можно сказать, что операция записи еще не закончена, как начат цикл чтения из памяти. В итоге имеем своеобразное кэширование! Несомненно это повышает общую производительность системы. Максимальный же эффект от применения данной опции может быть достигнут в мультипроцессорных системах, в которых несколько процессоров могут раздельно обращаться к общим данным без прямого доступа к памяти.
Но эта опция должна быть отключена, если в системе используются AGP-карты, построенные, например, на интегрированных графических чипсетах i740. Есть еще один момент, и он связан с функционированием памяти типа DDR SDRAM. Например, системные платы, построенные на чипсете VIA KT266A, поддерживающем такую память, не показали увеличения производительности при включении описываемой опции. Так что, ожидаемый эффект может отсутствовать.
Также стоит отметить еще такой нюанс. В компьютерной периодике можно встретить информацию о том, что данная опция характерна для современных систем с новейшими версиями BIOS. Полнейшая нелепица! Достаточно вспомнить системы на наборах логики от "VIA Technologies" (Apollo VP3, Apollo Pro) и др., где такие опции были замечены.
Опция может называться "DRAM Read-Around-Write".
Опция может носить название и "Extended Read-Around-Write". Эта опция характерна для серверных систем, например, на чипсетах i450GX (кстати, конец 95-го г.). Компоненты интерфейса памяти позволяют использовать расширенный механизм "read-around-write", при котором циклы записи вообще могут быть пропущены при циклах чтения, если их адреса не совпадают. В тех же серверных системах (например, на чипсете i450NX) возможно появление опции "Write-around-retried-Read".

Read Prefetch Memory RD
- в наименовании опции фигурирует название линии RD ("Ready Data"). А речь идет о том, что пока идет выполнение предыдущей инструкции по чтению данных (т.е. цикл чтения не завершен), чипсет инициирует следующий цикл чтения (режим "предвыборки").

SDRAM (CAS Lat/RAS-to-CAS)
- (задержка CAS/от RAS к CAS). Это интегрированный параметр, позволяющий комбинировать, точнее даже манипулировать двумя параметрами: "CAS Latency" и "RAS-to-CAS Delay". Устанавливаемое значение этого параметра зависит от характеристик применямой SDRAM, от быстродействия процессора. Параметр (или функция) весьма неудобен, поскольку возможности настройки предельно ограничены. Изменять этот параметр необходимо крайне осторожно. Может принимать значения: "2/2", "3/3".
Дополнительно отметим, что параметры "CAS Latency" и "RAS-to-CAS Delay" определяются архитектурой самого чипа памяти и в качестве характеристик приводятся для определенной частоты. Для современной SDRAM-памяти PC100 их значения, как правило, равны 2 или 3 тактам.

SDRAM Configuration
- (конфигурация SDRAM-памяти). Установкой параметров опции определяется, должен ли BIOS определять временные характеристики доступа к памяти на основании информации из SPD-модуля ("By SPD") или же пользователь проведет конфигурирование доступа самостоятельно (через установку "Disabled"). Нетрудно увидеть схожесть данной опции с "Auto Configuration". В качестве фиксированных значений могут быть предложены параметры: "7 ns (143 Mhz)" и "8 ns (125 Mhz)" как для памяти с временем доступа 7 нс/8 нс и соответственно частотой шины 143 МГц/125 МГц.

SDRAM Precharge Control
- (управление предварительным зарядом SDRAM). Данная опция определяет, чем управляется предзаряд SDRAM - центральным процессором или самой SDRAM-памятью. Если эта опция отключена ("Disabled"), то все циклы процессора к SDRAM завершаются командой "All Banks Precharge" в интерфейсе SDRAM-памяти, что улучшает стабильность, но понижает производительность памяти. Если же эта опция включена ("Enabled"), то предварительный заряд контролируется чипами памяти. Это уменьшает количество предзарядов SDRAM, значительно возрастает число циклов CPU-to-SDRAM до того момента, когда требуется регенерация памяти. Это однозначно ведет к повышению общей производительности системы, но может влиять на ее стабильность.


BIOS. Продолжение!

5. PCI

5.1. Арбитраж, Bus-Master

Bus Master (хозяин шины, задатчик) - возможный режим работы устройства на любой шине, в том числе и на PCI. Для работы в таком режиме устройство выдает запрос арбитру шины, сообщая о своем требовании на получение управления шиной. Арбитр, в соответствии с приоритетом и/или очередностью арбитража на данной шине, через определенное время после запроса отдает запрашивающему устройству управление шиной. Выполнив все необходимые ему операции, устройство сообщает арбитру об освобождении им шины.
На современных шинах, таких как PCI, для получения доступа к шине ВСЕ устройства проходят процедуру арбитража, в том числе и центральный процессор. Возможность быть "master"-устройством реализуется аппаратно при разработке устройства. Реализация механизма "BusMaster" позволяет общаться между собой только тем компонентам компьютера, которым это в данный момент необходимо. Этот механизм используется, например, для передачи данных TV-тюнером на видеокарту, если они обе находятся на PCI-шине, причем без участия центрального процессора, системной памяти и т.п.
Обычно, система управляет доступом к PCI-шине по фундаментальному принципу - "First-Come-First-Served" (первым пришел, первым обслуживается). Но возможности арбитража значительно шире и сложнее. Существуют и различные режимы действия самого механизма арбитража. Может быть установлен т.н. режим ротации устройств, при котором периодично меняется очередность устройств, т.е. их приоритет. Приоритет может оказаться фиксированным, т.е. какое-либо системное устройство "навсегда" получает наивысший приоритет. При "вращении приоритетов" (rotated) устройству, получившему контроль над шиной, присваивается самый низкий приоритет и любое другое устройство перемещается на шаг вверх в "очереди" приоритетов.
Как же все это реализуется? Арбитражем запросов на "захват" шины в составе чипсета занимается специальный узел, в который входит 8-разрядный ARBITRATION CONTROL REGISTER, позволяющий реализовать свойства, связанные с арбитражем на PCI-шине, а также с поддержкой спецификации шины PCI 2.1. (см. ниже). Каждое устройство-инициатор имеет пару сигналов - REQ# (Request - запрос на управление шиной) и GNT# (Grant - подтверждение предоставления управления шиной). Схема приоритетов (мы уже познакомились с фиксированным, циклическим, он же приоритет с ротацией, а есть еще и комбинированный) определяется программированием арбитра. Каждое "мастер"-устройство имеет собственный программируемый таймер MLT (Master Latency Timer), определяющий максимальное время, в тактах шины, для одной операции.

В современных системах механизмы арбитража, можно сказать, интеллектуализированы, что в итоге привело к постепенному изъятию из "BIOS Setup" функций, связанных с пользовательскими установками по арбитражу. "Старые" же версии BIOS вполне могут содержать некоторые из приведенных ниже опций, могущих вызвать душевный трепет у пользователя.

Arbitration Priority
- один из вариантов такой опции предложил достаточно "изощренный" вариант со значениями "PCI First" и "ISA/DMA First". Здесь возможности выбора зависят от применяемых устройств. "Master"-устройство может находиться и на ISA-шине и желать того же самого, а именно захвата шины. Для передачи данных оно может использовать и DMA-каналы. Тогда как бы конечным инициатором захвата выступает DMA-контроллер. Пользователю необходимо выбрать по сути шину, которая и будет иметь более высокий приоритет в случае конкуренции между "master"-устройствами.
Опция с тем же названием представила для отбора значения "CPU" и "PCI".

CPU Priority
- после вышеизложенного содержание этой опции может быть уже и не покажется странным. Пользователь должен установить, по сути, ранг центрального процессора в иерархии всех возможных "master"-устройств в системе. Если для остальных устройств, допустим, может выдерживаться "режим ротации", то для CPU его место всегда окажется фиксированным. Это место можно выбрать из ряда: "Always Last", "CPU 2nd", "CPU 3rd", "CPU 4th".
Опция с тем же названием была встречена и с обычными "Disabled" и "Enabled". Несложно предположить, что "Disabled" запрещает ротацию приоритета для центрального процессора, а "Enabled" ее разрешает.

DMA/ISA Master Before PCI
- опция предлагает стандартные значения - "Enabled" и "Disabled". В данном случае "Disabled" равносильно "PCI First".

Master Priority Rotation
- (ротация приоритетов "master"-устройств). Аппаратная реализация данной функции позволяет контролировать доступ центрального процессора к PCI-шине. Начнем с предлагаемых значений опции: "1 PCI", "2 PCI", "3 PCI".
"1 PCI" - процессор гарантированно всегда будет иметь доступ к PCI-шине после того, как текущее (т.е. находящееся в работе) "master"-устройство завершит полностью свои транзакции. Причем этот доступ будет получен независимо от числа других "master"-устройств на шине PCI, ожидающих своей очереди. Такой режим обеспечивает быстрый доступ процессора к PCI-шине, но ведет к замедлению работы других устройств на PCI-шине.
"2 PCI" - процессор гарантированно получит доступ к PCI-шине, но только после того, как полностью завершатся текущая и следующая PCI-транзакции. Причем этот доступ опять таки будет получен независимо от числа оставшихся в очереди других "master"-устройств на PCI-шине. Такой режим "понижает в ранге" центральный процессор, но обеспечивает более быстрый доступ уже для устройств на PCI-шине.
"3 PCI" - процессор получит доступ к PCI-шине уже после того, как будут закончены текущая и две последующих PCI-транзакции. Но необходимо понимать ситуацию таким образом, что речь может идти не о трех "master"-устройствах. Может возникнуть потребность у одного из устройств снова выставить запрос на захват шины сразу же после окончания собственных циклов, и это устройство может встать в очередь третьим, а то и за самим собой. Для PCI-устройств такой режим наиболее привлекательный. Но тем не менее процессор получит доступ к локальной шине после завершения трех циклов, опять таки несмотря на возросшую очередь.

PCI Bus Arbitration
Параметр может принимать уже понятные значения:
"Rotating",
"Fixed".
Опция с абсолютно таким же названием встретилась и с параметрами: "Favor CPU" и "Favor PCI". Пользователю остается определить своего фаворита. Если речь идет о потоковом видео, то желательно указать PCI-устройство. Выбор центрального процессора во многих случаях может оказаться более безопасным.
Такие же значения предложила опция "PCI Masters' Priority".

Рассмотренные выше варианты выбора параметров могут быть предложены и в функциях "Master Arbitration Protocol", "PCI Arbitration Mode", "PCI Arbit. Rotate Priority".
При этом, правда, могут возникнуть и другие сложности. Рассмотрим опцию

PCI Arbiter Mode
- данная опция предложила параметры "Mode 1" и "Mode 2". Поскольку идея арбитража заключается и в минимизации времени, требуемого для получения устройством контроля над шиной и передачи данных, то возникает вопрос, в каком из вариантов устройство на той же PCI-шине быстрее получит доступ к ней. В случае "Favor PCI" или с выбором "Favor CPU"? Естественно, что первый вариант более оптимален. В данном случае этому режиму соответствует "Mode 1", устанавливаемый по умолчанию. При возникновении каких-либо проблем в системе необходимо выбрать режим "Mode 2", как более безопасный.

Напоследок опция от "Phoenix BIOS":
Arbiter Priority on HB1
- ее значения: "CPU" и "Slot 6 to Slot 9". "HB" в названии опции означает "Host Bridge". Выбор "CPU" определял процессору наивысший приоритет, а второе значение определяло уровень приоритета для выбранного PCI-слота, начиная с 6-го слота, имевшего наивысший приоритет. Таким образом, пользователь имел возможность при установке карт расширения сконфигурировать имеющиеся "master"-устройства на PCI-шине наиболее оптимальным способом. Правда, это требовало абсолютно полного представления о потребностях имеющихся комплектующих. Столь необычные номера слотов - это системные номера слотов с точки зрения "Phoenix BIOS".

Теория приоритетов рассмотрена. Остановимся на других проблемах "master"-устройств.

Bus Mastering
- эта опция предназначалась еще не так давно для разрешения или запрещения работы устройств в режиме "Bus-Master" на шине ISA. Параметр может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

CPU Mstr DEVSEL# Time-out
- когда процессор в качестве "master"-устройства инициирует управляющий цикл, используя адрес (целевое устройство), не сопоставленный с PCI/VESA- или ISA-пространством, система в течение определенного времени будет контролировать выдачу специального сигнала подключенности устройства (DEVSEL - Device Select), свидетельствующего об инициировании цикла. Рассматриваемая опция определяет, как долго система будет ожидать данный сигнал (в тактах шины PCI). Может принимать значения: "3 PCICLK", "4 PCICLK", "5 PCICLK" и "6 PCICLK" (по умолчанию).
Чем меньше установленное значение, тем выше производительность системы. Но к уменьшению устанавливаемого параметра необходимо подходить осторожно - из-за возможности появления сбоев в системе.

CPU Mstr Fast Interface
- опция включения/отключения скоростного "back-to-back" интерфейса при участии центрального процессора в роли "master"-устройства. "Enabled" устанавливается по умолчанию.

CPU Mstr Post-WR Buffer
- содержание этой опции заключено, казалось бы, во включении буфера отложенной записи. Правильно. Только включение это достигается путем указания количества таких буферов, присутствует и возможность отказа от буферирования. Поэтому имеем такой ряд значений: "NA", "1", "2", "4" (по умолчанию).

CPU Mstr Post-WR Burst Mode
- данная опция позволяет включить высокоскоростной пакетный режим для информации, находящейся в буфере (буферах) отложенной записи. Стоит напомнить, что при пакетной передаче информации для блока данных указывается один адрес. При отказе от пакетирования (т.е. при стандартных операциях чтения/записи) каждому слову данных предшествует адресная информация. Содержание нескольких приведенных опций в общем-то уже знакомо читателю. Но в них подчеркивается роль центрального процессора, как "master"-устройства.

Enable Master
- установка в "Enabled" позволяет системе придать выбранному устройству статус "master"-устройства на PCI-шине, а также проверить, способно ли это устройство контролировать шину.

Master Prefetch And Posting
- данная опция допускает одновременное включение режима предвыборки и использование буфера отложенной записи для любого "master"-устройства.

Master Retry Timer
- этой опцией устанавливается, как долго центральный процессор, будучи задатчиком PCI-циклов, сможет сохранить свой статус до передачи управления другому "master"-устройству. Возможные параметры измеряются в тактах PCI-шины (PCICLKs). Вот этот ряд: 10 (по умолчанию), 18, 34 или 66.

PCI Bus Parking
- опция включения/выключения режима "парковки" устройств на PCI-шине. Режим "парковки" - одна из разновидностей режима "Bus-Master". Когда этот режим включен ("Enabled"), "запаркованные" на PCI-шине устройства будут иметь полный контроль над шиной в течение некоторого небольшого промежутка времени. Это повышает производительность данного устройства, однако приостанавливает работу остальных. Данный режим неплохо работает с контроллерами жестких дисков.

PCI Master 0 WS Write
- если опция установлена в "Enabled", в системе устанавливается нулевое время ожидания перед любыми циклами записи в PCI-шину, то есть PCI-шина получает данные, как только она готова их принять. Понятно, что такой режим наиболее оптимален для работы "master"-устройств на PCI-шине. Значение "Disabled" устанавливается по умолчанию, при этом автоматически вставляется один такт ожидания. Последнее значение несколько снижает производительность, но, как обычно, повышает стабильность системы. Оно может оказать существенную пользу и при "разгоне" шины PCI, результатом которого может быть нестабильность ее работы.

PCI Master Access to ISA
- само название опции "расшифровывает" ее содержание. Включение опции ("Enabled") дает возможность "master"-устройству на PCI-шине взять на себя управление обменом информацией с ISA-шиной.

PCI master accesses shadow RAM
- опция включения/выключения возможности копирования ПЗУ "master"-устройства на PCI-шине в более быструю оперативную память для повышения быстродействия этого устройства. При этом, конечно, задействуются и другие опции "BIOS Setup" (см. "Затенение памяти"). Но чтобы некое "master"-устройство могло получить такой доступ, данной опции, да и других, явно недостаточно. Такой режим закладывается в процессе создания конкретного приложения, что как раз и находит применение при проектировании специализированных карт расширения. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

PCI Master Read Ping-Pong
PCI Master Write Ping-Pong
- несколько ранее под термином "ping-ponging" подразумевалось переключение страниц экранной памяти. Для данных опций значения параметров одинаковы: "Disabled", "Enabled". Но смысл их функционирования пока не совсем ясен!

PCI Master Read Prefetch
- опция, позволяющая (через "Enabled") включать режим предвыборки для "master"-устройств на PCI-шине. Чтобы вспомнить о функционировании режимов предвыборки, имеет смысл заглянуть повторно в раздел "CPU". Но в нескольких словах! Когда режим предвыборки включен, "master"-устройство на PCI-шине инициирует следующую инструкцию чтения еще до завершения текущей операции чтения. В этом процессе участвует и контроллер интерфейса.

PCI Mstr Burst Mode
- данная опция позволяет включить высокоскоростной пакетный режим для информации, находящейся во внутренних буферах отложенной записи PCI-шины, доступ к которой имеет "master"-устройство.
Сюда же добавим и близкую по смыслу опцию "PCI Master Burst Read".

PCI Mstr DEVSEL# Time-out
- опция, аналогичная "CPU Mstr DEVSEL# Time-out", только в качестве "master"-устройства выступает PCI-устройство. Ряд значений тот же, только по умолчанию устанавливается "4 PCICLK".

PCI Mstr Fast Interface
- аналогичная опция ("CPU Mstr Fast Interface"), только в качестве "master"-устройства выступает устройство на PCI-шине.

PCI Mstr Post-WR Buffer
- опция, абсолютно аналогичная "CPU Mstr Post-WR Buffer", только в качестве "master"-устройства выступает PCI-устройство.

Preempt PCI Master Option
- когда опция включена ("Enabled"), операции чтения/записи на PCI-шине, даже в том случае, когда шиной владеет "master"- устройство, могут быть прерваны некоторыми системными операциями, например, такими, как регенерация памяти. В противном случае может вестись "незапланированная" параллельная работа различных системных компонент, что может привести к сбоям системы, в лучшем случае - к потере информации.

Shared PCI Master Assignment
- данная опция затрагивает тему интегрированности графического адаптера на системной плате. Вроде бы знакомая ситуация - надо указать, какой видеоадаптер используется, но... Значения опции следующие:
"VGA" - интегрированный адаптер может использоваться как "PCI bus master",
"Slot #1" - видеокарта установлена в первый слот PCI-шины и может функционировать в качестве "master"-устройства.

State Machines
- чипсет может иметь четыре состояния, точнее даже сказать, путем управления состоянием своих регистров чипсет может иметь четыре режима управления специфическими CPU- и/или PCI-операциями. Каждая из таких операций, а фактически - режим работы, представляет собой высокооптимизированный процесс, включающий в себя работу "master"-устройства и управляемой им шины. Четыре состояния системы следующие:
"CC" ("CPU master to CPU bus"),
"CP" ("CPU master to PCI bus"),
"PP" ("PCI master to PCI bus"),
"PC" ("PCI master to CPU bus").
Каждый вид операции имеет следующие установки, задействованные с помощью других функций "BIOS Setup":
"Address 0 WS" - устанавливается время задержки системы для успешного декодирования выставленного процессором/устройством адреса. "Enabled" - нет задержки;
"Data Write 0 WS" - аналогично для записи данных по целевому адресу. "Enabled" - нет задержки;
"Data Read 0 WS" - аналогично для чтения данных из целевого адреса. "Enabled" - нет задержки.

Stop CPU at PCI Master
- когда опция включена ("Enabled"), работа центрального процессора может быть приостановлена в момент инициирования PCI- устройством захвата шины. Установка в "Disabled" (по умолчанию) не позволяет прерывать работу CPU как задатчика шины.

5.2. Все о PCI-шине

PCI (Peripheral Component Interconnect) - 32-разрядная шина, поддерживающая до десяти внешних устройств, предусматривает передачу данных с тактовой частотой 33 МГц и обеспечивает максимальную пропускную способность, равную 132 Мб/с (32 бит x 33 МГц).
Стандарт PCI-шины предусматривает две дополнительные версии:
а) удвоенная тактовая частота (66 МГц);
б) 64-разрядная передача данных.
Впервые стандарт PCI был предложен "Intel" в декабре 1991 г. Первая спецификация была представлена в июне 1992 г. Тогда же спецификация PCI была принята как открытый индустриальный стандарт, а в ее разработке участвовали также "IBM", "Compaq", "DEC" и "NCR". В апреле 1993 г. была предложена версия 2.0. Спецификация шины PCI 2.1 вступила в силу в августе 95 г. В новую спецификацию 2.2 добавлены многочисленные функции управления энергопотреблением, "горячего" подключения периферийных устройств, поддержка 64-разрядности и частоты 66 МГц, т.п.
Спецификация PCI-X была разработана и предложена компаниями "Compaq", "Hewlett-Packard", "IBM". Пропускная способность интерфейса увеличивается до 1066 МБ/с. Стандарт обеспечивает частичную обратную совместимость новой шины с обычными адаптерами PCI, а также новых адаптеров с предыдущими реализациями шины. Версия стандарта PCI-X 1.0 была одобрена осенью 1999 г.
Стандарт PCI предусматривал конфигурирование устройств, подключаемых к системе, программным способом, что соответствовало концепции "Plug-and-Play". Шина PCI не поддерживает стандартных сервисов DMA и IRQ. У шины PCI имеются т.н. Distributed DMA и Scrialized IRQ. Это сервисы шины PCI, назначение которых обеспечить совместимость с режимами работы шины ISA.
Несколько подробнее о PC/PCI и DDMA.
Это аппаратные протоколы для обеспечения совместимости PCI-карт с традиционным способом прямого доступа к памяти (DMA). В стандартной реализации контроллера DMA он не может обслуживать устройства шины PCI, потому что в каждом устройстве уже реализован механизм режима "BusMaster". Протоколы PC/PCI и DDMA разработаны для совмещения контроллера DMA с PCI-устройствами; в первую очередь это сделано для разработки звуковых PCI-карт, совместимых с "Sound Blaster" и "Windows Sound System".
Протокол PC/PCI основан на выборочном переназначении на шину PCI сигналов запроса/выдачи данных, выведенных от каналов контроллера DMA на шину ISA, что позволяет PCI-устройству обмениваться с памятью под управлением основного контроллера DMA.
Протокол DDMA (Distributed DMA - распределенный DMA) основан на выборочной передаче обращений к регистрам каналов контроллера DMA на шину PCI, где эти регистры эмулируются PCI-устройствами с поддержкой DDMA. Сам обмен с памятью в этом случае выполняется в режиме "BusMaster", стандартном для PCI-устройств. Тема же стандартного DMA рассмотрена далее в отдельном подразделе.
Если речь идет о распространенных чипсетах, то протоколы PC/PCI и DDMA были реализованы еще в Intel 430TX, ALI Aladdin IV+, Aladdin V.
Возможностей PCI-шины с лихвой хватает для решения самых сложных задач, за исключением потребностей современных графических, презентационных и особенно игровых программ, зачастую требующих пропускную способность, превышающую возможности PCI-шины. Эти проблемы позволяет решать ускоренный графический интерфейс (AGP).

PCI 2.1 Support
- (поддержка спецификации шины PCI 2.1). При разрешении этого параметра поддерживаются возможности спецификации 2.1 шины PCI. Спецификация 2.1 имеет два основных отличия от спецификации 2.0: максимальная тактовая частота шины увеличена до 66 МГц и вводится механизм моста PCI-PCI, позволяющий снять ограничение спецификации 2.0, согласно которой допускается установка не более 4-х устройств на шине. К тому же внедрение спецификации 2.1 позволило оптимизировать совместное сосуществование PCI- и ISA-шин (подробнее в опции "Delayed Transaction"). Запрещение этого параметра имеет смысл только при возникновении проблем после установки дополнительной PCI-платы (как правило, проблемы могут возникнуть только с достаточно старыми PCI-устройствами), а также с ISA-устройствами, никак не желающими буферирования своей информации, а значит также не поддерживающими эту спецификацию. Параметр может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может называться "PCI 2.1 Compliance".

PCI Clock Frequency
- опция для установки частоты шины PCI. В приведенном виде такая опция была внедрена на первых "пентиумных" машинах, а затем перенесена на 486-е системы с процессорами AMD и PCI-шиной. Частота шины через множитель "привязывалась" к частоте центрального процессора и имела следующий ряд значений: "CPUCLK/1.5" (по умолчанию), "CPUCLK/2", "CPUCLK/3" и фиксированные "14 Mhz" (было и так!).
Опция "PCI Clock Speed" предлагала следующие значения: "Same as CPU", "2/3 CPU", "CPU/2", "1/8 CPU". Опция "HCLK PCICLK" представляла собой делитель между системной частотой и частотой локальной шины: "1-1", "1-1.5", "AUTO". Опция "PCI Bus Frequency" предлагала значения "CPUExt/3", "CPUExt/2.5", "CPUExt/2", и они связывали частоту PCI-шины с системной. Опция "CPU Host/PCI Clock" лишь через значение "Default" позволяла для PCI-шины получить стандартные 33 МГц.
Предварительная картина была бы неполной без двух совместных опций. Опция "PCI Clock Speed Override" через значение "Enabled" вообще давала разрешение на "переопределение" частоты PCI-шины, а вот опция "PCI CLK" могла бы удивить и искушенного пользователя. Значение "Asynchronous" позволяло выбрать для PCI-шины произвольную частоту. А вот значение "Synchronise" "жестко" связывало тактовую частоту системной шины и частоту PCI-шины. Только предварительно с помощью джамперов на системной плате необходимо было установить системную частоту и множитель для процессора и в итоге получить, например, для Pentium 120 частоты: 120, 60 и 30 МГц (PCI-шина).
Значительно более современный вариант - это опция "PCI/AGP Clock". Это означает, что данной опцией устанавливаются частоты для двух шин, хотя еще не так давно различные версии BIOS не предоставляли таких возможностей. Приведенный вариант опции в большей степени предназначен для "разгона" устройств на PCI-шине (весьма опасного) и для AGP. Значения опции, т.е. частоты шин, напрямую связаны с установками частоты системной шины в опции "CPU Host Clock". Если последняя превышает или равна 100 МГц, то для PCI и AGP устанавливаются значения, соответственно равные "CPU Host Clock"/3 и /1.5. Для более низкой частоты шины процессора деление производится на 2 и 1. Поэтому, если системная частота равна 66 МГц, то для PCI и AGP получаем стандартное соотношение 33/66 МГц. Тот же, т.е. стандартный, вариант имеет место при частоте в 100 МГц. Все остальные значения частоты системной шины ведут к "разгону" обоих интерфейсов.
Современные системы с опциями типа "System/PCI Frequency (MHz)" предоставляют широчайшие возможности для "разгона", а именно не набор из нескольких значений, а солидное меню с целым рядом параметров, начиная со значения "100/33" (делитель 3:1) и заканчивая значением "178/44.51" (делитель 4:1) и с шагом для системной шины в 1 МГц. Все это было бы замечательно, если бы не присутствовал элемент риска. Практически все производители системных плат "успешно" стали решать задачи "разгона" PCI- и AGP-интерфейсов, отодвинув на последний план возможность ускорения системной шины и процессора без "втягивания" в этот "разгон" остальных системных компонентов. Первой "ласточкой" в этом "разогнанном" мире была системная плата от "Gigabyte" - GA8IRXP, предложившая дополнительные отдельные делители для каждой из шин и тем самым давшая возможность по сути устанавливать оптимальные частоты интерфейсов PCI и AGP независимо от "разогнанного" системного.

PCI Dynamic Decoding
- установка в "Enabled" позволяет системе запоминать PCI-команду, которая только что была запрошена. Если последующие команды совпадают с некоторой адресной областью, циклы записи будут автоматически интерпретироваться как PCI-команды.

PCI Latency Timer (PCI Clocks)
- (таймер времени ожидания для шины PCI). Значение этой опции указывает, в течение какого времени (в тактах PCI-шины) поддерживающая режим "Busmaster" PCI-карта может сохранять контроль над PCI-шиной, если к шине обращается другая PCI-карта. Фактически это и есть таймер, ограничивающий время занятия PCI-шины устройством-задатчиком шины. По истечении заданного времени арбитр шины принудительно отбирает шину у задатчика, передавая ее другому устройству. Допустимый диапазон изменения этого параметра - от 16 до 128 с шагом, кратным 8. Правда, в некоторых случаях добавляется еще значение "Auto Configured" (по умолчанию), что значительно облегчает сомнения и мучения пользователя.
Значение параметра необходимо изменять осторожно, так как оно зависит от конкретной реализации материнской платы, и только в случае, если в системе установлены по меньшей мере две PCI-карты, поддерживающие режим "Busmaster", например, SCSI- и сетевая карты. Графические PCI-карты не поддерживают режим "Busmaster", скорее, не поддерживали. Чем меньше устанавливаемое значение, тем быстрее другая PCI-карта, требующая доступа, получит доступ к шине. Если требуется выделить для работы, например, SCSI-карты больше времени, то можно увеличить значение для PCI-слота, в котором она находится. Значение для сетевой карты, например, соответственно необходимо уменьшить или вообще установить равным 0, хотя в некоторых случаях установка 0 не рекомендуется. В общем случае, какое значение параметра пригодно и оптимально для данной системы, зависит от применяемых PCI-карт и проверяется с помощью тестовых программ и опытной эксплуатации. Необходимо также учитывать, в какой степени "карты-конкуренты" чувствительны к возможным задержкам. Учитывая вышесказанное, вспомним о существовании еще одного "master"-устройства, а именно - центрального процессора. Так что слишком заниженное значение времени ожидания может сказаться на эффективности управления процессором локальной шины.
Опция также может носить названия: "PCI Bus Time-out", "PCI Master Latency", "Latency Timer", "PCI Clocks", "PCI Initial Latency Timer". Для последней опции ряд возможных значений имел вид: "Disabled", "16 Clocks", "24 Clocks", "32 Clocks". Еще одна старенькая опция, "PCI Bus Release Timer", имела такой набор значений: "4 CLKs", "8 CLKs", "16 CLKs", "32 CLKs".
И еще одно очень важное замечание. В свое время эта опция (и ей подобные) вводились с учетом совместного существования PCI- и ISA-шин. ISA-шина позволяла использовать одно "master"-устройство. Это применялось редко, как раньше, так и в последние годы существования ISA-шины. Зато PCI-шина дала возможность одновременного использования нескольких "master"-устройств. Учитывая различия в скорости шин, а тем более в их пропускной способности, необходимо было решить проблему совместной работы "master"-устройств на PCI-шине и стандартных устройств на более медленной ISA-шине. Особенно это касалось распространенных в то время звуковых и сетевых карт для ISA-шины, обладавших незначительным объемом буферной памяти, т.е. чувствительных к любым задержкам при передаче данных.
"AMI BIOS" позволял выбрать значение параметра в диапазоне от 0 до 255 тактов с единичным шагом. Значение "66" устанавливалось по умолчанию, хотя меньшее значение владения шиной PCI-устройством оказывалось более предпочтительным. Более свежие версии "AMI BIOS" стали менее демократичны: 32, 64, 96, 128, 160, 192, 224, 248 и "Disabled". К тому же "мелькнуло" еще одно название опции - "Master Latency Timer (Clks)", а по умолчанию стало устанавливаться значение "64".
Правда, это еще не весь возможный перечень. Функции "Latency Timer Value" и "Default Latency Timer Value" применяются совместно. Если в последней опции установить "Yes" (оно же и по умолчанию), то тогда первая функция будет проигнорирована. Чуть выше уже зашла речь о возможности установки параметров для отдельных слотов. Вот как реализует такую возможность "Phoenix BIOS":
"PCI Device, Slot #n",
"Default Latency Timer: [Yes]",
"Latency Timer: [0040]",
Естественно, что для работы с этими параметрами выводится отдельное конфигурационное подменю. Для n-го слота пользователь может выбрать установку по умолчанию ("Yes"), тогда в нижнем поле будет выведено значение в 16-ричной форме. При этом доступ пользователя к полю "Latency Timer:" будет заблокирован. Если же в опции "Default Latency Timer:" установить "No", то появится возможность вручную установить значение из ряда: 0000h .... 0280h. Последнее значение соответствует десятичному 640. По умолчанию устанавливается 0040h (64 такта).
Еще один вариант значений опции "Latency Timer": "20h", "40h", "60h", "80h", "A0h", "C0h", "E0h", "Default" (т.е. "40h").
Поэтому при конкретном решении стоящей перед пользователем задачи (или проблемы) надо исходить прежде всего из возможностей чипсета, версии BIOS и используемых карт расширения.

PCI Parity Check
- некоторые мощные чипсеты, прежде всего серверных систем, предоставляют возможность (через "Enabled") контролировать поток данных на шине PCI по четности. При этом контролируются как адресные данные, так и собственно данные. Ошибки при этом не исправляются, но пользователь о них информируется. Что также важно, такой метод контроля должна поддерживать и сама PCI-карта расширения.
Опция может называться и "PCI Parity Checking", или "PCI Bus Parity Checking".

PCI Preempt Timer
- (таймер времени вытеснения для шины PCI). На первый взгляд по смыслу эта функция аналогична функции "PCI Latency Timer", возможна даже некоторая путаница, хотя в данном случае кое-что наоборот. Значение этой опции указывает, в течение какого времени (в тактах PCI-шины, или локальных тактах - LCLKs) поддерживающая режим "Busmaster" PCI-карта сможет не контролировать шину, а находиться в состоянии ожидания пока этой шиной владеет другая карта. Арбитр шины отслеживает указанный временной интервал с момента подачи запроса, после чего ожидающее "master"-устройство вытесняет своего "товарища".
Для выбора предагаются значения из ряда: 5, 12, 20, 36, 68, 132, 260, в цифровом виде или с отображением единицы измерения - "5 LCLKs" и т.д. Обязательным является параметр "No Preemption" (или "Disabled"). Причем последний, как правило, устанавливается по умолчанию. Эта опция в таком виде уже не применяется, так что встреча с ней на старых машинах может вызвать некоторые трудности. Во всяком случае при наличии хотя бы двух "master"-устройств на PCI-шине значение "Disabled" (или аналогичное) должно быть заменено на более оптимальное.
Опция может называться и "PCI Preemption Timer".

Peer Concurrency
- (параллельная работа или, дословно, - равноправная конкуренция). Этот параметр разрешает/запрещает одновременную работу нескольких устройств на PCI-шине. При включении опции включается дополнительное буферирование циклов чтения/записи в чипсете. Но могут возникнуть проблемы, если не все PCI-карты готовы поддерживать такой режим работы. В этом случае работоспособность системы проверяется опытным путем.
Действие этой опции затрагивает и совместную работу PCI- и ISA-шин. Например, шинные PCI-циклы могут перераспределяться и буферизироваться во время ISA-операций, таких как передача по DMA-каналам в режиме "Bus-Master". Параметр может принимать значения:
"Enabled" (по умолчанию) - разрешено,
"Disabled" - запрещено.
Опция может называться и "PCI Concurrency" или "Bus Concurrency". Дополнительные устройства, "жаждущие конкуренции", появляются в опциях "PCI/IDE Concurrency" или "PCI-to-IDE Concurrency".
Одной из характерных особенностей PCI-шины и ее системы мостов является возможность выполнения обмена данными между процессором и памятью одновременно с обменами между другими абонентами шины PCI - Concurrent PCI Transferring. Однако эта возможность реализуется не всеми чипсетами, а обычными абонентами шины (графические карты, контроллеры дисков, т.п.) используется редко.
PERR#
SERR#
- "AMI BIOS" через обычные "Enabled" (разрешено, включено) и "Disabled" (запрещено, отключено) предлагает пользователю "поработать" с интерфейсными сигналами PCI-шины: PERR# и SERR#. Этим сигналам, для справки, соответствуют контакты шины - B40 и B42 соответственно. Несколько слов о самих сигналах.
"PERR#" - I/O PCI Parity Error. Сигнал выставляется приемником данных на шине через один шинный такт после выдачи сигнала PAR (Parity Error - контакт A43). Сигнал PERR# становится активным, если определена ошибка по четности на PCI-шине. При этом в PCICMD-регистре по сигналу PERR# устанавливается бит "Enable". Данной опцией как раз можно запретить установку сигнала об ошибке ("Disabled" устанавливается по умолчанию).
"SERR#" - I/O PCI System Error. В итоге также в PCICMD-регистре устанавливается бит "SERRE" (SERR# Enable). Это интегрированный сигнал, для выставления которого требуется выполнение одного из условий:
1. Выставляется сигнал PERR# на PCI-шине, что контроллируется битом 3 ERRCMD-регистра,
2. Сигнал SERR# будет выставлен через один шинный такт после определения нарушения передачи данных в процессе инициированных PCI-циклов,
3. Сигнал SERR# будет выставлен при ECC-операциях. ECC-ошибка сигнализируется через ERRCMD-регистр управления при корректируемой однобитной ошибке или множественной некорректируемой,
4. Сигнал SERR# будет выставлен, когда ошибка по четности на PCI-шине определена во время передачи адресных данных с одновременной установкой некоторых сигналов ошибки в других регистрах,
5. Могут быть дополнительные ситуации, например, выставление входного сигнала ошибки G-SERR# в бите 5 ERRCMD-регистра.

6. ISA

ISA Bus Clock
- опция установки тактовой частоты ISA-шины. Стандартное значение скорости ISA-шины составляет около 8,33 МГц. В отличие от устаревших систем, ныне скорость ISA-шины напрямую связана со скоростью PCI-шины через т.н. "южный" мост. Можно установить более высокую скорость шины, выбрав соответствующий параметр (делитель). Этот параметр делит действительную скорость PCI-шины и тем самым задает скорость ISA-шины.
Например, тактовая частота PCI-шины составляет 33 МГц. Если изменить делитель с PCICLK/4 на PCICLK/3, то ISA-шина будет работать с частотой 11 МГц. Но необходимо помнить, что повышение тактовой частоты может привести к перегреву элементов ISA-карты и выходу ее из строя. В лучшем случае может возрасти риск ошибок при работе, особенно это опасно для контроллеров дисков (в случае устаревших систем). И хотя многие ISA-устройства работают на более высоких скоростях, необходимо снизить скорость шины, если какое-либо ISA-устройство функционирует неверно.
Из вышесказанного следует, что для правильной установки тактовой частоты ISA-шины необходимо знать тактовую частоту PCI-шины. В данном случае речь идет о том, что в первых системах с использованием PCI-шины частота самой PCI-шины зависила от системной тактовой частоты и поэтому имела ряд значений: 25, 30 и 33 МГц, т.п. В более "старых" системах частота ISA-шины была "привязана" к системной частоте, которая колебалась от 16 до 50 МГц, тем самым давая простор и для ISA-шины
Опция в разное время носила и разные названия: "ISA Clock", "ISA Clock Frequency", "ISA Bus Clock Frequency", "ISA Bus Clock Option", "ISA Bus Speed", "ISA Clock Select", "ISA Clock Divisor", "AT BUS Clock", "AT Bus Clock Frequency", "AT BUS Clock Selection", "AT Bus Clock Source".. Наличие в названиях опций сочетания "AT Bus" свидетельствует о "старости" опций. Стоит напомнить, что 8.33 МГц - это "стаpая" тактовая частота шины IBM AT.
Ну и, наконец, ряд возможных параметров для выбора: PCI (или PCICLK, или CLK {для системной шины}) / 2, 3, 4, 5, 6, 8, 10, и даже 12, а также фиксированное значение - "7.159 MHz" (оно может устанавливаться и по умолчанию). Опять необходимо дополнительно отметить, что некотоpые системные интерфейсные ISA-платы разрабатывались для такой фиксированной частоты. Для систем с 286-ми и 386-ми процессорами CLK могло означать половину скорости ядра CPU. Тогда в установках скорости ISA-шины параметр обозначался как CLK2/x.
Еще одно замечание. Необходимо не забывать о скорости ISA-шины при разгоне процессоров, если разгон строится от тактовой частоты системной шины.
Несколько другое содержание заключено в опции "ISA Clock Select Enable". Установив опцию в "Disabled", мы получаем стандартную частоту ISA-шины (PCI/4), выбрав же "Enabled", получаем возможность поварьировать частотой шины вручную.
И еще одна опция напоследок - "PCI-ISA BCLK Divider" (BCLK - Bus CLK). И значения: "AUTO", "PCICLK1/2", "PCICLK1/3", "PCICLK1/4".

ISA Slave Wait States
- опция установки тактов ожидания для ISA-устройства, не работающего в режиме задатчика шины, т.е. "мастер"-устройства. Возможные значения: "4 WS", "5 WS". Подобная опция могла называться и "ISA Wait States" со значениями "5 ISACLKs" и "4 ISACLKs", что говорит конкретно о тактах ожидания в частотах ISA-шины.


BIOS. Продолжение!

7. Peripherals & Resources

7.1. Функции "подключенности" периферийных устройств

AGP
- смысл этой опции интуитивно понятен, а возможных параметров всего два: "Enabled" (разрешено) и "Disabled" (запрещено).

Init AGP Display First
- при установке в "Enabled" первичным в системе становится дисплей, подключенный к AGP-карте. Если выбрано значение "Disabled", то тон будет задавать PCI-карта или даже ISA.
Аналогично функционирует и опция "Init Display First" с параметрами "AGP" и "PCI" ("PCI Slot"). При наличии в системе одного видеоадаптера эти опции не вызывают проблем. При установке же двух видеоадаптеров, поддерживаемых на уровне операционной системы, необходимо выбрать не только наиболее производительный, но и, что вполне реально, единственный вариант подключения двух дисплеев. Речь идет о ситуациях, когда PCI-адаптер не сможет работать вторым.
Опять таки аналогично функционирует опция "VGA BIOS Sequence" (последовательность загрузки BIOS видеокарт) с параметрами "PCI/AGP" и "AGP/PCI".
Такие же значения ("AGP" и "PCI") предлагает опция "Default Primary Video" из "AMI BIOS".
С опцией "Primary Display" мы уже встречались в разделе "Boot". В данном случае эта опция "Phoenix BIOS" о другом. Вот ее возможные значения: "AGP VGA" (последовательность загрузки - ISA VGA, AGP VGA, PCI VGA) и "PCI VGA" (последовательность загрузки - ISA VGA, PCI VGA, AGP VGA).
Несколько иной вариант выбора предлагает опция "Init Display First" в случае интегрирования видеоадаптера на материнскую плату. Значения могут такие: "Onboard" и "PCI Slot".
Напоследок более "древний" вариант аналогичной функции под названием "Graphics Adaptor" с параметрами "VL Bus" и "PCI Bus".

Joystick Function
- при наличии в системе джойстика и ...приведенной опции необходимо установить ее в "Enabled".

LAN Controller
- опция для управления разрешением/запрещением ("Enabled"/"Disabled") работы установленного на материнской плате сетевого адаптера. Некоторые системы со встроенным сетевым контроллером, даже при установленном значении "Disabled", при загрузке системы, определяя его наличие, автоматически переводят опцию во включенное состояние.

Multiple Monitor Support
- опция поддержки нескольких мониторов. Ничего сверхестественного в этой функции нет. Она даже подобна опции "Default Primary Video", но... Данная опция устанавливает, какой графический контроллер в системе будет первичным. Может принимать значения:
"Motherboard Primary" - активным становится графический контроллер, интегрированный в центральный процессор,
"Motherboard Disabled" - активным становится графический контроллер, интегрированный в чипсет,
"Adapter Primary" - активным становится графический контроллер платы расширения.

Onboard FDC Controller
- опция, определяющая использование ("Enabled" - по умолчанию) или отключение контроллера флоппи-дисководов, размещенного на материнской плате, т.е. встроенного (onboard).
"Phoenix BIOS" содержит подобные опции ("Diskette Controller", "Floppy Disk Controller") с теми же значениями - "Enabled"/"Disabled".
Но на этом возможные названия функции с подключением флоппи-дисковода не исчерпываются. Есть еще "AMI BIOS", да и "Award" может преподнести. Тогда имеем следующее:
"Onboard FDD Controller", "Onboard FDC", "Floppy Interface". Последние две вариации, кроме обычных "вкл./откл." имеют еще дополнение в качестве автоконфигурирования ("Auto"). Стоит сразу упомянуть, что при запрещении использования флоппи-контроллера оказывается свободным IRQ6.
"Phoenix BIOS" в своей другой вариации "Floppy Interface" предложил значения "Auto Configured" и "Disabled". Параллельно другая опция, "Floppy Status", давала возможность вывести на экран монитора состояние дисковода в процессе загрузки системы.

Onboard Parallel Port
- данная опция позволяет запретить ("Disabled") использование встроенного параллельного порта, автоматизировать процесс выделения требуемыех ресурсов ("Auto") или установить базовые адреса ввода/вывода вручную ("378" или "278").
Опция может называться "Parallel Port", значения которой могут быть следующие:
"Disabled",
"Enabled" - при этом для пользователя становятся доступными дополнительные поля с ручной установкой конфигурационных параметров,
"Auto" - адреса, прерывания, каналы DMA будут установлены автоматически,
"OS Controlled" - все проблемы должна разрешить операционная система. В других версиях BIOS аналогичная опция может называться "PnP OS".
Опция может называться и "Parallel". Опция "Parallel Port Interface" в виде небольшого меню предложила такой ряд параметров:
"Disabled",
"LPT1... 378... IRQ7" - это значение будет выбрано и при автоконфигурировании,
"LPT1... 378... IRQ5",
"LPT2... 278... IRQ7",
"LPT2... 278... IRQ5",
"LPT3... 3BC... IRQ7",
"LPT3... 3BC... IRQ5",
"Auto Configured" (по умолчанию).
Последняя опция уже несколько "устарела". Еще более "раритетным" является небольшое меню из следующих опций:
"On-Board LPT 3",
"On-Board LPT 2",
"On-Board LPT 1"
со стандартными значениями "Disabled" и "Enabled". Ранее считалось, что система автоматически присваивает имена от LPT1 до LPT3 любым обнаруженным параллельным портам (так оно есть и сейчас, и пользователь может и не знать, какие "потаенные" процессы происходят при этом, но включать одновременную поддержку трех портов...). Назначение же остальных ресурсов - "дело рук" PnP-совместимой ОС и пользователя.

Onboard PCI IDE Enable
- (разрешение работы интегрированного контроллера IDE). Этот параметр управляет разрешением/запрещением работы каждого из двух каналов контроллера IDE, установленного на материнской плате. Может принимать значения:
"Primary" - разрешена работа только первого канала,
"Secondary" - разрешена работа только второго канала,
"Both" - разрешена работа обоих каналов (по умолчанию),
"Disabled" - запрещена работа обоих каналов.
В "допентиумные" времена приведенную функцию, как правило, заменяла также интегрированная функция "Onboard 496B IDE Port", предлагавшая упомянутые четыре параметра. Но название функции оказалось не совсем корректным, хотя и прижилось в различных версиях BIOS. Дело в том, что нумерация портов (см. I/O Map) всегда представлялась (и представляется) в 16-ричном виде. Здесь же 496-й порт есть не что иное, как 10-ное отображение порта с номером 01F0. В общем случае для первичного IDE-канала отведены 8 однобайтовых портов с номерами 01F0-01F7. А под вторичный (secondary) IDE-канал отведены порты с номерами 0170-0177. Вот такая история!
Упомянутые четыре значения характерны и для опций "Onboard IDE", "IDE controller", "Onboard Local Bus IDE", "Local Bus IDE adapter", "Internal PCI/IDE". Стоит упомянуть, хотя об этом много написано, что низкоскоростные устройства (например, CD-ROM) должны быть расположены на вторичном канале.
Чуть более давняя опция "Onboard IDE Controller" не позволяла использовать вторичный интерфейс самостоятельно и имела значения: "Primary", "Both", "Disabled". Опция "Phoenix BIOS" "Hard Disk Controller" предложила аналогичные значения: "Primary", "Primary And Secondary" (при этом становились занятыми и IRQ14, и IRQ15), "Disabled". Та же опция "Phoenix BIOS" еще несколько лет назад предлагала только два значения: "Enabled" и "Disabled", но на то были, как говорится, свои причины.
В некоторых случаях интегрированная опция может быть заменена двумя ("Onboard IDE-1 Controller", "Onboard IDE-2 Controller"), и тогда не представит сложности настроить каждый из каналов в отдельности. Вот еще примеры с двумя опциями:
"Primary IDE Channel", "Secondary IDE Channel",
"OnChip IDE First Channel", "OnChip IDE Second Channel",
"On-chip Primary PCI IDE", "On-chip Secondary PCI IDE",
"PCI Slot IDE 1st Channel", "PCI Slot IDE 2nd Channel",
"PCI IDE 1st Channel", "PCI IDE 2nd Channel",
"Primary PCI IDE Interface", "Secondary PCI IDE Interface".
Последняя пара опций ("Phoenix BIOS") вместо обычных значений ("Enabled"/"Disabled") предложила "Auto Configured" и "Disabled". При этом еще одна пара ("Primary PCI IDE Status", "Secondary PCI IDE Status") через "Enabled" давала возможность вывести состояние каналов интерфейса в процессе загрузки системы.
На начальных этапах развития EIDE-интерфейса можно было встретить ситуацию, когда сохранялись привычные опции включения/отключения IDE-интерфейса ("On-Chip PCI IDE", "On-Chip IDE Controller"), к которым была добавлена возможность управления вторичным каналом. Все это объяснялось необходимостью избежать конфликтной ситуации на основном, т.е. первичном, канале. Вот и появились такие "одинокие" опции: "IDE Second Channel Control", "2nd Channel IDE". По вторичному интерфейсу еще несколько слов! При установке опции в "Enabled" IRQ15 предназначается для вторичного IDE-канала. Если опция установлена в "Disabled", IRQ15 может использоваться для других устройств. Последняя установка рекомендуется и в случае отсутствия какого-либо устройства на 2-м IDE-канале.

Onboard Serial Port 1/2
- опция включения/отключения и установки системных ресурсов (адреса портов и прерывания) для встроенных первого и второго последовательных портов. Если "BIOS Setup" позволяет, рекомендуется установить в "Auto". Стандартные и при этом вполне корректные установки, которые вряд ли будет необходимость потом менять, могут быть получены при начальной установке "BIOS Setup" по умолчанию (defaults). Может принимать значения:
"3F8/IRQ4" - первый последовательный порт,
"2F8/IRQ3" - второй последовательный порт,
"3E8/IRQ4" - первый последовательный порт,
"2E8/IRQ3" - второй последовательный порт,
"Disabled" - запрещено использование последовательных портов (или порта). При этом освобождающиеся прерывания могут быть использованы в других целях,
"Auto" (или "Auto Configured") - система автоматически выбирает I/O-адреса и прерывания.
Могут быть и дополнительные адреса и прерывания, а значения могут быть представлены в виде, например, "3F8/COM1" и т.д.
Опция также может носить названия: "Onboard Serial Port A/B", "Onboard Serial UART1/2", "Onboard UART 1/2", "Serial Port 1/2 Interface", "Serial 1/2".

В случае последовательного интерфейса конфликты обычно возникают при добавлении третьего или четвертого последовательного порта. Это происходит потому, что в системах с шиной ISA нечетные последовательные порты (1 и 3) часто настраиваются на одно прерывание; это относится и к четным портам (2 и 4). Если, например, "мышь" подключена к порту COM2, а внутренний модем использует порт COM4, то оба устройства могут быть настроены на одно и то же прерывание, и использовать их одновременно нельзя.
OffBoard PCI IDE Card
- эта опция "AMI BIOS" предназначается для включения IDE-интерфейса, размещенного на PCI-карте расширения. При этом, если внешний контроллер PCI IDE на начальном этапе определен, то автоматически блокируется встроенный (onboard - см. выше) IDE- интерфейс. Возможные значения: "Auto", "Slot1", ..., "Slot6". Если установлено "Auto", BIOS автоматически определит корректные установки, включая использование встроенного контроллера, если не используется внешний.
x OffBoard PCI IDE Primary IRQ
x OffBoard PCI IDE Secondary IRQ
- эти опции становятся доступными при выборе в базовой опции одного из PCI-слотов и позволяют напрямую назначить каналам контроллера соответствующее прерывание: IRQ14 и IRQ15.

Primary Master ARMD Emulated as
Primary Slave ARMD Emulated as
Secondary Master ARMD Emulated as
Secondary Slave ARMD Emulated as
- ARMD (ATAPI Removable Media Disks) являются гибридными дисководами (например, ZIP-дисководы). Они являются съемными, они могут использоваться как флоппи-дисководы, а также благодаря своей большой емкости в некоторых случаях могут быть использованы в качестве жестких дисков. И поскольку речь идет об использовании таких устройств в IDE-интерфейсе, то данная опция и определяет, в качестве какого системного устройства будет применен такой "гибридный" дисковод. Значения опции следующие: "Auto", "Floppy" или "Hard Disk".
Приведенные опции, в таком виде, обычно располагаются в каком-нибудь солидном конфигурационном меню настроек IDE-интерфейса, но пользователь уже столкнулся с аналогичной ситуацией в разделе "Boot" в опции "Boot Sequence". Так распорядился с ARMD "AMI BIOS".

PS/2 Mouse Function Control
- (управление функциями порта мыши PS/2). Разрешение этого параметра отдает IRQ12 только для порта мыши PS/2, одновременно подтверждается наличие в системе мыши с интерфейсом PS/2. В противном случае, при отсутствии подключенной к компьютеру мыши с интерфейсом PS/2, IRQ12 свободно для других устройств. Рекомендуется устанавливать значение "Auto". Может принимать значения:
"Enabled" - установлено разрешение и IRQ12 занято,
"Auto" - BIOS автоматически определяет присутствие или отсутствие PS/2-мыши. В некоторых вариантах BIOS параметр "Auto" может быть заменен стандартным "Disabled", и тогда эта функция становится абсолютно идентичной следующим опциям, которые могут иметь названия: "PS/2 Mouse Port", "PS/2 Mouse Support", "Mouse Support".
Аналогично действует и функция "Phoenix BIOS" "Mouse Controller", которая через "Disabled" освобождает IRQ12 для пользователя. Правда, при этом действуют еще два параметра: "Enabled" и "Auto Detect". Последняя установка автоматически активизирует мышь и позволяет операционной системе с поддержкой "Plug&Play" автоматически конфигурировать устройство.
Познакомившись со всеми предыдущими вариациями, легче будет разобраться с опцией "PS/2 Mouse", поскольку она вобрала в себя все возможное и не...:
"Enabled" - контроллер мыши допущен к работе, IRQ12 используется,
"Disabled" - контроллер не используется, IRQ12 свободно,
"Auto Detect" - подключенная мышь определяется автоматически и активируется через BIOS на этапе завершения POST,
"OS Controlled" - операционная система с поддержкой "Plug&Play" конфигурирует мышь PS/2 самостоятельно.
Правда, и здесь присутствуют вариации. Опция "PS/2 Mouse" встретилась со стандартными значениями: "Off" и "On".
Интерфейс "мыши" PS/2 впервые появился в 1987 г. в компьютерах PS/2 корпорации IBM. Порт "мыши" был встроен в системную плату, а электрически подключался к контроллеру клавиатуры 8042. Таким образом, для PS/2-мыши использовались "клавиатурные" адреса ввода/вывода (60h, 64h), и было нацелено прерывание IRQ12.

USB Controller
- опция включения/отключения установленного на материнской плате контроллера USB. Включение USB-контроллера имеет смысл только в случае использования соответствующей периферии. При этом система выделяет специальное прерывание, которое может вызвать конфликт в случае слишком большого количества различных устройств, нуждающихся в собственных ресурсах. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено (по умолчанию).
Опция также может носить названия: "USB Interface", "Integrated USB Controller", "OnChip USB", "USB Function". Опция может называться и "Legacy USB Support", а значения могут быть следующие: "Disabled", "Enabled" и "Auto" (по умолчанию).
"Phoenix BIOS" содержит опцию с тем же названием ("USB Controller"), иногда - "USB Host Controller".
Через "Legacy USB Support" (или аналогичную опцию) BIOS может эмулировать интерфейс обычной последовательной мыши для программ, которые не могут работать с USB-мышью напрямую.

USB Keyboard Support
- подобная функция, предназначенная в данном случае для поддержки USB-клавиатуры. При использовании такой клавиатуры предварительно должна быть активирована поддержка USB-контроллера. Если же USB-клавиатура отсутствует, то возможная установка опции только "Disabled" (оно же и по умолчанию).
Опция также может называться "USB Keyboard Legacy Support". Смотри дополнительно "USB Keyboard Support Via" в главе "Boot".
"AMI BIOS" также содержит "USB Function", но в некоторых случаях при ее включении активизируются опции, представленные ниже.

x USB KB/Mouse Legacy Support
- с этой опцией уже не должно быть вопросов. Тем более, что некоторые USB-клавиатуры имеют также стандартный порт мыши PS/2, благодаря чему "мышь" может быть подключена непосредственно к клавиатуре.
x Port 64/60 Emulation
- если опция установлена в "Disabled", USB-клавиатура будет нормально функционировать в различных ОС. Установка в "Enabled" необходима была для работы под "Windows NT", взаимодействующей с некоторым периферийным "железом" иначе, чем другие операционные системы. Тот, кто "сталкивался" с картой адресов портов ввода/вывода (I/O Map), знает, что однобайтовые порты 0060 и 0064 предназначены для контроллера клавиатуры, а точнее для стандартного функционирования через прерывание и командного режима соответственно (смотри дополнительную информацию в разделе "Keyboard").

Функции подключенности встроенного аудио и SCSI-интерфейса выделены в отдельные главу и раздел.

7.2. Функции конфигурирования распределения ресурсов

В 1993 г. "Compaq", "Intel", "Phoenix" и "Microsoft", стремясь сделать ПК еще более интеллектуальными, разработали концепцию "Plug & Play". Основная ее идея заключается в следующем: при загрузке ПК BIOS опрашивает все карты на предмет их потребности в ресурсах и распределяет их так, чтобы при работе ПК не возникали конфликтные ситуации. Общение между картой расширения и BIOS можно обеспечить еще эффективнее при использовании PCI-шины. Так, большинство PnP-карт разработаны только для шины PCI. Все PCI-карты отличаются, кроме того, дополнительными способностями. В отличие от своих ISA-родственников они могут работать с переменными ресурсами и посредством точно определенной идентификационной записи отчетливо заявлять о своих ресурсных потребностях. Соответственно этому BIOS, поддерживающий "Plug & Play", сперва проверяет жестко настроенные ISA-карты, а затем раздает оставшиеся ресурсы PCI-устройствам. В результате формируется список распределения ресурсов ESCD (Extended System Configuration Data), помещаемый BIOS в нечувствительной к отсутствию питания области памяти для того, чтобы при каждом старте иметь возможность сравнения и восстановления последней функционировавшей комбинации.

Configuration Mode
- опция "AMI BIOS", использующая технологию "Plug&Play" при общем конфигурировании ресурсов системы. Может принимать значения:
"Use BIOS Setup" - основное конфигурирование ресурсов осуществляется за счет возможностей "P&P BIOS". В данном случае речь идет прежде всего, как увидим далее, о "non-Plug and Play ISA add-in card". При этом операционная система берет на себя лишь часть P&P-функций. Установка такого значения может оказаться не только оптимальной, но и единственной при работе с такими ОС, как "Windows NT", "OS/2" и др.,
"Use PnP OS" - естественно, что для включения этой опции должна быть установлена ОС с поддержкой "Plug&Play" ("Windows 9x" и выше). При этом на BIOS возлагаются задачи предварительного устранения возможных конфликтов между не-"P&P"- и "P&P"-картами.
Опция "Phoenix BIOS" "Installed O/S" носит более расширенный характер. В нее включена дополнительно поддержка ACPI- технологии (об ACPI см. ниже в отдельном разделе). Поддержка же со стороны BIOS включена автоматически в значения параметров опции:
"Other" - установлена ОС, не поддерживающая "P&P"-технологию,
"PnP" (или "PnP OS"),
"PnP ACPI".
Более давний вариант опции "Installed O/S" предлагал всего два значения: "Other" и "Win95". С ними уже не должно быть проблем.
Тот же "Phoenix BIOS" может предложить и другой простой вариант, "Plug & Play O/S", для которого значение "No", например, означает возложение на BIOS задачи конфигурирования системных ресурсов. Другое значение - "Yes" (по умолчанию). Опция "PNP OS Installed", как и опция "AMI BIOS" "Plug and Play Aware O/S", абсолютно идентичны, также и по значениям параметров.
Современный "The Award Plug and Play BIOS" с опцией "PnP BIOS Auto-Config" позволяет полностью автоматизировать процесс конфигурирования прерываний и всего прочего для P&P-совместимых устройств. Для этого надо установить "Enabled".
Возможен еще и такой вариант. Опция может называться "Configuration Mode", но она "посвящается" выбору метода, с помощью которого BIOS получит информацию о т.н. "legacy" картах (см. ниже). Естественно, что возможные значения параметра будут заметно отличаться от предложенных выше:
значение "Use ICU" означает, что BIOS будет располагать информацией, предоставленной "P&P" программным обеспечением (например, "Configuration Manager" или "ISA Configuration Utility"),
значение "Use Setup Utility" предполагает настройку ресурсов вручную в "BIOS Setup" без применения каких-либо утилит.
x PnP OS
- достаточно нестандартный и, естественно, нечасто встречающийся вариант. В данном случае подопция активируется, если в основной опции выбрано значение "Use PnP OS". А возможные значения могут быть предложены такие:
"Disabled",
"Other PnP OS",
"Windows 95" (по умолчанию).

Configuration Mode Установка метода с помощью которого ваш ПК будет получать информацию об установленных в системе карточках. Используйте режим ICU (ISA Configuration Utility), если вы используете Plug and Play программное обеспечение, например Windows 95. И используйте режим Setup Utility, если вы не используйте Windows 95 и хотите устанавливать параметры аппаратуры вручную, используя BIOS Setup. Configuration Mode - опция, содержащаяся в новых версиях BIOS для поддержки технологии "Plug & Play". Большинство современных ISA-карт BIOS может автоматически распознавать и присваивать им соответствующие адреса. Установка значения "Use ICU" (ISA Configuration Utility) позволит BIOS самостоятельно управлять прерываниями. Для "Use ICU" необходимо указать и операционную систему, в которой работает пользователь. С помощью "Use Setup Utility" приводятся в действие также и те ISA-карты, которые не опознаются стандартными подпрограммами "Plug & Play". При установке "Use Setup Utility" появляются все имеющиеся в распоряжении IRQ, для которых устанавливаются значения "Available" или "Used by ISA-Card", резервирующее прерывание для ISA-карты.
Lock Setup Configuration
- весьма интересная опция "Phoenix BIOS". Установка опции в "Yes" запрещает операционной системе с поддержкой технологии "Plug & Play" модифицировать какие-либо установки, назначенные "BIOS Setup". "No", естественно, позволяет.
В том же "Phoenix BIOS" с теми же параметрами была замечена аналогичная опция "Secured Setup Configurations".

Reset Configuration Data
- (сброс конфигурационных данных). Рекомендуется устанавливать опцию в "Disabled" при условии постоянства всей подключенной периферии и ее конфигурирования. При установке "Enabled" BIOS очистит область памяти ESCD (Extended System Configuration Data - данные расширенной системной конфигурации), в которой хранятся данные о конфигурировании системы (прежде всего не "Plug&Play"-устройств). Затем перезапишет ее в процессе проведения POST. После чего BIOS автоматически переведет значение параметра в "Disabled", предотвращая систему от ошибок пользователя. Естественно, что при постоянстве параметра "Enabled" также постоянно происходило бы переконфигурирование распределения системных ресурсов. Опция может быть включена для перенастройки таблицы ресурсов либо при установке новых устройств или их перестановке.
"Phoenix BIOS" содержит опцию с тем же названием, но со значениями "Yes" и "No" (по умолчанию и аналогично "Disabled").
Опция также может называться "Reset Config Data", а еще "Force Update ESCD". Тем не менее приз за самый "красивый" вариант достался "AMI BIOS" - "Clear NVRAM on Every Boot".
Упомянутая опция "Force Update ESCD" имеет один нюанс. При установке в систему нового устройства и возникновении конфликта ресурсов, приводящего даже к невозможности загрузки операционной системы, установка опции в "Enabled" может оказаться одной из мер спасения возникшей ситуации. Это связано уже с возможностями, предоставляемыми "Plug&Play BIOS", и переконфигурированием ресурсов при выходе из "BIOS Setup".

Resources Controlled By
- (как управляются ресурсы). Если выбрано значение "Auto", то BIOS автоматически назначит прерывания и каналы DMA всем устройствам, подключенным к шине PCI, и эти параметры не будут появляться на экране. Но иногда и BIOS ошибается. В этом случае можно запретить ему использовать какие-либо ресурсы либо назначить другие, но уже в "ручном" режиме.
Выбрав значение "Manual", пользователь производит конфигурирование системных ресурсов вручную. В перечне ресурсов можно назначить ресурсы и для PCI/ISA PnP-устройств, и для не-PnP-карт расширения. В последнем случае требуется особая аккуратность. К тому же в этом случае системный BIOS не будет обращаться к области ESCD за информацией об IRQ и DMA.
При пользовательском конфигурировании ресурсов становятся доступными следующие опции:
x IRQ-n assigned to,
x DMA-n assigned to,
где n - номер аппаратного прерывания или DMA-канала, доступных для пользовательских настроек. Какие же ресурсы доступны в этих опциях? Для IRQ n может обозначать следующие прерывания: 3, 4, 5, 7, 9, 10, 11, 12, 14, 15. Для DMA - 0, 1, 3, 5, 6 и 7-й каналы. Подробнее об этих ресурсах чуть ниже. Также чуть ниже об этих же опциях, которые могут быть представлены в некоторых версиях BIOS как более самостоятельные функции.
Теперь о возможных значениях.
"Legacy ISA" - так называемые "Legacy Cards" ("унаследованные карты"). Это "старые" ISA-карты, устройства, совместимые только со стандартной спецификацией AT и не поддерживающие автоконфигурирование. Как правило, их настройки осуществляются физически различными ключами, переключателями, перемычками, расположенными на самой карте расширения. В этом случае через BIOS необходимо указать, что данный номер IRQ (или DMA) используется старой ISA-картой. Сразу вспоминаются ушедшие в прошлое 8-битовые звуковые карточки. Но дело в том, что эксплуатируются и продолжают выпускаться многочисленные промышленные устройства ввода/вывода, устройства сопряжения и т.п., с успехом внедряемые как в промышленные системы, так и в персональные,
"PCI/ISA PnP". PCI-устройства полностью автоконфигурируемы, а ISA PnP часто еще содержат дополнительные возможности как для автоконфигурации, так и для ручной установки ресурсов в случае установки в систему, не поддерживающую PnP-технологию. "Legacy ISA"-платы обычно требуют конкретный канал памяти и определенное прерывание, в то время как PnP PCI- и ISA-платы могут пользоваться любым предоставленным ресурсом.
И еще один вариант опции "Resources Controlled By". Значения ее почти стандартные: "Auto(ESCD)" и "Manual". Но при выборе последней пользователю "открываются" опции
x IRQ Resources,
x Memory Resources,
которые предлагают одно значение - "Press Enter", что означает дальнейшее открытие соответствующих подменю. Для установки прерываний последовательность действий следующая. Выбрав один из вариантов ("PCI" или "Legacy ISA"), назначаем конкретное прерывание. А вот "Memory Resources"... Неожиданно получаем уже привычный вариант, в виде двух подопций:
x Reserved Memory Base,
x Reserved Memory Lenght,
с помощью которых устанавливается базовый адрес резервируемой основной памяти (N/A, C800, CC00, D000, D400, D800, DC00) и размер этой области, так необходимой для некоей периферии (8K, 16K, 32K, 64K).


BIOS. Продолжение!

7.3. IRQ

Прерывания подразделяются на аппаратные (маскируемые и немаскируемые) и программные. Программные прерывания, собственно, прерываниями не являются, это способ вызова определенных процедур. Но процессором программные прерывания обрабатываются как один из типов прерываний.
Немаскируемые прерывания обрабатываются процессором независимо от состояния т.н. флага разрешения прерывания. К ним относятся прерывания, приходящие по линии NMI, а для процессоров, поддерживающих режим системного управления, еще и по линии SMI. Сигнал на линию NMI приходит от схем контроля паритета памяти, от линии IOCHK шины ISA или SERR# шины PCI.
Прерывание SMI возникает от схем чипсета, участвующих в управлении энергопотреблением. Это прерывание имеет наивысший приоритет и обслуживается несколько иначе, чем более привычные аппаратные прерывания от устройств. При этом процессор переходит в режим SMM. ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
То, что в соответствии с PCI-спецификациями должны уметь все PCI-карты, но в действительности очень редко реализуется, называется "IRQ-Sharing". Теоретически это означает, что несколько компонент должны довольствоваться одним и тем же IRQ. Но поскольку лишь немногие PCI-карты общаются друг с другом столь гармонично, "Windows 9x" ставит в соответствие каждой карте, насколько это возможно, собственный IRQ. Сложности конфигурирования системных ресурсов, их распределения между сетевыми и звуковыми картами, 3D-ускорителями, стандартными последовательными и параллельными устройствами, а ныне еще видео- и DVD-декодерами постепенно ослабляются с массовым внедрением USB-шины, точнее массовым распространением USB-периферии. Правда, шина USB сама занимает один IRQ. Но зато она обязана включить в систему без дальнейшего расходования ресурсов все периферийные устройства, будь то мышь, клавиатура, сканер или видеокамера.
Еще один термин. "Polling mode" - работа устройства без использования прерываний. Это встречается при работе с простыми SCSI-контроллерами на шине ISA.

IRQ | Устройство | Приор. | Комментарии
0 | Системный таймер | * 15 | Системное прерывание. Генерируется 91 раз за 5 сек. В данном качестве применяется со времени первого PC.
1 | Клавиатура | * 14 | Системное прерывание, генерируемое контроллером клавиатуры.
2 | Контроллер прерываний | * 13 | Каскадировано (связано) с IRQ9. Могут возникнуть конфликты, когда одновременно на IRQ2 и IRQ9 должны работать различные устройства. Его использование системой сохраняется для совместимости.
3 | COM 2 | 4 | Используется вторым коммуникационным адаптером (UART2). Какое же устройство будет его генерировать? Это может быть второй последовательный порт COM2 (интегрирован на материнской плате), внутренний модем, настроенный на COM2 или COM4, или инфракрасный адаптер. Можно отключить UART2, но присвоить IRQ3 ничему не удастся. Делит одно и то же IRQ3 с COM4 (при наличии последнего). Возможен конфликт при одновременном использовании.
4 | COM 1 | 3 | Используется первым коммуникационным адаптером. Все практически идентично: генерируется первым последовательным портом COM1, модемом на COM1 или COM3 (за исключением инфрапорта). Делит одно и то же IRQ4 с COM3 (при наличии последнего). В системах с подключенной к COM1 мышью использовать COM3 не следует.
5 | свободен | 2 | Прерывание изначально предназначалось для использования вторым параллельным портом LPT2. Практического применения такое решение не нашло, поэтому IRQ5 перешло в разряд свободных. В IBM XT на IRQ5 "висел" жесткий диск. Через некоторое время "Creative Labs", создавая звуковую карту "Sound Blaster Pro", нашла применение прерыванию. С тех пор IRQ5 стало излюбленным для большинства звуковых ISA-карт. Звуковые PCI-карты также иногда используют это прерывание для эмуляции "SB Pro". IRQ5 можно привязать к слоту PCI.
6 | Контроллер FDD-дисковода | * 1 | Прерывание используется контроллером флоппи-дисковода, начиная с первых ПК. Ныне его можно отключить, если перейти на совместимый с обычными дискетами накопитель LS-120 с интерфейсом EIDE. Однако прерывание все равно не может быть использовано: ISA-карты на работу с ним не рассчитаны, и к слоту PCI привязать его нельзя. Может быть использовано для привода на на магнитной ленте.
7 | LPT 1 | 0 | По умолчанию прерывание первого параллельного порта LPT1. При отключенном порте (если принтер отсутствует или рассчитан на USB) может использоваться различными устройствами: сетевыми, ISDN-картами. Это также "запасное" место для звуковых карт.
8 | Часы реального времени (RTC) | * 12 | Системное прерывание со времени первых IBM AT.
9 | свободен | 11 | Каскадировано с IRQ2. В остальном может использоваться по усмотрению.
10 | свободен | 10 | Может быть использовано по усмотрению. Устаревшие IDE-контроллеры на старых звуковых картах иногда используют это IRQ.
11 | свободен | 9 | Может быть использовано по усмотрению, часто используется видеокартами. В современных ПК обычно резервируется для шины USB. При отключении последней в BIOS может быть задействовано иначе.
12 | свободен или PS/2-мышь | 8 | Если используется мышь, это IRQ в большинстве случаев выдается лишь по разрешению BIOS. Почти всегда прерывание свободно.
13 | Сопроцессор | * 7 | Системное прерывание. Изначально применялось арифметическим сопроцессором, который в первых ПК являлся отдельной микросхемой. Ныне это прерывание зарезервировано для совместимости со старым ПО.
14 | Первичный EIDE-контроллер | 6 | По разрешению BIOS может быть использовано в SCSI- системах.
15 | Вторичный EIDE-контроллер | 5 | Также может использоваться SCSI-интерфейсом, хотя обычно на него "подгружают" дополнительные EIDE-диски. При отсутствии устройств может применяться в любых целях.

Примечания:
15 - наивысший приоритет,
* - эти системные компоненты жестко зафиксированы и их конфигурация не может быть изменена.

Несколько слов о слотах.

------------------------ Slot AGP
----------------------- Slot 1 PCI
----------------------- Slot 2 PCI
----------------------- Slot 3 PCI
----------------------- Slot 4 PCI
------------------------------ Slot 1 ISA
------------------------------ Slot 2 ISA
При установке в слоты карт расширения необходимо помнить о следующем:
- слоту AGP и первому слоту PCI присваивается один и тот же номер прерывания,
- если слотов PCI пять, то один номер разделяют также четвертый и пятый слоты,
- при установке сложного устройства, требующего сразу два IRQ, желательно следующий слот оставлять свободным, иначе возможна достаточно сложная процедура ручного присваивания ресурсов,
- термином "разделяемый слот" (Shared Slot) обозначают самый крайний и одновременно соседствующий с ISA-слотом PCI-слот. Электронные компоненты двух типов карт расширения оказываются направлены друг к другу, что делает невозможным одновременное использование двух соседних посадочных мест.

IRQ n Assigned to
- (прерывание с номером n назначено на...). Использование этой опции возможно, если установлен "ручной" режим конфигурации устройств. В данной опции каждому прерыванию системы может быть назначен один из следующих типов устройств:
"Legacy ISA" (классические ISA-карты) - обычные карты для ISA-шины, такие как модемы или звуковые карты, без поддержки технологии "Plug&Play". Эти карты требуют назначения прерываний в соответствии с документацией на них.
"PCI/ISA PnP" (устройства для шин PCI или ISA с поддержкой "Plug&Play") - этот параметр устанавливается только для карт расширения на PCI- или ISA-шинах с поддержкой "Plug&Play".
Несколько устаревшая опция "AMI BIOS" может носить название "IRQn" , а ее значения следующие: "ISA/EISA" и "PCI/PnP". При этом IRQ12 оказывается "в списке", если предварительно опция "Mouse Support" (или ей подобная) отключена. Точно также IRQ14 и 15 будут доступны, если будет отключен IDE-интерфейс или один из каналов.
IRQ n Used By ISA
- (прерывание с номером n используется на шине ISA). Параметр может принимать значения:
"No/ICU" (нет/конфигурационная утилита для ISA) - если установлено это значение, то BIOS может распоряжаться прерыванием по своему усмотрению. Для DOS настройка параметров в этом случае может также выполняться с помощью программы "ISA Configuration Utility" от "Intel",
"Yes" (да) - означает принудительное освобождение прерывания для какой-либо карты на шине ISA, не поддерживающей "Plug&Play". Рекомендуется всегда указывать "Yes" для таких карт и нужных им прерываний, так как в противном случае BIOS может назначить прерывание, жестко используемое какой-либо картой на ISA, другой карте, что может вызвать даже прекращение нормальной работы компьютера.
Для этой опции аналогичной может также оказаться опция "IRQ n" со значениями "Available" (по умолчанию) и "Used By ISA Card". Стоит напомнить ряд возможных прерываний: 3, 4, 5, 7, 9, 10, 11, 12, 14, 15. Первое значение позволяет системе решать проблему распределения ресурсов через автоконфигурирование, второе же напрямую назначает прерывание ISA-карте. При этом также может быть использована утилита ICU.

IRQ to PCI VGA
- установка этой опции в "Disabled" позволит сэкономить одно прерывание благодаря тому, что графические карты при работе с обычным набором офисных приложений не используют IRQ. Ситуация может упроститься и за счет того, что некоторые низкоуровневые видеокарты могут работать без выделения прерывания, но это необходимо выяснить в документации.
Но та же ситуация меняется при установке в систему 3D-акселлератора и его полнофункционального применения, а это стандартная ситуация. Выделение аппаратного прерывания для графической карты требуется уже не только для ее корректной работы в системе, а становится необходимым для организации обработки огромных массивов информации, для взаимодействия между центральным процессором, системной памятью, видеопроцессором, а ныне и геометрическим процессором видеокарты. Это же справедливо и для случая, когда карта содержит, например, дополнительный модуль MPEG-декодера. Ведь в этом случае используется режим "Busmastering", при котором карта расширения отбирает у процессора управление потоком данных. Необходимо напомнить, что режим "Busmastering" требует по одному IRQ для каждой из карт, поддерживающих этот режим.
Опция может носить название "Assign IRQ For VGA" или, как в "AMI BIOS", "Allocate IRQ to PCI VGA" со значениями "Yes" и "No".

Modem Use IRQ
- в таком виде данная опция, как правило, располагается в разделах BIOS, посвященных расширенным установкам режимов ACPI. Если опция, подобная "Modem Ring Resume", включена, то тогда надо указать номер аппаратного прерывания, используемого модемом. Входящий звонок тогда должен вызвать пробуждение системы.

PCI Device Search Order
- эта удивительная опция "AMI BIOS" позволяет изменить порядок PCI-слотов, что может пригодиться при расстановке прерываний в процессе конфигурирования ресурсов. По сути меняется последовательность сканирования слотов, производимого BIOS при начальных проверке и конфигурировании системы. Может принимать значения:
"First-Last",
"Last-First".

PCI IRQ Activated by
- (прерывания активизируются по ...). Выбор метода, с помощью которого контроллер прерываний будет распознавать запрос на прерывание от устройств на шине PCI. Смысл опции - в минимизации времени "захвата" шины и дальнейшей передачи данных от устройства. По умолчанию предлагается значение "Level", и менять его не следует, если только это не будет необходимо для конкретного случая, о чем должно быть написано в руководстве к устройству. Параметр может принимать значения:
"Level" (уровень) - контроллер прерываний реагирует только на логический уровень сигнала,
"Edge" (перепад) - контроллер прерываний реагирует только на перепад уровня сигнала.
Аналогичная опция, но укороченная - "PCI IRQ Actived By". Также аналогичная опция, но с редко встречающимся наименованием - "Edge/Level Select". Необходимо добавить, что в очень редких случаях может быть предоставлена возможность установки реакции на прерывание от конкретного устройства. Тогда значение "Edge" имеет смысл установить для интерфейса PCI IDE.

PCI/PNP ISA IRQ Resource Exclusion
- в данном случае это специализированное подменю "Phoenix BIOS", с помощью которого можно индивидуально блокировать отдельные аппаратные прерывания и предоставить их стандартным ISA-картам (т.е. не Plug&Play картам). Само же подменю имеет следующий вид:
IRQ 3: [Available]
IRQ 4: [Available]
IRQ 5: [Reserved]
IRQ 7: [Available]
IRQ 9: [Available]
IRQ 10: [Available]
IRQ 11: [Available]
Параметр "Available" (по умолчанию) означает, что прерывание может быть использовано PCI- и P&P ISA-картами. Значение "Reserved" означает, что прерывание не может быть использовано этими же устройствами.
Аналогичная опция и с теми же значениями может называться "IRQ Reservation".

PCI Slot n IRQ Priority
- в данной опции понятие "priority" (приоритет, первоочередность) не несет того смысла, с которым пользователь столкнулся выше при рассмотрении темы "арбитраж". Речь идет по сути о назначении PCI-слотам конкретного аппаратного прерывания. Здесь нет никаких противоречий с информацией об автоконфигурировании PCI-устройств. Дело в том, что существуют промышленные изделия (платы расширения для PCI-шины), которые лишены встроенного BIOS, настраиваемые на определенное прерывание и тем самым как бы "выпадающие" из обычного рассмотрения PCI-устройств. По сути такие PCI-платы не являются 100%-ными P&P-устройствами.
Все это выглядит в виде небольшого меню с несколькими опциями, в которых n меняется, обычно, от 1 до 4. При этом значения могут иметь вид: "Auto", "IRQ 3", "IRQ 4","IRQ 5" и т.д. Понятно, что выбор "Auto" приводит ситуацию в режим автоконфигурирования.

Report No FDD For WIN 95
- (сообщение об отсутствии накопителя на гибких дисках для "Windows 95"). Параметр используется, как правило, в сетевых компьютерах без флоппи-дисковода или в случае необходимости размещения в компьютере устройства, для которого не хватает прерывания. При выборе "Yes" и одновременном выборе "Disable" в параметре "Onboard FDC Controller" (обычно в разделе "Integrated Peripherals" "BIOS Setup") "Windows 9x" освободит IRQ6, занимаемое контроллером флоппи-дисковода, для использования другим устройством. Может принимать значения:
"Yes" (или "Enabled") - освободить IRQ6,
"No" (или "Disabled") - не освобождать (независимо от того, есть ли флоппи-дисковод или нет).
Значительно реже встречается аналогичная опция под названием "FDD IRQ Can Be Free". Выбор значений параметра также аналогичен: "Yes" и "No".

Slot n IRQ for VGA
- опция, позволяющая назначить конкретное прерывание для конкретного PCI-слота с учетом того, что в этот слот установлен графический адаптер. Из приведенных выше опций уже понятно, что это также небольшое меню с количеством опций, равным количеству слотов. Их число может равняться 4, 5 и даже 6. Поскольку речь идет об одном слоте, то остальные опции блокируются ("Disabled").

Trigger Method
- опция, позволяющая оптимизировать установку IRQ для PCI-слотов и могущая принимать значения "Auto" или "Forced". Для PCI- карты необходимо установить значение "Auto". Эта установка проверяет, нуждается ли PCI-карта в IRQ. Если карта не нуждается в IRQ, то система оставляет его для других ресурсов. Установка "Forced" используется в том случае, если BIOS автоматически не определяет, нуждается ли PCI-карта в прерываниях. Если установлено значение "Forced", то выделенный IRQ может использовать только данная PCI-карта.
Примечание! Если используемый в системе SCSI-контроллер с NCR-чипом не работает, то для этого контроллера необходимо установить прерывание IRQ15 и опцию "Level Trigger".

USB IRQ
- (прерывание шины USB). Параметр разрешает/запрещает назначение прерывания для контроллера шины USB. Поскольку в системе может не хватать свободного прерывания, разрешать этот параметр следует только при наличии устройства на шине USB. Также были замечены конфликты при одновременном использовании USB-устройств и звуковых карт на чипах "Aureal", и это было связано с распределением прерываний. Так что требуется внимательность. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может носить название "Assign IRQ For USB" или "Use An IRQ for USB". Для последней опции параметрами были "No" и "Yes".

Use IRQ12 For Mouse Port
- предварительно имеет смысл ознакомиться с расположенной выше опцией "PS/2 Mouse Function Control". В данной опции значениями параметра служат "No" и "Yes", что абсолютно идентично указанной опции и относится к использованию в системе PS/2-мыши.


BIOS. Продолжение!

7.3. DMA

DMA (Direct Memory Access - "прямой доступ к памяти", или ПДП). Это способ (механизм, технология) обмена данными между внешним устройством и памятью без участия процессора, что может заметно снизить нагрузку на процессор и повысить общую производительность системы. Необходимо сказать, что "прямой доступ к памяти" существовал в электронной вычислительной технике задолго до появления первых ПК. Он осуществляется через DMA-контроллер - специальный чип, получающий первоначальную команду на перенос данных от центрального процессора. Каналы DMA предназначены для передачи массивов информации по 8- или 16-битным шинам одновременно. В отличие от портов ввода/вывода каналы DMA непосредственно не сообщаются с центральным процессором, они работают напрямую с системной памятью. Всего каналов DMA - 8 (от 0 до 7).
Первоначально DMA-контроллер задумывался, прежде всего, для разгрузки CPU от тривиальных задач, например, контроля флоппи- дисководов или жестких дисков (на PC/XT DMA-каналов было 4). Начиная с компьютеров PC/AT передача данных от жестких дисков и к ним стала осуществляться уже не через каналы DMA, а через программируемый ввод/вывод.
Начиная с Intel 80386, процессоры располагают собственным устройством управления памятью (MMU - Memory Management Unit), которое пересчитывает логические адреса в физические. DMA-контроллеры "ничего не знают" о разрядности адресов. Поэтому, чтобы иметь возможность применять DMA вместе с управлением виртуальной памятью, нужно зарезервировать в качестве DMA-буфера какую-то область памяти в первом мегабайте адресного пространства, где логические и физические адреса совпадают. В эту область DMA-контроллер записывает данные, прежде чем они будут скопированы процессором из этого буфера. Эта технология, называемая двойной буферизацией, неэффективна.
Основными "потребителями" каналов DMA являются звуковые карты, CD-ROM-дисководы более ранних выпусков. В обоих случаях скорость передачи не превышает 500 Кб/с. Максимально возможная скорость передачи данных по DMA-каналам (около 2 Мб/с) значительно перекрывает потребности 8-битной звуковой карты. Если же необходимо осуществить быстрый обмен информацией, то в этом случае DMA не используется - процессор берет на себя управление процессом переноса информации, перекрывая все допустимые способности DMA-каналов.
Еще одно замечание. Возможность использования одного IRQ несколькими картами расширения требует поддержки со стороны драйверов и реализуется на уровне конкретного программного продукта. Использование разными картами (или устройствами) одного канала DMA в принципе возможно, но связано со множеством проблем и поэтому не рекомендуется. Простейший пример! При одновременном использовании DMA-канала звуковой картой и портом принтера может возникнуть треск в динамиках или "зависание" воспроизведения звука.
Небольшое уточнение. Цикл DMA начинается с запроса DMA от исполнителя, желающего произвести обмен. После освобождения шины текущим задатчиком (например, процессором) контроллер DMA формирует соответствующий сигнал - "DACK" (DMA Acknowledge - подтверждение ПДП), говорящий о предоставлении канала DMA запросившему его устройству.

DMA-канал | Разрядность | Назначение
0 | 8 | свободен (ранее использовался в PC/XT для обновления памяти
1 | 8 | обычно задействуется под звуковые или сетевые карты
2 | 8 | контроллер floppy-дисководов
3 | 8 | свободен (в PC/XT обеспечивал передачу данных от HD), иногда используется EPP-функцией параллельного порта
4 | 16 | каскадирование для 8-разрядного контроллера (координация между "старым" и "новым" чипами DMA)
5 | 16 | свободен (часто задействуется под 16-разрядные звуковые карты)
6 | 16 | свободен
7 | 16 | свободен

DMA Clock
- эта опция позволяет установить скорость DMA-каналов, равной полной или половинной системной тактовой частоте. Правда, слишком высокая тактовая частота может представлять опасность либо оказаться завышенной для некоторых микросхем. Опция может носить название "DMA Clock Selection" или "DMA Clock Speed". Значения параметров могли иметь следующий вид: "BUSCLK/2", "BUSCLK" или "ISA/2", "ISA".
Была встречена опция и с названием "Fast DMA Only". Только для нее высокая скорость передачи по DMA-каналам реализовывалась через "Enabled". Все перечисленные опции в таком виде уже не встречаются.
DMA Line Buffer Mode
- использование этой опции позволяет DMA-данным накапливаться в буфере с тем, чтобы не прерывать работу PCI-шины. Когда установлено значение "Standard", линейный буфер будет применяться в одиночном режиме передачи. "Enhanced"-установка позволяет оперировать с данными в 8-байтном режиме, что естественно более эффективно.
DMA n Assigned to
- (канал DMA с номером n назначен на...). Опция становится доступной пользователю при "ручном" контроле над ресурсами. Согласно этой опции каждому каналу DMA системы может быть назначен один из следующих типов устройств:
"Legacy ISA" (классические ISA-карты). Это стандартные карты для ISA-шины, такие как модемы или звуковые карты, без поддержки "Plug&Play". Эти карты требуют назначения каналов DMA в соответствии с документацией на них,
"PCI/ISA PnP" (устройства для шины PCI или устройства для шины ISA с поддержкой Plug&Play).
Данной опции абсолютно идентична "DMA Channel n" с параметрами "PnP" и "ISA/EISA". Естественно, что это не одна опция, а небольшое подменю с возможностью установки типа устройства по 0, 1, 2, 3, 5, 6 и 7-му каналам DMA.
Опция "DMA-n Type" встречалась и раньше, применяется и в более современных системах. Поэтому в качестве параметров собран, пожалуй, весь возможный ряд значений: "Normal ISA", "PC/PCI", "Distributed", "LPC DMA".
Спецификация LPC (Low Pin Count) была разработана "Intel" еще в 1997 г. и начала использоваться в системных наборах 8xx, первым из которых был 810-й. Эта шина была призвана заменить устаревшую шину ISA в тех системах, где без нее пока еще нельзя обойтись. В частности, к ней можно подключать контроллеры флоппи-дисководов, параллельные и последовательные порты, контроллер клавиатуры и т.п. То есть речь идет о всей низкоскоростной периферии, хотя тактовая частота интерфейсной шины составляет ни много, ни мало - 66 МГц.
DMA n Used By ISA
- (канал DMA с номером n используется на шине ISA). Параметр может принимать значения:
"No/ICU" (нет/конфигурационная утилита для ISA). Если установлено это значение, то BIOS может распоряжаться этим каналом DMA по своему усмотрению. Для DOS настройка параметров в этом случае выполняется с помощью программы ICU (ISA Configuration Utility) от "Intel", которая ранее изредка прилагалась к материнским платам. Она запрашивала у пользователя необходимые данные и загружала их при последующем пуске ПК,
"Yes" (да). Означает принудительное освобождение канала DMA для какой-либо карты на шине ISA, не поддерживающей технологию "Plug&Play". Рекомендуется всегда указывать "Yes" для таких карт и нужных им каналов DMA, так как в противном случае BIOS может назначить канал, жестко используемый какой-либо картой на ISA, другой карте, что может вызвать даже прекращение нормальной работы компьютера.
DMA Wait States
- этой опцией устанавливается количество тактов ожидания перед началом передачи данных по DMA-каналам. Уменьшение значения повышает быстродействие, но у пользователя остается резерв для возврата назад при возникновении сбойных ситуаций. В некоторых случаях версия BIOS может предоставить возможность такой регулировки отдельно для 8- и 16-битных каналов:
"8-Bit DMA Cycle Wait States",
"16-Bit DMA Cycle Wait States".
При этом предлагается следующий ряд значений: 1T, 2T, 3T, 4T.
Extended DMA Registers
- (расширенные DMA-регистры). В пределах AT-стандарта стандартный контроллер DMA оперирует в пределах 16 МБ адресуемой памяти. Если установлено "Enabled", DMA охватывает все 4 ГБ адресуемой памяти современного 32-битного процессора.
!!! При использовании некоторых системных плат с процессорами 386 и 486 адресация памяти свыше 16 МБ может вызвать сложности, связанные с контроллером прямого доступа к памяти. Если в разъеме шины ISA установлен адаптер, который использует канал DMA, то при установке памяти объемом более 16 МБ могут возникнуть проблемы, поскольку архитектура шины ISA позволяет организовать канал DMA только в пределах первых 16 МБ.
PCI/PNP ISA DMA Resource Exclusion
- в данном случае это специализированное подменю "Phoenix BIOS", с помощью которого можно индивидуально блокировать отдельные DMA-каналы и предоставить их стандартным ISA-картам (т.е. не Plug&Play картам). Само же подменю имеет следующий вид:
DMA 0: [Available]
DMA 1: [Available]
DMA 2: [Available]
DMA 3: [Available]
DMA 5: [Reserved]
DMA 6: [Available]
DMA 7: [Available]
Параметр "Available" означает, что DMA-канал может быть использован PCI- и P&P ISA-картами. Значение "Reserved" означает, что DMA-канал не может быть использован этими же устройствами.
TypeF DMA Buffer Control1(2)
- очень интересная опция "AMI BIOS". Обычный цикл прямого доступа к памяти занимает 8 циклов шины, а в данном режиме - только 3 (что, естественно, намного ускоряет доступ). Однако необходимо согласовать этот параметр с устройствами, использующими каналы DMA, передача данных которым будет ускорена, и убедиться, что такие устройства поддерживают ускоренный режим работы. Каждому из двух таких каналов DMA соответствует свой элемент управления. Впрочем, использование данного параметра существенного ускорения не приносит, так как наибольшее влияние этот параметр оказывает только на накопители на гибких дисках. По умолчанию (для каждой из двух! опций) устанавливается значение "Disabled". Другие возможные значения: "Channel-0", "Channel-1", "Channel-2", "Channel-3", "Channel-5", "Channel-6", "Channel-7".
Установка режима работы каналов DMA, как в режиме F, может быть представлена в несколько ином виде. Опция может называться "DMA Ch N TypeF Transfers", где N - это номера каналов: 0, 1, 2, 3, 5, 6 или 7. Это означает, что таких опций на самом деле 7. При этом для каждой из опций может быть установлено либо "Disabled", либо "Enabled".
Есть еще один вариант представления функции работы каналов DMA в режиме F. Опция называется "TypeF DMA Transfers #1(#2)". При установке опции (или опций) в "Enabled" активируется следующее поле:
x "Enabled DMA Channel #1(#2)" предоставляет возможность установки уже конкретного канала: 0, 1, 2, 3, 5, 6, 7 и ... "Disabled".
Дополнительная информация содержится в разделе, посвященном жестким дискам.

7.4. Ports

Порт ввода/вывода - соединение с процессором, которое конфигурируется или программируется для обеспечения обмена данными между процессором и внешним устройством. Порт ввода/вывода может быть однонаправленным и двунаправленным.
I/O-адреса (адреса портов ввода/вывода), а точнее сами порты нужны всем компонентам компьютера, там они временно хранят свои данные или данные о себе. Практически любое устройство использует порт ввода/вывода, а чаще всего набор этих портов. За каждым таким портом закреплен специальный адрес, работа с которым осуществляется через специальные команды процессора. Обратившись по одним адресам, можно получить информацию об устройстве, а по другим - изменить его параметры. Возможное число адресов портов ввода/вывода - 65536. Доступное же для использования количество портов значительно меньше.
Ну а теперь немного истории!
Интерфейсы шин расширения PC начали свою историю с 8-битной шины ISA. С появлением AT-286 шина была расширена до 16 бит, а значит, расширились возможности адресации. Но область адресов ввода/вывода 0-FFh (8 бит) осталась зарезервирована под устройства системной платы. В PC AT была принята 10-битная адресация ввода/вывода, что давало дополнительно аж 768 адресов. Это было результатом того, что линии адреса A[15:10] устройствами игнорировались, а диапазон адресов устройств шины ISA ограничивался областью 100h-3FFh адресов 8-битных регистров. К тому же на некоторые области этих адресов стали претендовать и системные устройства.
Впоследствии стали применять и 12-битную адресацию (диапазон расширился до FFFh). Но при ее использовании присутствие в системе старых "10-битных" карт могло привести к тому, что эти карты должны были бы "отозваться" на адрес с подходящими ему битами A[9:0] во всей допустимой области 12-битного адреса 4 раза (см. выше опцию "Extended I/O Decode").

Адреса | Размер | Назначение
0000 - 000F | 16 bytes | PIIX4 - DMA 1
0020 - 0021 | 2 bytes | PIIX4 - interrupt controller 1
002E - 002F | 2 bytes | Super I/O controller configuration registers
0040 - 0043 | 4 bytes | PIIX4 - Counter/Timer 1
0048 - 004B | 4 bytes | PIIX4- Counter/Timer 2
0060 | 1 byte | Keyboard Controller Byte - Reset IRQ
0061 | 1 byte | PIIX4 - NMI, Speaker Control
0064 | 1 byte | Keyboard controller, CMD/STAT Byte
0070 | bit 7, 1 bit | PIIX4 - enable NMI
0070 | bits 0-6, 7 bits | PIIX4 - real time clock, address
0071 | 1 byte | PIIX4 - real time clock, data
0078 | 1 byte | Reserved - system board configuration
0079 | 1 byte | Reserved - system board configuration
0080 - 008F | 16 bytes | PIIX4 - DMA page registers
00A0 - 00A1 | 2 bytes | PIIX4 - interrupt controller 2
00B2 - 00B3 | 2 bytes | APM control
00C0 - 00DE | 31 bytes | PIIX4 - DMA 2
00F0 | 1 byte | Reset numeric error
0170 - 0177 | 8 bytes | Secondary IDE channel
01F0 - 01F7 | 8 bytes | Primary IDE channel
0200 - 0207 | 8 bytes | Audio/game port
0220 - 022F | 16 bytes | Audio (Sound Blaster compatible)
0240 - 024F | 16 bytes | Audio (Sound Blaster compatible)
0278 - 027F | 8 bytes | LPT2
0290 - 0297 | 8 bytes | Hardware monitor
02E8 - 02EF | 8 bytes | COM4/Video (8514A)
02F8 - 02FF | 8 bytes | COM2
0300 - 0301 | 2 bytes | MPU-401 (MIDI)
0330 - 0331 | 2 bytes | MPU-401 (MIDI)
0332 - 0333 | 2 bytes | MPU-401 (MIDI)
0334 - 0335 | 2 bytes | MPU-401 (MIDI)
0376 | 1 byte | Secondary IDE channel command port
0377 | 1 byte | Floppy channel 2 command
0377 | bit 7, 1 bit | Floppy disk change, channel 2
0377 | bits 0-6, 7 bits | Secondary IDE channel status port
0378 - 037F | 8 bytes | LPT1
0388 - 038D | 6 bytes | AdLib (FM synthesizer)
03B4 - 03B5 | 2 bytes | Video (VGA)
03BA | 1 byte | Video (VGA)
03BC - 03BF | 4 bytes | LPT3
03C0 - 03CA | 11 bytes | Video (VGA)
03CC | 1 byte | Video (VGA)
03CE - 03CF | 2 bytes | Video (VGA)
03D4 - 03D5 | 2 bytes | Video (VGA)
03DA | 1 byte | Video (VGA)
03E8 - 03EF | 8 bytes | COM3
03F0 - 03F5 | 6 bytes | Floppy Channel 1
03F6 | 1 byte | Primary IDE channel command port
03F7 (Write) | 1 byte | Floppy channel 1 command
03F7 | bit 7, 1 bit | Floppy disk change channel 1
03F7 | bits 0-6, 7 bits | Primary IDE channel status port
03F8 - 03FF | 8 bytes | COM1
04D0 - 04D1 | 2 bytes | Edge/level triggered PIC
0530 - 0537 | 8 bytes | Windows Sound System
0604 - 060B | 8 bytes | Windows Sound System
LPTn + 400h | 8 bytes | ECP port, LPTn base address + 400h
0CF8 - 0CFB (*) | 4 bytes | PCI configuration address register
0CF9 (**) | 1 byte | Turbo and reset control register
0CFC - 0CFF | 4 bytes | PCI configuration data register
0E80 - 0E87 | 8 bytes | Windows Sound System
0F40 - 0F47 | 8 bytes | Windows Sound System
0FF0 - 0FF7 | 8 bytes | CS4236B audio control
FF00 - FF07 | 8 bytes | IDE bus master register
FFA0 - FFA7 | 8 bytes | Primary bus master IDE registers
FFA8 - FFAF | 8 bytes | Secondary bus master IDE registers
007C | bits 4-5, 2 bits | Chassis fan RPM sense selection
* DWORD access only
** Byte access only

7.5. Audio

AC'97 Audio
- опция "Phoenix BIOS", позволяющая сконфигурировать интегрированный на системной плате аудиоконтроллер. Аудиоконтроллер соответствует спецификации AC'97. Предлагаются следующие значения:
"Auto" - системный BIOS включает AC'97-совместимый аудиоконтроллер и выделяет необходимые системные ресурсы (IRQ, адреса, DMA). Если дополнительный AC'97-аудиоконтроллер инсталлирован на карте расширения, интегрированный аудиоконтроллер отключается и инициализируется дополнительный,
"Disabled" - AC'97-аудиоконтроллер на системной плате отключается.

Audio Controller
- "Phoenix BIOS" предлагает данную опцию для использования интегрированного на материнской плате аудиочипа. Запрещение же опции ("Disabled") имеет смысл только в случае использования обычной звуковой карты, тем более, если такая карта по своим возможностям превышает характеристики встроенного аудиопроцессора. При включении опции системный BIOS автоматически (но правильно ли) должен сконфигурировать потребности встроенной звуковой карты в ресурсах (прерывания, адреса портов, DMA- каналы).
Неспроста эта тема начата с "Phoenix BIOS". В некоторых случаях "Phoenix BIOS" представляет возможность работы с довольно впечатляющим "Audio Options Menu", дающим опять таки возможность установки различных аудиопараметров. Во первых, тот же "Phoenix BIOS" вместо приведенной опции "Audio Controller" может предложить "Sound", включение которой и вызывает нижеприведенный перечень опций.
x Base I/O address
- опция установки основного I/O-адреса (адрес порта ввода/вывода). Возможны варианты: "220 - 22F", "240 - 24F", "260 - 26F", "280 - 28F". Тот, кто давно работает со звуковыми картами, тот уже "прикипел" к адресу 220.
x MPU I/O address
- опция установки MPU I/O-адреса (адрес порта ввода/вывода). MPU - MIDI Processing Unit. Звуковые карты должны быть совместимы с интерфейсом MPU-401 фирмы "Roland", так как большинство игр всегда было ориентировано и на этот интерфейс, и на "General MIDI". Возможны варианты: "300 - 301", "330 - 331". В данном случае более привычен адрес 330.
x Interrupt
- опция установки системного прерывания. Возможные значения: IRQ2, IRQ5, IRQ7, IRQ10. По умолчанию устанавливается IRQ5.
x 8-bit DMA channel
- выбор 8-битного DMA-канала. Совместимость с "Sound Blaster Pro" превыше всего. Возможны варианты: DMA0, DMA1 (по умолчанию), DMA3.
x 16-bit DMA channel
- выбор 16-битного DMA-канала. Возможны варианты: DMA5 (по умолчанию), DMA6, DMA7.
Основные параметры установлены. Но есть и другие BIOS, а отсюда и разные наименования аналогичных опций:
"Audio",
"Audio Device",
"On-Board Audio",
"Onboard Audio Chip",
"Audio DMA Select",
"Audio I/O Base Address",
"On-Board Audio Address" с параметрами: 220h, 230h, 240h, 250h,
"Audio IRQ Select",
"MPU-401 Configuration" с параметрами: "Enabled", "Disabled",
x "MPU-401 I/O Base Address".
И снова "Phoenix BIOS":
Midiport
- значения опции:
"Enabled" - мидипорт интегрирован на плате. При этом предоставляется возможность ручного конфигурирования ресурсов,
"Auto" - конфигурирование с помощью BIOS производится автоматически,
"Disabled" - мидипорт отсутствует или заблокирован,
"OS Controlled" - ресурсы мидипорта назначаются операционной системой.
x Base I/O Address
- возможные значения: "330h", "300h".
x Interrupt
- возможные значения: "IRQ3", "IRQ4", "IRQ5", "IRQ7", "IRQ9", "IRQ10".
Audio Output
- очень интересная дополнительная опция "Phoenix BIOS", регулирующая выходные характеристики встроенной аудиосистемы. Возможные значения:
"Line Level" - устанавливается при подключении активных громкоговорителей, т.е. полноценной акустической системы,
"Full Power" - устанавливается при подключении пассивных динамиков или наушников.
Аналогичная опция того же "Phoenix BIOS" "Audio Output Level" предлагает и аналогичные параметры: "Line Level" и "Amplifier Level".

8. Клавиатура и флоппики

В клавиатурах первых "персоналок" использовался микроконтроллер 8048. В более поздних моделях стала применяться микросхема 8049 со встроенной ROM-памятью или некоторые другие.
Еще в компьютерах PC/XT на системной плате располагалась микросхема 8255, применявшаяся для связи с последовательным интерфейсом клавиатуры. Эта микросхема присоединялась к контроллеру прерываний через линию IRQ1. Сами данные от микросхемы 8255 передавались в процессор через порт ввода/вывода с адресом 60h.
В компьютерах класса AT последовательный интерфейс клавиатуры оказался подключенным к специальному контроллеру клавиатуры на системной плате. В качестве такого контроллера стала применяться микросхема 8042. При этом функции порта 60h не изменились. При необходимости работы в командном режиме или проверки состояния контроллера клавиатуры на системной плате может быть использован порт ввода/вывода с адресом 64h.
В старых системах контроллер 8042 использовался также для управления адресной линией A20.
KBC Input Clock
- контроль частоты тактового сигнала контроллера клавиатуры. Параметром задается, проще говоря, скорость, с которой центральный процессор связывается с контроллером клавиатуры. Таким образом, параметр служит для изменения скоростных характеристик работы клавиатуры и повышения стабильности ее работы. Значение параметра как "12 MHz" устанавливается по умолчанию. Если возникли проблемы при работе с клавиатурой, необходимо уменьшить значение параметра. Параметр может принимать значения: "8 MHz", "12 MHz", "16 MHz".
Опция также может носить названия: "KBC Input Clock Select", "Кeyboard Controller Clock".
В общем-то, это уже устаревшая функция, позволявшая в соответствии со спецификациями инсталлированного контроллера клавиатуры устанавливать либо фиксированные значения, например, 7.16 МГц, 9.5 МГц, другие значения, либо получать значения как частное от частоты системной или локальной шины. Опция "Кeyboard Controller Clock" как раз является хорошим примером сказанному, предлагая следующие значения: "7.16 Mhz" (по умолчанию), "PCICLKI/2", "PCICLKI/3", "PCICLKI/4".
Keyboard Reset Control
- опция контроля за пеpезапуском с клавиатуpы. Пpи установке опции в "Enabled" имеется стандартная возможность пеpезапуска компьютера пpи использовании набора клавиш <CTRL>+<ALT>+<DEL>.
Фактически эта опция изначально предназначалась для управления аппаратным сбросом процессора через контроллер клавиатуры, а в системах на 286-х процессорах служила для переключения из защищенного режима работы в реальный.
Typematic Rate Setting
- (установка скорости ввода символов). Эта опция возможно позволит устранить не совсем правильные режимы работы клавиатуры. Прежде всего необходимо установить значение опции в "Enabled" (по умолчанию - "Disabled"). Установка в "Disabled" блокирует доступ к следующим функциям: "Typematic Rate" и "Typematic Delay".
Опция также может носить название "Typematic Rate Programming". Правда, значения параметра могут оказаться несколько иные: "Default" и "Override". По умолчанию устанавливается, например, 30 или 60 символов в сек. и 250 мсек. (см. ниже). "Override" аналогично же "Enabled".
x Typematic Rate (Chars/Sec)
- эта опция позволяет регулировать скорость ввода символов с клавиатуры, но только при включенном состоянии опции "Typematic Rate Setting". С ее помощью устанавливается временная характеристика - количество сигналов повторения нажатой и не отпущенной клавиши за цикл, которое может изменяться от 6 до 30 символов в секунду (в некоторых вариациях BIOS до 60), т.е. задается частота автоматического повторения символов клавиатуры. Установка большего значения позволяла, например, при работе с "MS-DOS" ускорить передвижение курсора. По умолчанию, как правило, устанавливается 6 символов в сек. Опция может иметь нестандартные значения: "Fast" и "Slow".
x Typematic Rate Delay (msec)
- (задержка повторения в мсек.). Эта опция регулирует вторую временную характеристику - задержку перед автоповтором нажатой клавиши, которая может меняться от 0,25 до 1 сек., т.е. значение задержки от момента нажатия клавиши до начала повторения символа клавиатурой. Значение может быть выбрано из ряда: 250 (по умолчанию), 500, 750 или 1000 мсек. Опция также функционирует только при включенном состоянии опции "Typematic Rate Setting".
Опция также может носить название "Typematic Delay (Msec)".

Ну а теперь остановимся на "Phoenix BIOS". Во многих версиях, достаточно современных, пользователю предоставляется возможность работы в специализированном подменю под названием "Keyboard Submenu" (или "Keyboard Features"). Кое-что здесь представляет несомненный интерес.
"Num Lock" или "Numlock":
"Auto" - состояние клавиши устанавливается во включенное, если дополнительная цифровая клавиатура автоопределена,
"On",
"Off".
"Key Click":
"Enabled" - при нажатии любой клавиши генерируется тоновый (читай, звуковой) сигнал,
"Disabled" (по умолчанию) - беззвучный вариант.
"Keyboard auto-repeat rate": "2/sec", "6/sec", "10/sec", "13.3/sec", "18.5/sec", "21.8/sec", "26.7/sec", "30/sec".
"Keyboard auto-repeat delay": "1/4 sec", "1/2 sec", "3/4 sec", "1 sec".

Floppy Disk Access Control (R/W)
- функция может находиться в меню "BIOS FEATURES SETUP" и определять возможность чтения/записи на дискеты. Включение опции как "Read only" позволит защитить информацию от несакционированного копирования с компьютера. Некоторые BIOS в качестве значений параметра имеют обычные "Enabled" и "Disabled". В этом случае разрешение этого параметра позволяет записывать информацию на дискету, а в противном случае дискету можно только читать.
"Phoenix BIOS" содержит аналогичную опцию под названием "Diskette Write". "Enabled" позволяет производить любые операции с дискетами (по умолчанию), "Disabled" же аналогично "Read only". Опция может называться и "Diskette Write Protect".
"AMI BIOS" содержит аналогичную опцию под названиями "Floppy Access Control" или того проще, "Floppy Access", с параметрами "Read-Write" ("Read/Write" - по умолчанию) и "Read-Only" ("Read Only").


BIOS. Продолжение!

10. Serial, Parallel, ...

Последовательный интерфейс

Внимание!!! При не совсем корректном поведении "мыши" (неустойчивая работа, скачки, неравномерное движение) надо обратить свое внимание на установки BIOS. "Мышь" может быть подключена к последовательному порту на базе микросхемы 16550. В этом случае возможно придется отключить аппаратные функции микросхемы, чтобы она действовала как более старая микросхема 8250. В "BIOS Setup" этот параметр может быть обозначен как включение и отключение FIFO (аппаратного буфера очереди).

COM1/2 MIDI
- опция переключения портов COM1 или COM2 в режим совместимости с MIDI-интерфейсом. Осуществляется это через "Enabled", естественно при подключении MIDI-устройства к одному из COM-портов.
Функция может называться "Serial Port 1/2 MIDI".
MIDI (Musical Instrument Digital Interface - "цифровой интерфейс музыкальных инструментов) - стандарт, предложенный в 1983 г. фирмой "Roland" и тогда же утвержденный. Стандарт определялся как интерфейс обмена цифровой информацией между различными музыкальными устройствами, его поддерживающими. Стандарт MIDI был установлен благодаря усилиям производителей электронных музыкальных инструментов (ЭМИ), и жестко определял протокол передачи информации между ЭМИ, а также различными дополнительными устройствами - секвенсорами, семплерами и т.д. Передача данных в интерфейсе осуществляется аналогично тому, как это происходит в последовательном интерфейсе ПК - т.е. порциально, в виде отдельных коротких сообщений. Электрически интерфейс MIDI представляет собой соединение типа "токовая петля".
При переключении портов COM1 или COM2 в режим совместимости с MIDI-интерфейсом частота тактирования приемопередатчика порта повышается, чтобы при настройке на стандартную скорость 28800 бит/с (делитель частоты 4) порт фактически работал на стандартной для MIDI скорости 31250 бит/с. Однако это не делает последовательный порт программно совместимым с MIDI-портом звуковых карт; понадобится еще и программная поддержка обычного COM-порта.

IrDA - аббревиатура от "Infrared Data Association". Иногда можно встретить в литературе "D", как "Device", но это неверно. Ассоциация была создана в 1993 г. для решения накопившихся проблем по обеспечению совместимости оборудования от разных производителей, а также для стандартизации подходов к IrDA-интерфейсу. Создание такой ассоциации - один из успешных примеров взаимодейстия различных разработчиков, производителей аппаратного и программного обеспечения, направленного прежде всего на рынок. Примеров тому немало, прежде всего, "MPEG", "VESA" и т.п. Такое же буквосочетание закрепилось и как название интерфейса с использованием инфракрасного порта, обеспечивающего беспроводное подключение периферийных устройств низкого и среднего быстродействия, которые расположены в непосредственной близости от ПК.
Корректная работа приемопередатчиков инфракрасного диапазона может осуществляться на расстоянии нескольких метров. Для инфракрасного излучения непреодолимым препятствием являются стены помещений. Отсюда и ограничения по применению интерфейса. Интерфейс работает по тому же принципу, что и пульты управления бытовой радиоаппаратурой. IrDA-интерфейс "встраивается" в современные компьютеры, им обладают некоторые модели принтеров, проекционных аппаратов, т.п.
В процессе выработки стандартов появилось и разделение систем по скоростным характеристикам, хотя в данном случае, что является причиной, а что следствием? Низкоскоростные системы работают на скоростях до 115,2 Кбит/с, системы средней скорости - до 1,152 Мбит/с. Высокоскоростные системы пригодны даже для обмена информацией между компьютерами, поскольку скорость обмена достигает 4 Мбит/сек. В настоящее время действует стандарт IrDA 1.1, а также собственные системы компаний "Hewlett- Packard" (HP-SIR - Hewlett-Packard Slow Infra Red) и "Sharp" (ASK - Amplitude Shifted Keyed IR). Протокол последовательного интерфейса IrDA версии 1.0 обеспечивал пропускную способность в пределах от 2,4 до 115,2 Кб/с и позволял работать с клавиатурой, мышью, принтером, динамиками, т.п. Версия протокола 1.1 повысила пропускную способность до 1,152-4 Мбит/с. По значениям скоростей обмена это выглядит также следующим образом:
Sharp ASK - 9,6-57,6 Кбит/с,
IrDA SIR (Slow Infra Red), HP-SIR - 9,6-115,2 Кбит/с,
IrDA MIR (Middle Infra Red) - до 1,152 Мбит/с,
IrDA FIR (Fast Infra Red) - до 4 Мбит/с.
И еще! "Amplitude Shift Keying" - метод манипуляции сдвигом амплитуды, или проще говоря, метод амплитудной модуляции.
На скоростях до 115,2 Кбит/сек для инфракрасной связи используются приемопередатчики UART, совместимые с микросхемами 16450/16550. Это означает, что для инфракрасной связи может использоваться один из COM-портов (COM2). Для подключения устройств, обеспечивающих интерфейс, используется разъем системной платы (IR Connector).
На средних и высоких скоростях применяются специализированные микросхемы, ориентированные на интенсивный программноуправляемый обмен или DMA, с возможностью использования режима "Bus-Master".
IR Connector (разъем для инфракрасного излучателя/приемника) подключается к одному из встроенных COM-портов (обычно COM2) и позволяет установить беспроводную связь с любым устройством, снабженным подобным излучателем и приемником.
Внимание! Если в ПК нет встроенного ИК-порта, то для его организации используется специализированный адаптер, подключаемый к разъему ИК-связи (SIP - Serial Infrared Port) на материнской плате или к разъему последовательного порта RS-232C.

UART2 Mode Select
- наличие такой опции в "BIOS Setup" означает, что системная плата поддерживает IrDA-функцию. Сама же опция является "подчиненной", поскольку ее активирование напрямую связано с предварительным включением опции "Onboard Serial Port 2" или ей аналогичной. Хотя могут существовать и более "хитрые" варианты. Но, как правило, опция установки режима инфракрасного интерфейса становится недоступной, если в системе отключен соответствующий последовательный порт.
Если используется последовательный порт COM2, то это поле нужно установить в "Normal". В остальных случаях эта опция служит для установки типа, или можно сказать, спецификаций IrDA-стандарта, поддерживаемого IrDA-периферийным устройством. Правда, значение "Standard" в разных версиях BIOS может обозначать и стандартный RS-232C-интерфейс, и поддержку последовательного инфракрасного интерфейса. При активировании IrDA-функции становятся доступными пользователю опции "RxD, TxD Active" и "IR Transmission Delay". Приводим почти все множество возможных вариантов используемых значений:
"Normal",
"Default" - порт функционирует как стандартный последовательный порт,
"Standard" - см. выше,
"IrDA 1.0" (или просто, "IrDA") - инфракрасный интерфейс, совместимый со спецификацией 1.0,
"IrDA 1.1" - инфракрасный интерфейс, совместимый со спецификацией 1.1,
"IrDA SIR" или "SIR",
"IrDA MIR" или "MIR",
"MIR 0.57M" - инфракрасный порт со скоростью в 0,57 Мбит/сек.,
"MIR 1.15M" - инфракрасный порт со скоростью до 1,152 Мбит/сек.,
"IrDA FIR" или "FIR",
"Sharp IR" - интерфейс со скоростью передачи до 4 Мбит/сек.,
"HPSIR" - поддержка инфракрасного интерфейса с форматом фирмы "Hewlett-Packard",
"ASKIR" - Amplitude Shift Keyed Infrared port,
"Consumer",
"Disabled" - второй последовательный порт отключен.
В разных версиях BIOS аналогичная функция может называться "UART 2 Mode", "Onboard UART 2 Mode", "Infra Red Function", "IR Mode Select", "UR2 Mode", "UART2 Use Infrared", "Onboard IR Function", "IR Function", "Serial Port2 Mode", "Serial 2 Mode" или "Serial Mode".
Еще одна интересная опция (опять таки только для второго порта) - "Mode". И еще один вариант возможных значений:
"Normal",
"IrDA",
"ASK-IR",
"MIDI" - порт используется как MIDI-порт.
Еще одна опция - "Serial Port 2 IR Mode", и с минимальным набором значений: "Disabled" (по умолчанию) и "Enabled".
x RxD, TxD Active
- опция установки полярности сигналов приема/передачи инфракрасного интерфейса. Стоит упомянуть, что "RxD" означает receiver (приемник), а "TxD" - transmitter (передатчик). Для установки параметра необходимо из документации выяснить, в каком режиме должны работать эти сигналы приемопередатчика. В качестве значений используются комбинации параметров "High" и "Low". Опция может принимать значения: "Hi,Lo", "Lo,Hi", "Lo,Lo" и "Hi,Hi".
x IR Transmission Delay
- при выборе "Enabled" устанавливается режим медленной передачи данных, что может быть рекомендовано при появлении ошибок. Установка в "Disabled" снимает ограничения (задержки) на скоростные характеристики интерфейса.
IR Duplex Mode
- опция для выбора дуплексного или полудуплексного режима работы инфракрасного порта. По умолчанию устанавливается "Half". Другим значением является естественно "Full" (дуплекс). Стоит напомнить, что под дуплексом понимают двунаправленную передачу данных, которая может происходить в двух направлениях в одно и то же время. При полудуплексе передача данных в некий момент времени происходит только в одном направлении. Эта опция доступна, если функция "UART2 Mode Select" (или ей аналогичная) установлена в "HPSIR" или "ASKIR". В некоторых редких случаях к стандартным двум значениям опции может быть добавлено третье - "N/A" (нет ответа). Пожалуй, действительно нет ответа.
В некоторых версиях BIOS аналогичная функция может называться "IR Transfer Mode", а параметры могут звучать как "Half-Duplex" и "Full-Duplex". Опция может называться также "UR2 Duplex Mode", "UART 1/2 Duplex Mode", "Duplex Mode", "Duplex Select", "InfraRed Duplex Type", "IR Function Duplex", "IR Transmission Mode".
В некоторых случаях в параметрах установки может появиться значение "Disabled", как отказ от использования инфракрасного порта. Присутствие в наименованиях опций конкретного указания на второй последовательный порт может говорить только об одном: соединительный кабель уже опциально подключен ко второму последовательному порту, использование первого последовательного интерфейса в качестве инфракрасного не допускается и т.п.

Параллельный интерфейс

Существует четыре основных типа параллельных портов: однонаправленный, двунаправленный, EPP и ECP. Большинство современных компьютеров поддерживают все эти режимы.
Однонаправленный. Самый простой, медленный и устаревший вариант. Этот интерфейс был 4-разрядным. Данные могли передаваться только в одном направлении со скоростью около 40-80 Кб/с. Функционирование порта было возможно через линии состояния.
Стандартный параллельный порт (Standard Parallel Port). Как правило, обозначается как "Normal" или "SPP". Это 8-разрядный порт вывода с возможностью чтения сигналов с выходных линий, с синхронизацией по опросу или по прерываниям и максимальной скоростью передачи данных от ПК к периферийному устройству, равной 140 Кб/с. Сигнальные линии порта обеспечивают обратную связь с принтером или другим устройством. При помощи такого порта можно связать два компьютера. Обмен данными при этом осуществляется тетрадами. Порт может использоваться для ввода информации по линиям состояния, максимальная скорость ввода при этом примерно вдвое меньше.
Двунаправленный порт типа 1. Этот 8-разрядный порт впервые появился в ПК семейства PS/2 фирмы "IBM". В компьютерах PC он обозначается как параллельный порт типа PS/2. Скорость передачи данных - от 80 до 300 Кб/с и зависит от производительности подключенного устройства и программного драйвера. Передача данных в обоих направлениях в штатном режиме позволяет внешнему устройству сообщать детальную информацию о своем состоянии.
Двунапрвленный порт типа 3 стал новым шагом корпорации "IBM" в развитии своей технологии. Порт обладает очень высокой производительностью благодаря использованию прямого доступа к памяти (DMA).
EPP (Enhanced Parallel Port) - усовершенствованный параллельный порт. Двунаправленный протокол EPP был разработан фирмами "Intel", "Xircom" и "Zenith Data Systems" для высокоскоростных устройств, например, внешних накопителей, сетевых адаптеров, ZIP- и CD-ROM-дисководов, и позволяет достичь скорости в 2 МБ/с, максимальной скорости передачи данных для параллельных портов. При разработке этого варианта интерфейса было изменено назначение некоторых сигналов, введены 8-разрядный ввод данных, 16-байтовый аппаратный FIFO-буфер, возможность адресации нескольких логических устройств. Последнее сделало возможным обращение к нескольким устройствам в случае, если каждое из них подключено "сквозь" другое. Когда при установке режимов в "BIOS Setup" выбирается EPP, возможно (зависит от версии BIOS) будет предложено выбрать версию такого порта: 1.7 или 1.9. Для большинства периферийных устройств, выпущенных в последние годы, следует выбрать "EPP 1.9".
ECP (Enhanced Capabilities Port) - порт с расширенными возможностями. В 1993 г. "Hewlett-Packard" и "Microsoft" разработали протокол ECP, позднее включенный в стандарт IEEE 1284. Он был предназначен специально для подключения к компьютерам высокоскоростных периферийных устройств (сетевых принтеров, сканеров, цифровых видеокамер, т.п.), для увеличения скорости, улучшения двустороннего общения между устройством и компьютером, а также для повышения мощности сигналов при соединении с периферией. Протокол стал обеспечивать скорость передачи до 2,5 МБ/с. В ECP также была реализована возможность одновременного подключения нескольких периферийных устройств. Если принтер (или другое периферийное устройство) поддерживает ECP, можно получать отчеты о состоянии и ошибках непосредственно от устройства. Кроме того, введены возможность разделения передаваемой информации на команды и данные, поддержка DMA и сжатия передаваемых данных методом RLE (Run-Length Encoding - кодирование повторяющихся серий).
Чтобы внешний MPEG-декодер (устройство захвата видео) на параллельном интерфейсе достиг оптимальной скорости передачи данных, последний должен быть сконфигурирован в BIOS как ECP. Необходимо помнить, что эта эффективность достигается и за счет выделения собственного DMA-канала. При наличии проблем с режимом "ECP" следует перейти на более "спокойный" "EPP".

Parallel Port Mode
- (режим работы параллельного порта). Естественно, что эта опция не может быть активной при запрещении использования параллельного порта. Параметр позволяет задать режимы работы параллельного порта в соответствии со стандартом IEEE 1284. Однако надо помнить, что существуют устройства, выполненные с отклонениями от стандарта IEEE 1284, например, некоторые платы (устройства сопряжения) от фирмы "Xircom". Для совместимости с такими платами в большинстве версий BIOS существуют различные параметры установки режима "ECP+EPP". Какую версию режима выбрать, необходимо выяснить из документации на подключаемое устройство или проверить экспериментально.
Следует учитывать, что скорость обмена для некоторых устройств может быть существенно увеличена при правильной установке режима работы порта принтера, например, для внешних устройств хранения информации типа Iomega ZIP.
Может принимать значения: "Normal" (или "SPP"), "EPP", "ECP", "ECP + EPP" (интегрированная опция).
Функция может называться "Onboard Parallel Mode", "Parallel Mode" или "Parallel Port Type".
Опция может называться и просто "Mode", но если речь идет о конфигурационном меню параллельного порта.
В современных версиях "AMI BIOS" режимы работы параллельных портов имеют следующие наименования: "Compatible" (AT/PC- совместимый, что означает простейший однонаправленный порт. Иногда такой параметр может называться "Output Only"), "Bi-directional" (двунаправленный), а также "EPP" и "ECP".
x ECP DMA Select
- (выбор канала DMA для режима ECP). Параметр активизируется только при разрешении режима "ECP" или "ECP+EPP". Может принимать значения: "1" (или, например, "DMA 1"), "3" (по умолчанию), "Disabled" (запрещено использовать DMA-канал, или "N/A"). При выборе режима ECP порт будет использовать 8-разрядный канал DMA к памяти шины ISA (обычно DMA3).
Функция может называться "ECP Mode Use DMA", "Parallel Port DMA Channel" или просто - "DMA Channel".
x EPP Mode Select
- аналогично, как и для "ECP". Возможный выбор параметра: "EPP 1.7", "EPP 1.9". Как правило "1.9" стабильнее и быстрее. К сожалению информации по этому вопросу очень мало.
Функция может называться "Parallel Port EPP Type" или "EPP Version".


BIOS. Продолжение!

11. HD

32 Bit I/O
- данная опция "Phoenix BIOS" предлагает два значения:
"Enabled" - передача данных между системной шиной (процессор, память) и IDE-интерфейсом будет производиться с шириной полосы в 32 бита. Устанавливается по умолчанию,
"Disabled" - ширина полосы пропускания составляет 16 бит.
Опция может называться "IDE 32-bit Transfer Mode" или "32-bit Disk Access". Опция "AMI BIOS" может именоваться "32 Bit Transfer Mode", а ее значениями будут "On" и "Off".
Естественно, что установка "Enabled" (или "On") допускается, если локальная шина поддерживает 32-разрядную передачу данных (речь идет, прежде всего о PCI). В то же время речь идет вовсе не о жестком диске. Достаточно рассмотреть назначение 40 контактов разъема жесткого диска и увидеть 16-разрядную структуру данных. Это означает, что интерфейс жестких IDE-дисков 16-битный. Решение задачи берет на себя контроллер интерфейса, объединяя два 16-битных цикла чтения в одно двойное слово. Тем самым повышается эффективность работы PCI-шины.
Установив "Disabled", пользователь не снижает скоростные характеристики процессов чтения/записи в самом жестком диске, но при этом снижается общая производительность IDE-интерфейса.
К сожалению, запрещение 32-битного доступа может потребоваться для пользователей "WindowsNT 4.0". Так рекомендует сама "Microsoft": из-за возможности искажения данных при их передаче. Некоторые проблемы были сняты еще с выпуском "Service Pack 2", но как знать?!.

Hard Disk Access Control
- эта опция, в отличие от "Floppy Disk Access Control (R/W)", была замечена только в "AMI BIOS". Назначение же абсолютно идентично. Значения параметра таковы: "Read-Write" или "Read-Only".

Hard Disk Read Ahead 1
Hard Disk Read Ahead 2
- (опережающее чтение жесткого диска 1(2)). Попробуем понять смысл т.н. опережающего чтения. Если с носителя читается сектор данных z, то вполне вероятно, что следующей командой в следующий момент времени будет произведено чтение сектора z+1. Если система предоставляет возможность прочитать оба сектора сразу, в одном блоке данных, то это будет иметь значительный эффект при удачном предсказании последующей операции чтения. Реакция на команду чтения в отношении сектора z+1 будет мгновенной, т.к. данные будут уже находиться в специальном кэш-буфере.
Данная опция "Phoenix BIOS" предлагает два значения, "Enabled" и "Disabled", последнее из которых необходимо при работе с "Windows NT" или "OS/2".

HDD S.M.A.R.T. Capability
- (возможность S.M.A.R.T. диагностики). Опция позволяет разрешать/запрещать диагностику состояния жесткого диска в соответствии с требованиями S.M.A.R.T.-спецификаций. Авторы BIOS, к сожалению, не раскрывают механизма функционирования S.M.A.R.T.-диагностики в BIOS, поэтому не совсем понятно, каким образом обрабатывается информация от жесткого диска, так как граничные значения параметров жесткого диска зависят от конкретного производителя. Предполагается, что S.M.A.R.T. генерирует для BIOS или драйвера операционной системы отчет о возникшей неполадке. При разрешении параметра и нарушении нормального функционирования жесткого диска BIOS выдает на экран соответствующее сообщение до появления таблицы с характеристиками компьютера. Может принимать значения:
"Enabled" (разрешено),
"Disabled" (запрещено).
"AMI BIOS" содержит аналогичную функцию под названием "S.M.A.R.T. for Hard Disks", а "Phoenix BIOS" - "SMART Monitoring".

S.M.A.R.T. (Self-Monitoring, Analysis And Reporting Technology - "Самоконтроль, анализ и отчетность") - технология, разработанная и предложенная компаниями "IBM" и "Compaq", ставшая открытым промышленным стандартом и поддержанная позднее компаниями "Seagate", "Quantum", "Western Digital" и др. Впервые технология была разработана в 1992 г. "IBM" и коснулась она прежде всего SCSI-устройств. Лишь в 1995 г. технология была реализована для IDE/ATA-интерфейса. Стандарт изначально был направлен, прежде всего, на усовершенствование доступа к дисковой информации и на повышение надежности хранения данных.
S.M.A.R.T. позволяет контролировать множество параметров накопителя, осуществляя раннюю диагностику и профилактику сбоев, формировать прогноз и предупреждать о возможных проблемах накопителя и т.п. К контролируемым параметрам можно отнести, например, высоту полета головок над поверхностью диска, скорость передачи данных, количество перенесенных (передвинутых в другие области) секторов и неудачных попыток чтения и записи и т.п.
Для анализа надежности жесткого диска используются две группы параметров. Первая характеризует параметры естественного старения жесткого диска:
- количество циклов включения/выключения (старт/стоп),
- количество оборотов двигателя за время работы,
- количество перемещений головок.
Вторая группа параметров информирует о текущем состоянии накопителя. К этим параметрам относятся:
- расстояние между головкой и поверхностью диска,
- скорость обмена данными между поверхностью носителя и дисковой кэш-памятью,
- количество переназначений плохих секторов (когда вместо испорченного сектора подставляется свободный исправленный),
- количество ошибок поиска,
- количество операций перекалибровки,
- скорость поиска данных на диске.
Обычно вся эта информация записывается на серводорожках, недоступных аппаратным и программным средствам общего пользования.
Технология S.M.A.R.T. прошла в своем развитии через 3 стадии: от мониторинга совокупности определенных параметров диска и обеспечения предсказания ошибок через выполнение ряда профилактических операций в состоянии ожидания или покоя (idle mode) до определения сбойных секторов с попытками их восстановления. Все эти алгоритмы уже реализованы в электронике современных дисков.
Вкратце наименования некоторых "фирменных" технологий:
"Quantum" - SPS (Shock Protection System), DPS (Data Protection System),
"Seagate" - SeaShield,
"IBM" - DFT (Drive Fitness Test), Drive-TIP (Temperature Indicator Processor),
"Western Digital" - Data Lifeguard.

IDE Buffer for DOS & Win
- опция разрешения/запрещения использования чипсетом предназначенного для IDE-интерфейса буфера упреждающего чтения (read-ahead) и отложенной записи (posted-write). "Enabled" устанавливается по умолчанию. В некоторых версиях BIOS данная опция предлагает изменять размер такого буфера. Включая буфер или увеличивая размер буфера, пользователь может повысить пропускную способность при работе с IDE-устройствами. Правда, в зависимости от конкретной конфигурации ПК, существует возможность, что более медленные IDE-устройства могут заработать еще медленнее. Так что включение опции (или изменение размера буфера) потребует опытной проверки. Стоит отметить, что эта опция уже не встречается в таком виде.

IDE Burst Mode
- установка данной опции в "Enabled" приводит нас к рассмотрению нескольких важных положений. Во-первых, на командном уровне управления жесткими дисками нет т.н. "пакетных" команд. Речь может идти об операциях множественного чтения/записи, о "слиянии" пакетов, т.п. Тогда в этом случае данная опция, вроде бы, ничем не отличается от тех функций, с помощью которых устанавливаются режим блочной передачи данных и размер блока. Но как увидим ниже, здесь речь идет о возможностях интерфейса, а не только жесткого диска.
Во-вторых, жесткий диск может иметь "на своем борту" достаточно объемный буфер, обращение к которому со стороны интерфейса происходит как к кэш-памяти. Ведь именно по отношению к работе с кэш-памятью в свое время и вводились механизмы "потоковых" операций. Стоит напомнить, что современные EIDE-диски обладают буфером размером в 2 МБ и выше. Но все же назначение буфера состоит в том, чтобы минимизировать затраты времени при обращении к дисковой информации. Присутствие необходимой информации в дисковом кэше значительно повышает производительность всей дисковой системы.
И в третьих, основная "тяжесть" решения задачи с пакетированием дисковой информации ложится на контроллер (точнее, контроллеры) интерфейса и на "приписанные" к интерфейсу различные буферы, о которых и идет речь в других опциях.
Данная опция появилась уже давненько. Не должно вызывать удивления предупреждение в старой документации, что жесткий диск должен поддерживать эту функцию. Тут как раз и идет речь о поддержке диском операций множественного чтения/записи. Понятно, что для современных дисков такой проблемы нет. Если никаких препятствий для включения опции нет, то она и должна быть включена.
Опция может называться также "IDE Bursting".

IDE Data Post Write
- установив "Enabled", можно значительно ускорить процессы чтения/записи IDE-интерфейса. Но если интерфейс не содержит буфера отложенной записи, то включение опции может вызвать нестабильность в работе IDE-интерфейса. Появление ошибок потребует установки значения "Disabled".
Опция может называться также "IDE Data Port Post Write", "IDE Fast Post Write".
Функция может быть представлена в виде двух опций (для каждого из каналов): "Primary IDE Post Write Buffer", "Secondary IDE Post Write Buffer" и со значениями "Disabled", "Enabled", "5T", "6T".
Функция может быть представлена и в виде комбинированных опций:
"PM: Prefetch And Posting" (Primary Master)
"PS: Prefetch And Posting" (Primary Slave)
"SM: Prefetch And Posting" (Secondary Master)
"SS: Prefetch And Posting" (Secondary Slave)
Цифровые значения, встречающиеся в подобных опциях, указывают на количество тактов ожидания, установка которых может потребоваться для увеличения стабильности работы интерфейса.
Дополнительную информацию см. ниже в опции "IDE Prefetch Buffer".

IDE DMA Transfer Mode
- опцией устанавливается режим передачи по DMA-каналам для IDE-интерфейса. Опция предоставляет следующие значения:
"Disabled",
"Type B" (for EISA),
"Standard" (для PCI). Наиболее быстрый режим, однако могут возникнуть проблемы с устройствами CD-ROM, а точнее с ATAPI-интерфейсом. Стандартный режим обозначается также как "type F" (см. дополнительно раздел "DMA").

Хотя режимы программируемого ввода-вывода (PIO) являются стандартным методом, поддерживаемым в серийных устройствах IDE (см. ниже), и отличаются высокой совместимостью, существуют и другие способы повышения скорости обмена с жесткими дисками. Режимы PIO в дисковых контроллерах IDE получили более широкое распространение, в сравнении с режимами DMA, в связи с тем, что прерывание BIOS Int 13 и драйверы операционных систем поддерживают режим PIO, а не DMA. Уточним, режимы PIO поддерживаются всеми без исключения системами. Это означает, что для использования режимов DMA требуется поддержка со стороны BIOS, необходимы специальные контроллеры, а также драйверы для разных платформ и, что вполне естественно, учитывающие специфику как отдельных чипсетов, так и конкретных устройств. Поэтому, да и по другим причинам также, в однозадачных системах более предпочтительными являются режимы PIO, в многозадачных же - режимы DMA.
Метод "прямого доступа к памяти" (DMA) основан на передаче данных между диском и памятью компьютера без использования центрального процессора. Тип B для DMA в свое время был определен в спецификации EISA и обеспечивал обмен со скоростью 4 МБ/сек. Этот метод давал преимущество в сравнении со стандартной скоростью для шины ISA, но уступал характеристикам SCSI-интерфейса.
С развитием технологии локальных шин, конкретно спецификации PCI, был предложен новый вариант обмена с использованием DMA - тип F, обеспечивающий скорость 8.33 и 16.67 МБ/сек. В соответствии с возможностями существовавших на тот момент электронных компонентов была предложена спецификация DMA Mode 1 с циклом 150 нсек., обеспечивающая скорость обмена до 13,3 МБ/сек. за счет передачи нескольких слов за один запрос (режим Multiword-DMA). Уже в конце 1993 г. была налажена поставка соответствующих комплектов микросхем для производителей жестких дисков и DMA-контроллеров.
Сразу необходимо отметить, что инициирование DMA-передачи данных занимает довольно много времени, поэтому такой режим работы имеет смысл только тогда, когда передаются друг за другом сразу несколько слов данных в течение одного сеанса работы с шиной. При одиночном режиме устройство для передачи каждого слова вырабатывает сигнал запроса DMARQ (DMA Request) и сбрасывает его по сигналу DMACK# (DMA Acknowledge), подтверждающему каждый цикл обмена. При множественном режиме на сигнал "DMARQ" хост отвечает потоком циклов, сопровождаемых сигналами "DMACK#". При этом запрос не снимается на весь период передачи данных.
Каждый из режимов PIO и DMA имеет несколько разновидностей, характеризующих способ обмена и длительность цикла передачи одного слова, от которых зависит скорость передачи. Режимы DMA делятся на однословные (single word) и многословные (multiword), характеризуются различными временными характеристиками циклов обмена. Отсюда и такое "разнообразие" (см. таблицу).

Режим DMA | Тактирование (минимальное время цикла), нс | Максимальная скорость передачи (МБ/с) | Спецификация
Single word
0 | 960 | 2,08 | АТА
1 | 480 | 4,16 | АТА
2 | 240 | 8,33 | АТА
Multi word
0 | 480 | 4,12 | АТА
1 | 150 | 13,3 | АТА-2
2 | 120 | 16,6 | АТА-2
Ultra DMA/33
UDMA/33 | 120* | 33,3 | Ultra ATA

* - необходимо учесть, что за каждый такт передаются два слова данных (используются и передний, и задний фронты тактирующего сигнала)

IDE FIFO Size
- опция установки размера IDE-буфера, построенного по принципу "первым пришел - первым ушел". Размер такого буфера был вполне приличным - 64 байта. Можно было выбрать либо полный размер буфера, либо половинный ("32 bytes"). Использование прошедшего времени указывает на древность этой опции.

IDE HDD Auto Detection
- опция, функция "BIOS Setup", позволяющая автоматически регистрировать в системе EIDE-устройства, а также некоторые IDE-диски. Эта же функция позволяет установить автоматически и режим работы жесткого диска, а точнее метод адресации, протокол обмена: Normal, LBA или же Large. Для более старых IDE-дисков возможны ошибки в процессе автоопределения параметров жесткого диска, и их параметры необходимо будет ввести вручную.
Представленная опция является наиболее привычной для массового пользователя, а с другой стороны, в таком виде она уже не способна решать проблемы современных компьютерных систем с дисками большой емкости. Вот как решает такие задачи опция "IDE Translation Mode":
"Standard CHS" - стандартное количество цилиндров (не превышает 1024), головок чтения/записи, секторов. Аналогично "Normal",
"Logical Block" - аналогично "LBA",
"Extended CHS" - расширенная адресация для дисков с физическим количеством цилиндров более 1024. Предназначено для дисков большой емкости,
"Auto detected" (по умолчанию) - по сути предназначено для дисков с LBA-трансляцией (Logical Block Addressing).
Внимание! Не все пользователи однозначно понимают принципы трансляции, установки параметров дисков и зачастую ошибаются в процессе автоопределения параметров. Грубейшей ошибкой являются попытки изменить тип трансляции (адресации) для отформатированных дисков с информацией. Для более детального изучения этой темы имеет смысл познакомиться со специальной литературой.
Вернемся к вопросу "ручных" установок параметров, которые обычно вынесены в "STANDARD CMOS SETUP". Расширенные версии BIOS хранят параметры различных типов жестких дисков (1 - 46) в соответствии с их характеристиками (число цилиндров, головок, секторов). Это своего рода анахронизм, который может оказаться полезным только в случае совпадения параметров Вашего жесткого диска и данных, хранящихся в постоянной памяти. Тип 47 (User Type) позволяет задать произвольные параметры диска, он же используется и при автоматическом определении характеристик жестких дисков через сервисы BIOS и самих дисков.
Для дисков ESDI и SCSI в поле типа дисковода необходимо указывать "None", т.к. контроллеры указанных жестких дисков произведут их идентификацию самостоятельно.
Одно важное замечание, хотя и не имеющее непосредственного отношения к опциям "BIOS Setup". При подготовке жесткого диска к установке в компьютер перемычка SP ("Slave Present"), или DSP ("Drive Slave Present"), устанавливается на "мастер"-диске для указания на присутствие в системе "slave"-устройства. Если джампер установлен, а "вторичный" диск не обнаружен, то POST выдает сообщение об ошибке.

Максим. к-во секторов (512 байт/сектор) | Максим. количество головок | Максим. количество цилиндров | Максим. емкость диска
63 | 16 | 1024 | 504 МБ
63 | 256 | 1024 | 8,4 ГБ
255 | 16 | 65536 | 136,9 ГБ

Normal - максимальное количество цилиндров ("C" от cylinder), головок ("H" от heads), секторов ("S" от sector) ограничено 1024, 16, 63 соответственно.
LBA (Logical Block Adressing) - "логическая адресация блоков". При таком способе адресации определенный блок данных на носителе задается не с помощью дорожки, головки, сектора, а его логическим адресом. Преобразование этого адреса в номер цилиндра, головки, сектора осуществляется внутри жесткого диска контроллером. LBA-адресация начала внедряться и использоваться в 1994 г. совместно со стандартом EIDE (Extended IDE). В те времена возникла интересная ситуация. Выпускавшиеся новые EIDE-диски очень часто устанавливались в устаревшие системы с BIOS, не поддерживавшим LBA. Жесткие диски поставлялись со специальными драйверами, которые производители дисков создали для обхода BIOS. И в более поздние времена не обходилось "без обмана", поскольку BIOS не в состоянии был воспринять число цилиндров свыше 1024. При установке LBA-режима в n раз уменьшается количество цилиндров, во столько же раз увеличивается число головок. При этом, к сожалению, уменьшается форматированная емкость диска при округлении дробного числа цилиндров. Метод LBA соответствует "Sector Mapping" для SCSI. BIOS SCSI-контроллера выполняет эти задачи автоматически, т.е. для жестких дисков SCSI-интерфейса метод логической адресации был характерен изначально.
Large - редко встречающийся на практике метод адресации. Предназначался для устройств, количество цилиндров у которых превышало 1024 (при емкости жесткого диска до 1 Гб), при этом такие жесткие диски не поддерживали LBA. !!! Жесткий диск, pазмеченный и отформатированный в pежиме LBA, несовместим с pежимом Large и наобоpот.

IDE HDD Block Mode
- если опция включена ("Enabled"), BIOS автоматически определяет, поддерживает ли жесткий диск "блочный" режим, и, если поддерживает, то включает эту поддержку. BIOS автоматически определяет оптимальный размер блока жесткого диска и контроллирует этот параметр в процессе чтения/записи данных. Использование этой опции позволит применить мультисекторное чтение/запись (передача данных по несколько секторов одновременно), что значительно повышает скорость работы. В обычном режиме контроллер жесткого диска передает данные в систему посекторно. Необходимо помнить, что не все старые жесткие диски могут работать в таком режиме. Если жесткий диск не поддерживает "Block mode", то необходима установка опции в "Disabled".
"Блочный" режим также называется block transfer, multiple commands или multiple sector read/write, а опция может называться также "IDE Block Mode", "IDE HDD Block Mode Sectors", "Multi-Sector Transfers". В некоторых случаях пользователю может быть предложен параметр "Maximum" (или "HDD Max"), устанавливающий количество секторов в блоке равным максимальному значению, что, однако, не всегда является оптимальным режимом для накопителя. Для установки наилучшего значения необходимо обратиться к документации жесткого диска.
"AMI BIOS" содержит аналогичную опцию под названием, как правило, "Multiple Sector Setting" с возможными значениями параметров: "Disabled", "Auto Detected" (по умолчанию), "4 sec/block" и "8 sec/block". В общем случае ко всем приведенным значениям (с учетом различных версий BIOS) можно добавить еще 2, 16 и 32 сектора в блоке.
Вниманию пользователей "Windows NT"! Работа в таком режиме в этой ОС может привести к потере информации на жестком диске, т.к. "Windows NT" не поддерживает блочный режим работы жестких дисков.

IDE Multiple Sector Mode
- если опция "IDE DMA Transfer Mode" включена, то предоставляется возможность установить количество секторов, передаваемых в едином блоке (в поточном режиме). Максимальное количество секторов ограничено 64-мя. Поскольку речь идет о "блочном" режиме передачи, то эта опция аналогична вышеприведенной.

Блок данных. Этот термин используется для обозначения фрагмента данных, передаваемого с помощью одного из режимов PIO. Блок данных передается между контроллером и устройством как единое целое. В большинстве случаев (за исключением команд "READ MULTIPLE", "WRITE MULTIPLE", "READ LONG" и "WRITE LONG" - реализуются также в PIO-режимах) блок данных представляет собой один сектор (512 байт).
Несколько дополнительных слов о командах IDE-интерфейса.
Identify Device - команда идентификации позволяет считать из контроллера блок из 256 слов, характеризующих устройство.
Write DMA, Read DMA - команды, реализующие DMA-режимы.
Read Multiple - команда чтения в блочном режиме. Блочный режим отличается от обычного (со стандартным обменом по PIO) тем, что запросы прерывания вырабатываются не на каждый сектор, а на блок секторов, размер которого задается командой Set Multiple Mode.
Блочный режим за счет сокращения числа прерываний, обслуживаемых процессором, в многозадачной системе позволяет повысить производительность работы жестких дисков на 30%. В однозадачной системе существенного выигрыша от блочного режима нет.
Read Long - команда "длинного" чтения считывает сектор данных (512 байт) вместе с контрольными байтами (их количество задается производителем диска и обычно составляет 4 байта). Данные считываются словами (16 бит), а контрольные байты - 8-битными, т.е. побайтно. Некоторые ATA-диски неспособны быстро передавать байты ECC вслед за данными. Для их считывания необходимо использовать низкоскоростной и 8-битный обмен по PIO Mode 0 и DMA 0 (режим "Single word").
Команды управления энергопотреблением:
Idle - команда переводит устройство в состояние ожидания,
Standby - команда перевода устройства в дежурный режим. Контроллер способен принимать команды, но доступ к носителю потребует определенного времени,
Sleep - перевод в режим "сна". Время "пробуждения" может доходить до 30 сек.

IDE PIO Modes
Primary Master
Primary Slave
Secondary Master
Secondary Slave
- опции-меню назначения каждому из возможно четырех жестких дисков EIDE-интерфейса оптимального PIO-режима (Programmed Input/Output). Возможные значения: "Auto" (по умолчанию), "Mode 0", "Mode 1", "Mode 2", "Mode 3", "Mode 4". Режимы 0..2 относятся к обычным IDE-дискам (стандаpт ATA), 3 и 4 - к EIDE (ATA-2), pежим 5 - к ATA-3. Понятно, что в автоматическом режиме система выберет для каждого из дисков наилучший скоростной режим передачи данных. Но надо помнить, что автоматическая установка PIO-режима производится в соответствии с возможностью автоопределения функционирования жесткого диска и объемом информации, полученным от устройства. Если у пользователя имеются сомнения в правильности автоопределения PIO-режима, то в соответствии с документацией на жесткий диск пользователь может изменить режим PIO для любого из дисков. BIOS в режиме "Auto" может также неправильно идентифицировать PIO-режим EIDE-диска, и последний не распознается. Для использования режимов 3 и 4 необходимо использование в системе EIDE-дисков. Необходимо знать, что некорректное повышение PIO-режима может привести к потере и разрушению информации на диске.
Возможна и такая ситуация! В "разогнанной системе" PCI-шина функционирует на повышенной частоте, что в свою очередь может привести к сбойной работе жестких дисков. В этом случае ситуацию можно попытаться спасти понижением PIO-режима.
Аналогичные (четыре!) опции могут называться также "IDE Primary Master PIO", "IDE Primary Slave PIO" и т.д.
Опция "Fast Programmed I/O Mode(s)" предлагает такие значения: "Disabled", "Auto detected", "PIO0", ... "PIO4". Опция с тем же названием неожиданно предложила значения "Disabled" и "Auto Detected" (по умолчанию), т.е. без возможности "ручного" подбора. Первое приводит к установке скоростных характеристик, меньших чем оптимальные, "Auto Detected" устанавливает максимально возможную скорость.
Опция может называться также "Mode PIO Transfer Data" или "Transfer Mode". Последняя опция предложила такой набор значений: "Auto", "Default" (равносильно "Fast PIO 1"), "Fast PIO 1", "Fast PIO 2", "Fast PIO 3", "Fast PIO 4", "FPIO 3 / DMA 1", "FPIO 4 / DMA 2". Понятно, что речь идет каждый раз о параметрах одного из четырех жестких дисков, или двух для более старых систем. В этом случае опции могут называться "IDE Master PIO Mode" ("Master Drive PIO Mode") и "IDE Slave PIO Mode" ("Slave Drive PIO Mode"), а их значения будут: "0", "1", "2", "3", "4", "Auto".

PIO режим | Тактирование (минимальное время цикла), нс | Максимальная скорость передачи (МБ/с) | Спецификация
PIO Mode 0 | 600 | 3.3 | ATA
PIO Mode 1 | 383 | 5.2 | ATA
PIO Mode 2 | 240 | 8.3 | ATA
PIO Mode 3 | 180 IORDY | 11.1 | ATA-2
PIO Mode 4 | 120 IORDY | 16.6 | ATA-2 (FAST ATA)
PIO Mode 5 | 100 IORDY | 20.0 | ATA-3

PIO (Programmed Input/Output - "программируемый ввод/вывод") осуществляется центральным процессором и работает путем передачи данных по определенным адресам ввода/вывода (см. подраздел "Порты"). Режимы PIO определяют, насколько быстро данные могут передаваться между диском и контроллером. При их использовании задействуются регистры центрального процессора системы. Но это не все! Режимами PIO (или DMA) определяются величина пакетов передаваемой информации, способ их кодировки, скорость и последовательность передачи, все временные характеристики цикла обмена. В зависимости от режимов устанавливаются различные времена циклов, поэтому скорости передачи могут меняться в очень широких пределах (см. таблицу).
При получении команды "Identify Drive" диск возвращает, наряду с другими параметрами, информацию о поддерживаемых режимах PIO и DMA. Эти параметры можно определить и с помощью специальных утилит. Установка режима передачи осуществляется по значению одного из регистров - SC (регистра счетчика секторов ATA-устройств). Через один из режимов работы этого регистра и происходит управление режимом обмена.
Режимы ATA-2 (PIO 3 и PIO 4) используют аппаратное управление потоком данных. Если быть точным, то Enhanced IDE включает операции, называемые "управление потоком с использованием IORDY", которые позволяют диску включать пакетный режим передачи для 100%-ного использования полосы пропускания шины. Режим управления потоком передает инициативу устройству (диску) и позволяет избавиться от неэффективных "слепых" режимов PIO за счет установки полосы пропускания контроллера в соответствии с возможностями винчестера. Это означает, что в тех случаях, когда доступна вся полоса, винчестер будет управлять обменом данными с хост-адаптером.
Что это за сигнал? "IORDY" (Input/Output Ready) - сигнал от EIDE-винчестера, подтверждающий завершение цикла обмена с контроллером. Другие названия - "CHRDY", "IOCHDRY". Использование "IORDY" позволяет скоростному винчестеру затянуть цикл обмена с контроллером, когда он не успевает принять или передать данные. Это дает возможность свести стандартную длительность цикла обмена к минимуму, предельно увеличив скорость, а при необходимости удлинять отдельные циклы при помощи "IORDY". Для этого сигнал должен поддерживаться и винчестером, и контроллером. Управление потоком со стороны диска включается контроллером с помощью команды "Set Features", в результате чего такой обмен поддерживается одновременно и диском, и контроллером. Контроллеры, не поддерживающие "IORDY", могут приводить к потере данных при использовании быстрых режимов PIO; в этом случае следует использовать менее скоростные режимы. В некоторых источниках упоминается режим 5, однако распространения он не получил и стандартным не является.
При невозможности программировать режимы обмена индивидуально для каждого из устройств в системе и при подключении устройств, работающих оптимально в разных режимах, в системе будет установлен обмен со скоростью минимального из режимов. Отсюда, и стандартная рекомендация - не подключать к одному каналу жесткий диск и CD-ROM. Правда, данная рекомендация все меньше и меньше сохраняет свою актуальность. По причине того, что современные CD-ROMы поддерживают все PIO-режимы, вплоть до 4-го, да и в UltraDMA-режимах стали весьма "продвинутыми".
Режимы программируемого ввода/вывода достаточно эффективны только в однозадачных средах. Для многозадачных ОС режимы DMA более предпочтительны. Необходимо помнить, что высокоскоростные режимы множественного обмена по DMA реализуются драйверами операционной системы, а возможности программного конфигурирования драйвера определяют гибкость управления режимами DMA.

IDE Prefetch Buffer
- (буфер предвыборки IDE). Встроенный IDE-интерфейс поддерживает режим предвыборки, который служит для ускорения чтения из буфера диска, сокращая время занятия шины компьютера. На контроллере SiS496 (платы для 486-х процессоров) при одновременной работе двух устройств (неважно, на одном или разных каналах) возникали конфликты, приводившие к искажению передаваемых данных. Из-за этого более новые версии BIOS старались отключить этот буфер при обнаружении второго устройства, однако не все версии BIOS это делали. Похожие ошибки имелись в свое время в контроллерах PC-Tech RZ1000 и CMD PCIO 640. Если же интерфейс не поддерживает режима предвыборки, то необходима установка опции в "Disabled".
Опция может носить название "IDE Prefetch Mode" или "IDE Prefetching".
Еще одно замечание. Выключение данной опции рекомендуется в операционных системах (например, в "Windows NT"), которые не используют BIOS для доступа к диску и которые не отключают прерывания после окончания операций программного ввода/вывода. Кроме того, отключение данной опции позволит избежать ошибок и потерь данных в 32-битных операционных системах на компьютерах с некорректно работающим PCI-IDE интерфейсом. Новейшие версии BIOS позволяют при ошибках отключать данный режим автоматически.
Необходимо отметить, что результирующее действие от использования буфера предвыборки во многом совпадает с включением "блочного" режима. В некоторых случаях даже описания функций совпадают. А суть в том, что объем буфера позволяет "накопить" несколько секторов данных и транслировать их затем как при пакетном режиме.
В большинстве случаев различные версии BIOS предоставляют возможность раздельного управления каналами интерфейса. К этому могут быть добавлены возможности установки времени действия режима предвыборки (в системных тактах), что может оказаться необходимым, если граничные установки, т.е. "Disabled" и "Enabled", не устраивают пользователя и его систему. Тогда такие опции могут называться: "Primary IDE Prefetch Buffer", "Secondary IDE Prefetch Buffer". При этом возможны следующие варианты параметров: "Disabled", "Enabled", "5T", "6T".
Опция также может носить название "PCI IDE Prefetch Buffer".

IDE Primary Master UDMA
IDE Primary Slave UDMA
IDE Secondary Master UDMA
IDE Secondary Slave UDMA
- эти опции позволяют установить режим работы каждого из четырех жестких дисков в системе в отдельности, поддерживающих спецификации Ultra ATA (Ultra DMA). Если в системе установлен достаточно устаревший EIDE-диск (тем более IDE-диск), то необходимо установить значение "Disabled". Поскольку понятие "устаревший" - относительное, то необходимо воспользоваться информацией из документации. Процесс установки может быть автоматизирован с помощью параметра "Auto".
Те же значения предлагает такая пара опций: "Master Drive Ultra DMA", "Slave Drive Ultra DMA".
В свое время "на свет божий" появилась интересная опция "Ultra DMA", для которой значение "Disabled" устанавливалось по умолчанию. А остальными значениями были "Mode 0", "Mode 1" и "Mode 2". В этом был глубокий смысл, т.к. реально работающих на скорости в 33,3 МБ/сек. жестких дисков в тот момент еще не было. А вот использование значения "Mode 2" в некоторых случаях могло позволить в максимальной степени реализовать возможности имеющегося EIDE-диска.

Вкратце о модификациях IDE-интеpфейса.
Hа данный момент их насчитывается четыpе: обычный IDE (ATA), EIDE (Enhanced IDE - pасшиpенный IDE, или ATA-2 [Fast ATA в ваpианте "Seagate"]), ATA-3 и Ultra ATA.
В 1984 г. компания "Western Digital" создала контроллеры дисководов (WD1002) и винчестеров (ST506), которые были использованы фирмой "IBM" при разработке компьютера IBM PC AT. Успех архитектуры АТ привел к значительному расширению рынка IBM-совместимых ПК и сделал контроллеры "Western Digital" стандартом de facto. В процессе становления рынка персональных компьютеров "Western Digital" пришла к выводу о необходимости интеграции электроники контроллера АТ и дискового устройства. В результате сотрудничества с "Compaq Computer Corporation" был разработан интерфейс IDE (Integrated Drive Electronics), называемый также АТА (AT Bus Attachment - подключенный к AT). Первые промышленные устройства на базе IDE/ATA были выпущены в 1986 году. Жесткие диски в те времена подключались не к материнским платам, а к специализированным адаптеpам, вставляемым в слоты. IDE-интерфейс обычно не содеpжал собственного BIOS, все функции поддеpжки IDE были встpоены в системный BIOS.
Продолжая лидировать в сфере IDE-устройств, компания "Western Digital" предложила расширение интерфейса IDE. Новая спецификация (Enhanced IDE) повысила скорость обмена с диском, реализовала применение более скоростных дисков и обеспечила возможность установки в компьютере до четырех устройств IDE. Кроме того, Enhanced IDE позволила избавиться от других основных ограничений стандарта IDE/ATA: предельного размера диска в 504 МБ, позволила подключать к контроллеру не только винчестеры, но и другие устройства, поддерживающие спецификацию ATAPI (см. ниже).
В ATA-2 были введены дополнительные сигналы ("CHRDY", "CS" и т.п.), команды остановки двигателя, pежимы PIO 3-4 и DMA. Был также pасшиpен фоpмат инфоpмационного блока, запpашиваемого из устройства по команде "Identify".
В ATA-3 увеличена надежность pаботы в скоpостных pежимах (PIO Mode 4 и DMA Mode 2), введена технология S.M.A.R.T.
Стандаpт Ultra ATA (называемый также Synchronous DMA, а также Ultra DMA/33) разработан компанией "Quantum" при содействии "Intel". В нем повышена скоpость пеpедачи данных, пpедусмотpено стpобиpование пеpедаваемых данных со стоpоны пеpедатчика для устpанения пpоблем с задеpжками сигналов (в пpежних ATA-спецификациях стpобиpование всегда выполнялось контpоллеpом), а также введена возможность контpоля пеpедаваемых данных (метод CRC). Этот стандарт также включает в себя технологию захвата шины, использующую каналы DMA системы.
За счет чего же происходит удвоение скорости интерфейса в сравнении с ATA-2? И это при сохранении тактовой частоты в 8,33 МГц. А реализация оказалась достаточно "простой": данные передаются и по фронту тактового сигнала, и по его спаду.
Все четыpе pазновидности имеют одинаковую физическую pеализацию - 40-контактный pазъем, правда, с разным набором команд. Все интеpфейсы совместимы снизу ввеpх.
Ultra ATA/66 был предложен "Quantum" в 1998 г. в качестве расширения предыдущей спецификации. Известен также под названиями Ultra DMA/66 или Fast ATA-2. Двойное увеличение скорости интерфейса потребовало ввести дополнительные 40 заземляющихся проводников и это при сохранении стандартного 40-контактного разъема.
Ну и наконец, стандаpт ATAPI (ATA Packet Interface - пакетный интеpфейс ATA), пpедставляющий собой pасшиpение ATA для подключения устpойств пpочих типов (приводов CD-ROM, стpиммеpов). В число устройств, поддерживаемых интерфейсом ATAPI, вошли накопители IomegaZip, магнитооптические накопители. ATAPI не изменяет физических хаpактеpистик ATA, он лишь вводит пpотоколы обмена пакетами команд и данных, наподобие SCSI.

Landing Zone

Landing Zone (LZone). Этим термином обозначается по сути номер цилиндра для парковки головок жесткого диска. Если вспомнить былое, то можно было бы говорить даже и об опции с таким же названием. Ибо в старых системах при выборе зоны парковки явным образом указывался, скорее всего, последний цилиндр (например, 1023-й). Но при этом парковка головок осуществлялась программно, с помощью различных утилит.
Необходимость в парковке головок сохранила актуальность и по сей день, т.к. изначально была связана с невозможностью нахождения головок над поверхностью диска в состоянии покоя. Любые соприкосновения головок и поверхности диска в моменты разгона двигателя или его торможения в итоге могут привести к катастрофическим последствиям. В современных жестких дисках парковка головок осуществляется автоматически при снижении напряжения питания или же при снижении скорости вращения шпинделя ниже допустимого значения. Также действует и обратный принцип. Контроллер жесткого диска не выпустит головки из зоны парковки, пока шпиндель не наберет необходимой скорости вращения. Естественно, что даже если и будет установлено некое цифровое значение в "BIOS Setup", то параметр опции "LZone" будет проигнорирован.

Large Disk Access Mode
- опция "Phoenix BIOS" для управления режимом доступа к дискам большой емкости (более 1024 цилиндров и 16 головок). Опция связывает доступ к диску с тем, каким образом операционная система решает эти вопросы. Значения опции следующие:
"DOS" - если операционная система использует MS-DOS-совместимый доступ к жесткому диску (например, "MS-DOS", "Windows 9x"),
"Other" - если операционная система не использует MS-DOS-совместимый доступ к жесткому диску (например, "Novell", "SCO Unix").
В некоторых случаях опция с таким же названием может предложить уже знакомые значения: "LBA", "CHS" и т.д.

LBA Mode Control
- опция управления режимом LBA, точнее поддержки LBA. Значения опции - "Enabled" (по умолчанию) и "Disabled".
Аналогичная опция может называться "LBA/Large Mode", а ее значениями будут "Auto for Type", "On" или "Off".


BIOS. Продолжение!

12. Video, AGP

AGP -2x Mode
- (режим AGP 2X). По умолчанию устанавливается "Disabled". "Enabled" выбирается лишь в случае, если графическая карта, а также системные компоненты (чипсет) поддерживают режим AGP 2x.
Режим 2X использует дополнительно ниспадающий фронт тактового сигнала AGP-интерфейса для передачи данных. Включение данного режима для AGP позволяет удвоить пропускную способность при помощи передачи данных по обоим (возрастающему и нисходящему) фронтам тактового сигнала. Это равносильно функционированию AGP-шины на 133 МГц и полосе в 264 МБ/сек. Подобные решения нашли применение и в протоколах UltraDMA для жестких дисков. Если графический адаптер поддерживает "удвоенную" частоту, данную опцию необходимо включить. Понятно, что такие действия позволят значительно повысить пропускную способность всего видеотракта. Выключение режима может потребоваться при возможной нестабильности работы (особенно с системами на "Super Socket 7"), а также при разгоне AGP-шины свыше 75 МГц.
Опция могла называться "AGP 2X Mode".

AGP 4X Mode
- значения этой опции аналогичны: "Disabled" и "Enabled". И все действия пользователя также однозначны. Опция по умолчанию отключена, что дает достаточно прозрачный намек на необходимость поддержки 4X-протокола в системе. Поскольку в современных системах и видеокартах уже реализуются режимы AGP 8X, то некоторые прежние проблемы уже ушли в прошлое. А еще не так давно некоторые производители материнских плат специально блокировали данную опцию во избежание возможных осложнений при использовании видеокарт, поддерживающих только режимы AGP 1X или 2X.
Массовое распространение "интегрированных" систем ввело "в обиход" опцию "AGP Data Rate". Если для чипсета i740 значения опции были "1x" и "2x", то уже для i820 добавилось еще одно - "4x". Такое же содержание характерно было и для опций "AGP Transfer Mode" и "AGP Transfer Rate". Более поздняя опция "AGP Capability" уже не содержала значения "1x", а значит и не могла быть использована для старых AGP-адаптеров ("2X Mode", "4X Mode").

AGP Aperture Size
- (размер графической апертуры для AGP). Апертурой называется порция адресов памяти PCI, выделенная в адреса графической памяти. Циклы, обращающиеся к этим адресам, не требуют трансляции и передаются напрямую в AGP. Кроме того, размер указывает максимальный объем системной памяти, выделяемый для хранения текстур. Это означает, что видеоплатам выделяется адресное пространство, причем независимо от фактической емкости видеопамяти платы.
Размер апертуры незначительно сказывается на общей производительности системы. Но большинство современных 3D-акселераторов требует значительно больше, чем 8МБ апертуры для нормального функционирования. Замечено также, что на акселераторах TNT тесты по обработке больших массивов текстур существенно замедлялись в случае выделения менее 64 МБ памяти. Чтобы определить наиболее подходящее значение, надо провести тестирование. Поэтому для конкретной видеоплаты может оказаться оптимальным значение в 256 МБ (при физическом размере системной памяти в 64 МБ). На текущий момент стандартным размером является значение "64M", хотя рекомендованным является значение, равное половине инсталлированного объема памяти. И так же надо помнить о том, что при увеличении параметра увеличивается и размер GART-таблицы. Доступный ряд значений графической апертуры: "4M", "8M", "16M", "32M", "64M", "128M" и "256M".
Опция также может называться "Graphics Aperture Size" или просто "Graphics Aperture".

AGP Fast Write
- (быстрый цикл записи в AGP-интерфейс). Наличие данной опции в "BIOS Setup" и ее включение ("Enabled") могут оказаться неэффективными, если в современную систему будет установлена AGP-карта "с бородой". Современные BIOS поддерживают функцию "Fast Write", ее же поддерживают и современные графические адаптеры, обеспечивающие режим 2x и выше. Включение опции позволит центральному процессору (через чипсет, конечно) получить прямой доступ к видеоадаптеру на скоростях до 1 ГБ/сек. и выше. В противном случае общая пропускная способность видеотракта снизится за счет необходимости использования системной памяти. В этом случае системная память будет задействована как при обычном режиме работы AGP-адаптера в качестве "мастер"-устройства.
Необходимо помнить о том, что появление данной опции в системах конца 90-х годов сопровождалось зачастую ошибками. Функция "Fast Write" во многих версиях BIOS того времени попросту не функционировала, что требовало последующей перепрошивки CMOS-памяти.
Опция могла называться "AGP Fast Write Protocol", "AGP Fast Write Capability" или "AGP Fast Write Transaction". Значения всех опций: "Disabled" и "Enabled".

AGP Master 1 WS Read
AGP Master 1 WS Write
- опции, позволяющие вставить один дополнительный такт ожидания в циклы чтения/записи на шине AGP. "Disabled" не ведет к этому, позволяет ускорить процесс передачи данных, но тем не менее вставка одного такта может позволить оптимизировать трансляцию видеоданных.
AGP Parity Error Response
- опция позволяет включить ("Enabled") режим проверки по четности для AGP-интерфейса.

AGP SERR
- опция позволяет разрешить ("Enabled") установку сигнала SERR (System Error) на AGP-шине. Этот сигнал выставляется при любой глобальной ошибке интерфейса, что может быть вызвано сигналом входной ошибки, сигналом ошибки по четности, ошибкой целевой адресации данных. За всем этим следит управляющий ERRCMD-регистр "северного" моста чипсета.

Прежде всего остановимся на PCI-шине и вспомним тот факт, что шина является мультиплексированной. То есть PCI-шина не имеет раздельных адресных линий и линий данных. По 32-разрядной шине сначала следует адресная информация, затем данные. Шина позволяет в наиболее производительном, т.е. пакетном, режиме после 32-разрядного адреса переслать 4 двойных слова данных, и этот пакетный цикл "вложится" в 5 шинных тактов.
При разработке AGP-интерфейса, базировавшейся на спецификациях PCI-шины, возможности последней были значительно расширены. Мультиплексированность не была изъята, но была добавлена дополнительная 8-разрядная адресная шина, которая получила название "побочной". Side-Band Addressing (SBA) означает адресацию по побочной шине. Адресная информация по этой побочной шине может передаваться параллельно с данными по основной шине. Таким образом, за 4 такта шины AGP будет передан пакет данных в 4 DWord и 32-разрядный адресный пакет. Явное повышение производительности, в некоторых случаях до 15%. Но для достижения такого эффекта необходима прежде всего поддержка "побочной" адресации со стороны видеокарты, реализации этой функции в AGP-контроллере и чипсете видеокарты, но это происходит далеко не всегда, так как не все производители видеоакселлераторов пытаются реализовать возможности SBA. Эффективность от использования такого режима зависит также и от системного чипсета.

AGP Sideband Addressing
- опция в большинстве случаев предоставляет возможность включения/отключения "побочной" адресации ("Enabled"/"Disabled"), и тут нет сложности. Но в некоторых случаях может появиться и третье значение - "8 Devices", и оно требует дополнительного исследования.
Опция может называться "Sideband Addressing".
AGPCLK/CPUCLK
- опция установки частоты (скорости) AGP-интерфейса. "1/1" выбирается для частоты системной шины до 100 Мгц, "2/3" - для частоты шины выше 100 Мгц. Некоторые AGP-карты могут работать с повышенной частотой, но, тем не менее, это не всегда оправдано с точки зрения живучести AGP-карты.
По установке скорости AGP-интерфейса смотри дополнительно опцию "PCI/AGP Clock".
CPU-to-AGP 1WS Burst Write
CPU-to-AGP Dynamic Bursting
CPU-to-AGP Post Writes
- опции, абсолютно идентичные соответствующим опциям по работе с PCI-шиной, но предназначенные для оптимизации AGP- интерфейса (см. подробно выше). Кратко напомним, что в данных опциях речь идет о вставке дополнительного такта ожидания в пакетные циклы записи, о предварительной буферизации циклов записи в буфере отложенной записи, т.п. Естественно, что и значения этих опций такие же: "Enabled" и "Disabled".
В современных интегрированных чипсетах разделение памяти производится различными методами.
Это может происходить за счет программного разделения основной памяти под постоянную память и видеопамять (так, например, реализовано в чипсете i815).
В других случаях для встроенной графической подсистемы используются специально установленные дополнительные модули видеопамяти, которые "обслуживают" только канал графики. Для интегрированных плат (i810, например) в качестве специализированного дисплейного кэша (Display Cache) используется до 4 МБ видеопамяти типа SDRAM, работающей на частоте 100 МГц. Это внешняя кэш-память для канала графики, являющаяся дополнительной видеопамятью к основной, в качестве которой также может использоваться основная память системы.
И есть еще один путь. С помощью BIOS настраивается объем ОЗУ (16 или 32 МБ), выделяемый под видеопамять. Так, например, сделано в наборе Pro Savage PM133, построенном на базовом чипсете VIA Apollo Pro 133A.
Display Cache Window Size
- опция, устанавливающая объем кэш-памяти, доступной в качестве локальной графической памяти. Значения могут быть следующими: "32MB" или "64MB". Поскольку в роли локальной видеопамяти выступает системная память, то данной опцией устанавливается объем кэшируемой памяти.
Опция может называться "On-Chip Video Window Size", а к представленным значениям добавилось "Disabled".
Initialize Display Cache Memory
- установка опции в "Enabled" позволит вывести информацию о дисплейной кэш-памяти в процессе загрузки системы и произвести ее инициализацию. "Disabled" вызовет пропуск инициализационной процедуры дисплейного кэша.
Как правило, BIOS "интегрированных" плат содержит дополнительное подменю по оптимизации работы дисплейного кэша. Все эти опции, уже знакомые пользователю, становятся доступными, если опция "Initialize Display Cache Memory" включена. Такое подменю может называться, например, "Onboard Display Cache Setting":
x CAS# Latency
- значения "Slow" и "Fast". В других случаях могут быть предложены "цифровые" значения (см. выше).
x Paging Mode Control
- значения "Close" и "Open".
x RAS# Precharge Timing
- значения "Slow" (соответствует 2 тактам) и "Fast" (соответствует 3 тактам).
x RAS# Timing
- значения "Slow" (tRAS соответствует 7 тактам, tRC соответствует 10 тактам) и "Fast" (tRAS соответствует 5 тактам, tRC соответствует 8 тактам).
x RAS to CAS
- значения "Override" (RAS to CAS delay равно 2 тактам) и "Default" (задержка определяется битом "CAS# Latency").
Опция может называться "RAS-to-CAS Override", а одно из значений (остальные - цифровые) может выглядеть как "by CAS# LT".
Graphics Mode Select
- эта опция находит применение при интегрировании графических устройств на системной плате. При этом часть системной памяти используется как видеопамять, используются механизмы т.н. Unified Memory Architecture (UMA). Возможные значения: "UMA 1MB" и "UMA 512KB".
Unified Memory Architecture ("унифицированная архитектура памяти") отличается разделением памяти между графическим ускорителем и центральным процессором. Реализация этой технологии приводит к выделению в основной памяти значительных объемов под графику, соответственно уменьшению объемов под систему и в итоге к общему снижению производительности. Разделенная память не может обеспечить такую же производительность, как выделенная, тем более, что технология разделенной памяти изначально не поддерживалась "Microsoft".

PCI/VGA Palette Snoop
- (слежение за палитрой подсистемы видео или корректировка палитры VGA-видеокарты). Эта опция используется только при наличии карты видеозахвата (MPEG-карты) или TV-тюнера, подсоединенных к Feature Connector графической карты с помощью соединительного шлейфа, и в некоторых других случаях.
При установке опции в "Enabled" становится возможным корректировать цветовые палитры в буфере кадров видеокарты во время прохождения сигналов из MPEG-карты через VGA-коннектор, т.е. в случае некорректного отображения цветов. Собственно суть механизма действия этой функции заключена в способности платы графики "подсматривать" (перехватывать) циклы записи карты видеозахвата в регистры палитры цветов и их корректировке. Включение механизма корректировки палитры цветов может потребоваться и при передаче видеоинформации в обратном направлении, т.е. в ту же MPEG-карту. VGA-перехват (snooping) используется различными мультимедиа устройствами, например, фрейм-грабберами (захватчиками изображения) или картами MPEG-декомпрессии. В обычном режиме работы опция должна быть запрещена. Опция может быть отключена и в случае нормального отображения цветов.
Опция также может называться "PCI Palette Snoop", "VGA Palette Snoop", "Video Palette Snoop" или совсем необычно - "Multimedia Mode".
Snoop Ahead
- (предвидение). Эта опция применима, если в системе включено кэширование. Когда опция установлена в "Enabled", "master"- устройства на PCI-шине могут контролировать регистры VGA-палитры для непосредственных циклов записи и преобразования их в пакетный протокол PCI-формата с целью повышения скоростных характеристик обмена данными между PCI-шиной и памятью. В итоге значительно увеличивается производительность системы в процессе передачи видеоданных.
TV/VGA Selection
- опция установки качественных характеристик выходного видеосигнала. Используется только при наличии интегрированных видеокомпонентов и, естественно, при наличии дополнительных (add-on) разъемов на материнской плате. Опция может иметь несколько параметров:
"Auto Detection" - при этом автоматически определяется, какое внешнее видеоустройство подключено к видеокарте, и активизируется соответствующий выходной канал. Если подключен телевизионный приемник, то система переключается в RGB-режим, если подключен монитор, то - в VGA-mode. Если же подключены оба устройства, то активизируется VGA-порт, и система работает в VGA-режиме,
"Comp+VGA" - при подключении телевизионного приемника (к антенному разъему) выходной узел видеокарты вырабатывает т.н. FBAS-сигнал, в то время как монитор принимает VGA-сигнал с частотой в 50 Гц,
"TV-RGB" - телевизионный приемник работает с RGB-сигналом (лучшее качество),
"TV-YC + VGA" - при подключении телевизионного приемника выходной узел видеокарты вырабатывает S-VHS-сигнал, в то время как монитор принимает VGA-сигнал с частотой в 50 Гц.
S-Video (компонентное видео и, конечно, разъем видеокарты) - более высококачественное видео с расщепленным видеосигналом (информация о яркости и цвете передается раздельно). Композитный сигнал передается через стандартный антенный разъем.
+++
VGA 128k Range Attribute
- во включенном состоянии ("Enabled") к адресам VGA-памяти (A0000H-BFFFFH) чипсетом могут быть применены свойства, подобные функциям "CPU-TO-PCI Byte Merge" или "CPU-TO-PCI Prefetch", т.е. стандартным режимам буферизации записи от CPU в PCI-интерфейс. Это повышает быстродействие системы, в противном случае используется стандартный VGA-интерфейс.
Этот же смысл характерен для множества функций с непохожими наименованиями: "VGA Performance Mode", "Turbo VGA (0 WS at A/B)", "VGA Frame Buffer", хотя в некоторых случаях "оперативный" диапазон сужается до первых 64 кБ (A0000-B0000).
Опция "ISA VGA Write Combining" в общем-то аналогична вышеприведенным, но она выделена отдельно. С одной стороны, речь идет о диапазоне B0000h - BFFFFh, верхних 64 КБ привычного "VGA frame buffer", а с другой, в наименование опции вынесен режим работы с кэш-памятью - WC (write combine - объединенная запись), позволяющий значительно ускорить доступ к буферу видеопамяти и вывод данных на видеокарту. Подробнее об этом в следующих разделах.
Из "карты" памяти первого мегабайта системного ОЗУ, что жестко "привязано" к архитектуре IBM PC-совместимых компьютеров, хорошо известно, что адресная область A0000-C7FFF традиционно принадлежит видеопамяти графического адаптера и видео BIOS системы. Собственно под видео BIOS (или, как иногда говорят, ПЗУ видеоадаптера) выделяется 32 кБ памяти в области C0000- C7FFF. Это 768-й - 799-й килобайты памяти. Эта адресная область, в зависимости от установок "BIOS Setup", может и не использоваться.
Область в 128 кБ (A0000-BFFFF, или 640-й - 767-й килобайты) отведена под видеопамять графической карты расширения. В "древние" времена этого объема хватило бы на размещение в памяти одного графического кадра, пусть и с разрешением 320х200. По аналогии с 64-мя килобайтами верхней памяти область видеопамяти в 128 кБ стала тем "окошком" (или фрэйм-буфером), через которое стал возможным доступ ко всей адресуемой памяти. В свое время использование фрэйм-буферизации активно использовалось такими играми, как "DOOM".
Для справки! Frame Buffer (буфер кадра) - область памяти видеосистемы, в которой временно хранятся данные, необходимые для отображения одного кадра (в простейшем случае).

12. USB

USB (Universal Serial Bus) - совместная концептуальная программа "Intel" и "Microsoft", хотя основным инициатором разработки стандарта выступила компания "Intel". Это последовательный интерфейс с поддержкой одновременного подключения множества внешних устройств (USB позволяет последовательно подключить до 127 устройств, причем 4-проводным кабелем). Все периферийные устройства по цепочке, используя топологию звезды, включаются друг в друга. Точнее, USB-система строится на расширяющих концентраторах, первый из них может размещаться на материнской плате ПК (корневой концентратор). Концентратор может входить в периферийное USB-устройство, быть отдельным устройством, а расстояние между устройствами не должно превышать 5 метров.
Впервые интерфейс был реализован в наборе микросхем системной логики Triton II (82430HX) в микросхеме PIIX3 South Bridge. Надо отметить, что над разработкой и внедрением стандарта, кроме "Intel" и "Microsoft", работали еще несколько компаний, в том числе "Compaq", "IBM".
Максимальная пропускная производительность шины USB составляет 12 Мб/с, но фактическая скорость передачи данных может составить около 8 Мб/с (стоит напомнить, что последовательные порты ограничены 115 Кб/с). Такой полосы пропускания достаточно для работы практически всех устройств: мыши, сканеров, принтеров, клавиатуры, модемов, ISDN-карт и даже сжатого видео MPEG-2. Для внешних устройств со значительно большими, чем у "тихоходов" объемами передаваемой информации (видеокамера, видеомагнитофон) разработан другой последовательный интерфейс - FireWire, скорость которого достигает 100 Мб/с и более.

USB Speed
- далеко не все чипсеты и версии BIOS позволяют пользователю "вмешиваться" в работу USB-шины, в данном случае изменять ее скорость. Возможные параметры: "24 MHz", "48 MHz".

13. SCSI

SCSI (Small Computer System Interface) - "интерфейс малых вычислительных систем". Транспортный уровень соединений SCSI представляет собой "узкую" (narrow) 8-битную или "широкую" (wide) 16-битную параллельную передачу данных (разработаны также 32-разрядные системы). 8-битная передача данных реализуется с помощью 50-контактного соединительного кабеля, 16-битная - 68-контактного.
Стандарт был разработан в 1981 г. (на несколько лет раньше IDE-интерфейса) фирмами "Seagate" и "NEC" с целью создания универсального интерфейса большой пропускной способности для запоминающих устройств большой и сверхбольшой емкости, и первоначально назначение SCSI состояло в том, чтобы разделить физические свойства аппаратной части и логические свойства данных. Этот параллельный интерфейс обеспечивает последовательное подключение минимум семи устройств. Многозадачная ОС, например, "Windows NT" (и выше) позволяет обращаться к нескольким SCSI-дискам одновременно. Та же "Windows NT", в отличие от "Windows 9x", позволяет полностью реализовать возможности SCSI по одновременному выполнению операций ввода/вывода в нескольких приложениях, т.е. вести обработку множественных дисковых операций без существенной загрузки CPU.
В SCSI со времени введения CCS (Common Command Set) все устройства могут управляться на командном уровне. Внедрение в SCSI спецификации SCAM (SCSI Configured Automatically) приблизило стандарт SCSI к EIDE по простоте в использовании.
Дальнейшее развитие интерфейса, реализованное в Fast SCSI, предусматривало удвоение тактовой частоты до 10 МГц, которое позволило осуществить передачу данных со скоростью до 10 МБ/с по 8-разрядной или до 20 МБ/с по 16-разрядной шине. При этом контроллер и устройство работают синхронно, с одинаковой тактовой частотой, благодаря чему отпадает необходимость в отнимающей много времени оптимизации асинхронного режима (Handshaking).
Ultra SCSI (или Fast-20) повысило пиковую скорость до 20 МБ/с и с использованием Wide SCSI до 40 МБ/с. Но при этом длина кабеля уменьшилась до 1,5 м. Дополнительное устройство под названием "SCSI-BusExtender" увеличило допустимую длину кабеля до 6 м.
Протокол последовательной шины SBP (Serial Bus Protocol), реализованный в SCSI-3, за счет применения последовательного волоконно-оптического интерфейса позволяет увеличить скорость передачи данных до 1 ГБ/с. Этот стандарт называется также SSI (SCSI Serial Interface).
Основные применения интерфейса SCSI: серверы, высокопроизводительные рабочие станции. Очень эффективно использование интерфейса SCSI при работе с аудио- и видеоинформацией в режиме реального времени, где необходимо обеспечение четкой пропускной способности дискового интерфейса без задержек.

Embedded SCSI BIOS
- эта опция позволяет (через "Enabled") скопировать SCSI BIOS контроллера в системный BIOS. Преимущества такого решения очевидны. В противном случае BIOS SCSI-контроллера будет системой распознаваться в обычном порядке. Данная опция характерна для серверных систем.
On Board PCI/SCSI BIOS
- установка значения "Enabled" (включено) необходима, если на материнской плате имеется встроенный SCSI-контроллер, подключенный к PCI-шине, и используется жесткий диск с интерфейсом SCSI. Стоит напомнить, что в процессе загрузки одновременное нажатие клавиш <CTRL>+<A> вызывает BIOS SCSI. Об этом подробнее будет сказано чуть ниже. Может принимать значения:
"Enabled" - включено;
"Disabled" - отключено.
Опция может называться также "Onboard PCI SCSI Chip".
ONB AHA BIOS First
- (запуск BIOS контроллера "Adaptec" первым). Параметр разрешает/запрещает запуск BIOS встроенного контроллера "Adaptec" до запуска любого другого SCSI-контроллера. Может принимать значения:
"Yes" - разрешено,
"No" - запрещено.
ONB SCSI LVD Term.
- (терминаторы встроенного контроллера SCSI LVD). Параметр разрешает/запрещает подключение нагрузочных резисторов (терминаторов) на встроенном контроллере SCSI с LVD-передачей сигналов. "Phoenix BIOS" предложил аналогичную опцию под названием "SCSI Termination LVD". Опция может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено. Такая установка имеет смысл, если SCSI-контроллер не является последним устройством в цепочке.
ONB SCSI SE Term.
- (терминаторы встроенного контроллера SCSI SE). Параметр разрешает/запрещает подключение нагрузочных резисторов (терминаторов) на встроенном SCSI-контроллере с SE-передачей данных. Может принимать значения:
"Enabled" - разрешено;
"Disabled" - запрещено.
Обычная шина SCSI называется также однопроводной (Single-Ended - SE), поскольку для передачи каждого сигнала используется один провод. Можно сказать, что SE - технология устройств, передачи данных, разъемов, в которой используются однополярные сигналы в уровнях TTL-логики, что характерно для Ultra Wide SCSI и более ранних стандартов. Основной недостаток такой передачи сигналов - малая помехозащищенность.
Внутренние ограничения SCSI-стандартов были в значительной степени преодолены в интерфейсе Ultra2 Wide SCSI, обеспечившем скорость передачи до 80 МБ/с. Постоянное развитие SCSI-интерфейсов ставило целью повышение частоты, что приводило в итоге и к снижению помехозащищенности, и к ограничению максимальной длины интерфейсного кабеля.
Дальнейшее совершенствование интерфейса привело к внедрению т.н. дифференциальной шины. В дифференциальной шине для передачи каждого сигнала используется двухпроводная линия связи. По одному из проводников передается прямой сигнал, а по второму - ему инверсный (т.е. в противофазе). В приемное устройство передается уже разница этих двух сигналов (отсюда и название - дифференциальная шина). Значительно повышается помехоустойчивость, а отсюда и длина кабеля. Вначале была внедрена дифференциальная шина высокого напряжения с определенным набором различных недостатков. На смену ей пришла низковольтная дифференциальная передача сигналов, или Low Voltage Differential (LVD), которая стала базовой технологией Ultra2 Wide SCSI. Благодаря ей удалось увеличить допустимую длину соединительного кабеля до 12 метров.
Onboard AHA BIOS
- (BIOS встроенного SCSI-контроллера "Adaptec"). Параметр разрешает/запрещает выполнение BIOS-функций встроенного SCSI-контроллера и тем самым разрешает/запрещает его работу. Параметр может принимать значения:
"AUTO" - разрешен автоматический поиск SCSI-контроллера "Adaptec" и запуск BIOS для него,
"Disabled" (запрещено) - выбор этого значения рекомендуется при отсутствии SCSI-карты.
Необходимо помнить, что некоторые SCSI-контроллеры той же фирмы "Adaptec", например "AHA-2940AU", не имеют собственного Flash-BIOS, и их конфигурирование осуществляется в BIOS компьютера и средствами ОС.
Onboard SCSI
- в таком виде "AMI BIOS" предлагает установить наличие ("Enabled") или отсутствие ("Disabled") встроенного SCSI-интерфейса. Как говорят, комментарии излишни.
SCSI Controller
- опция поддержки SCSI-контроллера. В этой опции нет ничего необычного, если не указать, что она предназначалась еще для ISA- плат. Дело прежде всего в том, что SCSI-контроллер занимает одно ISA-прерывание, даже если опциально контроллер отключен ("Disabled"). Поэтому для использования прерывания в других целях необходимо дополнительно воспользоваться установками меню "PCI Configuration" (или аналогичного). Опция с таким же названием встречалась и в более современных системах, и речь уже шла о контроллере на материнской плате.
SCSI Parity Checking
- включение опции ("Enabled") позволит "ultra-wide SCSI"-контроллеру использовать метод проверки по четности для потока данных от SCSI-устройств. Если хотя бы одно из устройств не поддерживает "Parity Checking", надо заблокировать опцию.
SYMBIOS (NCR) SCSI BIOS
- параметр устанавливает разрешение на поиск SCSI-контроллера на базе микросхемы NCR 810, используемой, например, в карте "ASUS SC-200". Параметр может принимать значения:
"AUTO" - разрешен автоматический поиск SCSI-контроллера и запуск BIOS для него;
"Disabled" (запрещено) - устанавливается в это значение при отсутствии SCSI-карты.


BIOS. Продолжение!

16. Power Management - ACPI

Примерно с конца 1994 г. каждый ПК стал соответствовать спецификации "Energy Star" (наличие функций энергосбережения), а BIOS компьютера обогатился встроенными функциями т.н. "Advanced Power Management" (APM) - совместного стандарта корпораций "Microsoft" и "Intel", первая редакция которого появилась еще в 1992 г. Все началось с того, что EPA (Environmental Protection Agency - Агенство по защите окружающей среды) начало реализовывать программу "Energy Star" по энергосберегающим технологиям под патронатом правительства США. Затем кампания по сертификации различного оборудования коснулась энергосберегающих персональных компьютеров и периферийного оборудования. Соответствующий логотип, т.е. сертификат, могли получить только те продукты, которые выполняли квоту по экономии энергии.
"APM" был первой спецификацией для изготовителей ПК, которая установила взаимодействие между операционной системой и BIOS в задаче управления энергопотреблением (Power Management).
"ACPI" (Advanced Configuration and Power Interface) - интерфейс расширенного конфигурирования и управления питанием, заменяющий стандарт расширенного управления питанием (APM). ACPI - это технология, лежащая в основе разработанного "Microsoft" стандарта энергосбережения и стандарта "Plug-and-Play" - "On Now".
Спецификация разрабатывалась совместно "Intel", "Microsoft" и "Toshiba" и представляла собой новую архитектуру "Microsoft Windows 98". Операционная система взяла на себя управление многочисленными параметрами функционирования ПК. Технология реализует управление состоянием системы, работой компонентов и энергопотреблением на основе модели событий и использования программирования по таймеру. Все это достигается средствами ОС и представляет собой программируемый вход в режимы энергосбережения, а также выход из "спящего" режима от обращения к "мыши" или клавиатуре, в связи с приходом телефонного звонка или удаленного сетевого управления, т.п. Системный BIOS дополнился и другими многочисленными функциями, о которых будет рассказано далее. Присутствие в этой троице "Toshiba" более чем объяснимо, поскольку проблемы и задачи энергосбережения пришли в мир настольных ПК от ПК-блокнотов.
Спецификация "ACPI" была реализована "Intel" впервые в чипсете 440LX с одновременной реализацией архитектуры AGP.
Параллельно с развитием и совершенствованием технологий энергосбережения, затрагивающих прежде всего производителей чипсетов, материнских плат, BIOS и разработчиков операционных систем, шел процесс совершенствования моделей мониторов. Стандарт "EPA Energy Star VESA DPMS" определил унифицированную процедуру энергосбережения и ступенчатого выключения монитора в трех стадиях:
¤ On (номинальный режим работы) >
¤ Standby (режим ожидания). В режиме ожидания изображение на экране пропадает (при этом прекращается выдача сигнала горизонтальной развертки), но внутренние компоненты монитора функционируют в нормальном режиме, а энергопотребление снижается до 80% от рабочего состояния >
¤ Suspend (режим приостановки). В режиме приостановки, как правило, отключаются высоковольтные узлы, также не подается сигнал вертикальной развертки, а потребление энергии падает до 30 Вт и менее >
¤ Off ("сон"). В режиме так называемого "сна" монитор потребляет не более 8 Вт, а функционирует у него только микропроцессор.
Стандарт DPMS (Display Power Management Signaling - система сигналов управления питанием монитора) ассоциации VESA определяет состав сигналов, передаваемых компьютером в монитор, при вхождении системы от состояния простоя в режимы пониженного потребления энергии. В этих системных процедурах контроль берет на себя драйвер, посылающий соответствующие сигналы через графическую карту. При нажатии клавиши на клавиатуре или движении "мыши" монитор переходит в нормальный режим работы.
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Как же реализуются эти богатейшие возможности аппаратно? Попробуем осветить хотя бы вкратце эти вопросы.
Современные модели 32-разрядных процессоров, кроме стандартных (обычных) режимов работы - реального, защищенного и виртуального (V86) - имеют дополнительный режим системного управления SMM (System Management Mode). Главным образом, этот режим предназначен для реализации системы управления энергопотреблением.
Если заглянуть в прошлое, то окажется, что "Intel" еще в "зеленые" 486SL-процессоры заложила систему SMM, которая с того времени непрерывно совершенствовалась. Кстати, упомянутые процессоры первоначально предназначались для портативных ПК.
В режим SMM процессор может войти только по сигналу на входе SMI# (System Management Interrupt). Сигнал SMI# для процессора является немаскируемым прерыванием с наивысшим приоритетом. Оно и предназначено для обслуживания всех событий, связанных с управлением энергопотребления. При входе в режим SMM автоматически запрещаются аппаратные прерывания. Сразу при входе в SMM процессор сохраняет состояние почти всех своих регистров в специальной памяти SMRAM, которая представляет собой выделенную область физической памяти, недоступной для ОС и прикладных программ. В том же фрагменте располагается и обработчик SMI (SMI Handler). Размер памяти SMRAM может меняться от 32 КБ (минимальные потребности SMM) до 4ГБ.
Если режим SMM используется для отключения питания процессора с возможностью быстрого "пробуждения", память SMRAM должна быть энергонезависимой. Если SMRAM не является энергонезависимой, то системная логика должна обеспечить возможность ее инициализации процессором из обычного режима работы до появления сигнала SMI#.
В системах с процессорами 6-го поколения (Pentium Pro, PII, ..) в процедуре ввода в режим SMM могут принимать участие и программируемые регистры MTRR.

ACPI Control Register
- данная опция "AMI BIOS" абсолютно идентична "ACPI Function", но она вынесена отдельно. И вот почему! Возможности операционных систем по реализации ACPI-технологии связаны прежде всего с наличием в современных чипсетах специального регистра, осуществляющего управленческие функции. Для того, чтобы операционная система могла реализовать эти возможности, данная опция должна быть включена ("Enabled").
ACPI Function
- (функционирование ACPI). Разрешается или запрещается поддержка через BIOS стандарта ACPI. Включение этой функции имеет смысл, если только операционная система поддерживает ACPI. Если опция включена, система будет игнорировать установки полей "Suspend Mode", "HDD Power Down" и некоторых аналогичных, поскольку уже операционная система ("Windows 98" и выше) возьмет на себя решение многих вопросов. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено (по умолчанию).
Опция "Phoenix BIOS" с теми же значениями называется просто - "ACPI".
Сказанное выше абсолютно точно выражено в названии опции "AMI BIOS" "ACPI Aware O/S". Установка значения в "Yes" одназначно означает поддержку стандарта со стороны BIOS и операционной системы. По умолчанию устанавливается "No".
ACPI I/O Device Mode
- опция в общем-то подобная вышеприведенным, но трактуется несколько шире. Она предполагает поддержку стандарта со стороны периферии. В частности, речь может идти о поддержке удаленного включения.
APM
- так просто называется опция "Phoenix BIOS", предоставляющая возможность ("Enabled") операционной системе использовать, а также влиять на установки управления энергопотреблением системного BIOS. При этом естественно включаются соответствующие аппаратные функции и возможности системы. Естественным является требование поддержки APM-функций со стороны операционной системы.
Аналогично функционируют опции "APM BIOS", "Advanced Power Management" и "Power Management" (чаще встречаемый вариант см. ниже).
Также идентична перечисленным опция "AMI BIOS" "Power Management/APM".
BIOS PM on AC
- нестандартная опция, направленная на сохранение свойств и функций управления энергопотреблением при ...использовании внешних источников питания. Значения же обычны: "On" (т.е. включено) и "Off".
CPU Sleep Pin Enable
- включение опции ("Enabled") позволит задействовать контакт "Sleep" разъема центрального процессора. Это даст возможность при определенных выключениях системы сохранять состояние процессора и памяти.
Power Management
- опция управления энергопотреблением, осуществляющая основной контроль за функциями энергосбережения, включая снижение энергопотребления жесткого диска, режимы резервирования, приостанавливающие режимы (Suspend Modes), включение таймеров устройств, т.п., которые все вместе составляют аппаратную схему консервации. Может принимать значения:
"User Define" (определяется пользователем). При установке этого параметра пользователь может самостоятельно установить таймеры переходов в режим пониженного энергопотребления, самостоятельно сконфигурировать все свойства режимов спасения и консервации,
"Max Saving" (максимальное энергосбережение). Компьютер перейдет в режим пониженного энергопотребления через 10 - 30 сек. после прекращения работы пользователя. При этом, как правило, по умолчанию используется заводская установка с максимально возможными режимами энергосбережения,
"Min Saving" (минимальное энергосбережение). При выборе этого параметра компьютер будет переходить в режим пониженного энергопотребления через время от 40 мин. до 2 часов (зависит от конкретного BIOS материнской платы),
"Disable" (запрещение) - запрещает режим энергосбережения.
Опция "Power Management Mode" (по названию совпадает со следующей опцией) предлагает такие значения:
"Customize" (аналогично "User Define") дает возможность пользователю установить "свои" параметры в полях "Standby Timeout", "Hard Disk Timeout", "Standby CPU Speed", "Video Timeout" (или им аналогичных) (устанавливается по умолчанию),
"Maximum",
"Medium",
"Minimum",
"Disabled".
Вот еще один вариант, предложенный "Phoenix BIOS". Опция "Power Savings":
"Disabled", "Enabled" (аналогично "User Define"), "Maximum Power Savings", "Maximum Performance".

Power Management Mode
- опция с таким названием может принадлежать любой версии BIOS. Современный вариант от "AMI" предлагает такие значения параметра:
"APM",
"ACPI",
"Disabled".
Power Saving Type
- опция предлагает выбрать один из режимов значительного энергосбережения, а точнее одну из разновидностей "сна". Значения опции следующие:
"POS" ("Power On Suspend") - наиболее "мягкий" режим "сна". Подробнее см. ниже,
"Sleep",
"Stop Clock" - полная остановка тактового генератора,
"Deep Sleep" ("глубокий сон") - максимальное энергосбережение.
Power Supply Type
- опция позволяет установить тип источника питания, а вместе с этим уровень компьютерной системы, ее возможность реализовать задачи энергосбережения, самотестирования источника питания, функций включения/выключения системы, т.п. Значения могут быть следующие: "AT", "ATX".
Video Off Method
- (метод выключения монитора). Устанавливается способ перехода монитора в режим пониженного энергопотребления. Может принимать значения:
"Blank Screen" - система очищает только экран, при этом происходит запись пустых кадров в видеобуфер. Видеокарта же работает в обычном режиме, в обычном режиме работает и монитор, с потреблением полной мощности,
"V/H SYNC+Blank" - параметр устанавливается по умолчанию и выбирается, если в системе имеется монитор с функциями PM. В добавление к очищенному экрану система отключит вертикальный и горизонтальный синхронизирующие сигналы, идущие от видеокарты,
"DPMS Supported". Использование этой опции возможно, если видеоподсистема поддерживает стандарт DPMS. DPMS (Display Power Management Signaling) - стандарт VESA, реализуемый с помощью программных функций операционной системы.
Не совсем аналогична, но все таки подобна приведенной опция "VGA Power Control". Она становится доступной, если предварительно включена опция "Inactive Mode". Опция очистки монитора может иметь следующие значения: "Normal", "DPMS" или "SMART".

Функции перевода в режимы пониженного энергопотребления

Hard Disk Power Down Mode
- данной опцией устанавливается режим консервации (энергопотребления), в который войдет жесткий диск после окончания установленного периода неактивности. Возможные значения: "Disabled" (рекомендуется), "Stand By" или "Suspend".
Аналогичная опция может также называться "HDD Off After".
Несколько другой смысл у опции "IDE Drive Power Down". Она имеет только два значения: "Disabled" и "Enabled" (по умолчанию). Последнее значение предусматривает автоматическое и безусловное отключение двигателя жесткого диска в конце периода неактивности.
"Phoenix BIOS" в опции "Power mode IDE-drive" предложил значения "Deaktiwated" и "Aktiwated".
Hard Disk Timeout
- для использования этой опции предварительно опция "Power Management Mode" должна быть установлена в "Customize" (или "Power Savings" в "Enabled"). Данной опцией устанавливается период неактивности жесткого диска, после чего производится отключение его двигателя, точнее перевод в состояние, установленное в опции "Hard Disk Power Down Mode". Практически каждая версия BIOS может внести свои коррективы в предлагаемые значения, которые в итоге могут изменяться от "1 Minute" до "1 Hour", а также "Disabled" (или "Off"). Поскольку практически любое воздействие на систему приводит к включению двигателя и его разгону (если он все-таки был отключен), то последнее наносит жесткому диску больший ущерб в сравнении с малоощутимым эффектом от экономии электроэнергии. Поэтому рекомендуется только "Disabled".
Опция может также называться "Hard Disk Time Out (Minute)", "HDD Power Down". Последняя опция, хотя и схожа по названию с представленной выше, тем не менее требует установки периода неактивности.
Еще несколько слов об опции "HDD Power Down", так как она, пожалуй, встречалась ранее чаще всего. При установке "базовой" опции "Power Management" в значения "Min. Power Saving" или "Max. Power Saving" для опции "HDD Power Down" автоматически фиксировались значения в 1 час и 1 минуту соответственно. Лишь параметр "User Define" позволял пользователю менять установки для жесткого диска. Естественно, что при отключении жесткого диска все остальные устройства продолжали находиться в активном состоянии.
Еще не так давно в название опций для жестких дисков входило наименование режима, т.е. период неактивности для конкретного режима энергопотребления указывался явным образом и сразу. Такие опции могли называться, например, "HDD Standby Timer". Интересно, что рекомендованное значение было связано с тем, какая операционная система установлена на диске и каков объем памяти. От этого зависила интенсивность использования системой жесткого диска. Например, для стандартной машины под MS-DOS рекомендовалась установка от 2 до 5 минут.
Slow Clock Ratio
- эта опция позволяет установить (в процентах от нормальной частоты процессора) частоту тактового сигнала при входе системы в режим "Standby". Ряд возможных параметров следующий: 0%-12.5%, 12.5%-25%, 25%-37.5%, 37.5%-50%, 50%-62.5%, 62.5%-75% и 75%-87.5%.
Опция может также называться "Manual Throttle Ratio" с аналогичным рядом значений: 12.5%, 25%, 37.5%, 50%, 62.5%, 75%, 87.5%.
И еще одна аналогичная опция - "Throttle Duty Cycle".
Standby CPU Speed
- опция "Phoenix BIOS", в общем-то аналогичная "Slow Clock Ratio", но ее значения заметно отличны от вышеприведенных. Для использования этой опции предварительно опция "Power Management Mode" должна быть установлена в "Customize" (или должны быть включены аналогичные установки). Если речь идет о серверной системе, то установка энергосберегающих режимов просто недопустима. Возможные значения данной опции следующие:
"Max" - стандартный режим работы процессора,
"High" - внутренняя тактовая частота процессора составляет 1/4 от максимального (стандартного) значения,
"Medium" - означает 1/8 стандартной частоты (по умолчанию),
"Low" - означает 1/16 стандартной частоты.
Standby Timeout
- для использования этой опции предварительно опция "Power Management Mode" должна быть установлена в "Customize" (или "Power Savings" в "Enabled"). Данной опцией устанавливается период неактивности всей системы, после чего производится перевод системы в режим "Standby". При этом все подсистемы компьютера переводятся в этот режим, а это видеосистема, жесткие диски. Тактовая частота процессора при этом устанавливается в соответствии с опцией "Standby CPU Speed". Если версия BIOS содержит еще установки для режима "Doze", то необходимо помнить, что этот режим предшествует режиму "Standby". Поэтому для последнего временные значения должны быть выше. А они могут изменяться от "1 Minute" до "1 Hour", а также "Disabled" (отказ от использования режима "Standby", или "Off").
Опция может также называться "Standby Timer Select", "Standby Timers", "Standby Time Out". Последняя опция предложила неожиданно такой временной диапазон - от 4 минут до 508 минут и с шагом в 4 минуты, а опция "Standby Timer Select" - диапазон 2 -:- 256 минут.
Standby/Suspend Timer Unit
- данная опция функционирует совместно с опциями "Standby Time Out" и "Suspend Time Out" и предназначена для выбора шага при работе с последними. Возможны следующие значения: "4 msec", "4 sec", "32 sec", "4 min".
Video Off Option
- (установка режима погашения монитора). Опция позволяет установить, при каком режиме энергосбережения на мониторе будет "погашен" экран. Может принимать значения:
"Always On" (всегда включен) - монитор никогда не будет погашен, даже если система будет находиться в одном из режимов,
"Suspend - Off" (погашение при включении режима "Suspend"),
"Susp, Stby - Off" (погашение при включении одного из режимов, "Suspend" или "Standby"),
"All modes - Off" (погашение во всех режимах).
Опция может также называться "Video Off After".
Video Power Down Mode
- данной опцией "AMI BIOS" устанавливается режим консервации (энергопотребления), в который войдет видеоподсистема после окончания установленного периода неактивности монитора. Возможные значения: "Disabled", "Stand By" или "Suspend".
Аналогичная опция может также называться "VESA Video Power Down" (т.е. речь идет о VESA-совместимой видеокарте), а значениями опции являются "Disabled", "Standby" (минимальное понижение энергопотребления), "Suspend" (значительное понижение), "Sleep" (по умолчанию - максимальное понижение). Но опция "VESA Video Power Down" может предложить и более "прозаический" вариант: "Disabled" и "Enabled" (по умоланию). Последнее означает разрешение на перевод видеоподсистемы в режимы "standby" или "suspend".
Тот же "AMI BIOS" может предложить опцию "Green PC Monitor Power State". То, что эти опции идентичны, ясно по значениям последней: "Off", "Stand By", "Suspend".

Серверные системы, как правило, имеют BIOS, отличный от "обычных" систем. Но эти отличия затрагивают прежде всего структурное построение "BIOS Setup", хотя хватает и функциональных различий. Вот и "Phoenix BIOS" предлагает свое специализированное подменю "Power On/Off", с опциями которого пользователь уже познакомился.

Power Off Source
Software
specifies whether the system can be switched off with a program (DeskOff, SWOFF) or an operating system (Windows 95, Windows NT with Siemens HAL). Enabled The system can be switched off with a program (default entry).. Disabled The system cannot be switched off with a program. Keyboard
specifies whether the system can be switched off using a special on/off button on the keyboard. Enabled The system can be switched off using a special on/off button on the keyboard. Disabled The system cannot be switched off using a special on/off button on the keyboard. (default entry). Power Button
specifies whether the system can be switched off with the On/Off switch on the front of the unit when the ACPI function is not active. Enabled The system can be switched off with the On/Off switch on the front of the unit. Disabled The system cannot be switched off with the On/Off switch on the front of the unit. If the On/Off switch on the front of the unit is pressed for longer than 4 seconds, the system always switches off. Power On Source
Remote
specifies whether the system can be switched on by an incoming message (e.g. via modem, fax or telephone). The signal can be supplied externally via serial port 1 or internally via the modem on connector. Enabled The system can be switched on by an incoming message (default entry). Disabled The system cannot be switched on by an incoming message. Keyboard
specifies whether the system can be switched on using a special on/off button on the keyboard. Enabled The system can be switched on using a special on/off button on the keyboard. (default entry). Disabled The system cannot be switched on using a special on/off button on the keyboard. Lan
determines whether the system can be switched on by means of an LAN controller (onboard or additional board). Enabled The system can be switched on by means of an LAN controller. Disabled The system cannot be switched on by means of an LAN controller. Timer
specifies whether the system can be timed to switch on at a particular time or after a particular period of time. The switch-on time cannot be specified in BIOS Setup. You require a suitable program for setting this switch-on time. Enabled The system can be switched on at set times. Disabled The system cannot be switched on under timer control (default entry). Rebooting after a critical system error (ASR&R Boot Delay field in the Server menu) is not affected by this setting.


BIOS. Продолжение!

Детальнее о режиме Suspend

ACPI Suspend Type
- возможные значения:
"S1(POS)" - включение функции "Power On Suspend",
"S3(STR)" - включение функции "Suspend to RAM".
Современные материнские платы все чаще поддерживают режим "Suspend to RAM". При активизации этого режима посредством интерфейса ACPI в "Windows 98" (или выше) компьютер полностью выключается, а питание сохраняется лишь для модулей памяти, куда и записывается информация о состоянии системы. После выхода из режима "STR" (путем нажатия клавиши на клавиатуре, по сигналу от модема, т.п.) состояние ПК, в том числе ОС и всех прикладных программ, восстанавливается.
Небольшая рекомендация! Для включения функции ACPI в процессе инсталляции "Windows 98" необходимо добавить следующие параметры в командную строку: setup.exe /pj.
Auto Suspend Timeout
- опция установки периода неактивности, по окончании которого система автоматически переводится в режим "Suspend". Если просуммировать различные версии BIOS, то этот интервал может меняться от 30 сек. до одного часа, а также присутствует стандартное "Disabled" (или "Off"). Правда, эти возможности доступны, если предварительно опция "Power Management Mode" установлена в "Customize" (или присутствует аналогичный вариант).
Опция может называться "Suspend Timeout", "Suspend Time Out", "Suspend Time Out (Minute)", "Suspend Time".
Опция может называться также "Suspend Mode" (см. ниже) и при этом предлагать целый ряд временных интервалов.
Пара важных замечаний! Поскольку режим "Standby" предшествует режиму "Suspend", то временные характеристики для последнего должны быть установлены несколько большей величины. И еще! Ниже будут рассмотрены вопросы, связанные с удаленным включением и пробуждением от сети. Но ситуация представляется иной, если речь идет о серверных установках. Тогда "Suspend Timeout" должен быть установлен в "Disabled". Опция должна быть заблокирована и при работе под "Windows NT", т.к. эта ОС не поддерживает доступа к функциям "power management".
Опция "Suspend Time Out" предложила также несколько нестандартный временной диапазон - от 4 минут до 508 минут и с шагом в 4 минуты.
PC98 Power LED
- если опция установлена в "Enabled", индикатор питания компьютера переключается в желтый цвет при переходе системы в режим "Suspend". Если ПК не имеет двухцветного индикатора, то при переходе системы в режим "Suspend" индикатор питания (мощности) будет отключен. Но это случится, если опция окажется включенной. Значения опции - это "Enabled" и "Disabled".
Несколько слов о сокращениях. PC98 - это спецификация компьютеров 1998 г., ежегодно предлагаемая "Microsoft" и "Intel". LED (Light-Emitting Diode) - светодиод, светодиодный индикатор.
Опция может называться "PC98 LED".
Save To Disk
- эта опция "Phoenix BIOS" носит самостоятельный характер. Основное требование - функция "Power Management Mode" должна быть установлена в "Customize". При включении опции ("Enabled") состояние системы: содержание основной памяти, рабочей памяти, видеопамяти, кэша сохраняется на жестком диске в файле SAVETO.DSK при входе системы в режим "Suspend". Если установлено "Disabled", никакого "спасения" не производится (устанавливается по умолчанию).
Suspend Mode Option
- опция позволяет выбрать один из вариантов режима "Suspend", почти аналог "ACPI Suspend Type":
"POS" ("Power-on suspend", иногда обозначается "Static Suspend") - центральный процессор находится в режиме пониженного энергопотребления с приостановкой внутренней тактовой частоты,
"Auto" - по окончании периода "неактивности", установленного в поле "Auto Suspend Timeout", система автоматически переводится в "STD"-режим. Если же такой режим недоступен, система переводится в "STR"-режим,
"STD" ("Suspend to Disk", иногда как "Save to disk", а иногда такой режим называют "0V Suspend") - информация о состоянии системы, действующих приложениях записывается на жесткий диск, система отключается с последующим восстановлением,
"STR" (Suspend to RAM).
Опция может также называться "Suspend Option", хотя и с другими значениями: "POS", "STD".
Suspend Power Saving Type
- данной опцией устанавливается тип, а точнее даже одна из ступеней режима "Suspend". Возможны следующие значения:
"S1" (standby 1) - останавливаются тактовые генераторы CPU и всей системы, но при этом состояние памяти остается неизменным. Выход из S1 осуществляется мгновенно,
"S2" (standby 2) - также останавливаются тактовые генераторы CPU и всей системы, но к тому же отключается питание кэш-памяти и CPU, а данные, хранившиеся там, перезаписываются в основную память. Включение системы также происходит достаточно быстро.
Suspend Switch
- (переключатель режима "Suspend"). Параметр разрешает ("Enabled") или запрещает ("Disabled") переход в режим "Suspend" с помощью кнопки на системном блоке. Для этого необходимо соединить джампер SMI (System Management Interface) на материнской плате с кнопкой на лицевой панели. Как правило, для этого используется либо специальная кнопка <SLEEP>, либо кнопка <TURBO>.
Опция "Switch Function" вроде бы аналогична предыдущей, но ее возможности несколько шире. При выборе значения "Deturbo" и последующем нажатии кнопки <POWER> система переходит в режим пониженного энергопотребления. Нажатие любой клавиши на клавиатуре возвращает систему к полной мощности. Следующий вариант: "Break" > кнопка питания - система вводится в "Suspend"-режим. Эффект от нажатия любой клавиши тот же. И еще вариант: "Break/Wake" > кнопка питания > "Suspend"-режим. Только в этом случае к полной мощности систему вернет повторное нажатие кнопки <POWER>.
Video Off In Suspend
- эта опция активирует функцию "Video Off", когда система входит в "Suspend Mode". Возможных вариаций для ответа две: "Yes" и "No".

Функции отключения системы

After G3 Enable
- данная опция позволяет (если установлено "Enabled") в результате переключения режимов энергосбережения выйти на состояние G3, которое по методологии ACPI означает полное отключение питания (mechanical off).
Power Button Function
- опция отключения системы, во многом аналогичная последующим функциям. Может принимать значения:
"On/Off" - в этом случае включение ПК и его отключение производится от кратковременного нажатия кнопки <POWER>,
"Suspend" - при включенном состоянии ПК кратковременное нажатие кнопки питания активирует режим "Suspend". При более длительном удержании кнопки (более 4 сек.) система отключается.
Аналогичная опция может называться "Power Button Mode".
Power Button Over Ride
- еще один вариант функции по отключению ПК. Может принимать значения:
"Enabled" (по умолчанию) означает, что для выключения питания компьютера могут применяться другие методы, а не механическое нажатие кнопки <POWER>. В данном случае речь идет об удержании кнопки более 4 сек.,
"Disabled" - безусловное отключение системы.
Power-Off by PWR-BTTN
- опция выбора метода для управления отключением системы. Возможные значения параметра:
"Hold 4 Sec" (удерживать 4 секунды) - независимо от того, какая установка сделана в поле "Power Management", если кнопка включения питания нажата и отпущена менее чем через 4 сек., система входит в режим "Suspend". Назначение этой функции в предотвращении выключения системы в случае непреднамеренного нажатия кнопки <POWER>. Удержание кнопки более 4 секунд приводит к отключению ПК,
"Instant-Off" - если установлено это значение, то при нажатии кнопки <POWER> система отключается безо всяких условий и немедленно.
Аналогичная опция "AMI BIOS" может называться "Soft-Off by PWRBTTN" и со значениями "Instant Off" и "Delay 4 Sec.".
Следующая функция почти во всем аналогична текущей, но из-за некоторых различий приведена полностью.
PWR Button < 4 Secs
- (кнопка питания нажата менее 4 секунд). Опция управления функциями кнопки <POWER> на системном блоке компьютера. Может принимать значения:
"Soft Off" - программное выключение. Кнопка работает как обычная кнопка включения/выключения питания компьютера, но при этом разрешается программное выключение компьютера при выходе из "Windows",
"Suspend" - временная остановка. При нажатии на кнопку питания на время менее 4 секунд компьютер переходит в состояние "Suspend",
"No Function" - функция не задействована. Кнопка <POWER> становится обычной кнопкой включения/выключения питания.
Soft Power Off
- опция программного выключения системы от "Phoenix BIOS". Если опция включена ("Enabled"), компьютер может быть выключен программным путем. Это же значение устанавливается по умолчанию.

Функции включения системы

AC PWR Loss Restart
- (рестарт после пропадания питания). Разрешение этого параметра позволяет системе включиться автоматически после пропадания питания. В противном случае после восстановления питания система не включится, и необходимо будет снова нажать кнопку подачи питания. Может принимать значения:
"Enabled" - разрешено (по умолчанию),
"Disabled" - запрещено.
Абсолютно аналогична опция "AMI BIOS" "Auto Start On AC Loss".

Automatic Power Up
- (автоматическое включение). Используя этот параметр, можно включать компьютер ежедневно в указанное время или включить его в указанный день и час. Может принимать значения:
"Everyday" (ежедневно) - при вводе времени компьютер будет включаться ежедневно в назначенное время. Время вводится в поле "Time (hh:mm:ss) Alarm" в порядке - часы:минуты:секунды,
"By Date" (по дате) - компьютер включится в заданный день и в заданное время. При выборе этого параметра появляется дополнительное поле для ввода времени (такое же, как и для "Everyday") и поле для ввода дня месяца - "Date of Month Alarm",
"Disabled" - запрещение применения автоматического включения.

Display Activity
- опция "AMI BIOS", позволяющая отслеживать любую активность видеосистемы и тем самым выводить всю систему из состояния одного из режимов энергосбережения в полнофункциональный режим. Для этого опция должна быть установлена в "Monitor". Значение "Ignore" блокирует эти возможности.
Аналогичны также опции "VGA Active Monitor", "Video Detection", хотя в некоторых случаях речь может идти конкретно о выходе из режима "Standby". Аналогична вышеприведенным и опция "Monitor Event in Full On Mode".

HDD Detection
- если опция включена ("Enabled"), любая активность жесткого диска вызовет пробуждение всей системы или перезапуск таймера неактивности.

IRQ8 Resume by Suspend
- (пробуждение по IRQ8). Опция включения "alarm"-функций. Разрешение этого параметра позволяет "разбудить" компьютер, соответствующим образом запрограммировав "Alarm Time" (время тревоги), так как сигнал от RTC (часы реального времени) заведен на IRQ8. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Абсолютно идентичная опция "IRQ8 Break Suspend".
Аналогична и опция "IRQ8 Clock Event" со значениями "Turn On" и "Turn Off". Хотя в таком виде эта опция может входить и в отдельное меню "PM Events".

Keyboard/Mouse Power On
- для использования этой функции в некоторых случаях возможно придется переставить в положение "On" соответствующую перемычку на материнской плате, например, под названием "The Wake-On-Keyboard/Mouse". При активизации опции при использовании режимов энергосбережения система будет просыпаться при воздействии на "мышь" или клавиатуру. Выбирая один из возможных параметров, мы устанавливаем источник, обнаружив изменение состояния которого BIOS пробуждает систему. Может принимать значения: "Disabled" (по умолчанию), "Password", "Hot Key", "Mouse Left", "Mouse Right", "Any Key", "Keyboard 98".
x KB Power On Password
- когда в базовой опции выбрано значение "Password", активным становится поле "KB Power On Password". За нажатием клавиши <ENTER> следует ввод пароля. При выходе из режима Suspend необходимо ввести корректный пароль, иначе не спасет и кнопка включения питания.
x KB Power On Hot Key
- при выборе значения "Hot Key" активируется поле "KB Power On Hot Key". Пользователю предлагается на выбор один из вариантов для запуска системы с помощью "горячих клавиш" из ряда: <CTRL+F1> -:- <CTRL+F12>.
С некоторыми значениями все интуитивно понятно. А с "Keyboard 98" объяснение следующее. Это значение будет работать, если ПК укомплектован "Windows 98"-совместимой клавиатурой, на которой есть клавиша "Wake Up" (или просто "Wake"). Тогда для пробуждения системы будет использоваться только эта клавиша. Правда, еще одно условие - наличие "Windows 98" (или выше).
Базовая опция может также называться "Power On Function" с подобными параметрами: "Button Only", "Keyboard 98", "Hot Key", "Mouse Left", "Mouse Right". Для стандартной работы должно быть установлено "Button Only" (только кнопкой), чтобы система срабатывала только при нажатии на кнопку питания на корпусе. Возможны проблемы с "мышиным" использованием, т.к. гарантировано срабатывают только PS/2-мыши, да и то не все. Мыши для USB- и COM- портов не срабатывают. Об этом косвенно можно судить по названию опции "PWR up on PS2 KB/Mouse".

Keyboard Wake-up Function
- опция, несущая аналогичную нагрузку, как и предыдущая (за исключением "мышиных" параметров). Т.е. могут присутствовать те же значения ("Any Key", "Disabled", т.п.). Такая же опция может предложить более простой выбор: "Enabled" и "Disabled".
Опция с названием "Keyboard Resume" имеет абсолютно те же (простые) значения.

Mouse Wake-up Function
- также самостоятельная опция. Предлагается пробуждение от "мыши". Значения стандартные: "Enabled" и "Disabled".

On PME
- опция "Phoenix BIOS", разрешающая ("Power On" - по умолчанию) или запрещающая ("Stay Off") системе реагировать на внешние воздействия в тот момент, когда система находится в отключенном состоянии или в одном из состояний "сна". PME есть не что иное, как "power management event".

PM Events
- в этой секции (отдельное подменю) указываются те прерывания, от обращения к которым компьютер должен "просыпаться". Понятно, что под прерываниями "скрываются" конкретные периферийные устройства.
"IRQ 3 (Wake-up)" - разрешение этого параметра приведет к "пробуждению" компьютера от модема или мыши, подключенных к COM2.
"IRQ 4 (Wake-up)" - разрешение этого параметра приведет к "пробуждению" компьютера от модема или мыши, подключенных к COM1.
"IRQ 8 (Wake-up)" - разрешение этого параметра приведет к "пробуждению" компьютера от часов реального времени. Рекомендуется оставить его запрещенным, так как некоторые программы могут использовать функцию "будильника" часов компьютера для своих целей.
"IRQ 12 (Wake-up)" - разрешение этого параметра приведет к "пробуждению" компьютера от мыши, подключенной к порту PS/2.
Каждая из опций может принимать значения: "Enabled" (разрешено) или "Disabled" (запрещено).

PWR Lost Resume State
- опция определения метода включения (или не включения) питания компьютерной системы после пропадания сетевого напряжения. Возможности этой опции значительно шире приведенной выше "AC PWR Loss Restart", поэтому она и выделена отдельно. Может принимать значения:
"Keep Off" - при потере питания в сети и его восстановлении для включения ПК необходимо нажать кнопку питания,
"Turn On" - восстановление питания вызывает автоматическое включение системы,
"Last State" - к автоматическому включению ПК добавляется возможность восстановления системы в том состоянии, в котором она находилась на момент пропадания питания.
"AMI BIOS" содержит аналогичную опцию "Restore on AC/Power Loss" со следующими значениями:
"Last State" (по умолчанию) - аналогично вышеуказанному,
"Stay Off" - аналогично "Keep Off",
"Power On" - аналогично "Turn On".
Опция с названием "After Power Failure" имеет абсолютно те же значения.
Еще одна интересная опция - "PWRON After PWR-Fail". Возможные значения параметра:
"On" - автоматическое включение ПК после восстановления питающего напряжения,
"Off" - никакая информация о состоянии системы не сохраняется. Обычный перезапуск компьютера через нажатие кнопки,
"Former-sts" - система возвращается в состояние, которое было перед пропаданием сетевого напряжения, но только через нажатие кнопки <POWER>.
И еще одна опция - "State After Power Failure". Возможных значений также три: "Auto", "Off", "On". Если последние два значения уже легко распознаваемы, то первое обозначает и "автоматическое" включение, и восстановление системы в прежнем состоянии.

Resume on PCI Event
- при установке опции в "Enabled" появляется возможность "пробуждения" системы, если PCI-карта (модем или сетевая карта) получили сигнал извне. При этом PCI-карта должна поддерживать функцию "Wake Up". При запрещении опции система никак не отреагирует на внешнее воздействие.

Resume by Ring
- при установке опции в "Enabled" входящий звонок приводит к "пробуждению" системы. При входящем звонке прежде всего активизируется линия модема и последовательного интерфейса Ring Indicator. По умолчанию опция устанавливается в "Disabled".
В других версиях BIOS опция может называться "Power On By Modem", "PWR Up On Modem Act" или "Ring Resume From Soft Off".
Использование этих опций возможно при использовании как внешнего, так и внутреннего модемов, обязательно поддерживающих функцию "Modem Wake Up". При этом внешний модем должен быть естественно включен в то время, как система находится в "спящем" состоянии.
Напоследок еще некоторые варианты аналогичных опций.
"AMI BIOS":
"RI Resume",
"Power-On COM1 Ring",
"On Modem Ring". Значения "Stay Off" (по умолчанию) и "Power On" идентичны приведенным выше "Disabled" и "Enabled".
И еще одна опция от "Phoenix BIOS", название которой может смутить пользователя, - "Remote Power On". Речь, хотя и идет об удаленном включении, но о включении от того же факса, например. "Enabled" устанавливается по умолчанию.
И еще одно важное замечание! Модем только инициирует пробуждение системы, которое, собственно говоря, начинается со стандартной загрузки операционной системы. А она в свою очередь инициирует полноценную (Full On) работу модема только после своей загрузки, а значит, процедуру соединения придется повторить. Естественно, что эта задача несколько упрощается, если включены режимы сохранения состояния системы на жестком диске или в памяти (см. выше).
Кстати, если все компоненты системы поддерживают функцию "Modem Wake Up", то включение питания модема (речь идет о внешнем модеме, конечно) может инициализировать включение компьютера.

RTC Alarm Resume
- при установке опции в "Enabled" система включится в указанное время, устанавливаемое в следующих 4-х полях. Эти поля будут недоступны при запрещении опции.
x RTC Alarm Date
x RTC Alarm Hour
x RTC Alarm Minute
x RTC Alarm Second
Из этого нетрудно увидеть, что при установке конкретной даты система запустится только один раз в месяц. Поэтому в этом поле предусмотрен и отказ от указания какого-либо числа месяца. Уже из названия функции следует, что за временем зорко следят "часы реального времени" (real-time clock), выводя систему из режима Suspend.
Опция может также называться "Power Up by Alarm", "Power On By Alarm", "RTC Wake Up Timer", "RTC Wake-up", "Resume by Alarm", "Resume On Alarm", "RTC Alarm Resume From Soft" или "RTC Resume".
В зависимости от "звучания" основной опции могут по-другому именоваться и подопции. Так, "Resume On Alarm" предложила, например, подопции "Date (of Month) Alarm" и "Time (hh:mm:ss:) Alarm". Независимо от многообразия форм представления подобных меню сложности это не должно вызывать. Надо помнить только один нюанс! Для некоторых систем при установке времени желательно, чтобы устанавливаемое (alarm) время было больше текущего времени по RTC.

USB Controller Resume
- включение опции ("Enabled") имеет смысл при включенном USB-контроллере и используемой периферии, например, той же USB-клавиатуре.

Wake On LAN
- (пробуждение от сети). При разрешении этого параметра компьютер может быть включен ("пробудится") по сигналу от локальной сети. Такое включение возможно только при установке в компьютер сетевой карты, поддерживающей удаленное "пробуждение" (сетевая карта, как минимум, должна иметь специальный трехконтактный разъем для подключения к системной плате), а также при полной поддержке данной технологии со стороны BIOS.
Кроме того, реализация технологии удаленной сетевой активизации/управления (Wake On LAN) напрямую взаимосвязана с новой спецификацией соединителей для источников питания, соответствующей требованиям спецификации ATX 2.01. Согласно этой спецификации разъем питания ATX имеет контакт 5VSB (или STB5V - 5V standby) - "питание в дежурном режиме". По требованиям спецификации устройства в этом режиме должны потреблять не более 10 мА, но для поддержания технологии "Wake On LAN" (т.е. для поддержания в дежурном режиме функционирования сетевого оборудования) производители блоков питания должны обеспечивать в этом режиме не менее 720 мА. Стоит напомнить, что если система находится в режиме "Suspend", то она пробуждается только через активизацию IRQ или DMA. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Необходимо понимать также и то, что речь ведется не о каком-нибудь "возбуждающем" сигнале. По сети передается "адресный" пакет, который к тому же может быть "запакован" в один из стандартных сетевых протоколов (IPX, IP, ...). "Заголовок" пакета представляет собой несколько байт единиц, что можно назвать синхронизирующей последовательностью. После чего следует 48-битный MAC-адрес, абсолютно уникальный для каждой сетевой карты.
Опция может также называться "Resume On LAN", "Wake up on LAN" или, как в "AMI BIOS", "LAN Wake-up".
"Phoenix BIOS" предлагает еще один вариант под названием "On LAN" и со значениями "Stay Off" и "Power On" (по умолчанию). Смысл этих значений уже понятен.
Опция "LAN Wake-up For Addon LAN" (или "LAN Wake-up For Onboard LAN") отличается от уже предложенных разве только тем, что речь идет об интегрированной сетевой карте.
x LAN wake-up mode
- опция доступна при включении предыдущей опции. Через эту опцию "Phoenix BIOS" позволяет при удаленном включении включить и монитор ("On"). В противном случае - "Off".

Wakeup on Keyboard
Wakeup on Mouse
Wakeup on Modem
Wakeup on COM1
Wakeup on USB
- в некоторых случаях версия BIOS может предложить пользователю поработать с небольшим меню-набором "пробуждающих" опций, в данном варианте "не привязанных" к аппаратным прерываниям. Это также может оказаться удобным для неподготовленных пользователей. Содержание опций понятно. Стоит добавить, что значениями являются "No" и "Yes".
Почти идентичный вариант работы с подменю в некоторых случаях предлагает "AMI BIOS":
Device 0 (Primary master IDE)
Device 1 (Primary slave IDE)
Device 2 (Secondary master IDE)
Device 3 (Secondary slave IDE)
Device 5 (Floppy disk)
Device 6 (Serial port 1)
Device 7 (Serial port 2)
Device 8 (Parallel port)
Значения этих опций следующие: "Monitor" (по умолчанию) и "Ignore". Если установлено "Monitor", то система будет отслеживать выставление запроса от периферийных устройств, т.е. система будет реагировать на аппаратное прерывание. Естественно, что предложенные опции выполняют те же функции, что и разнообразные меню типа "PM Events".

BIOSFaX menu

Это специализированное меню (небольшой раздел), характерное для некоторых версий "Phoenix BIOS", связано с возможностью включения системы от модема. В процессе этого включения любой входящий звонок или факс будут сохранены. Естественно, что дальнейшие возможности работы со звонками или факсами связаны с применяемым прикладным коммуникационным ПО. Важнейшее требование к системе - это реализация возможностей удаленного включения (Remote on).
x Receive Mode
- опция для установки режима приема. Возможные значения:
"Voice and Fax" - любой входящий звонок или факс будут записаны,
"Voice" - только входящий звонок будет записан,
"Fax" - только входящий факс будет записан,
"Disabled" - функционирование модема невозможно при отключении системы (устанавливается по умолчанию).
x Ring Count
- это поле используется для определения, сколько раз будет звучать тональный сигнал при приходе входящего звонка перед ответом модема. Возможные значения: 2, 3, 4, 5, 6, 7 или "Auto" (по умолчанию).
x Fax Tone Count
- это поле используется для определения, сколько раз будет звучать тональный сигнал при приходе факса перед ответом модема. Возможные значения: 1, 2, 3, 4, 5, 6, 7 или "Auto" (по умолчанию).
x Fax Modem Port
- это поле показывает основную характеристику последовательного интерфейса, используемого модемом. Значение параметра, присвоенное системой, не может быть изменено. Может принимать значения: "COM1", "COM2", "COM3" или "COM4".
Опция может также называться "Serial Port".

15. Monitoring

Первой фирмой, которая стала применять встроенные средства контроля в массовых моделях системных плат, стала компания "ASUSTeK". Один из лидеров производства материнских плат начал встраивать систему "PC Health Monitoring", построенную на основе специальной аналого-цифровой микросхемы LM78 производства "Analog Devices" (США). С помощью этого АЦП стало возможным измерять температуру и напряжения, определять состояние охлаждающих вентиляторов, т.п.

Hardware monitor
- опция включения (если "Enabled") функции аппаратного мониторинга системы.
Temperature Monitoring
- опция включения ("Enabled") функции температурного мониторинга системы.

Секция "Fan Monitor"

Chassis Fan Speed
CPU Fan Speed
Power Fan Speed
- (скорость вращения дополнительного вентилятора в корпусе компьютера, вентилятора охлаждения процессора, вентилятора блока питания). Один из возможных вариантов мониторинга за состоянием охлаждающих вентиляторов. При выборе значения "Ignore" скорости вращения этих вентиляторов отслеживаться не будут. Значение "Monitor" (или аналогичное) позволяет системе вести наблюдение за состоянием вентиляторов и их скоростью. При этом в информационной части секции будут выведены поля типа Chassis Fan Speed (xxxx RPM), например.
CPU fan on temp high
- согласно этой опции вентилятор процессора включится, когда его температура достигнет установленного опцией предельного значения.
Fan Control
- данная опция позволяет управлять скоростью вентилятора центрального процессора. Значения опции следующие:
"Enhanced Cooling" - вентилятор вращается с максимально возможной скоростью,
"Auto" - скорость вращения вентилятора регулируется автоматически в соответствии с температурой процессора,
"Silent" - изменение внутренней скорости процессора, связанное с различными режимами работы CPU, в том числе режимами энергосбережения, приводит к уменьшению скорости вращения вентилятора. Это в итоге ведет к уменьшению шума.
Опция с тем же названием предложила совсем иные параметры:
"Enabled" - скорость вентилятора системой контролируется. При этом никаких дополнительных сообщений не выводится,
"Disabled" - установка максимальной скорости вентилятора (по умолчанию).
Практически идентичны последним параметры опции "Fan Speed":
"Auto" - скорость вентилятора процессора регулируется автоматически,
"Full" - удерживается максимальная скорость вентилятора.
Fan OFF at Suspend
- если опция включена ("Enabled"), вентилятор CPU отключится при входе системы в режим "Suspend". При выборе "Disabled" вентилятор процессора останется включенным.
Опция может называться и "CPUFAN Off in Suspend".
Fan State
- с помощью этой опции есть возможность контролировать не скорость вентиляторов системы, а их состояние. Предполагается, что таких вентиляторов три. Это вентиляторы центрального процессора, блока питания и дополнительный вентилятор на корпусе компьютера ("CPU", "Power Supply", "Auxiliary"). Естественно, что вентиляторы должны поддерживать функцию контроля (это решается аппаратно). По всем трем вентиляторам значения могут быть следующими и они носят информационный характер:
"OK" - состояние вентилятора контролируется и выводится на монитор ("включен"),
"None" - вентилятор не распознается BIOS,
"Fail" - BIOS распознал неисправный вентилятор, или вентилятор изъят из системы.
Если вентилятор не поддерживает функцию, то будет выведено сообщение "None" при работающем вентиляторе.

Секция "Thermal Monitor"

CPU Temperature
MB Temperature
- (температура процессора, температура материнской платы). Один из возможных вариантов температурного мониторинга. При выборе значения "Ignore" температуры процессора и системной платы отслеживаться не будут. Значение "Monitor" (или аналогичное) позволяет системе вести наблюдение за температурой. Естественно, что в отдельных полях (опциях) устанавливаются предельные значения для соответствующих компонентов. Тогда при критическом повышении температуры BIOS будет выдавать сообщение на экране перед загрузкой операционной системы.
CPU Warning Temperature
- уже из названия опции ясно, что речь в ней идет о допустимой температуре процессора, за пределами которой возможны нарушения в его работе. Для надежной работы системы можно порекомендовать пользователю иметь предустановленное прикладное ПО для постоянного мониторинга жизнедеятельности компьютера. Значения опции могут быть представлены, например, в таком виде: "Disabled", "50C/122F", "53C/127F", "56C/133F", "60C/140F", "63C/145F", "66C/151F", "70C/158F".
Shutdown Temperature
- согласно параметрам этой опции система автоматически отключится (без каких-либо предварительных условий) при достижении температуры процессора критического значения. Вот один из возможных наборов таких температур: "60C/140F" (по умолчанию), "65C/149F", "70C/158F", "75C/167F".
System Thermal
- установка режима наблюдения за системной температурой. Выбор вариантов для данной функции невелик. Установка "Ignore" блокирует возможность перевода центрального процессора на безопасный режим работы. Параметр "Monitor" позволяет системе отслеживать возможность появления опасной ситуации. В данном случае речь идет о достижении процессором критической температуры, устанавливаемой в поле "CPU Critical Temperature". При достижении центральным процессором этой температуры внутренняя частота процессора снижается до величины, устанавливаемой в процентах в поле "Thermal Slow Clock Ratio".
x Thermal Slow Clock Ratio
- возможные варианты: 0%-12.5%, 12.5%-25%, 25%-37.5%, 37.5%-50%, 50%-62.5%, 62.5%-75% и 75%-87.5%.
x CPU Critical Temperature
- возможные варианты: "Disabled", "45C", "50C", "55C", "60C", "65C", "70C", "75C".
Thermal Sensor State
- с помощью этой опции есть возможность контролировать не величины температур в системе, а состояние температурных датчиков. Предполагается, что таких датчиков три. Это датчики центрального процессора, системной платы и дополнительный датчик, размещенный пользователем, например, на корпусе компьютера ("CPU", "System", "Auxiliary"). Естественно, что все датчики должны поддерживать функцию контроля (это решается аппаратно). По всем трем датчикам-сенсорам значения могут быть следующими и они носят информационный характер:
"OK" - состояние датчика контролируется и выводится на монитор ("включен"),
"None" - датчик не распознается BIOS,
"Fail" - BIOS распознал неисправный датчик, или датчик изъят из системы.
Если датчик не поддерживает функцию контроля, то будет выведено сообщение "None" при работающем датчике.

16. Special

MPS 1.4 Support
- поддержка режима MPS 1.4 (Intel Multiprocessor Specification). Этот параметр появляется только в BIOS материнских плат, допускающих установку нескольких процессоров. Параметр указывает операционной системе, какую версию мультипроцессорной спецификации поддерживает плата. При этом возможности BIOS достаточно велики, т.к. BIOS подготавливает таблицы, из которых операционная система получит информацию о мультипроцессорной конфигурации системы.
В MPS версии 1.4 добавлена поддержка расширенной таблицы, улучшающей работу с несколькими PCI-портами. При запрещении устанавливается режим MPS 1.1. Большинство современных серверных мультипроцессорных ОС поддерживают режим MPS 1.4. Рекомендуется устанавливать режим MPS 1.1 ("Disabled") только при работе со старыми операционными системами, в т.ч. различными версиями ОС "Windows". Для "Windows NT", "Novell Netware" естественно рекомендуется "Enabled".
MPS Version Control For OS
- аналогичная опция со следующими значениями:
"1.4" (по умолчанию),
"1.1".
С теми же параметрами в "AMI BIOS" замечены опции "MPS Revision", "MP Version", "MPS Version". Тот же "AMI BIOS" предложил вот такой "длинный" вариант - "Use Multiprocessor Specifications".
Аббревиатуре MPS очень близка по звучанию другая, а именно - SMP. Поскольку речь идет также о мультипроцессорных системах, то имеет смысл хотя бы несколько слов сказать об этом. Тем более, что может возникнуть некоторая неясность при чтении компьютерной литературы у неподготовленного пользователя.
При SMP (Symmetric MultiProcessing - симметричная мультипроцессорная обработка) процессоры, объединенные общей шиной, разделяют между собой общие системные ресурсы компьютера, включая память и внешние устройства. Но и в такой "могучей" системе действует принцип, характерный для функционирования "мастер"-устройств в "обычной" системе. Системной шиной может управлять в каждый момент времени только один процессор, при этом каждый процессор продолжает "вести" свою задачу.

Spread Spectrum Modulated
- (распространение модулированного спектра). При работе тактового генератора может возникать такое явление, как электромагнитная интерференция (ElectroMagnetic Interference - EMI). Физически интерференция есть не что иное, как взаимодействие (наложение) двух или более волновых колебаний. В их появлении, сопровождающемся характерными для таких процессов многочисленными частотными гармоническими составляющими, "виноваты" экстремальные значения (пики) генерируемых тактовых импульсов. Включение опции позволяет сгладить пики и уменьшить интерференцию, а также уменьшить взаимное электромагнитное влияние различных компонент системной платы друг на друга. Также необходимо отметить, что при нынешнем глобальном повышении внутренних частот процессора растет и электромагнитное воздействие последнего на другие компоненты системы. На решение означенных выше задач направлен целый комплекс средств, следящий за работой тактового генератора и качеством вырабатываемых им сигналов.
Уменьшение электромагнитного излучения, кроме чисто технических задач, затрагивает и экологические проблемы, оно может достигать в некоторых случаях 6%. Следует заметить, что это может отрицательно отразиться на работе чувствительных к форме сигнала устройств, например, жестких дисков с интерфейсом Fast Wide SCSI. Поэтому параметр рекомендуется разрешать только при испытаниях компьютеров на электромагнитную совместимость.
Кроме того, есть еще режим "Smart Clock". В этом режиме тактовые сигналы для разъемов AGP, PCI и SDRAM отключаются в момент, когда не требуется их использование. В таком случае включение опции не сказывается на стабильности работы. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено,
"0.25%",
"0.5%",
"Smart Clock".
Опция может называться "Spread Spectrum".
Дополнительная информация содержится также в подразделе "CPU Speed".
Auto Detect DIMM/PCI Clk
- чтобы снизить возможность появления электромагнитной интерференции, BIOS определяет наличие/отсутствие компонентов в DIMM- и PCI-слотах и выключает подачу импульсов тактового генератора системы в пустые слоты. Может принимать значения:
"AUTO" - автоматический режим,
"Disabled" - запрещено.
Обычно "Disabled" устанавливается по умолчанию, к тому же "AUTO" в других версиях может быть заменено "Enabled".
Clock for Spread Spectrum
Возможные значения: "Disabled", "0.5%", "1.0%", "1.5%", "3.0%".

17. Server Menu

EMP Password
- серверная плата (например, C440GX) обязательно имеет порт под названием EMP (Emergency Management Port - порт аварийного управления), представляющий собой последовательный порт, посредством которого оператор (администратор) может включать и отключать сервер, выполнять его сброс и (с монитора и клавиатуры локального сервера) подключаться к удаленным серверам. Подключение к EMP осуществляется через последовательный порт другого компьютера или модема для доступа по коммутируемой линии телефонной связи. Данный параметр позволяет защитить доступ к консоли EMP ("Enabled") или открыть доступ к ней ("Disabled").
Аналогичная функция "Phoenix BIOS" называется "EMP Password Switch", а вот собственно пароль устанавливается опцией "EMP Password". Опция становится доступной при включении предыдущей. Для ввода пароля могут использоваться буквенные и цифровые символы: A..Z, 0..9. При неправильном вводе пароля выдается звуковой сигнал.
EMP Restricted Mode Access
- если опция включена ("Enabled"), нельзя дистанционно отключать и включать питание сервера и перезапускать удаленное оборудование.
EMP Access Mode
- данной функцией выбирается одна из опций, определяющих, при каких условиях или режимах будет доступен порт EMP. Возможные значения следующие:
"Pre-boot Only" - доступ разрешается только до момента завершения теста самопроверки. При завершении POST в процессе загрузки операционной системы порт COM2 возвращается операционной системе для стандартного использования,
"Always Active" - EMP постоянно доступен. COM2 не может быть использован операционной системой, т.к. специально выделяется под EMP,
"Disabled" - EMP запрещен. COM2 всегда доступен для использования операционной системой или "Console Redirection Submenu" (см. ниже).
EMP Direct Connect/Modem Mode
- BIOS использует управляющую последовательность, последовательность отключения и начальную строку для работы с модемом. Режим прямого подключения подавляет эти последовательности, исходя из предположения, что связь с другим компьютером осуществляется посредством связанных друг с другом последовательных портов (конкретнее, - с помощью "null"-модемного кабеля). Возможные значения: "Direct Connect" и "Modem Mode". По умолчанию в разных версиях BIOS устанавливаются и разные значения.
EMP Escape Sequence
- в случае взаимодействия с EMP посредством модема системе требуется способ перевода присоединенного модема в командный режим. Для указания запроса на переход в режим команд в большинстве модемов используется специальная строка "+++", называемая управляющей последовательностью (escape sequence). Одно условие - используемый модем должен быть совместим с набором команд Hayes AT. Какая бы управляющая последовательность не требовалась модему, ее необходимо ввести в этой опции. Эта опция используется только в том случае, если опция "EMP Direct Connect/Modem Mode" установлена в режиме модема.
EMP Hangup Line Sequence
- системе требуется также иметь возможность заставить модем прервать действующий вызов. Совместимые с набором команд AT модемы используют управляющую последовательность для перехода в командный режим, а затем отправляют команду "ATH". И эта опция используется только в том случае, если опция "EMP Direct Connect/Modem Mode" установлена в режиме модема (как и некоторые последующие).
Аналогичная функция "Phoenix BIOS" называется "EMP Hang-up Line String".
Modem Init String
High Modem Init String
- опции ввода строки инициализации. Пример строки - "AT&F0S0=1S14=0&D". Длинная строка используется, если общая длина последовательности превышает 16 символов. При этом 16 символов вводится в начальной строке, а "излишек" вводится в "High Modem Init String".

Console Redirection Submenu

BIOS серверных систем, как правило, содержит дополнительное подменю для установки параметров, доступ к которым обычно производится при настройке операционной системы, а точнее, коммуникационных параметров ОС (имеется ввиду, например, "Windows9x"). Довольно близки в этом плане по содержанию различные версии BIOS, но данная информация изложена на конкретном варианте "Phoenix BIOS".

COM Port Address
- возможны варианты:
"Disabled",
"3F8" - обычно адрес COM1,
"2F8" - обычно адрес COM2,
"3E8".
После указания адреса все действия пользователя на клавиатуре, с мышью, вся видеоинформация будут направляться на указанный порт. Но все это будет возможно только под DOS и в текстовом режиме.
IRQ #3(4)
- когда "console redirection" доступна пользователю (включена), в этом поле показывается IRQ, назначенное порту после выбора соответствующего адреса в предыдущей опции. Если же в предыдущей опции было выбрано "Disabled", то параметр "None" означает, что прерывание будет выбрано автоматически.
Baud Rate
- возможны варианты: "9600", "19.2k", "38.4k", "115.2k".
Flow Control
- опция выбора типа управления потоком. Возможны следующие варианты параметров:
"No Flow Control" - управление потоком не установлено,
"CTS/RTS" - аппаратное управление потоком,
"XON/XOFF" - программное управление потоком,
"CTS/RTS + CD" - аппаратное управление потоком плюс определение несущей (carrier detect) при использовании модема.
Flow Control (управление потоком данных) использует два протокола - аппаратный и программный.
При аппаратном протоколе управления потоком (Hardware Flow Control), который носит также название CTS/RTS, сигнал CTS (Clear To Send - готовность модема к приему данных для передачи в линию связи) позволяет приостановить передачу данных, если приемник не готов к их приему. Аппаратный протокол обеспечивает самую быструю реакцию передатчика на состояние приемника.
Через CTS-провод модем сообщает ПК о своей готовности принимать данные от компьютера. В обратном направлении ПК через другой провод (RTS - Request To Send) сообщает модему о своей готовности к приему данных.
Программный протокол (XON/XOFF) предполагает наличие двунаправленного канала передачи данных. При этом время реакции передатчика на изменение состояния приемника в сравнении с аппаратным протоколом возрастает значительно.

System Event Logging Submenu

Наряду с конфигурационным подменю консоли BIOS серверной материнской платы может содержать подменю с характеристиками различных системных событий. Установленный пользователем (администратором) ряд имеющих решающее значение системных событий, таких как, например, скорректированные с помощью кода коррекции ошибки памяти, может заноситься системной платой в специальный журнал. Предлагаемые опции активируют или отключают журнал, отдельные составные его части. Просмотр журнала осуществляется с помощью программы System Setup Utility (SSU), поставляемой вместе с материнской платой.

System Event Logging
- опция для включения ("Enabled") ведения журнала или отказа ("Disabled") от его использования.
Event Log Control
- опция управления журналом имеет подопции:
"All Events" с возможными "Enabled" (по умолчанию) и "Disabled",
"ECC Events" с возможными "Enabled" и "Disabled".
Понятно, что отказ от протоколирования всех событий равносилен отключению журнала.
Clear Event Log
- опция установки параметров очистки журнала. Возможны значения:
"Keep" - пропустить очистку журнала при следующем POST-тестировании (по умолчанию),
"On Next Boot" - при следующем запуске системы журнал будет очищен, а опция установится в значение "Keep".
"Phoenix BIOS" для данной опции предлагает значения "No" и "Yes".
Event Log Capacity
- опция выводит на монитор информацию о заполненности журнала. Возможны "Not Full" или "Full".
Event Count Granularity
- опцией устанавливается количество событий, которые будут пропущены перед записью очередного события в журнал. По умолчанию устанавливается "0". Другое название опции - "Event Log Count Granularity".
Event Time Granularity
- опцией устанавливается промежуток времени (в минутах), который должен пройти до следующей записи события в журнал. По умолчанию устанавливается "0".
Mark Existing Events
- назначение этой опции довольно простое, а вот применимость? Пользователю предлагается установить атрибуты для всех записей в журнале; предназначены ли они для чтения или не предназначены. По умолчанию параметр устанавливается как "Do Not Mark". Назначение выбранного параметра станет более понятным, если "BIOS Setup" будет содержать аналогичную опцию под названием "Mark Existing Events as Read". Другое значение параметра - "Mark" или "As Read".
Critical Events in Log:
- данная опция - вовсе не опция, а небольшая система внутренних меню и подменю. Прежде всего мы выбираем, какие же конкретно события будут подлежать регистрации в журнале, а далее, какая информация выводится по конкретному типу событий.
x Single Bit ECC Events
- фиксируются однобитовые ошибки при работающем механизме коррекции ошибок.
x Multiple Bit ECC Events
- фиксируются двух- и более битовые ошибки при работающем механизме коррекции ошибок.
x Parity Error Events
- фиксируются ошибки по контролю четности.
x Pre-Boot Events
- фиксируются ошибки при проведении POST-тестирования.
Для эффективной работы с этими меню необходимо рационально использовать опцию "On Next Boot" для очистки журнала. Выбирая любой из типов системных событий, пользователь "имеет дело" с небольшим подменю (subscreen), содержащим три информационных поля. Они не имеют параметров (опций) и предназначены исключительно для информирования. Вот они:
"Date of Last Occurrence",
"Time of Last Occurrence",
"Total Count of Events/Errors".
В некоторых случаях к вышеперечисленным опциям отбора может быть добавлена опция
x Single Bit ECC Events Memory Bank with Errors, и тогда добавится еще одно информационное поле - "Memory Bank with Errors", которое указывает на банк памяти с однобитовой ошибкой. Такое же поле может выводится и в обычном варианте, а также для меню об ошибках по четности.

18. Security

Clear All Passwords
- (очистка всех паролей). Малоэффективная опция с точки зрения защиты (даже наоборот), но могла оказаться очень полезной при определенной забывчивости пользователя. Предварительно требовалось переставить соответствующую перемычку на материнской плате в режим "Configure" и тогда получить доступ к этой опции.
Floppy Disk Access Control (R/W),
Hard Disk Access Control - смотри в соответствующих разделах.
Hardware Reset Protect
- включение опции ("Enabled") запрещает перезапуск системы нажатием на кнопку <RESET>. Использование опции носит защитный характер, если речь идет о возможном случайном нажатии. В остальном применение этой опции малооправдано, разве что опция может оказаться полезной для машин серверного класса.
Password Checking
- опция "AMI BIOS", аналогичная "Security Option" для "Award BIOS", с той лишь разницей, что значению "System" соответствует значение "Always", но только лишь с блокировкой загрузки системы. А еще есть третье значение - "None" (т.е. никаких паролей).
Опция может называться Password Checking Option.
Security Option
- опция, позволяющая ограничить доступ к системе и к "BIOS Setup", или только к "BIOS Setup". Выбор "System" блокирует загрузку компьютера и доступ к "BIOS Setup". Вход в систему тогда возможен только при вводе правильного пароля. Выбор "Setup" не ведет к блокировке загрузки ПК, но блокирует вход в "BIOS Setup". По умолчанию - "Setup".


BIOS. Это так просто!

BIOS

Современный и ...несовременный BIOS компьютера

Вниманию изучающих BIOS ПК!

Вы можете почитать рецензию на книгу по адресу http://www.terralab.ru/system/31939

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  1. "Загрузочные" функции BIOS, проверяемые в процессе самотестирования системы, т.п.
    • Звуковые сообщения при загрузке системы
    • Сообщения об ошибках
  2. Основные функции чипсета, выраженные в функциях BIOS
    • Оптимизация функционирования PCI-интерфейса и ISA-шины
    • Специальные функции чипсета
  3. Центральный процессор
    • CPU Speed
  4. Все о памяти
    • Функции контроля памяти
    • "Затенение" памяти, выделенная память
    • Кэширование памяти
    • Регенерация памяти
    • Конфигурирование основной памяти
  5. PCI-шина
    • Арбитраж, "Bus-Master"-режим
    • Все о PCI-шине
  6. ISA
  7. Все о периферии, системных ресурсах и их распределении
    • Функции конфигурирования распределения ресурсов
    • IRQ
    • DMA
    • Порты ввода/вывода
    • Audio
  8. Клавиатура и флоппики
  9. Последовательный и параллельный интерфейсы
  10. Жесткие диски
  11. Как настроить графическую подсистему
  12. USB-интерфейс
  13. Немного о SCSI-интерфейсе
  14. Энергосберегающие технологии и прочее
    • Функции перевода в режимы пониженного энергопотребления
    • Детальнее о режиме "Suspend"
    • Функции отключения системы
    • Функции включения системы
  15. Мониторинг системы на уровне BIOS
  16. Special
  17. Некоторые функции серверного BIOS
  18. "Защитные" функции BIOS

Просим всех заинтересованных лиц присылать не совсем понятные Вам опции БИОС с подробным перечнем значений параметров, наименований опций, версий БИОС и реализаций чипсетов.